GeoWorks Ensemble User's Guide
Copyright

The software is copyright © 1990 GeoWorks. All rights reserved. You are licensed to use the software under the terms set forth in the End User License Agreement printed on the diskette envelope which contains the software. You may not copy, rent, lease, decompile, disassemble, or create derivative works of the software or documentation, but may transfer this entire package to another person under the terms of the License Agreement. If you do not agree to the End User License, you may return all the materials for a full refund as set forth in the License Agreement.

This manual is copyright © 1990 GeoWorks. All rights reserved. No part of this publication may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated into any language in any form by any means without the written permission of GeoWorks.

The software contains Nimbus Q from Digital Typeface Corporation and typefaces from URW, GmbH. Certain background images are copyrighted works of COMSTOCK, Inc. and certain clip art is copyrighted work of T/Maker Company.

Trademarks

GEOS®, PC/GEOSTM, GeoWorksTM, GeoWorks EnsembleTM, Ensemble™, GeoComm™, GeoDex™, GeoDraw™, GeoManager™, GeoPlanner™, and GeoWrite™ are trademarks of GeoWorks.

URW Roman™, URWSans™, URW Mono™, and URW Symbol™ are trademarks of URW, GmbH.

America Online® is a registered trademark of Quantum Computer Services, Inc. Prodigy® is registered service mark and trademark of Prodigy Services Company.

Microsoft® and MS-DOS® are registered trademarks of Microsoft Corporation. IBM® is a registered trademark of International Business Machines Corporation.

Printed in the United States of America

3rd Printing, February 1991
Thank you for purchasing GeoWorks Ensemble and congratulations on being an innovator. People like you make new software technologies possible. By buying this product you have invested in our company and in our vision for the future of personal computers. We will work hard to honor that trust.

GeoWorks has spent three years creating this product. We've had one goal in mind: to help you get the most out of your computer.

By buying GeoWorks Ensemble, you have purchased much more than a package of integrated applications. You have purchased a set of applications built on the most sophisticated system software environment available for any personal computer: PC/GEOS.

To create PC/GEOS we studied early graphical environments like the Macintosh and Microsoft Windows; we studied state-of-the-art systems like NeXT and OS/2; and we studied university research into operating systems and user interface technology. We analyzed the strengths and weaknesses of these technologies and combined the best features with numerous innovations of our own. Using old fashioned hard work, we coded these features in efficient, high performance assembly language to deliver great performance on all PC's.

PC/GEOS is so efficient that you can get great software performance from the computer you already own. If you've got an XT-class machine, you'll find PC/GEOS to be very responsive. If you've got a 286 or 386 machine, you'll get the performance you deserve from your hardware investment. And PC/GEOS adjusts to your level instead of forcing you to adjust to its. We call this “scalable user
interface" technology, which means that you can choose the appropriate look and feel for your level of expertise. If this is the first time you've used a computer, try the software appliances. If you're a veteran, then the Motif professional user interface is probably more your speed. Over time we will continue to refine this technology, offering more choices of interfaces so there's one that's just right for you.

GeoWorks Ensemble and PC/GEOS are the start of a whole new world for personal computers. I hope you share the excitement we have felt in creating this software and I hope you will be a part of evolving it.

Brian P. Dougherty
Chairman and CEO
GeoWorks
CONTENTS

One  INTRODUCTION
1  Why GEOS?
3  How to Use This Manual

Two  GETTING STARTED WITH THE WELCOME SCREEN
9  Starting GEOS
11  What You See When You First Start GEOS
12  Using the Mouse
13  When Things Go Wrong
19  Getting Help
22  Where You Can Go From the Welcome Screen
26  Exiting GEOS

Three  THE APPLIANCES
27  Turning Appliances On and Off
29  The Notepad Appliance
30  The Calculator Appliance
31  The Address Book Appliance
32  The Planner Appliance

Four  THE PROFESSIONAL WORKSPACE
35  About the Professional Workspace
37  Entering the Workspace
38  The Professional Workspace Screen
39  Applications and Documents
41  Leaving the Workspace
43  Using Windows
45  Using Menus
46  Using Dialog Boxes
53  Using Applications
56  Working With Documents
65  Selecting
72  Entering and Editing Text
77  Cutting and Pasting
103  Printing

Five  USING GeOManager
113  What You Can Do with GeoManager
115  The GeoManager Window
120  Selecting Files and Directories
122  Opening Directories
128  Changing the Viewing Options
133  Starting a GEOS Application
135  Managing Files and Directories
136  Starting a DOS Program or Batch File
147  Managing Disks
151  Using the Directory Tree
154  Changing GeoManager Options
156  Exiting GeoManager
# Table of Contents

## Six

### 157 Using GeoDraw

- 159 What GeoDraw Can Do
- 161 Starting and Exiting GeoDraw
- 162 Opening a Document
- 164 The GeoDraw Window
- 168 Setting the Document Size
- 169 Creating an Image
- 181 Selecting and Modifying Objects
- 185 Moving and Reshaping Objects
- 192 Copying and Pasting
- 194 Deleting
- 195 Changing Colors, Patterns, and Styles
- 203 Editing Text
- 210 Arranging Objects Within a Stack
- 212 Working With Multiple Documents
- 214 Importing an Image From a DOS Application
- 216 Printing
- 219 Saving a Document
- 221 Closing a Document
- 268 Inserting Graphics
- 270 Changing the Page Setup
- 273 Creating a Title Page
- 275 Adding a Header and Footer
- 278 Adding Page Breaks
- 279 Working With Columns
- 281 Using the Window Menu
- 284 Using the Options Menu
- 285 Printing
- 288 Saving a Document
- 291 Closing a Document

## Seven

### 223 Using GeoWrite

- 225 What GeoWrite Can Do
- 226 Starting and Exiting GeoWrite
- 227 Opening a Document
- 229 The GeoWrite Window
- 234 Entering Text
- 235 Selecting Text
- 236 Editing Text
- 238 Formatting Text
- 244 Units of Measure
- 245 Using the Ruler
- 251 Setting Paragraph Spacing
- 254 More About Tabs
- 258 Storing a Style
- 259 Creating Borders for Text
- 262 Creating a Table
- 263 Using Color in GeoWrite
- 315 Saving a Document
- 317 Linking to GeoPlanner
- 319 Cutting and Pasting

## Eight

### 293 Using GeoDex

- 295 Starting and Exiting GeoDex
- 296 The GeoDex Window
- 298 Adding Cards
- 301 Flipping Through Cards
- 302 Making Changes
- 303 Dialing
- 307 Browsing
- 309 Searching
- 312 Printing
- 315 Saving a Document
- 317 Linking to GeoPlanner
- 319 Cutting and Pasting

## Nine

### 321 Using GeoPlanner

- 323 Starting and Exiting GeoPlanner
- 324 The GeoPlanner Window
- 325 Working With the Calendar Window
- 327 Working With Events
- 331 Setting the Alarm
- 333 Working With Repeating Events
- 343 Searching
- 344 Printing
Welcome! We think you’re going to enjoy using GEOS. This chapter gives you a general idea of what you can do with GEOS and explains how to get the most out of this user’s guide.

If you haven’t yet installed GEOS, you should do so now by following the instructions in the Quick Start Guide.
INTRODUCTION

3 Why GEOS?
6 How to Use This Manual
Computers. They’re supposed to make life easier. But the time it takes to learn a new program—all the commands you must remember, all the trial and error you must go through—these things can take all the fun out of using a computer, even for experienced users.

So we created GEOS, an exciting new environment to work in, along with a family of applications (including GeoWrite and GeoDraw) that make full use of its power. Together they make up GeoWorks Ensemble. GEOS is designed to give you powerful tools for doing your work, but also to bring a little fun back into using your computer. And it’s so easy that anyone can learn to use it.

GEOS is easy to use because it’s visual and intuitive. Instead of using hard-to-remember commands, the screen shows you pictures of things, like buttons and icons. Everything you can do in GEOS is represented somewhere on the screen, whether it’s in a menu, in a list, or on a button. You spend less time trying to remember how to do things and more time doing them. Simply move an arrow-shaped pointer around on the screen with your mouse until it points at a visual representation of what you want to do, then press and release the mouse button.

With the graphic abilities of GEOS, things appear on the screen exactly as they will on the printer. Whether it’s a business letter you’re writing or some artwork you’re creating, what you see is what you get (WYSIWYG). So when you print, there aren’t any surprises.

These are just a few of the reasons that we think GEOS is easy and fun to use. Go ahead and explore... Find a few reasons of your own.
Why GEOS?

**Something for Everybody**

When you first start GEOS, a Welcome screen greets you. The Welcome screen provides a friendly and simple starting place. Everything is large and clearly labeled.

The Welcome screen has something for everybody. The software Appliances can be used by anyone in the family. For more advanced users, there's a Professional Workspace and a DOS Programs area for running DOS programs and batch files.

**Power When You Need It**

In addition to being simple and friendly, GEOS has power on tap. The Professional Workspace is where you put this power to work.

The Professional Workspace helps you get started and keep organized. It has a desktop file manager called GeoManager for working with files and directories, as well as a calendar (GeoPlanner), address book (GeoDex), and Notepad for keeping track of dates, people, and notes.

The GEOS word processing and drawing application programs let you create documents and complement them with graphics. In GeoDraw you can draw graphs, charts, abstract shapes and lines, then copy them into GeoWrite.
GeoDraw lets you shade, fill, and pattern to create detail. All you do is go to a toolbox, where you can choose different tools, which draw different shapes. You can change the size, color, and texture of a shape. You can rotate a shape, including text, to any orientation.

With the GeoWrite word processor, you can change fonts and text styles at any time, to any size. You can center, justify, and move blocks of copy. You can work in multiple columns, in different colors, on different sizes of paper—right on the screen. And of course, you can also cut and paste to combine text and graphics.

You can print your documents exactly as they appear on the screen, on any of the supported dot matrix or laser printers. You can even print in color if your printer supports it.

The rest of this chapter tells you how to use this manual to get the most out of this new software product.
This book is organized sequentially—most topics build upon previous topics—so if you like that kind of instruction, you can read from cover to cover.

But that doesn’t mean you have to read the whole thing.

Start with this chapter. Skip ahead if something seems obvious. Turn back if you miss something important.

Try things out. Use the index. Peruse the table of contents. Look up words you don’t know in the glossary.

In short, don’t feel like you have to do things “by the book.” Use this manual in whatever way helps you most.

In fact, the best way to learn about GEOS is to play with the software. As you try things out—and become more comfortable experimenting—GEOS becomes easier to learn and use.

And, if you’re worried about accidentally damaging something important, remember this: GEOS asks you for permission before it updates or removes anything important, and it almost always gives you a way to undo your changes.

Putting the Manual to Work

This user’s guide consists of chapters, and each chapter is divided into topics. Each topic begins with an explanation, and then gives simple tasks you can follow. Scan down the page for the task you want, then follow the steps.
**Once you** have adjusted the GeoComm window to a size you are comfortable with and have set the parameters for your computer, you may start telecommunications with another computer.

If the two computers are already connected, just start typing. Otherwise, you will want to dial a number with your modem.

**To dial a number...**

1. Choose Quick Dial from the Dial menu. The Quick Dial dialog box appears.

![Quick Dial dialog box]

2. Type the phone number you wish to dial.
3. Click Dial. GeoComm dials the number.

GeoComm accepts numbers in almost any format. Here are some guidelines for entering phone numbers:

- Omit the area code for local numbers.
- For long distance calls, include the 1 and the area code, as in this example:
  
  1-415-555-1212

- If the number needs a special dialing sequence — to access a long distance service, for instance — be sure to enter this sequence before the regular number.

Special symbols in this manual, such as **A**, **X**, and **Y**, represent keys on your keyboard.

The symbols shown in the manual won't always match the keys on your keyboard. For example, not all keyboards have a **Ctrl** key; sometimes it is marked with the word “Control.” Also, the **Backspace** key appears as a **←** key on some keyboards. Refer to your computer’s owner's manual for more information.

When you see a group of keys separated by a + sign, it means to hold down the first set of keys while pressing the second. For example, if you see **Shift Ctrl + P**, it means to hold down both the **Shift** and **Ctrl** keys while pressing the **P** key.
This chapter introduces you to the GEOS Welcome screen. It assumes you have already gone through the installation process described in the Quick Start Guide.

In this chapter you learn
• How to start and exit GEOS
• How to use the mouse
• About the elements of the GEOS Welcome screen
GETTING STARTED WITH THE WELCOME SCREEN

11   Starting GEOS
12   What You See When You First Start GEOS
13   Using the Mouse
19   When Things Go Wrong
20   Getting Help
22   Where You Can Go From the Welcome Screen
26   Exiting GEOS
If you've just finished running the Setup Program, GEOS starts automatically. Thereafter, you need to start GEOS from DOS whenever you want to use it.

To start GEOS from DOS...

At the DOS prompt type `GEOS` and press `Enter`.

GEOS loads from disk. After a few moments, the Welcome screen appears.

If you are unable to start GEOS, refer to the booklet *Troubleshooting, Tips, and Extra Features* for troubleshooting help.
What You See When You First Start GEOS

When you first start GEOS, you see the Welcome screen. It is your gateway into the GEOS environment.

Pointer: You use the pointer to "point" to items on the screen. Moving the mouse on a flat surface moves the pointer on the screen.

Buttons: Buttons represent actions or choices you have. You click buttons on the screen by positioning the pointer over a button and pressing and releasing the left mouse button.
GEOS is designed for use with a mouse. The mouse lets you point and click to get things done.

As you move the mouse on a flat surface, such as a tabletop, a small arrow-shaped pointer moves on the screen. The motion of the pointer corresponds to the motion of the mouse.

Sometimes the pointer changes its shape to remind you of what you are doing or to give you information.

**Arrow pointer:** This is the normal pointer. It moves with the motion of the mouse.

**Hourglass pointer:** The Hourglass (or “Busy”) pointer indicates an operation is in progress and that you can’t perform another task until the operation is completed.

**Circle/Slash pointer:** When the pointer is outside of the active area of the screen, it becomes a circle with a slash through it.

**I-beam pointer:** The I-beam pointer shows that you can change the text under it.

**Different Mouse Buttons**

You can control GEOS with either a two-button or three-button mouse. If you have a two-button mouse, the buttons are referred to as “left” and “right.” If you have a three-button mouse, the buttons are referred to as “left,” “right,” and “middle.”

The left and right mouse buttons have specific functions. The middle button is unused.
Using the Mouse

Left button: The left button performs most operations in GEOS. If the instructions don’t specify a particular mouse button to use, always use the left button.

Right button: The right button is for moving items around the screen. This is called direct manipulation. Not all direct manipulations require you to use the right mouse button, so the documentation makes it clear when you should.

Moving the Pointer and Clicking

To control GEOS, you move the pointer around the screen until it is over an item you want to use—such as a button, a menu item, or an icon—then press and release the mouse button. Moving the pointer over an item is called pointing to the item. Pressing and releasing the mouse button is called clicking (or, sometimes, single-clicking).
To move the pointer on the screen...

1. Place the mouse on a flat surface. The cord should face away from you.

2. Move the mouse in any direction. The pointer movement corresponds to the movement of the mouse.

If you want to move the mouse without moving the pointer, lift the mouse off of its surface and place it down somewhere else. The pointer stays where it is.

As you move the mouse on the table, the pointer moves the same way on the screen.
**To click an item on the screen...**

1. Position the pointer so that its tip is over the item you want to click.

2. Press and release the mouse button—usually the left one—once.

---

**Double-Clicking**

A *double-click* is two quick clicks of the mouse button. A double-click often provides a shortcut way of doing something you could normally do with multiple single-clicks, such as starting an application with GeoManager.
To double-click an item on the screen...

1. Position the pointer over the item you wish to double click.

2. Press and release the mouse button twice, rapidly in succession.

The trick to double-clicking is steadiness and speed: Don’t move the mouse; press and release quickly. You might need to practice this until you get it just right.

**Triple-clicking, Quadruple-clicking, Quintuple-clicking, and more.** Sometimes GEOS extends the idea of double-clicking to include additional clicks. There are triple-clicks (three clicks), quadruple-clicks (four clicks), and even quintuple-clicks (five clicks). Multiple-clicks are useful in a variety of situations, such as when selecting text. In a word processor, for example, each successive click selects a larger unit of text—a double-click selects a word, a triple-click selects a line, a quadruple-click selects a paragraph, and a quintuple-click selects an entire page. See “Entering and Editing Text” in Chapter 4, “The Professional Workspace,” for more information.

**Pressing**

*Pressing* means positioning the pointer on the screen, then pressing and holding down the mouse button. Pressing an item on the screen is like pressing and holding a key on your keyboard: Just as some keys auto-repeat and cause a continuous action, some items on the screen auto-repeat and cause continuous actions. For example, pressing on a down arrow—such as those used to scroll through lists—often causes the list to scroll continuously.
Using the Mouse

To press an item on the screen...

1. Position the pointer over the item you want to press.
2. Press and hold down the mouse button. Do not release it immediately.
   Pressing causes a continuous action (like scrolling) while the mouse button is down.
3. Release the mouse button. The continuous action stops.

Dragging

Dragging means to press and hold down the mouse button while moving the mouse. As Chapter 4 explains, dragging is one way to browse through menus and choose commands. It is also convenient for moving and resizing windows, and for selecting areas of text in a window.

You can also use dragging to pick up items and move them around the screen. This kind of dragging is called direct manipulation. You often use the right mouse button for direct manipulation.

To drag an item on the screen...

1. Position the pointer where you want to begin dragging.
2. Press and hold down the mouse button.
3. Move the pointer in any direction.
4. Release the mouse button.
When GEOS encounters a problem that you need to know about, or when you need to make an important decision, a dialog box appears in the middle of the screen.

The dialog box tells you what the problem is, or what decision you need to make, and usually presents you with several options—visually represented as buttons on the screen. You must click one of the buttons before you can continue with what you were doing.

If one choice is particularly good, or is at least the safest of the choices given, the box shows you this by marking the button with an especially heavy outline.

Press [Enter] to select this choice, and the dialog box goes away.
Many screens have a special Help button in the upper right corner.

When you click the Help button, a window appears with information and instructions for the screen.

Help window: The text in the help window explains how to use the current screen. You can scroll to different pages.

Paging buttons: Use the Page Up and Page Down buttons to flip between pages of help.
**Close Button:** The Close button closes the Help window when you are finished using it.

---

**To display the Help Window...**

Click the Help button in the upper right corner of the screen. The Help window appears.

---

**To view different Help pages...**

Click the paging buttons:

- Click the Page Down button to view the next page of help.
- Click the Page Up button to view the previous page of help.

If one of the paging buttons appears dimmed (light grey), then the function of that button is not available because you are already on the first or last page of help. If both buttons are dimmed, then there is only one page of help and it is currently displayed. Clicking a dimmed button has no effect.

---

**To make the Help window go away...**

Click the Close button. The Help window goes away.
Where You Can Go From the Welcome Screen

The buttons on the Welcome screen represent the different parts of GEOS.

When you click one of the buttons on the Welcome screen, another screen appears. You work with the new screen and then return to the Welcome screen when you are finished.

Appliances: Use the Appliance button to access a screen of software appliances, including a computerized calculator, notepad, calendar, and address book.

Professional: Use the Professional button to access a screen of professional applications, such as the GeoManager file manager and the GeoWrite word processor.
**DOS Programs**: Use the DOS Program button to access a screen of DOS applications and batch files you can run.

**Exit**: Use the Exit button to leave GEOS and returns to DOS.

**Help**: Use the Help button to access the Help window.

---

**Appliances**

Clicking the Appliances button reveals a screen of software appliances.

Software appliances are designed to be simple enough for anyone to learn how to use them. In some respects they resemble conventional appliances you might find in a home. For example, the Calculator appliance resembles a handheld calculator. It has large, familiar buttons and a red LED display.
Software appliances are easy to use, and there's nothing you can do with them that will harm your computer. Software appliances are a great way to introduce family and friends to GEOS.


Professional Applications

Clicking the Professional button reveals a workspace where you can use advanced GEOS applications, like GeoDraw and GeoWrite.

The screen that appears when you click the Professional button is called a workspace. Software programs you run in the workspace are called applications.

If you can't figure out how to exit the Professional workspace, press F2 to return to the Welcome screen.

See Chapter 4, "The Professional Workspace," for more information.
**DOS Programs**

Clicking the DOS Programs button reveals a screen of buttons representing DOS programs you can run. At first this screen has only one button, labeled “Enter DOS.”

The Enter DOS button lets you temporarily enter DOS. Once in DOS, you can invoke normal DOS commands. Type `exit` and press `Enter` to leave DOS and return to the DOS Programs screen.

After you become comfortable with GEOS, you can add your favorite DOS applications to the DOS Programs screen as buttons.

If you want to use the DOS Programs screen right away, you might ask somebody who understands GEOS and DOS to set up your DOS Programs screen for you.

See Chapter 12, “Using The DOS Programs Screen,” for information on setting up and using the DOS Programs screen.
To exit GEOS and return to DOS...

1. Click the Exit button in the upper left corner of the Welcome screen. Or, alternatively, press **F3**.

   A dialog box appears, asking if you wish to exit GEOS.

2. Click the Yes button in the dialog box or press **Enter**. GEOS exits and returns you to DOS.

Get in the habit of exiting GEOS before shutting off your computer. If you shut off your computer while GEOS is running, you may lose work.
Anybody in your household who can use a familiar home appliance—washing machine, telephone answering machine, remote-control television—can also use GEOS software appliances. GEOS software appliances are designed to be especially easy to learn.

GEOS comes with four appliances available for use:

- An Address Book for looking up names and addresses
- A Planner for showing important upcoming events
- A Calculator for quick calculations
- A Notepad for making notes
THE APPLIANCES

29 Turning Appliances On and Off
30 The Notepad Appliance
31 The Calculator Appliance
32 The Address Book Appliance
33 The Planner Appliance
Turning Appliances On and Off

To use an appliance, you must first turn it on. Turning on an appliance is as simple as clicking a button. When you are finished using the appliance, you can turn it off with the click of another button.

To turn on an appliance...

1. On the Welcome screen, click the large Appliances button. The Choose an Appliance screen appears.

2. Click the button of the appliance you wish to use—for example, click the Calculator button. The appliance turns on and fills the screen.

If you need help using an appliance, click the Help button in the upper right corner of the screen. See “Getting Help” in Chapter 2, “Getting Started With the Welcome Screen” for more information.

To turn off an appliance...

1. Click the Exit button in the upper left corner of the appliance. The appliance turns off and the Choose an Appliance screen reappears.

2. Click a button to use another appliance or click Exit to return to the Welcome screen.
The **Notepad** appliance is a handy place to write quick notes or lists.

**Shopping List:**
- Eggs
- Milk
- 50 fish sticks
- Resealing storage bags
- Spaghetti
- Industrial bathroom cleaner
- Salisbury steak TV dinner
- Ice cream

**Instructions:**
- **Click to return to the Appliances screen**
- **Click to print the entire Notepad**
- **Click to cut or copy selected text, then click Paste to bring the text back into the Notepad**
- **Type text in this area of the screen**
- **Click for help**
- **Click to switch to other pages of the Notepad**
- **You can make the text larger if you have trouble reading it**
The Calculator appliance works like a normal desktop calculator.
The Address Book appliance works much like a common office card file.

Name: Smith, Adam
Address: Adam Smith
12 Knottswood Pl.
Kensington, CA 91409

Phone Numbers:
- HOME 555-9836
- OFFICE
- CAR
- FAX

Click to return to the Appliances screen
Click for help
Flip to another card
Click a letter tab to see cards for a particular letter
Dials one of the phone numbers shown
The Planner appliance works like a desk calendar and date book.

- Click to change year, month, and day shown.
- Today's date is marked with a heavy outline.
- Click a day to show the scheduled events on it.
- Days that have scheduled events are marked with a small triangle.
- Prints monthly calendar or scheduled events.
- Events scheduled for highlighted days.
- Shows more events (can only be clicked if there are more events to be seen).
The GEOS Professional Workspace turns your computer into an electronic desktop. With this desktop, you can write documents, draw pictures, look up phone numbers and check appointments, and even jot down notes to yourself.

Everything in the Professional Workspace is based on a standard called Motif. This chapter explains the parts of Motif and the Professional Workspace that are common to all GEOS applications.

This chapter contains a lot of information—certainly more than you’ll need right away—so after reading the sections at the beginning that help you get started, you’ll probably want to skip ahead to other chapters. You can always come back to this chapter when you want to learn more or when you encounter something you don’t understand.
The Professional Workspace is like a real desktop in that you can place everything out in the open in any way that you want, you can do many things at once, and you don’t need to finish one task before starting another.

Another way the Professional Workspace is like a real desktop is that you can stop working at any time. You don’t need to finish what you are doing before you exit or quit for the day. No matter how long you are gone, and no matter what you do in the meantime (you can even turn off your computer after you exit GEOS), everything in the Professional Workspace stays exactly as you left it, ready for you when you start working again. Nothing is ever lost, or misplaced, or rearranged.

The desktop metaphor of the Professional Workspace is based on the Motif graphical user interface (GUI). Like other interfaces, Motif provides a friendly, consistent, graphical way to control your computer. The Motif standard was developed by the Open Software Foundation and is supported by some of largest hardware and software manufacturers in the world, including IBM, DEC, Hewlett-Packard, and Groupe Bull (Zenith).

Whether you are a seasoned computer user or someone who is new to graphical software, the Professional Workspace is right for you. You’ll find the Professional Workspace both easy to learn and exceptionally powerful. You’re not likely to get stumped trying to use it, nor are you likely to outgrow its capabilities.
Like other areas of GEOS, you enter the Professional Workspace from the Welcome screen. The first time you enter the Professional Workspace, the screen appears with the GeoManager window. The GeoManager window shows all the applications you can use. Thereafter, whenever you enter the Professional Workspace, the GeoManager may or may not appear, depending on how you last left it.

To enter the Professional Workspace from the Welcome screen...

1. On the Welcome screen, click the Professional button.

   A dialog box appears, asking you if you want to enter the Professional Workspace. This dialog box only appears the very first time.

   ![Dialog box](image)

   **You are about to enter the Professional Workspace. If this is your first time using the Professional Workspace, you may want to have your User’s guide at hand.**

   **Are you sure you want to enter the Professional Workspace?**

   ![Yes and No buttons](image)

2. Click Yes. The Welcome screen clears and the Professional Workspace appears.
The **GeoManager window** is the first thing you see when you enter the Professional Workspace. From the GeoManager window, you can start GEOS applications as well as manage your documents, files, directories, and disks.

Programs you run in the Professional Workspace are called *applications*. You use applications to create *documents*. Applications use *windows*, rectangular areas of the screen, to display information.

The GeoManager window appears. When you leave the Professional Workspace, GEOS stores your work so that when you come back, everything appears as you last left it. 

**Workspace background:** This is the background area of the screen, usually light or dark gray, where windows and icons appear.

**Window:** Windows are the rectangular areas of the screen where information appears. Windows may be moved and stacked on the workspace like sheets of paper on a desktop; they may overlap one another, partially or completely. GeoManager uses its window to display the contents of disks and directories.
Icons: Icons are small pictures on the screen that represent things you can work with. In the GeoManager window, icons represent files and directories on your disks. When you want to work with a file or directory, you can do so by working with its icon.

File icon: A file icon in the GeoManager window represents a file on your disk drive. The file can be either a DOS file or a GEOS file.

Directory icon: A folder icon in the GeoManager window represents a directory on your disk drive. Because directories appear as folders in the GeoManager window, “directory” and “folder” are often used interchangeably.

WORLD and DOCUMENT directory buttons: GEOS has two main directories: WORLD and DOCUMENT. The WORLD directory contains applications (programs you can run), and the DOCUMENT directory contains documents (data files you can use). The WORLD and DOCUMENT buttons quickly display these two directories.

Floppy disk buttons: The floppy disk drives in your computer appear as buttons along the bottom edge of the GeoManager window. The letters on the buttons indicate which drives the buttons represent. Floppy disk drives are labeled “A” and “B.”

Hard disk buttons: The hard disk drives in your computer appear as buttons along the bottom edge of the GeoManager window. The letters on the buttons indicate which drives the buttons represent. Hard disk drives are labeled starting with “C.” (Note: If you have a RAMdisk, a ROMdisk, or other kind of disk device, such as a LAN device, it too appears as a button along the bottom edge of the window.)

Wastebasket icon: Putting a file or a directory folder in the Wastebasket is one way to delete the file or directory (it is a lot like the DOS delete command). Whatever you put in the Wastebasket is removed from the disk and cannot be retrieved.
Programs you run in the GEOS Professional Workspace are called applications. You use applications to create and edit documents. A document can be a one-page letter, a ten-page report, an architectural drawing, or even a complete address book with names and addresses. Documents are stored as data files on your disks. They are similar to the files you create and save with DOS programs.

Each application in GEOS uses a unique type of document. A graphics application uses graphics documents, a word processor application uses word processor documents, and an address book application uses address book documents. You can't open a word processor document with a graphics application, or vice versa, because the documents are of different types—but you can share information between the two documents by cutting and pasting.

In GEOS, you use the WORLD and DOCUMENT directories for storing applications and documents. Applications are stored in the
WORLD directory; documents are stored in the DOCUMENT directory. You can switch between these two directories by clicking the WORLD and DOCUMENT directory buttons at the bottom of the GeoManager window.
You can leave the Professional Workspace at any time. You can return to the Welcome screen first, or you can exit directly to DOS. There’s no need to clean up or save documents before you exit the Professional Workspace. GEOS remembers exactly what you are doing when you leave. This way, whenever you come back, no matter how long you’ve been gone or what you’ve done in between (you can even exit to DOS and turn off your computer), the Professional Workspace stays just as you left it: The same applications are running with the same documents open. Nothing is ever lost!

To leave the Professional Workspace and return to the Welcome screen...

1. Click the Express button on whichever window you see it. At first, the Express button is on the GeoManager window, near the upper left corner. However, if you are running more than one application, the Express button moves to the window of the active application.

2. On the Express menu, click Welcome (the topmost item). The Professional Workspace goes away and the Welcome screen appears.

You should always exit to DOS before turning off your computer. Do not turn off your computer while in the Professional Workspace or the Welcome screen.
You may also press [F2] to return to the Welcome screen without using the Express menu.

---

**To exit directly to DOS...**

1. Click the Express button at the top of the active window. The Express menu appears.

2. On the Express menu, click Exit to DOS. The Professional Workspace goes away and the DOS prompt appears.

Exiting directly to DOS is a shortcut way to exit, without returning to the Welcome screen. As when returning to the Welcome screen, nothing is lost when you exit directly to DOS.
Windows are rectangular areas of the screen where applications display information. You can move, stack, and resize windows on the workspace.

**Title bar**: The title bar names the contents of the window. You can move a window by dragging its title bar.

**Menu bar**: If an application has menus, the menu names appear on the menu bar. Not all applications have menus.

**Menu name**: Clicking a menu name displays that menu.

**Control button**: Double-clicking the Control button closes the window. Single-clicking the Control button displays a special menu, the Control menu.

**Express button**: Clicking the Express button displays the Express menu. The Express menu contains options for switching between
running applications, starting new applications, returning to the Welcome screen, and exiting directly to DOS.

**Maximize button:** Clicking the Maximize button enlarges the window to fill the entire screen. The window loses its resize borders and can no longer be moved or resized, and the button is now referred to as the Restore button, since it clicking it now will restore the window to its previous size.

**Restore button:** The Restore button is the same button as the Maximize button. Clicking the Restore button returns the window to its previous size so you can move and resize it as usual.

**Minimize button:** Clicking the Minimize button collapses the window to an icon, moving it out of your way temporarily. Minimizing an application does not exit the application or stop it from running, but merely shrinks it to an icon. Double-clicking the icon restores the application to a window.

**Resize borders:** Dragging a resize border in any direction resizes the window.

**Scroll bar:** When the contents of a window are larger than the window itself, scroll bars appear at the right and bottom edges of the window. Scroll bars let you scroll the contents of the window to see different parts.

**Activating Windows**

The *active* window is the window you are currently working in. You can tell which window is active by looking at the border and title bar.
To activate a window...

Click the window you wish to activate. The best place to click is the title bar, although you can click anywhere inside the window. The window moves to the top of the workspace and its title bar is highlighted.

If the window you want to activate is obscured by other windows, you may need to first move or close the other windows.

If more than one application is running in the workspace, you can switch between them by activating their respective windows. See “Using Applications” later in this chapter for more information on switching between running applications.

Moving and Resizing Windows

By moving and resizing windows you can rearrange your workspace to suit your needs. You move a window by dragging its title bar. You resize a window by dragging its resize borders.
Using Windows

To move a window...

1. Position the pointer over the title bar of the window you wish to move.

2. Press and hold down the mouse button. The pointer changes and a rectangular outline of the window appears.

3. Drag the outline in any direction.

4. Release the mouse button. The window redraws at the location of the outline.

To resize a window...

1. Position the pointer over one of the resize borders on the window. The pointer changes to a shape which indicates the edge or edges you are resizing.

2. Press and hold down the mouse button. An outline of the window appears.
3. Drag in any direction. The outline shrinks or grows as you move the pointer.
If you drag a horizontal or vertical border, the outline shrinks or grows horizontally or vertically only. If you drag a corner border, the outline shrinks or grows in both dimensions, horizontally and vertically.

4. Release the mouse button. The window redraws to the size of the outline.

If you try to make a window smaller than it can actually get, the window automatically becomes its smallest size.

Some windows don’t have resize borders. You cannot resize these windows.

**Scrolling Windows**

When the contents of a window cannot fit within the window itself, scroll bars appear. Scroll bars let you scroll the window to view more of its contents. You can scroll a window to the right, for example, to see parts of a document located off to the right. You can scroll a window down, to see portions of a document located off the bottom.

Dear Mom,

I’ve settled in at my new apartment, more or less. I still have boxes everywhere, and there appear to be things growing in the grout in the bathroom, from the previous tenants. Other than that, things are fine. The store is just a block away, so I just hopped over there to buy a bag of 50 frozen fish sticks. What a deal!!
Scroll arrows: Clicking a scroll arrow scrolls the window a single step in a particular direction. For example, clicking a down-facing arrow shifts the contents of the window to reveal more of the document at the bottom.

Slider: The slider indicates the portion of the document now visible in the window. The entire length of the scroll bar represents the length of the document. If the slider is at the top of the scroll bar, the top of the document is showing in the window. If the slider is at the bottom of the scroll bar, the bottom of the document is showing in the window. If the entire document fits in the window, the slider fills the entire scroll bar. Dragging the slider scrolls the contents of the window to a particular position.

The length of the slider varies depending on how much of the document is displayed in the window. The more of the document displayed in the window, the longer the slider.

Paging areas: The paging areas on either side of the slider indicate the portion of the document hidden from view. Clicking a paging area scrolls the window a page or a full window at a time.

To scroll a window in small steps...

Click the scroll arrow. The window scrolls a small step in the direction of the arrow.

To scroll continuously, hold down the mouse button with the pointer over the scroll arrow.

With a window full of text, each click of a scroll arrow scrolls the window a line or column at a time. With windows full of other items, each click of a scroll arrow scrolls the window a uniform distance.
To scroll a full window at a time...

Click one of the paging areas to scroll the window a full window at a time. The window scrolls in the direction of the nearest scroll arrow.

To scroll continuously a full window at a time, hold down the mouse button with the pointer over the paging area.

To scroll directly to a particular position...

1. Position the pointer over the slider in a scroll bar.
2. Press and drag the slider to a new position.
3. Release. The window scrolls to match the position of the slider.

Closing Windows

Closing a window removes the window from the screen. If close a window with a document you’ve made changes to, you are asked if you want to save the changes. If you close the main window of an application, the application exits.

To close a window...

Double-click the Control button of the window.

The window closes.

You can also close a window by choosing Close from the window’s Control menu.
**A menu is** a list of commands and options. You control an application by choosing items from its menus. Menu names appear on the menu bar at the top of an application’s window. Beneath each menu name, out of sight until you need it, is the menu itself.

The Control button and Express button reveal special menus for managing windows and working with applications. Even though they are not on the menu bar, you use them in the same way you use regular menus.

Most items on menus represent commands. By choosing a command, you initiate some sort of action. Other items on menus represent settings that can be either on or off. These items have special symbols that indicate whether they are check boxes or radio buttons and whether they are on or off.
Radio buttons and a single check box on an EGA or VGA monitor...

When a check box is highlighted, the item is on; otherwise, it is off. Choosing a check box from a menu switches the item from off to on, or from on to off.

Radio buttons always come in groups of two or more. Only one of the items in the group can be on at a time. Choosing a radio button from a menu turns on that item and turns off any others in the group.

...and the same buttons and check box on a monochrome monitor

A check box can be turned on or off, without affecting any other check boxes.

...and off
Choosing From Menus

You can use two different methods to choose from menus. You can use the clicking method, in which you click once to display a menu and then click again to choose an item. Or you can use the dragging method, in which you press and hold the mouse button to display the menu, drag down to the item you want, and release to choose the item.

Items on a menu that appear dimmed (light grey) are unavailable for use. Some items only become available after you make a selection. See “Selecting” later in this chapter for more information.

To choose from a menu by clicking...

1. On the menu bar, click the name of a menu. The menu appears.

   If you don’t find the item you want, click the name of another menu. The first menu closes, and the new menu appears.

   You can continue clicking menus in this way until you see an item you want to choose. Dimmed items are not available, which means you can’t choose them.
2. With a menu displayed, click the item you want to choose. The item is selected, and the menu closes.

If you are just browsing, you can close the menu without making a choice by clicking anywhere off of the menu.

To choose from a menu by dragging...

1. Position the pointer over the name of a menu on the menu bar.
2. Press and hold down the mouse button. The menu appears.
3. Drag the pointer across the menu bar. As you pass over different menu names, the corresponding menus appear.
4. Continue looking through menus until you see the item you want to choose. Dimmed items are not available, which means you can't choose them.
5. With a menu displayed, drag the pointer down the menu without releasing the mouse button. Available items highlight as the pointer passes over them.
6. When the pointer is over the item you wish to choose, release the mouse button. The item is selected, and the menu closes.
If you are just browsing, you can close the menu without making a choice by dragging the pointer off the menu and release the mouse button.

Using Cascade Menus

Menu items that have a right-facing arrow reveal another menu of additional choices. This secondary menu is called a *cascade menu*.

You can choose from a cascade menu by either clicking or dragging in much the same way as you choose from other menus.
**To choose from a cascade menu by clicking...**

1. Click to open a menu in the normal fashion.

2. Click the cascade menu item (the item with the right-facing arrow). The cascade menu appears.

3. On the cascade menu, click the item you want to choose. The item is selected, and the cascade menu closes.

To close the cascade menu without making a choice, click anywhere off of the menu.

**To choose from a cascade menu by dragging...**

1. Drag open a menu in the normal fashion.

2. Drag the pointer down the menu to highlight the cascade menu item (the item with the right-facing arrow).

3. With the pointer on the cascade menu item, drag to the right so that the pointer is over the right-facing arrow. The cascade menu appears.

4. Drag the pointer off of the main menu and onto the cascade menu.

5. Drag the pointer down to the item you want to choose and release the mouse button. The item is selected, and the cascade menu closes.
If you don't want to make a choice from the cascade menu, drag the pointer back on to the first menu or off of both menus completely.

Pinning Menus

You can "pin" a menu to the workspace so that it stays open all the time.

A pinned menu
behaves like a window.
It has a title bar so you can move it and a Control button so you can close it.
Once a menu is pinned, you can move it around the workspace and place it wherever you need it most. When you're done, you can close the pinned menu so it no longer takes up space on the screen.

**To pin a menu...**

Choose the push-pin item at the top of a menu you want to keep open.

The menu stays open. A title bar and Control button appear on the menu for moving and closing.

**To move a pinned menu...**

Move a pinned menu as you would move a window, dragging it by its title bar. The menu moves to its new position.
To close and unpin a menu...

Close a pinned menu in the same way you would close a window: Double-click the Control button in the upper left corner. The menu unpins and closes.

Using Keyboard Accelerators With Menus

A keyboard accelerator is a single keystroke you can use to choose a particular menu item or command. If an item has a keyboard accelerator, the accelerator appears at the right edge of the menu. Not every item has a keyboard accelerator.

Most keyboard accelerators require you to hold down the Ctrl key while pressing another key. Sometimes you need to hold down both the Ctrl key and the Shift key. There is a simple notation that indicates which keys you should press: When a + sign separates two groups of keys, it means hold down the first set of keys while pressing the second. If you see Ctrl+P on a menu, you would hold down the Ctrl key while pressing P to choose the command.
To choose from a menu using a keyboard accelerator...

Press the accelerator key combination indicated on the menu.

The menu item is selected exactly as if you had chosen it using the mouse.

Navigating Menus With the Keyboard

While you normally browse and choose from menus using the mouse, you can also use the keyboard. Browsing and choosing from menus using the keyboard is called keyboard navigation.

Knowing how to navigate menus with the keyboard saves you time, especially when you’re doing a lot of typing because you don’t need to take your hands off the keyboard to reach for the mouse.

You can navigate through menus using the ← → ↑ ↓ keys or by using mnemonics. A mnemonic is a single letter or number that represents a menu name or item on a menu. Mnemonics appear in three different ways, as shown below.
To choose from a menu using the arrow keys...

1. Press and release the [Alt] key. The name of the first menu on
the menu bar is highlighted.

2. Press the [←] keys to move left and right from menu to menu,
highlighting names as you go.

3. Press [↑], [Spacebar], or [Enter] to display the menu for the
currently highlighted name.

   If you want to display a different menu, press the [↑] or [↓] key
to show the previous or next menu.

4. When you see the item you want, use the [↑] [↓] keys to move
up and down the menu. Items are highlighted as you move up
and down.

   If an item has a right-facing arrow and leads to a cascade menu,
you can open the cascade menu by pressing the [↓] key. With
the cascade menu open, press the [↑] [↓] keys to move up and
down the cascade menu. Press the [↑] key to close the cascade
menu and move back onto the previous menu.

5. With the item you want to choose highlighted, press the
[Spacebar]. The item is selected and the menu closes.

   If you are just browsing, you can press the [Esc] key to close the
menu without making a choice.

If you move the highlight off of either the left or right edge of the
menu bar, you move up to the area of the window occupied by
the Control button and the Express button. You can choose from
the Control menu and Express menu in the same way you choose
from other menus.
To choose from menus using mnemonics...

1. While holding down the \[\text{Alt}\] key, press the mnemonic of the menu you wish to open. For example, hold down \[\text{Alt}\] and press \[\text{F}\] to display the File menu.

2. With a menu open, press the mnemonic of the item you wish to choose. For example, press \[\text{S}\] to choose the Save item from the File menu.

    The item is selected and the menu closes.

3. Release the \[\text{Alt}\] key.
**Whenever GEOS needs** more information from you, or needs to alert you to a problem, a dialog box appears.

Some dialog boxes are like windows—they have a title bar for moving and a Control button for closing. You can keep these boxes open and switch between them and other windows if you want.

Other dialog boxes require a response before you can continue. Such boxes do not have a title bar or a Control button, and the image of the pointer changes to a circle-and-slash symbol when you move outside of the box. Your computer beeps if you try to click outside the box while the pointer is a circle-and-slash symbol.
Some boxes even have symbols indicating their purpose.

? A question you need to answer

 Something is preventing you from continuing with an action

 i Information you might find useful

 ! A warning, such as when information may be lost

**Elements of a Dialog Box**

Dialog boxes are assembled from standard elements, such as text fields, radio buttons, and scrolling lists.
Button: Every dialog box has buttons. Clicking a button causes an action to occur. If the label on a button is followed by an ellipsis (…), then that button leads to another dialog box.

Some common buttons include those marked OK and Cancel. You will see others, too, such as Yes, No, Apply, Reset, and Close. The function of a button is usually self-explanatory.

<table>
<thead>
<tr>
<th>Button Name</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply</td>
<td>Apply the current settings without closing the dialog box.</td>
</tr>
<tr>
<td>Reset</td>
<td>Reset the box to its previous settings, undoing any changes you may have made.</td>
</tr>
<tr>
<td>Close</td>
<td>Close the box without applying the current settings. You can do the same thing by double-clicking the Control button.</td>
</tr>
<tr>
<td>OK</td>
<td>Apply the current settings and close the dialog box.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Close the box without applying the current settings.</td>
</tr>
<tr>
<td>Yes</td>
<td>Answers &quot;yes&quot; to the question presented and closes the dialog box.</td>
</tr>
<tr>
<td>No</td>
<td>Answers &quot;no&quot; to the question presented and closes the dialog box.</td>
</tr>
<tr>
<td>Stop</td>
<td>Ends the task in progress at the next possible stopping point.</td>
</tr>
</tbody>
</table>
**Default button:** If a button is surrounded by a thick border, then that button is the default button. The default button represents the safest or most common choice in the dialog box. Pressing [Enter] selects the default button.

**Radio buttons:** Radio buttons always come in groups of two or more. Only one of the buttons in a group can be on at a time. Clicking a radio button turns that item on and turns off any others in the group. On EGA and VGA monitors, radio buttons appear as diamond markers.

**Check boxes:** A check box can be either on or off. When the box is highlighted, the item is on; otherwise, it is off. Clicking a check box switches the box from on to off, or from off to on.

**Up and down arrows:** Many items have up and down arrows for cycling through options or for incrementing and decrementing a number. Clicking the up arrow cycles to the next item or increments the number. Clicking the down arrow cycles to the previous item or decrements the number. Pressing an arrow (rather than clicking), cycles continuously.

**Scrolling list:** When there is a list of options to choose from, these choices are provided in a scrolling list. A scrolling list is like a miniature window.

**Text field:** A text field appear in a dialog box when you need to enter text. You can edit the text in a text field just as you edit text anywhere else.
Responding to a Dialog Box

To respond to a dialog box you set options and fill in the text fields provided. Then, you click one of the buttons at the bottom of the dialog box to apply the settings and continue.

To respond to a dialog box...

1. Set any options in the dialog box by clicking to turn them on or off.

To select an item from a list, click the item you wish to select. To change your selection, simply click another item. You may need to scroll the list to see more choices. See "Using Windows" earlier in this chapter for more information on scrolling.

To enter and edit text in a text field, first click in the text field you want to edit. The text cursor appears where you click. Now type on the keyboard. Characters appear at the text cursor. Press [Backspace] to delete characters if you make a mistake. See "Entering and Editing Text" in this chapter for more information on text editing techniques.

2. Click one of the buttons at the bottom of the box to proceed.

Most dialog boxes have a default button, identified by a thick border. Pressing [Enter] on the keyboard is the same as clicking this button.

If the dialog box has a Cancel button, pressing [Esc] on the keyboard is the same as clicking this button.

Some dialog boxes stay open when you are done. You can move such a box by dragging its title bar, and you can close it by double-clicking its Control button.
Using Dialog Boxes

**Entering Measurements**

In some dialog boxes you can enter units of measure. The default is usually inches, but you can use any of the following units as long as you type the correct abbreviation.

<table>
<thead>
<tr>
<th>Units of Measure</th>
<th>Abbrev.</th>
<th>Sample Entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>inches</td>
<td>in or &quot;</td>
<td>1</td>
</tr>
<tr>
<td>picas</td>
<td>pi</td>
<td>6 pi</td>
</tr>
<tr>
<td>points</td>
<td>pt</td>
<td>100 pt (about 1.39 inches)</td>
</tr>
<tr>
<td>centimeters</td>
<td>cm</td>
<td>2.54 cm</td>
</tr>
<tr>
<td>millimeters</td>
<td>mm</td>
<td>635 mm (about 25 inches)</td>
</tr>
<tr>
<td>ciceros</td>
<td>ci</td>
<td>5.63 ci</td>
</tr>
<tr>
<td>European points</td>
<td>ep</td>
<td>67.57 ep</td>
</tr>
</tbody>
</table>

**Responding to a Dialog Box With the Keyboard**

You can also use the keyboard to select options in a dialog box. When responding with the keyboard, you move a dotted selection cursor to highlight different items and turn them on or off.
To respond to a dialog box using the keyboard...

1. Use the following techniques to move the selection cursor and set options in the dialog box:

   • If a dialog box has more than one group of options, press \( \text{Tab} \) or \( \text{Shift} + \text{Tab} \) to move forward and backward between the groups.

     Once the selection cursor is in a group, press the \( \uparrow \) \( \downarrow \) \( \leftarrow \) \( \rightarrow \) keys to move from item to item.

   • To jump quickly within a dialog box, press the mnemonic for one of the items. (As in menus, a mnemonic is a single character or number marked by an underline. To jump directly to an item titled Style, you would simply press \( T \)). If you are editing in a text field, you need to hold down \( \text{Alt} \) while pressing the mnemonic.

   • To switch an item from on to off or from off to on, move the selection cursor to the item and press \( \text{Spacebar} \) on the keyboard.

2. When you finish setting options, select one of the buttons at the bottom of the box to proceed. Use the following techniques:

   • Most dialog boxes have a default button, which is identified by a thick border. To select this button press \( \text{Enter} \) on the keyboard.

   • You can press \( \text{Tab} \) or \( \text{Shift} + \text{Tab} \) until the selection cursor surrounds the button, then press \( \text{Enter} \) or \( \text{Spacebar} \).

   • You can press the mnemonic of the button you want to select. If you are editing in a text field, you need to hold down the \( \text{Alt} \) while pressing the mnemonic.

   • If the dialog box has a Cancel button, pressing \( \text{Esc} \) on the keyboard is the same as clicking this button.
Before you work with an application, you first need to start it. Starting an application loads it from disk into memory and opens its window. Once an application starts, you can work with its documents. When you are finished using an application, you can exit it, which closes its window and removes it from memory.

You can start as many applications as you want, and you can switch between them with ease. However, because every application you start takes up memory in your computer, it’s a good idea to only start applications you think you’re going to use. If you start too many applications, and your computer seems sluggish, you should exit a few of them to free up some memory.

Starting an Application

You can start an application from the GeoManager window by opening its file or one of its documents. You can also start an application from the Express menu.

To start an application by opening its file...

Double-click the application icon to select and open the application in one quick step.

You can also double-click the application icon to select and open the application in one step.

See “Starting a GEOS Application” in Chapter 5, “Using GeoManager,” for more information.

To start an application by opening one of its documents...

1. Click the DOCUMENT directory button to display the window of GeoManager documents.
2. In the DOCUMENT directory, click to select the icon of the document you wish to start. If you have created additional directories, you may need to open them to find the document.

3. With the document selected, choose Open from the File menu. The application loads from disk and the selected document opens.

You can also double-click the document icon to select and open the document in one step.

See “Starting a GEOS Application” in Chapter 5, “Using GeoManager,” for more information.

---

**To start an application using the Express menu...**

1. Choose Startup from the Express menu. A cascade menu appears, showing all the available applications.

2. On the cascade menu, click the name of the application you wish to open. The application loads from disk and its window opens.
Switching Between Applications

You can start as many applications as you want in the Professional Workspace. When you start a new application, its name gets added to the list on the Express menu. The Express menu shows all applications currently running in the workspace.

You can switch between applications by clicking their respective windows or by choosing from the Express menu.

To switch between running applications...

Do one of the following:

- Click the window of the application you wish to use.
- Choose an application from those listed at the top of the Express menu.

The application activates and its window comes to the top of the screen.

Shrinking and Enlarging an Application

When you work with multiple applications, it's easy to end up with a lot of windows on the screen. To minimize the clutter, there are a couple of things you can do.
If you want to concentrate on the contents of a particular application, you can *maximize* (enlarge) the application to fill the entire screen. Likewise, if you want to set an application aside while you work on something else, you can *minimize* (shrink) it to an icon on the workspace.

**To shrink an application to an icon (minimize)...**

Click the minimize button at the top-right of the window. The window shrinks to an icon. The application continues to run, its contents just don’t display in a window.

You can also choose Minimize from the Control menu.

**To move an icon on the workspace...**

With the pointer over the icon, press and drag it to a new location. The icon moves to its new position.

**To restore an application from an icon to its original size...**

Double-click the icon. The application is restored to its original size.
To enlarge an application to fill the screen (maximize)...

Click the Maximize button in the top right corner of the window.

The window enlarges to fill the screen, and the Maximize button is now called a Restore button.

You can also choose Maximize from the Control menu.

To restore an enlarged application to its original size...

Click the Restore button in the top right corner of the window. The window is restored to its previous size. The Restore button changes back to a Maximize button.

You can also choose Restore from the Control menu.

Exiting an Application

You exit an application when you finish working with it. Exiting an application removes the application from memory and closes its window.

To exit an application...

Do one of the following:

- Choose Exit from the File menu of the application.
- Double-click the Control button in the upper left corner of the application's window.

The application closes its window and removes itself from memory. If you have made changes to any open documents, the application asks you if you wish to save the changes before exiting.
Most applications automatically create an untitled document when they start. You can also create an untitled document by choosing New from the File menu. Most applications make you name the document the first time you save it.

As you enter new information into a document, these changes are stored in the computer's memory but are not automatically made permanent. To make any changes permanent, you need to save the document.

You normally save documents in the DOCUMENT directory (or in subdirectories within that directory), although you are free to save them anywhere you want. Since documents appear as files in the GeoManager window, you can move, copy, and delete them like any other files.

You don't need to save after every small change—only at major milestones—because GEOS has a special safeguard feature that periodically copies your work to disk and keeps it safe in case of a power outage or other mishap (see “The Preferences Desk Tool” in Chapter 11, “Using the Desk Tools,” for more information). Additionally, if you've made some changes you don't want to keep, you get rid of them and go back to the last saved version of a document by using the Revert command on the File menu.

To create a new, untitled document...

With the application started, choose New from the File menu. A new, untitled document appears.

Since many applications automatically create a new, untitled document when you start them, it may be easiest to just start the application when you want to create a new document. (Note: This shortcut does not work with all applications. Some applications,
such as GeoDex and GeoPlanner, open default documents instead of creating new ones when they start in this manner.)

To open a document from within an application...

1. Choose Open from the File menu. A dialog box appears, listing the documents you can open with the current application.

Items on the list which have a folder symbol represent directories. They are not documents. You can open a directory by double-clicking a directory entry in the list.

2. If there are more items in the list than will fit in the window, use the scroll bar to view different parts of the list.

3. If you wish to open a document that is in a different directory or on a different disk drive, use the file list to change directories or disk drives first. See “Using File Lists” later in this chapter for information.

4. When you see the document you wish to open, click to select its name in the file list. The name is highlighted, indicating the selection.
5. Click Open. The dialog box goes away and the selected document opens.

You may also double-click the name of the document in the file list to select and open the document in one step.

To open a document from within GeoManager...

1. With the GeoManager window displayed, click the DOCUMENT directory icon. The DOCUMENT directory window appears.

2. Select the document you wish to open.

3. Choose Open from the File menu. The application which created the document starts; the selected document opens automatically.

You may also double-click the document to select and open it in one step.

To work on a copy of a document...

1. Open a document in the normal manner.

2. Choose Save As from the File menu. The Save As dialog box appears.

3. Type a name for the new copy of the document.

4. Click Save or press \( \text{Enter} \). An exact copy of the document is created and appears ready for editing. The original document is left unchanged.

You can also work on a copy of a document by duplicating the document with GeoManager. See “Managing Files and Directories” in Chapter 5, “Using GeoManager,” for more information.
To save a document for the very first time...

1. Choose Save from the File menu. A dialog box appears, asking you to supply a name and destination directory for the document.

2. If you wish to save the document in a different directory or on a different disk drive, use the file list to change directories or disk drives first. See “Using File Lists” later in this chapter for more information.

3. Type a name for the document, up to 30 characters in length. The name you type appears in the dialog box.

4. Click Save or press [Enter]. The newly-created document is saved to disk.

To save a document and make its changes permanent...

Choose Save from the File menu. The document is saved to disk. Any changes you have made are now made permanent.
To save a copy of a document under a different name...

1. Choose Save As from the File menu. The Save As dialog box appears.

2. Type a new name for the document, up to 30 characters in length. The name you type appears in the text box, replacing the original name of the document.

   If you wish to save the document in a different directory or on a different disk drive, use the file list to change directories or disk drives. See "Using File Lists" later in this chapter for information.

3. Click Save or press [Enter]. The document is saved to disk under its new name. The original document is left unchanged, as you last saved it.

   If you have made a lot of changes to a document, but you’re not quite sure you want to make them permanent, use the Save As command to save the document and its changes under a different name. After using Save As, you are left editing the new document. Any further changes are saved in the new document. To edit the
original document again, use the Open command on the File menu to reopen the original document.

For example, if you open a document named “Joe’s Monthly Report,” and make changes to it, but decide you don’t want to save those changes over the original document, you can use the Save As command to save the new version of the document under a different name. You could save the document as “Joe’s Revised Monthly Report,” leaving the original “Joe’s Monthly Report” unchanged.

To recover the last saved version of a document...

1. Choose Revert from the File menu. A dialog box appears, asking if you are sure you wish to revert.

2. Click Yes. The document is restored to its last saved version. If you have made changes since the last time you saved the document, those changes are lost.

Use the Revert command to undo changes you wish you hadn’t made. Revert restores the document to its last saved version, erasing any changes from memory.

If you make changes to a document but do not want to overwrite the original document, use the Save As command to save the changes to a new document.

To close a document when you are finished working with it...

Choose Close from the File menu. The document closes.

If you’ve made changes to the document, a dialog box first appears asking if you wish to save your changes. Follow the directions in the dialog box if necessary. If you don’t save your changes when you close a document, your changes are lost forever.
You can also close a document by exiting the application. If you have unsaved changes in a document, the application automatically asks you if you would like to save the changes before exiting.

**Using File Lists**

A file list lets you select documents you want to open and lets you choose the directories where you save your documents. Commands that use file lists include Open, Save, and Save As.

**List window**: Files and directories available for selection appear in this window. Use the scroll bar to see more of the list. Click to select a file or directory.

**Name of current disk**: The volume name of the disk whose directories are being shown appears at the top of the file list. If the disk does not have a volume name, its name is shown as "[Untitled]."
Current pathname: The pathname of the current directory appears above the file list. When you open a directory, the name of the directory is added to the pathname and the contents of the directory appear in the list window.

Change Disk button: Click the Change Disk button to switch to another disk drive or floppy disk.

Up Directory button: Click the Up Directory button to close the current directory and display the contents of the previous directory, one level up.

To open a directory in a file list...
Double-click the name of the directory you wish to open. (Small folder icons appear next to directory names in the file list to distinguish directories from files.)

To close the current directory...
Click the Up Directory button. The current directory closes and the contents of the previous directory (the directory one level up) appear in the file list window.

To display the contents of a different disk...
1. Click the Change Disk button located above the file list. A catalog of disk drives attached to your computer appears in the file list window.

Disk drives are listed by drive letter. Floppy drives are usually shown as A: and B:. Your hard disk and hard disk partitions appear as other letters, starting with C:.
2. If the disk you want to use is not in a disk drive, insert it now.
   (If another disk is already in the disk drive, remove it before
   inserting a new one)

3. Double-click the letter of the drive you wish to use. The
   contents of the disk display in the file list window.

**Summary of the File Menu**

Most applications have a file menu with at least the following commands:

**Open:** The Open command opens a document you have already created.

**New:** The New command creates a new, untitled document.

**Close:** The Close command closes the current document. If you have
made changes, you are asked if you wish to save your changes.

**Save:** The Save command saves the current document.

**Save As:** The Save As command saves the current document under
a different name. The original document remains as it was when you
last saved it and you are left editing the new document with the
different name.

**Revert:** The Revert command recovers the last saved version of the
document. Any changes you have made since then are lost.

**Exit:** The Exit command exits the applications and closes all
documents. If you have made changes to any documents, you are
asked if you want to save your changes.
Working With Multiple Documents

Many applications let you work with more than one document at a time. When you open multiple documents, you can control how you use them with the commands on the Window menu.

Every document appears in its own window. You can work with these document windows as either overlapping or full-sized.

Work with one document at a time...

...or many at once.
When working in the full-sized mode, you only see one document window at a time. If you switch to the overlapping mode, you can work with more than one document side by side.

**To open multiple documents...**

Use the Open command on the File menu to open each document you want to work with. If the Open command is dimmed, then the application you are using can't open any more documents.

The documents appear in the order that you open them, each in its own window. You normally can't see all the windows because they are stacked on top of each other in full-sized mode.

**To work with documents as overlapping windows...**

Choose Overlapping from the Window menu. All open documents become overlapping windows.

When working with documents as overlapping windows, the document windows behave much like any other kind of window—they can be moved, resized, and activated in the same way as application windows. The only difference is that document windows are confined to the area of the application that would normally display the single document window.

**To switch back to full-sized document windows...**

Use one of the following methods:

- Choose Full-Sized from the Window menu.
- Click the Maximize button on any one of the overlapping windows.

All open documents become full-sized windows, with the active window on top.
To switch between open documents...

If you are in full-sized mode, choose the name of the document from the Window menu.

If you are in overlapping mode, either click in the window of the document you want to use or choose the name of the document from the Window menu.

To close a document window...

When working in either full-sized or overlapping mode, do this:

Activate the window of the document you wish to close, and choose Close from the File menu. The window closes.

When working with overlapping windows, however, you can also do the following:

Double-click the Control button on the document window.

Alternatively, you can single-click the Control button, then choose Close from the menu that appears.

If you have a lot of documents open and you wish to close them all, it might be quicker to simply exit the application (which closes all the documents), then restart.
Many actions require that you first select an item in a window and then choose a command to act upon it. The act of selecting doesn’t change anything; it is merely how you specify what you want to work with.

For example, to duplicate a file with the GeoManager, you first select the file you wish to duplicate and then choose the Duplicate command from the File menu.

Another example: To change the pattern or color of a shape in a drawing program, you first select the shape you want to change and then choose the pattern and color you want. The selected shape changes to reflect your choices.

When you select an item, it becomes highlighted on the screen. Different applications have different ways of highlighting items. The most common method of highlighting is to reverse the colors so that white becomes black. Some applications, such as those for drawing and painting, have other methods of highlighting selected items. In every case, though, selected items and unselected items are visually distinct.

<table>
<thead>
<tr>
<th>Type of item</th>
<th>unselected</th>
<th>selected</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application icon</td>
<td><img src="image1" alt="GeoWrite" /></td>
<td><img src="image2" alt="NotePad" /></td>
</tr>
<tr>
<td>Text</td>
<td>Unselected text</td>
<td>Selected text</td>
</tr>
<tr>
<td>GeoDraw graphic</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

If you select an item and forget what to do next, simply browse through the menus. Commands that won’t work with the selected items are dimmed and are therefore unavailable for use.
You can select a single item or you can select a group of items. Selecting a group of items lets you work with many items at once. You can also select text, but you need to use completely different techniques to do so. See “Entering and Editing Text” later in this chapter for more information on selecting text.

**Selecting a Single Item**

Most of the time you only need to work with one item at a time, and so you only need to select a single item.

**To select a single item…**

Click the item in the window. The item is highlighted to indicate the selection.

If you accidentally select the wrong item, click another item to change the selection.

If the item you click isn’t highlighted, it may not be selectable.

**To deselect a single item…**

Do one of the following:

- Click a different item. The new item is selected and the original item is deselected.
- Click an area of the window where no item appears. The original item is deselected.

**Selecting a Group of Items**

By selecting a group of items you can work on many items at once. If you select a group of items and then choose a command, the command affects all items in the group.
For example, if you are in the GeoManager application and you want to duplicate more than one file, you can select all the files as a group—this is called a group selection—then choose the Duplicate command from the File menu. GeoManager duplicates each file in the group.

There are many ways to select a group of items. You can select the items one at a time or you can select them by specifying a range. Once you have a group of items selected, you can adjust or extend the selection to include items that are not yet selected. You can also deselect specific items to remove them from the group selection.

To select a group of items one at a time...

1. Click the first item. The item is highlighted to indicate the selection.

2. Hold down the Ctrl key and click additional items you wish to add to the group. Items are highlighted as you add them to the group selection.

   If you make a mistake selecting an item and wish to deselect it, click the item again with the Ctrl key still held down. The item is deselected.

3. When finished selecting items, release the Ctrl key.

To select a group of items by dragging...

1. Position the pointer near—but not on—the first item you want to select.

2. Press and hold down the left mouse button while dragging in any direction. The outline of a box follows the pointer, shrinking and growing as you drag the mouse. Drag the outline so that it encloses the items you want to select.
3. When the outline of the box surrounds the items you want to select, release the mouse button. All items contained in the box are highlighted to indicate the selection.

To select a group of items between two points...

1. Click the first item. The item is highlighted to indicate the selection. This is the first point.

2. Hold down the [Shift] key and click another item. This is the second point. All items between the two points become selected.

If you make a mistake selecting the item for the second point, click another item while holding down the [Shift] key. The selection changes to comprise the new group.

To start over, release the [Shift] key and begin a new selection.
To add additional items to a group...

1. With the \texttt{Ctrl} key held down, select items in the normal manner: click to add a single item to the group or drag to add a range of items to the group. Items are highlighted to indicate their selection.

2. When you finish selecting, release the \texttt{Ctrl} key.
   
   You may repeat this process to add as many items to the group as you desire.

To subtract items from a group...

1. With the \texttt{Ctrl} key held down, do one of the following:
   
   • Click a selected item to subtract it from the group. The item is deselected.
   
   • Drag over a range of selected items to remove the range of items from the group. The items in the range are deselected.
   
   When the items are deselected, it means they are no longer part of the group.

2. When you finish, release the \texttt{Ctrl} key.
   
   You may repeat this process to remove as many items from the group as you desire.

To select multiple ranges...

1. Select the first range of items in the normal manner, either by dragging or using some other method.

2. With the \texttt{Ctrl} key held down, select another range.
   
   You may repeat this step as many times as you like to select additional ranges.
3. Release the **Ctrl** key. The items remain selected.

**To deselect a group of items...**

Click an area of the window where no item appears. You should not hold down any keys while doing this. The group of items is deselected.

You can also click to select a single item (don't hold down the **Ctrl** or **Shift** key). The single item is selected, and the group of items is deselected in the process.
Nearly every GEOS application allows you to enter and edit text. Sometimes you enter and edit text to fill out text fields in dialog boxes; other times, as in a word processor, entering and editing text is central to the whole application.

The techniques for entering and editing text are the same in all applications. So once you learn how to use a word processor to edit text you'll be able to edit text in a drawing program or address book or calendar.

Anywhere you enter and edit text you see a flashing text cursor. The text cursor marks the place where new characters appear when you type on the keyboard.

To position the text cursor...

Click anywhere in text. The text cursor moves to where you click.
To enter characters...

Type on the keyboard. Characters appear at the position of the text cursor.

- Press [Backspace] to delete characters to the left of the text cursor, one at a time.
- Press [Del] to delete characters to the right of the text cursor, one at a time.
- Click to reposition the text cursor. You can also reposition the text cursor using the [←] [→] [↑] [↓] keys.

Selecting and Editing Text

Selecting text is a way of specifying a particular range of text you want to change as a whole. When you select a range of text, the characters reverse their colors to indicate the selection: Black becomes white and white becomes black.

The simplest way to select a range of text is by dragging. In addition to dragging, there are additional ways of selecting text, including ways to quickly select multiple words, lines, and paragraphs at a time.

Once you have selected a range of text, you can operate on that range. The two simplest operations involve deleting the range and replacing the range.
To select a range of text by dragging...

1. Position the pointer over the first character you want to select.

2. Press and hold down the mouse button while dragging across the text. Text is highlighted as you drag the pointer.

3. When the range you want to select is highlighted, release the mouse button. The text remains selected.

To select a range between two points...

1. Click to place the text cursor to the left of the first character you want to select.

2. Hold down the \[\text{Shift}\] key and click at the point where you want to extend the range. Text between the text cursor and where you click is highlighted to indicate the selection.

If you make a mistake in selecting the range, hold down the \[\text{Shift}\] key and click somewhere else. The selection adjusts to where you click.
To select words quickly...

Double-click a word to select that word.

To select a range of words, start a double-click, but don’t release after the second click. Instead, keep the mouse button pressed and drag in any direction. Words are highlighted as you drag. You can also hold down the [Shift] key and click to extend the word selection.

To select lines quickly...

Triple-click anywhere over a line to select that line.

To select a range of lines, start a triple-click, but don’t release after the third click. Instead, keep the mouse button pressed and drag up or down. Lines are highlighted as you drag. You can also hold down the [Shift] key and click to extend the line selection.

To select larger units...

In the same way that you double-click to select words and triple-click to select lines, you can quadruple-click (four times) and quintuple-click (five times) to select even larger units of text, such as paragraphs and pages. Each successive click selects a larger unit of text.

As with words and lines, you can extend the selection by dragging instead of releasing after the last click. Also, you can hold down the [Shift] key and click to extend the selection in the larger units.

To adjust a range...

Once you have selected a range of text, you can adjust the range to include more or less text.

To adjust the range, hold down the [Shift] key and click to where you want the range to end. The selection changes.
If you hold down the Shift key and press the ↑ ↓ ← → keys, you can adjust the range a character or line at a time using the keyboard. See “Keyboard Editing” later in this chapter for more information.

To delete a range of text...

1. Select the range of text you wish to delete.
2. Press Del or Backspace. The selected range goes away.

To replace a range of text...

1. Select the range of text you wish to replace.
2. Type on the keyboard. The selected range goes away and is replaced by the characters you type.

Keyboard Editing

As you become more proficient editing text, you will probably want to start editing mostly from the keyboard so you don’t have to stop typing to reach for the mouse. As the following table illustrates, there are numerous keyboard editing techniques.
## Entering and Editing Text

### Keyboard Editing Tables

#### Moving the Text Cursor

- **A character/line in any direction**
  - Select to beginning of paragraph
  - Select to end of paragraph
  - Select whole paragraph

- **One word backward**
  - Ctrl + End

- **One paragraph backward**
  - Ctrl + Home

- **One paragraph forward**
  - Ctrl + End

- **To beginning of line**
  - Ctrl + Home

- **To end of line**
  - Ctrl + End

- **To beginning of text**
  - Ctrl + Home

- **To end of text**
  - Ctrl + End

#### Selecting Text

- **Select left, right, up, down**
  - Shift + Home

- **Select to beginning of word**
  - Shift + Home + Ctrl

- **Select to end of word**
  - Shift + Home + End

- **Select whole word**
  - Shift + Spacebar

- **Select to beginning of line**
  - Home

- **Select to end of line**
  - End

- **Select whole line**
  - Ctrl + Home + End

- **Select to beginning of paragraph**
  - Home

- **Select to end of paragraph**
  - End

- **Select whole paragraph**
  - Ctrl + Home + End

- **Select to beginning of column/page**
  - Ctrl + Home + Page Down

- **Select to end of column/page**
  - Ctrl + End + Page Down

- **Select whole column/page**
  - Ctrl + Home + End + Page Down
### Adjusting a Text Selection

<table>
<thead>
<tr>
<th>Operation</th>
<th>Key Sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust selection in any direction</td>
<td>Shift + Up, Down, Left, Right</td>
</tr>
<tr>
<td>Adjust to previous word</td>
<td>Shift (Ctrl) + ←</td>
</tr>
<tr>
<td>Adjust to next word</td>
<td>Shift (Ctrl) + →</td>
</tr>
<tr>
<td>Adjust to beginning of line</td>
<td>Shift + (Home)</td>
</tr>
<tr>
<td>Adjust to end of line</td>
<td>Shift + (End)</td>
</tr>
<tr>
<td>Adjust to beginning of paragraph</td>
<td>Shift (Ctrl) + ↑</td>
</tr>
<tr>
<td>Adjust to end of paragraph</td>
<td>Shift (Ctrl) + ↓</td>
</tr>
<tr>
<td>Adjust to beginning of column/page</td>
<td>Shift (Ctrl) + (Home)</td>
</tr>
<tr>
<td>Adjust to end of column/page</td>
<td>Shift (Ctrl) + (End)</td>
</tr>
</tbody>
</table>

### Deleting Text

<table>
<thead>
<tr>
<th>Operation</th>
<th>Key Sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete character to right</td>
<td>Del</td>
</tr>
<tr>
<td>Delete character to left</td>
<td>(Backspace)</td>
</tr>
<tr>
<td>Delete to end of word</td>
<td>Ctrl + (Backspace)</td>
</tr>
<tr>
<td>Delete to beginning of word</td>
<td>Ctrl + Del</td>
</tr>
<tr>
<td>Delete to end of line</td>
<td>Shift (Ctrl) + Del</td>
</tr>
<tr>
<td>Delete to beginning of line</td>
<td>Shift (Ctrl) + (Backspace)</td>
</tr>
<tr>
<td>Delete selection</td>
<td>Del or (Backspace)</td>
</tr>
</tbody>
</table>

### Overtyping and Inserting

Normally when you type, characters appear at the position of the text cursor and existing characters move to the right. This is called insert mode because new characters are inserted at the cursor position.
There is another mode, called overtype mode, where characters type over characters to the right, like a typewriter, rather than pushing characters over. You can switch between insert and overtype mode at any time. The shape of the text cursor indicates the mode you are currently in.

To switch between insert and overtype mode...

Press the \texttt{Ins} key. Text editing switches from insert mode to overtype mode or vice-versa. The shape of the text cursor changes to indicate which mode you are in.
You can share text and graphics between two documents by cutting and pasting between them. You cut or copy items from one document and then paste them into the other. You can also cut and paste within the same document.

**Using the Clipboard**

GEOS uses a computerized clipboard to store text or graphics you are moving or copying. First you select the text or graphics you want to work with, then you choose either the Cut or Copy command. The Cut and Copy commands place the selected text or graphics on the clipboard, where they remain until the next time you cut or copy.

Once you have placed something on the clipboard, you can paste it anywhere else—in the same document or in another document.
If you are using the clipboard with different documents, the documents don’t even have to be of the same type or created by the same application. This is how you can transfer information from a drawing program to a word processing program.

You use the commands on the Edit menu to transfer items to and from the clipboard.

![Clipboard Commands](image)

**Cut:** The Cut command moves the selected text or graphics from the current document onto the clipboard.

**Copy:** The Copy command places a copy of the selected text and graphics onto the clipboard; the original selection remains unchanged.

**Paste:** The Paste command copies the contents of the clipboard into the current document. If you are pasting into text, the contents appear at the position of the text cursor.

**To move text or graphics using the clipboard...**

1. Select the text or graphics you want to move.

2. Choose Cut from the Edit menu. The selected information is removed from the document and placed on the clipboard.
3. Choose where you want the information to appear, either in the same document or another document. For example, this could mean clicking to position the text cursor.


**To copy text or graphics between two documents...**

1. Select the text or graphics you want to copy.
2. Choose Copy from the Edit menu. The selected information is copied from the document to the clipboard.
3. Choose where you want the information to appear, either in the same document or another document. For example, this could mean clicking to position the text cursor.

**Using Quick Move and Quick Copy With Text**

If you want to swiftly move or copy text between two documents or even within the same document, you can use the Quick Move and Quick Copy features of GEOS.

The Quick Move and Quick Copy features let you take nearly any text you see in one document on the screen and quickly move or copy it somewhere else. The Quick Move and Quick Copy do not use the clipboard, so the contents of the clipboard remain intact.
To Quick Copy text...

1. Select the text you want to Quick Copy.

2. Position the pointer over the selected text.

3. Press and hold down the right mouse button. The pointer changes to a Quick Copy pointer.

4. With the right mouse button still held down, position the pointer where you want to copy the text.

5. Release the right mouse button. A copy of the selected text appears at the position of the pointer.

If the text doesn’t copy, then you positioned the pointer over an area of the screen that won’t accept Quick Copy text.

To cancel a Quick Copy, position the pointer back over the original selection and release the right mouse button.

Quick Copy summary:
Select text, then drag the selected text with the right mouse button.

To Quick Move text...

1. Select the text you want to Quick Move.

2. Position the pointer over the selected text.

3. Hold down the \texttt{[Alt]} key while pressing and holding down the right mouse button. The pointer changes to a Quick Move pointer.

4. With the \texttt{[Alt]} key and the right mouse button still held down, position the pointer where you want to move the text.

5. Release the right mouse button first, then the \texttt{[Alt]} key. The selected text moves to the position of the pointer.

If the text doesn’t move, then you positioned the pointer over an area of the screen that won’t accept Quick Move text.

To cancel a Quick Move, position the pointer over the original selection, then release the right mouse button and the \texttt{[Alt]} key.

Quick Move summary:
Select text, then hold down the \texttt{[Alt]} key while dragging the selected text with the right mouse button.
**When you first** install GEOS, you have the opportunity to identify the printer attached to your computer. If you want to change your printer, or if you get a second printer, you can use the Preferences desk tool to tell GEOS about the change. See “The Preferences Desk Tool” in Chapter 11, “Using the Desk Tools,” for more information.

You print from within most applications by choosing the Print command from the File menu. A Print dialog box appears. The Print dialog box is more or less the same for most applications.

**Printer Options**: The Printer Options area displays the name of the current printer. A Change Options button lets switch printers (if you have more than one attached) and change other settings, such as paper size and the paper tray to use if your printer has more than one.

**Print Quality**: With most printers you have a choice of printing in either high or low quality. The High setting offers the best results. The Low setting offers the fastest printing. Some printers have an additional Medium setting.
Text Mode Only: Turning on this option prints a quick text-only draft of your document. The text-only draft uses your printer's internal fonts. It does not print in different fonts or styles, nor does it print graphics.

Print Pages: You have the choice of printing all the pages in your document, or, if there is more than one page, specifying a range of pages to print.

Number of Copies and Collate: You can print multiple copies of the same document. If the document has more than one page, you can choose to collate the copies by turning on the Collate option. Printing with the Collate option on can be slower than printing with it off.

To print with the default settings...

1. Choose Print from the File menu. The Print dialog box appears.
2. Click OK. The document prints with the standard settings.

To change the print quality...

1. Choose Print from the File menu. The Print dialog box appears.
2. Next to Print Quality, choose the setting you want:
   - High—highest quality print out; prints the maximum resolution of your printer.
   - Medium—prints at a medium quality (not available on all printers).
   - Low (Fast)—faster printing for drafts and documents where looks are less important than speed.
3. If you want to get a text-only draft, turn on the Text Mode Only option. This option prints using your printer’s internal fonts and does not print graphics.
4. Set any other options as desired.
5. Click OK. The document prints using the settings you have chosen.

**To print a range of pages...**

1. Choose Print from the File menu. The Print dialog box appears.

2. Next to Print Pages, click to select From. If your document only has one page, this option is disabled.

3. Change the From and To fields to the range of pages you want to print. Change these fields by clicking the arrows or by typing new numbers. To print all the pages in your document, click All.

4. Set any other options as desired.

5. Click OK. The pages you have selected are printed using the settings you have made.

**To print more than one copy...**

1. Choose Print from the File menu. The Print dialog box appears.

2. Change the Number of Copies by clicking the arrows or typing a new number.

3. If you want to print the document so that each copy is printed and sorted independently, turn on the Collate option. (If you are only printing one page, the Collate option is disabled.)

4. Set any other options as desired.

5. Click OK. The document prints.
Changing the Printer and Paper Options

The Change Options button in the Print dialog box leads to the Change Options dialog box, which you use to set the printer and paper options.

**Printer:** The printers you have identified as being attached to your computer are listed under this setting. The printer currently being used for printing is selected. You can select a different printer from the list if you want. To add printers to the list, use the Preferences desk tool to install them.

**Paper Size:** You can select the size of the paper in your printer from those listed in the scrolling list. If your paper size isn't listed, you can change the Width and Height fields to the custom size. Changing the paper size does not change the size of the printed image.

**Paper Source:** Some printers have multiple paper sources, such as different paper trays. Depending on your printer, you may be offered up to three Tractor feed and three Tray sources. Additionally, there may be a Manual Feed option, which pauses the printout between pages to let you insert sheets by hand.
To change printer and paper options...

1. In the Print dialog box, click Options. The Options dialog box appears.

2. Click to select the printer you want to use.

3. Click to select the paper size. If you can't find the paper size you want, enter the dimensions in the Width and Height fields.
GeoManager is a file management application that lets you easily perform file and disk management tasks, such as copying or deleting files and duplicating or formatting disks. There's no need to remember cryptic DOS commands, either, because you can do everything you want by dragging icons and choosing from menus.

The first part of this chapter introduces you to GeoManager and tells you how to open directories and view files in the GeoManager window. The remainder of the chapter provides instructions on managing files and disks.
USING GEO MANAGER

115  What You Can Do with GeoManager
116  The GeoManager Window
120  Selecting Files and Directories
122  Opening Directories
128  Changing the Viewing Options
133  Starting a GEOS Application
135  Starting a DOS Program or Batch File
136  Managing Files and Directories
147  Managing Disks
151  Using the Directory Tree
154  Changing GeoManager Options
156  Exiting GeoManager
With **GeoManager**, you can perform all your file and disk management tasks without having to remember a single DOS command. GeoManager shows files as icons—small symbolic pictures—on the screen. Instead of typing commands, you open files and perform management tasks by using the mouse to select and move icons that represent files, directories, and tasks.

GeoManager's features let you

- Open and view the contents of more than one directory at a time
- View the contents of a directory by name, size, or the date and time files were last modified
- Open GEOS applications and documents, as well as DOS programs and batch files
- Copy and move files and directories by selecting them with the mouse and dragging them to other disks and directories
- Delete files and directories by selecting them with the mouse and dragging them to the Wastebasket
- Perform all disk management tasks, such as formatting, copying, and renaming disks
- View the directory structure of a disk as a hierarchical tree, expanding and collapsing branches to see more or less detail
When you open a directory to view its contents, GeoManager displays the contents in the window. Normally the files and folders appear as icons (small pictures) in the window, although there are other ways to view the contents.

**Information bar:** The information bar displays the following information about the directory, including

- The directory pathname (the path of directories that leads to the directory).
- The number of files shown out of the total number contained in the directory (files not shown are hidden files).
• The number of bytes used by the files shown and the number of bytes free on the disk.

**File icon:** A file icon is an icon in the GeoManager window that represents a file on your disk drive. GeoManager displays both DOS and GEOS files. The name of the file appears below its icon.

**GEOS file:** Each type of GEOS application and document has a unique icon. The different icons help you quickly spot particular types of files. Additionally, a GEOS file can have a filename up to 32 characters in length, counting punctuation and spaces.

**DOS file:** Though you won't often see DOS and GEOS files in the same directory, DOS files have a unique icon that sets them apart if you do. Unlike GEOS files, DOS files must adhere to the standard DOS naming conventions: an eight-character file name and an optional three-character extension (FILENAME.EXT).

**Folder icon:** A folder icon in the GeoManager window represents a directory on your disk drive. A directory is like a folder in that it can contain other files. The name of a folder must adhere to the standard DOS naming conventions: an eight-character name with a three-character extension.

**Drive buttons:** The drive buttons let you display the contents of another disk drive. A floppy disk button appears for each floppy disk drive attached to your computer and a hard disk button appears for each hard disk. Additional buttons appear if you have a RAM disk, ROM disk, or other type of disk device (such as a LAN device) attached to your computer.

**Up Directory button:** Use this button to move up a level in the directory hierarchy. Displays the previous (parent) directory.

**Scroll bar:** The scroll bar lets you scroll the window to see more of the directory's contents, if any. See “Using Windows” in Chapter 4, “The Professional Workspace” for more information on using scroll bars.
**Wastebasket icon:** Use the Wastebasket to delete files and directories permanently.

**Full-Sized and Overlapping buttons:** The Full-Sized and Overlapping buttons let you switch between (respectively) viewing one directory at a time and viewing multiple directories at once.

**WORLD and DOCUMENT buttons:** GEOS has two main directories: WORLD and DOCUMENT. The WORLD directory contains applications (programs you can run), and the DOCUMENT directory contains documents (data files you can use). The WORLD and DOCUMENT buttons quickly open these two directories.

The GeoManager window also has standard features common to all GEOS windows (as shown below). See “Using Windows” in Chapter 4, “The Professional Workspace,” for more information.

---

**About Directories**

A directory is like a folder that contains other files—in fact, GeoManager uses folder icons to represent directories.

You can view the files contained in a directory by opening the directory.

A directory can contain only files, or it can contain other directories—as folders can contain other folders. A directory within another directory is sometimes called a *subdirectory*—and the directory that contains it is called the *parent* directory. All directories are subdirectories of the *root* directory, which is the topmost directory level on a disk. The root directory has no name.

The *directory pathname* represents the “path” of directories that lead to the directory shown in the window. Each directory level is separated by a backslash (\). For example, suppose the BAROQUE directory is contained within the MUSIC directory, which is contained
within the DOCUMENT directory. The pathname of the BAROQUE directory would look like this:

**DOCUMENT\MUSIC\BAROQUE**

To get to the BAROQUE directory from the root directory, you follow a path of opening first the DOCUMENT directory, then the MUSIC directory, then the BAROQUE directory.

An open directory is always identified by its pathname in the information bar of a GeoManager directory window.
Selecting Files and Directories

**Before you can** open a file or directory, or perform any other operation on it, such as moving or copying it to another place, you need to *select* it. You can select multiple items in the GeoManager window and perform the same operation on all of them. For example, you can select a group of files and then move all of them at the same time.

**To select a single item...**

Click the item you want to select. The item highlights to show that it is selected.

If you accidentally select the wrong item, try again. Clicking another item deselects the first item.

**To select a group of items by dragging...**

1. Visualize an imaginary box surrounding the group of items you want to select. Then position the pointer at one “corner” of this imaginary box.

2. Hold down the mouse button and drag diagonally until the dotted selection rectangle surrounds all the items you want to select. Then release the mouse button. The items highlight to show that they are selected.

If you missed an item, you can try again, or you can hold down the *Shift* key and drag to readjust the selection rectangle.
To add items to (or subtract them from) a selection...

1. Hold down the [Ctrl] key.

2. Click to select (or deselect) a single item.

   Or,

   Drag to select (or deselect) a group of items (see “To select a group of items by dragging,” earlier).

3. When you have finished selecting, release the [Ctrl] key.

To select all the items in a directory...

Choose Select All from the File menu.

To deselect all the items in a directory...

Choose Deselect All from the File menu.
Opening Directories

**When you want** to perform file management tasks (such as copying or moving files and directories), you begin by opening the directory that contains the items you want to work with. You can also open a directory to simply view its contents.

When you open a directory, its contents appear in a new window. When you are in the Overlapping view, you can open multiple directories from the same disk or from different disks. Each directory you open gets added to the list of directories at the bottom of the Window menu. You can switch between the open directories by choosing from this menu or by clicking the window of the desired directory. The directory you are working with is called the *current* or *active* directory, and its name is selected on the Window menu.

**Switching Between Full-Sized and Overlapping Windows**

You can view either one directory at a time in a full-sized window, or open directory windows together in an overlapping arrangement.

You can arrange overlapping directory windows any way you want. To move a directory window, you can drag its title bar; to resize a directory window, you can drag its resize borders. Arranging directories side-by-side lets you copy and move files between them with ease.
To view directories as overlapping windows...

Click the Overlapping button or choose Overlapping from the Window menu.

To view directories as full-sized windows again...

Click the Full-Sized button or choose Full-Sized from the Window menu.

Alternatively, click the Maximize button on any of the overlapping windows.

Opening the WORLD and DOCUMENT Directories

The WORLD and DOCUMENT directories contain your GEOS files. The WORLD directory contains GEOS applications; the DOCUMENT directory contains documents created with GEOS applications.

When you want to start a GEOS application or open a GEOS document, you can quickly display the contents of the WORLD or DOCUMENT directories by clicking their buttons at the bottom of the GeoManager window.

To open the WORLD or DOCUMENT directory...

Click either the WORLD directory button or the DOCUMENT directory button at the bottom of the GeoManager window.

The WORLD or DOCUMENT directory opens and its contents display in the window. If the directory is already open, its window comes to the top.
Opening a Directory From its Icon

Directories appear as folder icons in the window. When you open a directory, its contents appear in a separate window.

To open a directory from its folder icon...

Double-click the icon of the directory you want to open.

Or,

Select the icon of the directory you want to open and choose Open from the File menu.

The directory opens and its contents display in the window. If the directory is already open, its window comes to the top.

Opening the Parent Directory

You can display the preceding level in the directory hierarchy—often referred to as the parent directory—by clicking the Up Directory button on the directory window. When you click the Up Directory button, GeoManager displays the contents of the parent directory in a new directory window.

You can continue clicking the Up Directory button to display preceding directory levels until you reach the root directory (the highest directory level). When you are viewing the root directory, the button is dimmed to indicate there are no higher directory levels to view.

To open the parent directory...

Click the Up Directory button on the directory window.

The parent directory appears in a separate window.
Opening a Directory on Another Disk

You can display directories on another disk by clicking the appropriate drive button at the bottom of the GeoManager window. The letters on the buttons indicate which drives they represent.

To open a directory on another disk...

1. If you want to open a directory on a floppy disk, insert the disk in a floppy disk drive.

2. Click the Drive button for the floppy disk or hard disk you want to view.

GeoManager displays the root directory of the floppy disk or hard disk. You can display a directory by double-clicking the folder icon of the directory you want to view.

Changing the Active Directory

Only one of the open directories is active at a time. If you have more than one directory open, you can activate a different directory by
choosing the directory pathname from the Window menu. If you are viewing directories as overlapping windows, you can simply click the window of the directory you want to activate.

To activate another directory...

Choose the directory pathname from the Window menu.

If you are using the Overlapping view, you can also click the directory window you want to activate.

Closing Directories

A directory remains open until you close it. If you open a lot of directories, you should periodically close the ones you aren’t using any more.

To close the active directory...

Choose Close from the Window menu. The window of the active directory closes.

If you are viewing directories as overlapping windows, you have the option of double-clicking the Control button of the window you want to close instead of choosing Close from the Window menu.
To close all open directories...

Choose Close All from the Window menu. All the directory windows close.
Changing the Viewing Options

**Items in** a directory window normally appear as icons alphabetized by name. The Choices option on the View menu lets you change how files appear—for example you can view them by name instead of as icons, or you can arrange them in a different order, such as by size.

**Viewing as Icons or as a List**

You can choose to view the contents of a directory as icons or as a list. The View menu has three options for switching between icons and lists. The highlighted option is the one currently selected for the active directory.
Names Only: This option shows the contents of the directory as a list of small icons with the name to the right of the icons. This view is especially useful if you have a lot of files in a directory and want to see as many as possible without scrolling.

Names and Details: This option shows the contents of the directory as a list of small icons with the name, size, modification date, and attributes to the right of the icons. The four possible file attributes appear as single-letters to indicate they are set: Read Only (R), Hidden (H), System (S), and Archive (A). See “To change file attributes” later in this chapter for more information about file attributes.

The modification date that appears for a directory is the date you created the directory.
Changing the Viewing Options

**Icons:** This option shows the contents of the active directory as icons with the name below the icon.

**To change the current viewing option...**

1. Activate the directory you want to change.
2. Choose the option you want from the View menu.

The directory view changes according to your choice.

**Ordering Items**

The Sort By cascade menu on the View menu lets you control the order in which items are sorted in a directory. Directories always appear before files in any sort arrangement. The highlighted option is selected for the current directory.

There are three different ways to sort the items in a directory:

- **Name:** This option arranges the contents of the active directory alphabetically by name.
- **Date and Time:** This option arranges the contents of the active directory by the date and time the files were last modified, with the most recent first.
- **Size:** This option arranges the contents of the active directory by size, beginning with the largest file.

New windows you open "adopt" the viewing options of the window from which they were opened.
To change how files are sorted...

1. Activate the directory you want to change.
2. Choose Sort By from the View menu. A cascade menu appears.
3. Choose the arrangement you want from the cascade menu.

The directory view changes according to the option you choose.

Showing Hidden Files

When you turn on the Show Hidden Files option on the View menu, files that have the Hidden or System attribute assigned to them also appear in the directory window and are included in the byte count on the information bar. Hidden and System files do not appear in the directory window when the Show Hidden Files option is turned off.

To turn the Show Hidden Files option on or off...

Choose Show Hidden Files from the View menu.

If the Show Hidden Files option is on, choosing the option turns it off. If it is off, choosing the option turns it on.
**Compressing the Directory Display**

When the Compress Display option in the View menu is turned on, directory items are displayed in a compact format that allows you to view as much of the directory's contents as possible without scrolling.

To turn the Compress Display option on or off...

Choose Compress Display from the View menu.

If the Compress Display option is on, choosing the option turns it off. If it is off, choosing the option turns it on.
Starting a GEOS Application

You can start another GEOS application while you are running GeoManager. When you start another GEOS application, its window appears on top of GeoManager (unless the Minimize on Run option is turned on in the Options menu). The title bar of the application you start appears highlighted to indicate that it is the active window—the one you are currently working in. You can start an application directly from the WORLD directory, or you can start an application by opening one of its documents from the DOCUMENT directory.

You can switch between GeoManager and any other open applications by choosing from the list at the top of the Express menu or by clicking the window to activate it (if you can see the window). Switching to another application moves its window to the top and makes it active.

See “Using Applications” in Chapter 4, “The Professional Workspace,” for more information.

To start a GEOS application...

1. Open the WORLD directory by clicking its icon.
2. Double-click the application in the WORLD directory.
   Or,
Select the application and choose Open from the File menu.

The application window appears on top of the GeoManager window. GeoManager remains open.

**To open a GEOS document...**

1. Open the DOCUMENT directory by clicking its icon.
2. Double-click the document in the DOCUMENT directory.
   
   Or,

   Select the document and choose Open from the File menu.

   The application which was used to create the document opens and the document appears in the window (which appears on top of the GeoManager window). GeoManager remains open.

**To switch to another open application...**

Choose the application from the Express menu, or click its window if the window is visible.

The window of the selected application becomes active.
Starting a DOS Program or Batch File

You can start a DOS program or batch file directly from GeoManager. The GeoManager window temporarily closes and the DOS program or batch file appears. When you quit the DOS program or the batch file finishes, the GeoManager window reopens automatically. The window appears exactly as it looked before it closed.

To start a DOS program or batch file...

1. Open the directory that contains the DOS program or batch file you want to start.
2. Double-click the file in the directory.
   
   Or,
   
   Select the file and choose Open from the File menu.

   The GeoManager window temporarily closes and the DOS program or batch file appears. When you quit the DOS program or batch file, you see a message that lets you return to GEOS or go directly to DOS. Follow the directions on the screen.

A DOS batch file is a sequence of DOS commands in a text file.

You can use the Notepad desk tool to edit batch files.
When you first create documents and directories, you might not have a clear system in mind for organizing or naming them. As you gain experience, you may decide to change your directory structure and reorganize your files. You may want to create new directories and move items from one directory to another. You may decide to rename files or directories and delete old ones to free up space on your disk.

This section describes how to use GeoManager to perform all your file and directory management tasks.

A Word About File and Directory Names

You assign a name to a file or directory when you

- Create a new directory

- Duplicate or rename a directory folder or a GEOS or DOS file

The names of GEOS applications and documents can be up to 32 characters long, including spaces and punctuation.

The names of directories and DOS files must conform to the standard DOS format. The file name can be from one to eight characters long. You can use both numbers and letters in the file name. The optional file name extension follows the file name and begins with a period. An example of a file name and extension is shown below:

![File name and extension](PROJECT3.TXT)

Optional period and extension

Creating a New Directory

You can create a new directory folder in any open directory. The new directory folder is empty until you move or copy items into it.

The more items a directory contains, the longer it takes to display its contents. If a directory takes too long to open, you may want to move some of its files into another directory.
To create a new directory...

1. Open the directory in which you want to place the new directory. If the directory is already open, make it active.

2. Choose Create Directory from the File menu.
   A dialog box appears requesting a name for the new directory.

3. Type the name of the new directory.
   For information about naming restrictions, see "A Word About File and Directory Names," earlier in this chapter.

3. Click Create.
   A new directory appears in the active directory.

Moving and Copying Files and Directories

The easiest way to move or copy a file or directory is to drag it from one window to another, or onto another icon such as a disk drive icon or a directory folder icon. You can also copy and move by using the Copy and Move commands on the File menu.

You drag items with the right mouse button. Dragging an item to a directory on the same disk moves the item to that directory. Dragging an item to a directory on a different disk copies the item. You can copy an item directly into the root directory of another disk by dragging the item to the disk icon at the bottom of the GeoManager window.

In the following procedures, the directory you copy or move items from is sometimes called the source directory, and the directory you copy or move them to is called the destination directory. If the destination directory already contains an item with the same name, you’re asked if you want to replace the existing item (unless you have turned off the Confirm Replace option in the Options menu). For more information about the confirmation options, see “Changing GeoManager Options,” later in this chapter.
To move or copy an item by dragging...

1. Select the item or items you want to move or copy.

2. Position the pointer over one of the selected items and press and hold down the right mouse button (not the left mouse button). The pointer changes to indicate whether you are dragging a single item or multiple items.

3. Drag the pointer and position it over one of the following elements, according to where you want to move or copy the items:

   • Over a folder icon in a directory window.
     If the directory represented by the folder is on the same disk, then the items are moved into the directory; if the directory is on a different disk, then the items are copied into the directory.

   • Over any area of a directory window, except over a folder icon.
     If the directory in the window is on the same disk, then the items are moved into that directory; if the directory is on a different disk, then the items are copied.

   • Over the up directory icon on a directory window.
     The items are moved to the parent directory, one level up in the directory hierarchy.

   • Over one of the disk drive icons at the bottom of the GeoManager window.
     The items are copied to the root directory of the disk currently in the drive.
4. Release the right mouse button.

When you move or copy more than one item, a dialog box appears showing you the progress of the operation. If you want to halt the move or copy operation, click Stop. The operation stops after finishing with the current file.

Normally GeoManager copies or moves depending on whether the source and destination directories are on the same disk or not. You can force a move operation by holding down the \texttt{Alt} key during the drag operation, or force a copy operation by holding down the \texttt{Ctrl} key.

**To move an item using the Move command...**

1. Select the item (or items) you want to move.

2. Choose Move from the File menu. In the Move dialog box, find and select the destination directory.

The Move dialog box shows the directories within the current directory (files in the directory are not listed; if the list is empty then there are no folders in the current directory).

To open a directory and view additional directories contained within it, double-click the directory, or select it and click Open.
3. Click Move to move the files into the directory.

When you move more than one item, a dialog box appears showing you the progress of the operation. If you want to halt the move operation, click Stop. The operation stops after finishing with the current file.

**To copy an item using the Copy command...**

1. Select the item (or items) you want to copy.

2. Choose Copy from the File menu. In the Copy dialog box, find and select the destination directory.

The Copy dialog box shows the directories within the current directory. Files in the directory are not listed; if the list is empty then there are no folders in the current directory.

To open a directory and view additional directories contained within it, double-click the directory, or select it and click Open.

3. Click Copy to copy the files into the directory.

When you move more than one item, a dialog box appears showing you the progress of the operation. If you want to halt the move operation, click Stop. The operation stops after finishing with the current file.
Duplicating a File or Directory

The Duplicate command on the File menu creates a duplicate copy of an item within the same directory. For example, you may want to duplicate a document file so that you can use the duplicate copy as a template for a new document.

When you duplicate many items, a dialog box gives you the chance to change the name of the duplicate copy of each item.

Choosing Duplicate automatically creates a duplicate copy of the file or directory, entitled "Copy of (file or directory name)." Clicking Next skips the current item. Clicking Cancel closes the message box without duplicating additional items.

To duplicate an item...

1. Select the item (or items) you want to duplicate.
2. Choose Duplicate from the File menu.
   A dialog box appears.
3. To change the name of the duplicate file or directory, type a new name.
   For information about naming restrictions, see "A Word About File and Directory Names," earlier in this chapter.
Managing Files and Directories

4. Click Duplicate.

A duplicate of the selected item (or items) appears in the same directory as the original.

If you're duplicating more than one item, the name of the next item appears in the dialog box.

Deleting a File or Directory

You can permanently delete a file or directory folder by dragging the item to the Wastebasket or by using the Delete command on the File menu. This section describes both methods. As when copying and moving by dragging, you use the right mouse button when deleting an item by dragging.

Be careful, though. You cannot recover a deleted item using GEOS.

To delete an item by dragging it to the Wastebasket...

1. Select the item (or items) you want to delete.

2. Use the right mouse button to drag the selection to the Wastebasket.

To drag, position the pointer over the selected item (or one of the items if multiple items are selected). Then, hold down the right mouse button and drag the file to the Wastebasket.

If the Confirm Deletes option is turned on, a dialog box appears asking you to confirm each deletion. Clicking Yes deletes the item. Clicking No preserves the item. Clicking Cancel closes the dialog box without deleting additional items.

If you delete more than one item, a dialog box may appear showing you the progress of the operation. If you want to halt the deletions, click Stop. The delete operation stops after the current file is deleted.
To delete an item using the Delete command...

1. Select the item (or items) you want to delete.

2. Choose Delete from the File menu.

   A dialog box may appear asking you to confirm the delete operation. Follow the instructions in the dialog box.

Renaming a File or Directory

You can change the name of a file or directory by using the Rename command on the File menu. The new name immediately replaces the old name in the directory window. For information about naming restrictions, see “A Word About File and Directory Names,” earlier in this section.

To rename an item...

1. Select the item (or items) you want to rename.

2. Choose Rename from the File menu.

   A dialog box appears. Enter the new name in the box. Click Rename to apply the new name. Click Next to skip the current item and go on to the next selected file. Click Cancel to close the dialog box without renaming the rest of the selected files.
If a file with the same name already exists, a dialog box asks you to type a different name.

**Changing DOS File Attributes**

There are four DOS file attributes that define the kinds of operations you can perform on a file or directory: Read Only (R), Hidden (H), System (S), and Archive (A).

An item can have one or more file attributes. File attributes appear in the directory window when you select the Names and Details option on the View menu. The file attributes appear in the last column of the listing.

The most useful attribute, and the only one you may ever want to change, is the Read Only attribute. When the Read Only attribute is set on a file, it adds a level of protection to the file and prevents the file from being changed or deleted easily. For example, if there are certain documents that you don't want to change accidentally, setting the Read Only attribute is a good way to protect them.

The Archive, Hidden, and System attributes are used by DOS and DOS utilities. They are not very useful to GEOS applications. Refer to your DOS reference manual for more information on these attributes.
To change file attributes...

1. Select the item (or items) whose attributes you want to change.

2. Choose Attributes from the File menu.

   The Change Attributes dialog box appears. Click to select the attributes you want to assign. Clicking a selected attribute deselects it.

3. Click Change to apply the attributes you've selected. Click Next to skip the current item and go on to the next one (if you selected more than one item). Click Cancel to close the dialog box without making any further changes.

Getting Information About a File or Directory

The Get Info command on the File menu displays the following information about a file. When you display information about a GEOS application or document, you can also enter your own notes.

To display information about an item...

1. Select the item (or items) and choose Get Info from the File menu.

   The Get Info dialog box appears.
2. If the item is a GEOS application or document and the Read Only attribute is not set, you can enter and edit text in the User Notes box. Notes are saved along with the file.

![File Information Dialog]

See “Entering and Editing Text” in Chapter 4, “The Professional Workspace,” for more information on editing text.

3. Click OK to save the notes and display information about the next item.

Click Next to skip this item and display information about the next item.

Click Cancel to close the dialog box.
The Disk menu commands let you perform the following disk management tasks:

- Copy a disk's contents onto another disk
- Format a disk so that it can be used
- Rename a disk
- Rescan any drives needed to update the contents of the open directories.

The disk name can be from 1 to 11 characters long, upper-case (lower-case letters are converted to upper-case). You can use both numbers and letters in the name, as shown in the following example:

LETTERS 12

Formatting a Floppy Disk

The Format Disk command on the Disk menu lets you format (or reformat) a disk. If the disk is unformatted, you must format it before you can use it. If you want test whether a disk is formatted, insert the disk in a floppy drive and click the drive icon to open the disk directory. A message tells you if the disk needs formatting.

Your formatting options depend on the capacity of your disk drive and the size of the disk you are formatting. In many cases you are given the option to choose high density formatting. High density formatting requires special high density disks, which you can find at most computer stores.

To format a floppy disk...

1. Insert the floppy disk into one of the disk drives.
2. Choose Format Disk from the Disk menu.

![Select drive and size for format:]

- **Select drive and size for format:**
  - **Drive:**
    - [ ] A:
    - [ ] B:
  - **Size:**
    - [ ] 1.2M (Requires High Density Diskette)
    - [ ] 360K (Low Density)
    - [ ] 320K (Rarely Used)
    - [ ] 180K (Rarely Used)
    - [ ] 160K (Rarely Used)

- For single-floppy systems, only A: appears

3. Click the drive that contains the disk you are about to format.

4. Click the option for the disk capacity you want.

5. Click OK.

   A dialog box appears requesting a name for the disk.

   Type a name for the disk, and click Format.

   GeoManager formats the disk according to the options you specified. A message lets you know how the formatting is proceeding and when it is complete.

### Copying a Floppy Disk

The Copy Disk command on the Disk menu lets you create an exact duplicate of a floppy disk. The original disk is called the *source disk* and the duplicate disk is called the *destination disk*. When you finish copying, the destination disk contains the same name and files as the source disk. GeoManager writes over any files that were on the destination disk.
To copy a floppy disk...

1. If you haven't done so already, label the source and destination disks.

2. Choose Copy Disk from the Disk menu.

   The following dialog box appears.

   ![Select source and destination for disk copy dialog box]

   3. Click to select the source drive and the destination drive.

      If you have only one drive, drive A appears as both the source and destination drive.

   4. Click Copy.

   5. GeoManager tells you if you need to insert a new disk. Just follow the instructions on the screen.

Renaming a Disk

The Rename Disk command on the Disk menu lets you change the name of a disk.

To rename a disk...

1. Choose Rename Disk from the Disk menu.

   -----------
Managing Disks

The following dialog box appears.

```
Select drive for disk rename:
○ A: ○ B: ○ C: ○ D:
From: HARD DISK
To: OLD_DISK

Rename  Cancel
```

2. Click to select the drive that contains the disk you want to rename.

3. Click in the text field and type a new name for the disk.

4. Click Rename to rename the disk.

Rescanning

If the contents of a disk have somehow changed (for example, if you use another computer to copy additional files onto a floppy disk), you can use the Rescan Drives command to update the directory display and show the new files.

To rescan...

Choose Rescan Drives from the Disk menu.

GeoManager rereads the contents of all displayed disks and changes the windows if necessary to reflect any changes.
The items on the Tree menu lets you see how directories are organized on a disk by displaying the directory hierarchy as an organizational tree. The root directory appears at the top of the tree, and branch lines connect directory names and show their relationship to the root directory.

You can control how much of the directory tree is displayed by expanding or collapsing the directories in the tree. Expanding a directory displays its subdirectories; collapsing a directory hides its subdirectories. A plus sign indicates that a directory can be expanded. A minus sign indicates that a directory is already expanded.

The Tree window does not show the files within a directory. However, you can open directory to view its files by double-clicking the directory name in the tree window. You can also create new directories and perform all directory file management tasks (such as copying or moving directories) from within the Tree window. You
can click the directory name to select it and then choose the command you want from the File menu. Or just drag a directory from the Tree window to move or copy it into another directory.

**To open the Tree window...**

To display the contents of the current drive, choose Show Tree Window from the Tree menu in the Tree window.

To display the contents of a different drive, choose Drive from the Tree menu and choose the drive from the cascade menu.

**To expand all directories in the tree...**

Choose Expand All from the Tree menu.

**To expand the next directory level...**

- Click the plus sign next to the directory you want to expand.
  
  Or,
  
- Click to select the *name* of the directory you want to expand (do not click the plus or minus sign), and choose Expand One Level from the Tree menu.

**To expand all directories within a branch...**

1. Click to select the *name* of the directory you want to expand (do not click the plus or minus sign).

2. Choose Expand Branch from the Tree menu.

**To collapse all directories within a branch...**

- Click the minus sign next to the directory you want to collapse.

  Or,
• Click the *name* of the directory you want to collapse (do not click the plus or minus sign), and choose Collapse Branch from the Tree menu.

**To display the directory tree for another disk...**

1. Choose Drive from the Tree menu. A cascade menu appears, listing the drives connected to your computer.

2. Click the drive you want to display. The Tree window changes to show the contents of the selected drive.
Changing GeoManager Options

**The Options menu** has three options that control whether a confirmation message appears when you delete a file or replace a file. A fourth option controls whether GeoManager shrinks to an icon when you run another GEOS application.

When options are turned on, they are selected in the menu. When a confirmation option is deselected (turned off), no confirmation message appears when you perform the action.

Remember, when you delete or replace a file, you cannot undo the operation if you change your mind. Do not turn off a confirmation option unless you are very experienced with the system and do not need a warning message for operations that cannot be undone.

<table>
<thead>
<tr>
<th>View</th>
<th>Options</th>
<th>Disk</th>
<th>Window</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Confirm Delete" /></td>
<td><img src="image" alt="Confirm Read-Only" /></td>
<td><img src="image" alt="Confirm Replace" /></td>
<td><img src="image" alt="Minimize on Run" /></td>
</tr>
<tr>
<td><img src="image" alt="Save Options" /></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Confirm Delete**: This option displays a confirmation message when you delete a file. It does not affect deletion of Read-Only files.

**Confirm Read-Only**: This option displays a confirmation message when you delete a Read-Only file. For more information about Read-Only files, see “Changing DOS File Attributes,” earlier in this chapter.

**Confirm Replace**: displays a confirmation message when you copy or move a file to a directory that contains another file with the same name. When this option is deselected, a file you’re copying or moving
automatically replaces the files of the same name without your confirmation.

**Minimize on Run:** This option causes GeoManager to shrink to an icon when you run another GEOS application. When this option is deselected, the GeoManager window remains open when you run another GEOS application.

---

**To turn an option on or off...**

Choose the option from the Options menu.

If the option is currently selected, choosing it deselects the option (turns it off).

---

**To save the current options and make them permanent...**

Choose Save Options from the Options menu.
Exiting GeoManager

The Exit command closes GeoManager. Normally you never exit GeoManager, but if you are running several additional applications and notice that your system is running slowly, you can exit GeoManager to free up memory on your computer.

To close GeoManager...

Choose Exit from the File menu.

The GeoManager application closes.

If another GEOS application is currently open, you see the open application when you close GeoManager. If no other GEOS applications are open, you are returned to the Welcome screen.

To restart GeoManager...


2. From the cascade menu, choose GeoManager. The GeoManager application restarts.
GeoDraw is a powerful and easy-to-use drawing application that lets you produce full-color graphics with integrated text.

The first part of this chapter introduces you to GeoDraw's features and describes how to open the application and GeoDraw documents. The remainder of the chapter explains how to use the drawing tools and menu commands to create, edit, and print your drawing.
**USING GEODRAW**

<table>
<thead>
<tr>
<th>Page</th>
<th>Topic</th>
</tr>
</thead>
<tbody>
<tr>
<td>159</td>
<td>What GeoDraw Can Do</td>
</tr>
<tr>
<td>161</td>
<td>Starting and Exiting GeoDraw</td>
</tr>
<tr>
<td>162</td>
<td>Opening a Document</td>
</tr>
<tr>
<td>164</td>
<td>The GeoDraw Window</td>
</tr>
<tr>
<td>168</td>
<td>Setting the Document Size</td>
</tr>
<tr>
<td>169</td>
<td>Creating an Image</td>
</tr>
<tr>
<td>181</td>
<td>Selecting and Modifying Objects</td>
</tr>
<tr>
<td>185</td>
<td>Moving and Reshaping Objects</td>
</tr>
<tr>
<td>192</td>
<td>Copying and Pasting</td>
</tr>
<tr>
<td>194</td>
<td>Deleting</td>
</tr>
<tr>
<td>195</td>
<td>Changing Colors, Patterns, and Styles</td>
</tr>
<tr>
<td>203</td>
<td>Editing Text</td>
</tr>
<tr>
<td>210</td>
<td>Arranging Objects Within a Stack</td>
</tr>
<tr>
<td>212</td>
<td>Working With Multiple Documents</td>
</tr>
<tr>
<td>214</td>
<td>Importing an Image From a DOS Application</td>
</tr>
<tr>
<td>216</td>
<td>Printing</td>
</tr>
<tr>
<td>219</td>
<td>Saving a Document</td>
</tr>
<tr>
<td>221</td>
<td>Closing a Document</td>
</tr>
</tbody>
</table>
**GeoDraw** offers many powerful graphics features. It includes drawing tools that create geometric shapes or smooth outlines, and a text tool that creates a full range of text fonts, sizes, and styles.

You can add colors and patterns and use a variety of line widths. GeoDraw gives you the power to create some of these special effects:

- Change size and proportions

- Rotate and flip shapes and text

- Add colors and patterns
What GeoDraw Can Do

- Add line widths and dashed line styles

- Add colors and halftones to text

GRAPHICS

- Use different text fonts, sizes, and styles

Sophistication is a matter of *style*.

In GeoDraw, your drawing appears exactly as it will print.
You start and exit GeoDraw from GeoManager, the same way that you start and exit all GEOS applications.

There are ways to start GeoDraw other than those described in this section. For more information, see “Using Applications” in chapter 4, “Using the Professional Workspace.”

**To start GeoDraw and open a new document...**

- From the GeoManager WORLD directory, double-click the GeoDraw icon. GeoDraw starts, opening a new, untitled document.

- From another GEOS application, choose Startup from the Express menu. A cascade menu appears. Choose GeoDraw from this second menu. GeoDraw starts, opening a new, untitled document.

**To start GeoDraw and open a particular document...**

From the GeoManager DOCUMENT directory, double-click the icon of the GeoDraw document you wish to open. GeoDraw starts and automatically opens the document.

**To exit GeoDraw...**

Choose Exit from the File menu.

If you’ve made changes to any of the documents since the last time you’ve saved, GeoDraw asks you if you wish to save these changes. Click Yes to save your work or click No to ignore all the work you’ve done since the last time you saved. For more information about saving documents, see “Saving a Document” later in this chapter.
**You can work** with the untitled document that appears when you start GeoDraw, or open a new or existing document from within the application. You can open as many documents as you want—each document appears in its own window.

You can also open an existing document directly from the GeoManager window (which automatically opens the GeoDraw application).

---

**To open a new document from within GeoDraw...**

Choose New from the File menu.

A new, untitled document appears.

---

**To open an existing document from within GeoDraw...**

1. Choose Open from the File menu.

   The directory dialog box appears for you to choose the file. The files and directories in the current directory appear in a scrolling list.
2. Change the drive or directory as necessary to locate the document you want to open.

3. Double-click the name of the document you want to open.
   The document appears in its own window.

---

**To open an existing document from the GeoManager...**

1. Click the DOCUMENT icon in the GeoManager window to see the documents.

2. Double-click the GeoDraw document you want to open.
   The GeoDraw application starts and the document appears in its own window.
The GeoDraw window is your electronic drawing board. It includes a drawing area and a Toolbox that contains tools for drawing, moving, and reshaping objects. The dotted margin lines around the edge of the drawing area define the printable area of the page (for most printers). You'll want to make sure that your image does not extend over these dotted lines, because the image may appear cropped at this margin when you print.

The GeoDraw window also has standard features common to all GEOS windows (as shown in the following figure). For detailed information about using the standard window features, see "Using Windows," in Chapter 4.
Moving and Closing the Toolbox

You can move or hide the Toolbox whenever you want an unobscured view of your drawing.

To move the Toolbox...

1. Position the pointer over the title bar at the top of the box.

2. Drag the box to its new position.

   To drag, hold down the left mouse button and continue holding it down as you move the mouse to position the box. Then release the mouse button.

As you drag the box, the pointer changes to two crossed arrows and an outline shows where the box will be positioned when you release the mouse button.
To close the Toolbox...

- Double-click the Control button on the box.

Or,

- Click the Control button and choose Close from the menu that appears.

To reopen the Toolbox...

Choose Show Toolbox from the Options menu.

The Toolbox reappears exactly where it was positioned when you closed it.

Changing the Size of Your View

The View menu lets you change the magnification of the page within the window. As you create your image, experiment by choosing different magnification levels from the View menu to find the one that's most appropriate for the work you're doing. For example, when you want to precisely align two objects, it's easier if you magnify the view. When you want to get an overview of the entire layout of the image, a reduced view is better.

To magnify or reduce the view...

Choose the level of magnification or reduction you want from the View menu.
To return the document to its original size...

Choose Actual Size from the View menu.

Correcting for Aspect Ratio

Some monitors, such as those that display Hercules and CGA graphics, have rectangular pixels rather than perfectly square ones (pixels are the small dots on your monitor that make up the display). These monitors have a *rectangular aspect ratio* which tends to elongate the image of your document, making it look stretched or squashed.

If you have a monitor with a rectangular aspect ratio, you can turn on the Correct for Aspect Ratio option. With this option on, your documents appear in their proper proportions and more closely resemble their printed result. Screen drawing is sometimes slower when this option is on, so you might want to use it only for previewing your document.

To turn on the correct for aspect ratio option...

Choose Correct for Aspect Ratio from the View menu. The option turns on and the document appears as if your monitor had square pixels.

If the Correct for Aspect ratio is dimmed, it is because your monitor already has square pixels and no correction is necessary.

To turn off the correct for aspect ratio option...

Choose Correct for Aspect Ratio from the View menu. The option turns off and the document redraws.
The size of a new document is automatically set at 8.5 x 11.5 inches. You can use the Document Size command to change the page size and orientation. These settings control the size and shape of the drawing area in the GeoDraw window.

To set the page size and orientation...

1. Choose Document Size from the Options menu.
   The Document Size dialog box appears.
   ![Document Size dialog box]

2. Click the radio button for the size and orientation you want.
   The Portrait setting orients the page vertically; the Landscape setting orients the page horizontally.

3. Click OK to apply the settings, then close the dialog box.
In GeoDraw, an image is composed of one or more objects. An object can be text or a shape, such as a rectangle or a polygon. Each object can be selected, edited, and manipulated separately from the other objects in the image.

You create objects using the text tool and drawing tools in the Toolbox. Two additional tools—the Arrow Pointer and Rotate Pointer—are used for selecting and manipulating objects after they are drawn.

As you draw, don't worry if an object is not exactly the right shape or positioned just where you want it. You can easily move and reshape an object—or delete it and try again. You can also flip an
Creating an Image

object (including a text object) or rotate it to the angle you want. These techniques are described in “Moving and Reshaping Objects,” later in this chapter.

When you create an object, it appears in the currently selected color, pattern, or style. You can change any of these properties after the object is created. You can also edit text and change its font, size, and style. The “Editing an Image” section, later in this chapter, describes how to make these changes.

After you create an object handles appear around the object and one handle, called the move handle, appears in the center of the object. The handles are used for dragging, rotating, and reshaping the object (see “Moving and Reshaping Objects” later in this chapter).

In the procedures that follow, “click” always refers to clicking the left mouse button unless the right mouse button is specified.

A Word About Overlapping Objects

If you draw one object on top of another, the object on top may hide part or all of the object underneath. Often this is exactly the effect that you want. Objects are said to be stacked when they overlap each other. You can move an object towards the front or the back of a stack
by using the Arrange menu commands. This is covered in “Arranging Objects Within a Stack,” later in the chapter.

These three objects are overlapping, or stacked.

Selecting a Tool

To create and manipulate objects, you first select the appropriate tool from the Toolbox. The Arrow Pointer tool is automatically selected when you first enter GeoDraw. You use it to select, move, and resize objects.

If you select one of the drawing tools, the pointer changes to crosshairs when you move it over the drawing area. The center of the crosshairs shows where the shape will begin as you draw.

If you select the Text tool, the pointer changes to an I-beam when you move it over the drawing area. The I-beam shows where the text cursor will appear when you click the mouse button.

If you select the Rotate Pointer, the pointer shape changes to a curved pointer. The Rotate Pointer works like the Arrow Pointer, except that you can also use it to rotate objects.

A tool remains selected after you have finished drawing the object. You can use the same tool again or select another tool.
To select a tool...

Position the pointer over the tool you want and click the left mouse button.

The selected tool is highlighted in the Toolbox.

**Drawing Lines**

The Toolbox has two tools for drawing lines. With the Line tool, you can draw a single continuous line in any direction. With the Connected Line tool, you can draw any number of connected lines to create a simple geometric outline or a smoother outline that resembles a freehand drawing. The technique for drawing a smooth outline is the same as for drawing a geometric outline—the line segments in the smooth outline are just very small.

When you draw a line, it appears in the currently selected color, pattern, width, and style (solid or dashed).

To draw a line...

1. Select the Line tool in the Toolbox.
2. Position the center of the crosshairs where you want the line to begin.
3. Hold down the mouse button and drag until the crosshairs are centered over the point where you want the line to end. Then release the mouse button.

As you drag, a dotted line follows the crosshairs. When you release the mouse button, the line is drawn and its handles appear.

---

**To draw connected lines...**

1. Select the Connected Line tool in the Toolbox

2. Position the center of the crosshairs where you want the line to begin, and click to anchor this point.

3. Move the crosshairs to where you want the first segment of the connected line to end (you don’t have to hold down the mouse button). Then click again to anchor the segment.

4. Continue positioning the crosshairs and clicking to create as many segments as you want. At the end of the last segment, double-click to finish the connected line.

The line is drawn and its handles appear.
You can also finish a connected line by pressing the \texttt{Esc} key or the right mouse button. When you end the connected line this way, GeoDraw doesn't connect the last point to the first one, the way it does when you double-click to end.

**Drawing Circles**

The Circle tool draws filled circles and ovals.

To draw a circle...

1. Select the Circle tool in the Toolbox.
2. Position the crosshairs where you want the circle to begin.
3. Hold down the mouse button and drag diagonally in any direction until the circle (or oval) is the size you want. Then release the mouse button.

Press here... 

...drag to here and release
As you drag, a dotted outline indicates the circle’s size. You can adjust the size until you release the mouse button. When you release the mouse button, the circle is drawn and its handles appear.

The dotted outline appears as either a circle or a rectangle, depending on whether you choose the Drag as Rectangle or the Drag as Outline option from the Options menu. For more information, see “Setting the Drag Option” later in this chapter.

**Drawing Rectangles**

The Rectangle tool draws filled rectangles and squares.

**To draw a rectangle...**

1. Select the Rectangle tool in the Toolbox.
2. Position the crosshairs where you want the rectangle to begin.
3. Hold down the mouse button and drag diagonally in any direction until the rectangle (or square) is the size you want. Then release the mouse button.
As you drag, a dotted outline indicates the rectangle's size. You can adjust the size until you release the mouse button. When you release the mouse button the rectangle is drawn and its handles appear.

**Drawing Polygons**

The Polygon tool draws a simple geometric shape, or a smoother shape that is filled with the currently selected color or pattern. The Polygon tool works like the Connected Line tool except that it creates a filled object instead of an outline. You can make a smooth polygon by drawing very small line segments.

To draw a polygon...

1. Select the Polygon tool in the Toolbox.
2. Position the crosshairs where you want the first line of the polygon to begin, and click to anchor this point.
3. Move the crosshairs to where you want the first segment of the polygon line to end. Then click again to anchor the segment.
4. Continue positioning the crosshairs and clicking to create as many segments as you want. At the end of the last segment, double-click to finish the polygon.
When you double-click the last segment, GeoDraw closes the polygon by drawing a line from that last point to the starting point. The polygon is then filled, and its handles appear.

You can also finish a polygon by pressing the [Esc] key or the right mouse button. The polygon is closed at the last segment you clicked.
Typing Text

The Text tool lets you create a simple caption or fill the page with many paragraphs of text. In GeoDraw, text is an object and can be moved, reshaped, rotated, and flipped like any other object—this lets you create some interesting effects.

Text is fun...

The letterform comes to us through many ages and reflects the evolutionary solution to efficient written communication. It should, indeed, seem amazing to us that we are able to scribble marks on a page—marks that represent thoughts—and then decipher them at a later date.

What is it that drives man to communicate? To write a poem. To construct a novel. When as children we stack block A on block B, and smile, and then write a poem or scratch a deer on a cave wall, what is this force?

When you select the text tool, the pointer changes to an I-beam. You define the width of a text object by dragging the I-beam. As you type, text wraps within the text object, and the object automatically grows to accommodate new lines of text. The blinking vertical line, or text cursor, indicates where the next character you type appears.

Enter text

To be or not to be— that is the question:
Whether 'tis nobler in the mind to suffer
The slings and arrows of outrageous fortune,
Text appears in the current font, size, style, and justification. You can change these attributes and also add color and halftones to text. Text is fully editable, and can be cut, copied, and pasted.

**To type text...**

1. Select the Text tool in the Toolbox.
   
The pointer changes to an I-beam to indicate that the Text tool is selected.

2. Position the I-beam where you want the first character to begin.

3. You can create a text object with a standard three-inch line width by just clicking.

   ![Click for standard 3-inch line width](image)

   Or,

   You can create a custom line width by holding down the mouse button and dragging the I-beam to the right.

   ![Or, for a custom width, press here.](image)

   The line width can be as wide as the page. If the page is wider than the window size, continue dragging when you reach the right edge of the window—the page scrolls until you reach the right page margin.

4. Type the text.
You don't need to press [Enter] at the end of each line—text wraps automatically to the next line when it reaches the right edge of the text object. Press [Enter] only when you want to begin a new paragraph.

I will never forget the first words of Steve Holden, my longtime friend and traveling mentor. I hadn't known him more than ten seconds when he looked across his desk and said, "Pack lightly!"

"Pack lightly?" I thought, "what a strange thing to say." But I followed his

When you finish typing, the Text tool remains selected. You can create additional text objects or select another tool. To edit text, or change the text font, size, or style, see “Modifying Text,” later in this chapter.
After you create and select an object, you can edit or modify it in the following ways:

- Moving or reshaping
- Duplicating by copying and pasting
- Deleting
- Changing the color or pattern
- Changing the line style or width (for draw objects)
- Changing the text font, size, style or justification (for text objects)

Before you change an object, you first need to select it. You can select one object or multiple objects. If you select multiple objects and make a change, the change applies to all the selected objects.

You can use either the Arrow pointer or Rotation pointer tool to select objects.

The techniques for selecting objects in GeoDraw are the same as for selecting items in any other GEOS application. For more information about selecting, see “Selecting” in Chapter 4.

To select an object by clicking...

1. Select the Arrow pointer or the Rotation pointer.
2. Position the pointer over the object.

   The pointer does not need to be over the center of the object. You can position it over any part of the object which is not overlapped by another object.

With text objects, you can select the entire object or specific characters. See “Selecting Characters Within a Text Object” later in this chapter.
3. Click to select the object.

To add additional objects to a selection...

1. Position the pointer over the next object you want to select.
2. Hold down the \texttt{Ctrl} key and click to select.
   
The object is added to your selection.

To select objects by dragging...

1. Select the Arrow pointer or the Rotation pointer.
2. Visualize a box surrounding the group of objects you want to select. Then position the pointer at the "corner" of the imaginary box.
3. Hold down the mouse button and drag diagonally until the dotted selection rectangle surrounds all the objects you want to select. Then release the mouse button.
As you select an object, its handles appear. If you missed an object, try again.

Selecting Characters Within a Text Object

When you want to edit or modify selected characters within a text object, use the Text tool to select the characters you want to change. The selection appears highlighted, as shown in the following figure.

And there is a Catskill eagle in some souls that can alike dive down into the blackest of gorges, and soar out of them again and become invisible in the sunny spaces. And even if he forever flies within the gorge, that gorge is in the mountains; so that even in his lowest swoop the mountain eagle is still higher than the other birds upon the plain, even though they soar.

To move or reshape a text object or make the same change to all its characters, select the text as an object. For example, you select text...
as an object when you want to rotate it or change all the characters
to the same text font. For information about selecting objects, see
“Selecting and Modifying Objects,” earlier in this chapter.

To select characters in a text object...

1. Select the Text tool.
2. Position the I-beam next to a character at the beginning of the
text you want to select.
3. Hold the mouse button down and drag to the end of the
selection. Then release the mouse button.

The selected text is highlighted.

Note: You can also use various other techniques for selecting
text. For detailed information, see “Entering and Editing Text,”
in Chapter 4.
This section explains how to move and manipulate an object you've created by

- Dragging it to a new location
- Nudging it a pixel at a time
- Rotating it in any direction
- Flipping it horizontally or vertically
- Stretching it to change its size and proportions

Moving Objects by Dragging

In GeoDraw, you can move objects by dragging them using the right mouse button—the same way you move files in GeoManager. You can also use the left mouse button to drag a selected object if you drag the object's move handle (the center handle).

To drag one or more objects using the left mouse button...

1. Select the objects you want to drag.

2. Position the pointer over the center handle of the selected object (or over one of the objects if multiple objects are selected).

3. Press the left mouse button and drag to where you want the object positioned. Then release the mouse button.

Note that Quick Move, a special quick method of moving items, works with most GEOS applications but not with GeoDraw.
As you drag, a dotted outline follows the pointer on the screen. When you release the mouse button, the object appears in place of the outline.

Press on center handle...

...drag to new position and release

**To drag one or more objects using the right mouse button...**

1. Position the pointer on the object (or on one of the objects if multiple objects are selected).
   
   The pointer does not need to be over the center of the object.

2. Press the right mouse button and drag to where you want the object positioned. Then release the mouse button.

**Setting the Drag Option**

When you draw, drag, or reshape an object, a dotted outline shows the size and location of the object as you manipulate it. The outline can appear as a rectangle or as an outline of the object's shape, depending on whether you select the Drag as Rectangle or the Drag as Outline option from the Options menu.
GeoDraw performs much faster if you use the Drag as Rectangle option when you drag or reshape a complex object.

To set the drag option...

Choose the drag option you want from the Options menu.
Nudging Objects

You can precisely position an object by moving it one pixel at a time using the Nudge command on the Modify menu. Pixels are the small dots that form the character image.

To move an object slightly by nudging...

1. Select one or more objects.
2. Choose Nudge from the Modify menu.
   The Nudge cascade menu appears.
3. Choose the direction in which you want to nudge the selection.

Rotating Objects

The Rotate 45° Right and Rotate 45° Left commands on the Modify menu let you rotate an object precisely 45° clockwise or counterclockwise.

The Rotation pointer lets you rotate an object freehand to any position. An object rotates around its center point.
You cannot rotate a circle, an oval, or an image imported from another application. Text characters cannot be edited when the text object has been rotated. To edit text characters, first rotate the object back to its original orientation.

**To rotate objects 45°...**

1. Select one or more objects.

2. To rotate 45° clockwise, choose Rotate 45° Right from the Modify menu.

   To rotate 45° counter-clockwise, choose Rotate 45° Left from the Modify menu.

   Each object in the selection rotates 45° around its center point.

**To rotate an object freehand...**

1. Select the Rotate pointer in the Toolbox.

2. Click the object you want to rotate.

   The object selects and its handles appear.

3. Position the Rotate pointer over one of the corner handles.

4. Hold down the mouse button and drag clockwise or counter-clockwise to rotate the object to the position you want it.

   As you drag, the outline shows how the object appears if you release the mouse button.

5. Release the mouse button. The object appears in its rotated position.
Flipping Objects

You can flip an object on its horizontal or vertical axis using the Flip Horizontal and Flip Vertical commands on the Modify menu.

You’ll just flip over this...

Text characters cannot be edited when the text object has been flipped. To edit text characters, first flip the object back to its original orientation.

To flip an object on its horizontal axis...

1. Select one or more objects.
2. Choose Flip Horizontal from the Modify menu.

To flip an object on its vertical axis...

1. Select one or more objects.
2. Choose Flip Vertical from the Modify menu.

Reshaping Objects

You can change the size and shape of an object by stretching it vertically or horizontally—or both directions at the same time. Stretching an object distorts the object’s shape.

Note: Reshaping a text object changes the line width, but does not
Moving and Reshaping Objects

affect the shape of the characters. The line width determines how words wrap within a text object.

To stretch an object...

1. Select the Arrow pointer.

2. Click the object you want to select.

   The object's handles appear. Smaller objects don't have middle handles.

3. To stretch an object vertically, position the pointer on one of the handles on the top or bottom edge.

   To stretch an object horizontally, position the pointer on one of the handles on the left or right edge.

   To stretch the object both vertically and horizontally, position the pointer on any corner handle.

4. Hold down the mouse button and drag to stretch the object. Then release the mouse button.

   Until you release the mouse button, you can continue adjusting the shape. An outline shows the size as you stretch.

   When you release the mouse button, the object appears in the stretched shape.
Copying and pasting produces an exact replica of an object and makes it easy to create an image that contains many identical parts. After you paste, you can drag, rotate, or flip the object to position it where you want it.

With text, you can also copy selected characters and paste them within an existing text object or a new text object.

The Copy and Paste commands can also be used to copy a selection from one document and paste it in another. For more information, see “Cutting and Pasting,” in Chapter 4.

To copy and paste an object...

1. Select one or more objects.

2. Choose Copy from the Edit menu.
   GeoDraw copies the selection.

3. Choose Paste from the Edit menu.
   A copy appears in the center of the window. To move the object, see “Moving and Reshaping Objects,” earlier in this chapter.

To copy and paste text characters...

1. Select the characters you want to copy.

Note that Quick Copy, a special quick method of copying, works with most GEOS applications but not with GeoDraw.
2. Choose Copy from the Edit menu.

3. To insert the text in an existing text object, position the I-beam where you want to insert the text, and click. Then choose Paste from the Edit menu.

   To insert text in a new text object, choose Paste from the Edit menu. The pasted text appears in the center of the screen.

   Or,

   Position the I-beam where you want the new text object to appear, and click. Then choose Paste from the Edit menu.

   GeoDraw inserts the text at the cursor position.
There are two ways to delete selected objects or text characters—cutting or deleting. Cutting removes the selection to a storage area called the clipboard so that you can paste the selection in another document. Deleting permanently removes a selection without saving it on the clipboard.

To cut...

1. Select one or more objects or specific text characters.
2. Choose Cut from the Edit menu.
   
The selection is removed and placed on the clipboard.

To delete...

1. Select one or more objects or specific text characters.
2. Choose Delete from the Edit menu.
**Changing Colors, Patterns, and Styles**

**You can use** colors and patterns to distinguish objects and to add style and pizzazz to your image.

GeoDraw has a palette of 16 colors and 16 patterns that you can apply to lines and to the area inside filled objects (rectangles, circles, and polygons). You can also apply color and halftones to text.

You can work with colors only if you have a color system. To print a document in color you need a color printer and the appropriate printer driver installed.

**Opening, Moving, and Closing the Properties Boxes**

GeoDraw has three properties boxes for changing colors, patterns, and styles—an Area Properties box, a Line Properties box, and a Text Properties box. You open a properties box by choosing its command from the Modify menu. A properties box can be moved within the window just like the toolbox. You can leave a properties box open so that you can make additional changes as you work.
To open a properties box...

Choose the Area Properties, Line Properties, or Text Properties command from the Modify menu.

The selected properties box appears. You can have all three properties boxes open at the same time.

To move a properties box...

1. Position the pointer over the title bar at the top of the box.
2. Drag the box to its new position.

To drag, hold down the left mouse button and continue holding it down as you move the mouse to position the box. Then release the mouse button.
As you drag the box, the pointer changes to two crossed arrows and an outline shows where the box will be positioned when you release the mouse button.

To close a properties box...

- Double-click the Control button on the box.

Or,

- Click the Control button and choose Close from the menu that appears.

Changing Line Color, Pattern, Width, or Style

The Line Properties command lets you change the color, pattern, width and style of lines and object outlines. The outline of a filled object is treated as a line and can have a different color and pattern than the object’s interior. You can choose from seven line widths and five dashed or solid line styles.
You can change the objects you've already drawn or the next object you plan to draw by clicking the settings you want in the Line Properties box.

<table>
<thead>
<tr>
<th>Line Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width:</td>
</tr>
<tr>
<td>Style:</td>
</tr>
<tr>
<td>Pattern:</td>
</tr>
<tr>
<td>Color:</td>
</tr>
</tbody>
</table>

**To change line color or pattern...**

1. To change the line color or pattern of existing objects, select the object (or objects).
   
   If you do not select an object before you change the line color or pattern settings, the change will be applied to the next object you draw.

2. Choose Line Properties from the Modify menu to open the Line Properties box if is not already displayed.
   
   The Line Properties box appears.

3. Click to select the Color or Pattern you want.
   
   You can click both a color and a pattern setting.

   Each time you click a setting the objects show the new color or pattern. You can continue trying different settings until you get the effect you want.

   You can leave the Line Properties box open if you want to select and change additional objects, or close the box by double-clicking the Control button.
To change line width or line style setting...

1. To change the line width or style setting of an existing object, select the object.

If you do not select an object before you change the line width or style setting, the change will be applied to the next object you draw.

2. Choose Line Properties from the Modify menu to open the Line Properties box if it is not already displayed.

The Line Properties box appears.

3. Click to select the Width or Style setting you want.

You can click both a width and a style setting.

Each time you click a setting the selected objects reflect the change. You can continue trying different settings until you get the effect you want.

You can leave the Line Properties box open or double-click the control button to close it.

Filling an Object With a Color or Pattern

The Area Properties command lets you change the color or pattern of the area within a filled object. A pattern can be either solid or transparent.
A filled object is any object created with the Rectangle, Circle, or Polygon tools. A closed shape created with the Line or Connected Line tool cannot be filled with a color or pattern.

You can change the area color or pattern of objects you’ve already drawn or the next object you plan to draw by clicking the settings you want in the Area Properties box.

To change the fill color or pattern...

1. To change the fill color or pattern of existing objects, select the object (or objects).

   If you do not select an object before you change the fill color or pattern settings, the change will be applied to the next object you draw.

2. Choose Area Properties from the Modify menu to open the Area Properties box if it is not displayed.

   The Area Properties box appears.

3. Click to select the Color or Pattern you want to apply to the object (or objects) you’ve selected.

   You can click both a color and a pattern setting.

   Each time you click a setting the selected objects show the new color or pattern. You can continue trying different settings until you get the effect you want.

   You can leave the Area Properties box open if you want to select and change additional objects, or close the box by double-clicking the Control button.
Changing Text Color and Halftone

The Text Properties command lets you change text color and set a dark, medium, or light halftone for text. A halftone is a lighter shade of the color you have selected. The illusion of shades is created by turning off some of the pixels (the small dots that form the character image). For this reason, halftones look best on larger font sizes and bolded characters that have more pixels.

You can change the color or halftone of text you’ve already typed or text you’re about to type by clicking the settings you want in the Text Properties box.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Concentration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Solid</td>
<td>100%</td>
</tr>
<tr>
<td>Dark</td>
<td>75%</td>
</tr>
<tr>
<td>Medium</td>
<td>25%</td>
</tr>
<tr>
<td>Light</td>
<td>15%</td>
</tr>
</tbody>
</table>
To apply text color or halftones...

1. To change the color or halftone of existing text, select the text you want to change. You can select specific characters or a text object.

   If you do not select text before you change color or halftone settings, the change will be applied to the next characters you type.

2. Choose Text Properties from the Modify menu (or the Text menu) to open the Text Properties box if it is not already displayed.

   The Text Properties box appears.

3. Click to select the Text Color you want.

   To change the Halftone setting, click the radio button for the setting you want.

   When you click a setting, the selected text reflects the settings you chose. You can continue trying different settings.

   You can leave the Text Properties box open if you want to select and change additional text, or close the box by double-clicking the Control button.
In **GeoDraw**, text is fully editable. You can copy, paste, or delete text using the same procedures you use to edit draw objects. For instructions on copying, pasting and deleting, see the relevant sections earlier in this chapter.

In addition to the standard editing techniques, you can modify text by changing the text font, size, style, and justification, as described in the following procedures.

### Changing the Text Font

The Fonts option on the Text menu lets you change the font of selected text or the next characters you type. The most commonly used fonts appear on the Fonts cascade menu. You can select one of these or choose More Fonts from the Fonts cascade menu to display the complete list of fonts available on your system.

![Image of Fonts menu]

To change the text font to a standard font...

1. Select the text you want to change.

You can select characters or an entire text object.
2. Choose Font from the Text menu.
   The Font cascade menu appears.

3. Select one of the fonts listed.

**To change the text font to a non-standard font...**

1. Select the text you want to change.
   You can select specific characters or a text object.

2. Choose Font from the Text menu.
   The Fonts cascade menu appears.

3. Choose More Fonts from the cascade menu to display a complete listing of fonts in your system.

4. Select a font from the scrollable list of fonts in the dialog box, and click Apply. You can close the box or keep it open to make additional changes.

**Changing Text Size**

The Sizes command on the Text menu lets you change the font size of selected text or of the next characters you type. You can choose from a list of standard font sizes, make the size larger or smaller, or set your own custom size. You can enter a custom size from 4 points to 792 points (a 792-point character fills an entire 8.5-by-11 inch page).

If you want to experiment by selecting different fonts, pin the cascade menu so that it stays open.

Seventy-two points is equal to one inch.
To choose a standard text size...

1. Select the text you want to change.
   
   You can select specific characters or a text object.
   
   If you do not select text before you choose the text size, the change will affect the next characters you type.

2. Choose Sizes from the Text menu.
   
   The Sizes cascade menu appears.
3. Click the size you want.

If text is selected, the sizes menu reflects the new size setting.

To make the size smaller or larger...

1. Select the text you want to change. You can select characters or text objects.

If you do not select text before you change the size setting, the change will affect the next characters you type.

2. Choose Sizes from the Text menu.

The Sizes cascade menu appears.

3. Choose Smaller or Larger.

The size of the selected text decreases or increases depending on the setting you chose.

To set a custom text size...

1. Select the text you want to change. You can select characters or text objects.

If you do not select text before you choose a custom text size setting, the change will affect the next characters you type.

2. Choose Sizes from the Text menu.

The Sizes cascade menu appears.

3. Choose Custom Size.

The Custom Size dialog box appears.

If you want to change the size of additional text, pin the Sizes cascade menu so that it stays open.

Again, if you want to change the size of additional text, pin the Sizes cascade menu so that it stays open.
4. Click the up arrow or down arrow in the dialog box to increase or decrease the custom size.

Or,

Type a new size.

5. Click Apply to apply the size, then close the dialog box.

Selected text reflects the new text size.

**Changing Text Style**

The Styles command lets you apply styles (such as bold or italic) to selected text or to the next characters you type. You can apply more than one style to the same text selection, except when you select the Plain style. For example, text can be bold and italic style.

To change the text style...

1. Select the text you want to change.

   You can select specific characters or a text object.

   If you do not select text before you change the text style setting, the change will affect the next characters you type.
2. Choose Styles from the Text menu.
   The Styles cascade menu appears.
3. Click the style you want.

Changing Text Justification

The Justification command lets you set how the left and right edges of text are aligned with the borders of the text object. You can choose from four justification settings.

Left Justification aligns the left text edges and leaves the right edges ragged.

Right Justification aligns the right text edges and leaves the left edges ragged.

Center Justification centers text between the left and right borders of the text object.

Full Justification spreads each line of text out so that both the left and right text edges are aligned with the borders of the text object.

You can change the justification setting for selected paragraphs within a text object or the entire text object.

**To change text justification...**

1. To change a selected paragraph, position the cursor in the paragraph.
   
   To change all text in an object, select the object (or objects).

2. Choose Justification from the Text menu.
   
   The Justification cascade menu appears.

3. Choose the justification setting you want.
   
   The cascade menu closes. The text justifies according to the setting you chose.
When you have a stack of overlapping objects, use the Arrange menu commands to move an object towards the front or the back of the stack to get the effect you want.

To bring an object to the front...
1. Select the object.
2. Choose Bring to Front from the Arrange menu.

The selected object moves in front of all the other objects in the stack.

To send an object to the back...
1. Select the object.
2. Choose Send to Back from the Arrange menu.

The selected object moves behind all the other objects in the stack.

To move an object one level towards the back of the stack...
1. Select the object.
2. Choose Move Backward from the Arrange menu.
The selected object moves one level towards the back of the stack because the Move Backward command moves the object one level at a time, you may need to use this command several times to get the object exactly where you want it in the stack.

To move an object one level towards the front of the stack...

1. Select the object.
2. Choose Move Forward from the Arrange menu.

The selected object moves one level up in the stack because the Move Forward command moves the object one level at a time, you may need to use this command several times to get the object exactly where you want it in the stack.
When you have multiple documents open, you can switch to another document by choosing the document title from the Window menu.

You can also use the Overlapping command on the Window menu to display open documents in an overlapped arrangement so that you can switch between them by simply clicking on the document you want.
You can arrange multiple documents exactly as you want them. To move a document window, drag it by its title bar; to resize a window, drag its resize borders. The following example shows two documents arranged side-by-side.

When you want to expand a document to full-window size, use the Full-Sized command in the Window menu, or click the Maximize button on one of the document windows.

**To arrange multiple documents as overlapping windows...**

Choose Overlapping from the Window menu.

**To switch between open documents...**

- Choose the document title from the Window menu.

  Or,

- Choose Overlapping from the Window menu. Then click the document window you want to work in.
The **Import command** on the File menu lets you import an image saved in another file format. An imported image is treated as a single object in GeoDraw. You can manipulate the imported object as you would any other GeoDraw object.

You can import TIFF files or PC Paintbrush files into GeoDraw. TIFF files have the file extension .TIF and PC Paintbrush files have the extension .PCX.

**To import an image...**

1. Choose Import from the File menu.

   The Import dialog box shows the files and directories in the current directory. To open a directory, double-click its name or icon in the scrolling list.

2. Click TIFF or PCX to see a list of these files contained in the current directory.

3. Select the file you want to import.

4. To preview the image before importing the file, click View. You can use the scroll bars to scroll the image in the dialog box.
5. When you are ready to import a file, click Import.

To close the Import dialog box without importing, click Cancel.

When you click Import, the Import dialog box closes and the image appears in the document window. If the image is large, it may take a several minutes for the image to be imported.
The Print command opens a dialog box that lets you tailor printing for a fast draft or high quality final output. You can start and end printing at specific pages, and ask GeoDraw to collate the pages when printing more than one copy.

If you have more than one printer connected, you can select the one you want to use for this printing. You can also change other printer options, such as paper size and paper source.

To print a document...

1. If necessary, choose Page Setup from the File menu and choose a paper size and page orientation.

2. Click OK to close the Page Setup dialog box.
3. Choose Print from the File menu.

4. Select the Print Quality:
   - Select High to print at the highest resolution of your printer.
   - Select Medium to print at medium resolution (if the selected printer has this capability).
   - Select Low to print at the low resolution for quick drafts.

5. To print only a portion of the document, enter the page numbers by clicking the arrows or typing the page numbers.

6. Enter the Number of Copies. If you want more than one, you can select the Collate option, which prints one copy at a time from beginning to end.

7. Click Print to start printing.

---

**To choose a different printer or paper size or paper source...**

1. Choose Print from the File menu.

2. Click the Change Options button in the Print dialog box.
3. To change printers, select a printer from the list.

    The printer list shows the printers you chose when you installed GEOS. When your printer environment changes, choose Setup from the Express menu and choose the Preferences desk tool. The changes you make using the Preferences desk tool appear in the Print dialog box the next time you choose the Print command. See "The Preference Desk Tool" in Chapter 11, "Using the Desk Tools," for more details.

4. Select a Paper Size from the list of sizes.

    You can override these choices by entering the Width and Height of your paper in the boxes below. Paper height can be as large as 34 inches. If you enter a width that is wider than your printer allows, GeoDraw uses the maximum supported size.

5. Select Tractor or Manual Feed as the Paper Source for this printing.

6. Click OK, then click Print in the Print dialog box.
The File menu contains two commands that let you save the current document to disk:

- Save: Use this command when you're through with the document, want to make your changes permanent, or when you're about to try something new and want to be able to Revert back to the current document.

- Save As: Use this command to save a copy of your document under a different name.

The first time you save, a dialog box appears for you to name the document.

You don't actually need to save your document while you're working on it. GeoDraw automatically safeguards your data as you go—in other words, it keeps a temporary “working” copy on hand. In the event of a power failure or other problem, your work isn't lost even if you haven't saved. You can set how frequently GeoDraw safeguards your document using the Preferences desk tool. See “The Preferences Desk Tool” in chapter 11, “Using the Desk Tools,” for more information.

To name and save a GeoDraw document...

1. Choose Save or Save As from the File menu. The Save As dialog box appears.

2. Go to the directory where you want to save the document.

   The Save dialog box shows you the files and subdirectories in your current directory. To go into a subdirectory, double-click its name or icon in the scrolling list.

3. Type a name for the document and click Save.
To save a copy of the GeoDraw document with a different name...

1. Choose Save As from the File menu. The Save As dialog box appears.
2. Go to the directory where you want to save the new document.
3. Type the new name for the document and click Save.

The title of the document at the top of the window changes to the new name. This means that your changes are saved into this new document from now on.

To save your changes as you work...

After you have named and saved the document once, choose Save from the File menu to save any additional changes as you work. It's a good idea to save after you make an important change.

To revert to the previously saved version...

If you start revising your document and don't like the changes you've made, you can return to the last saved version by choosing Revert from the File menu.
The **Close command** closes a document. If the document contains changes that haven’t been saved, a message gives you the option of saving them.

---

**To close a GeoDraw document...**

1. Choose Close from the File menu.

   If you have changes that you haven’t saved, a message appears asking if you want to save them.

2. To save the changes, click Yes.

   To close the document without saving, click No.

   To return to the document without saving, click Cancel.

   If you click Yes and the document is untitled, a dialog box asks you to select a directory and enter a file name. If you need help to complete these steps, see “Saving a Document,” earlier in this chapter. When you are ready to save, click Save in the dialog box.
This chapter introduces you to GeoWrite, a straightforward and powerful word processor. The chapter begins with instructions on opening the application and opening GeoWrite documents, followed by an explanation of how the GeoWrite window works. You should read through these sections if you are new to GeoWrite.

The remainder of the chapter provides procedures for performing the full range of your word processing tasks. Refer to these procedures as needed in the course of your work.
**GeoWrite offers** complete word processing with a direct and intuitive approach. You work with a clear and completely WYSIWYG (What You See Is What You Get) view of your document. You see one page at a time with margins, headers, and footers clearly outlined. The basics of entering, selecting, and editing text are accomplished by typing, selecting text with the mouse, and using the menu commands.

In addition to the basics, GeoWrite has special features that let you easily increase the readability and impact of your documents.

These special features include the ability to

- Color text and paragraph backgrounds and produce white-on-black reversed-out type
- Add borders to text, then color and customize the borders
- Apply halftones to text, backgrounds, and borders
- Create multi-column formats with the flexibility to control the space between columns and add a line of variable width between the columns
- Store and copy paragraph styles, including ruler settings
- Paste graphics and import text files from GeoDraw
- Work with four types of tabs, set the default tabs, and add tab leaders and tab lines
- Easily access headers and footers
- Automatically number pages
**You start** and exit GeoWrite from GeoManager, the same way that you start and exit all GEOS applications.

---

**To start GeoWrite and open a new document...**

From the GeoManager WORLD directory, double-click the GeoWrite icon.

GeoWrite starts, opening a new, untitled document.

From another GEOS application, choose Startup from the Express menu. A cascade menu appears. Choose GeoWrite from this second menu. GeoWrite starts, opening a new, untitled document.

---

**To start GeoWrite and open a particular document...**

From the GeoManager DOCUMENT directory, double-click the icon of the GeoWrite document you wish to open. GeoWrite starts and automatically opens the document.

---

**To exit GeoWrite...**

Choose Exit from the File menu.

If you’ve made and changes to any of the documents since the last time you’ve saved, GeoWrite asks you if you wish to save these changes. Click Yes to save your work or click No to ignore all the work you’ve done since the last time you saved. For more information about saving documents, see “Saving a Document” later in this chapter.
You can work with the Untitled document that appears when you start GeoWrite, or open a new or existing document from within the application. You can open several documents at a time. Each document appears in its own window.

To open a new document from within GeoWrite...

Choose New from the File menu.

To open an existing document from within GeoWrite...

1. Choose Open from the File menu.

   The directory dialog box appears for you to choose the file. The files and subdirectories in the current directory appear in a list.

2. Change the drive or directory as necessary to locate the document you want to open.

![Select Document to Open dialog box]
3. Double-click the name of the document you want to open. The document appears in its own window.

**To open an existing document from GeoManager...**

1. Click the DOCUMENT icon in the GeoManager window to see the documents.

2. Double-click the document you want to open.
**GeoWrite** gives you a true view of a document, one page at a time. You know exactly where you are on the page at all times.

Across the top of the GeoWrite window is the menu bar. Browse through the menus to see where the various commands are located.

**Maximize/Restore button:** Click the Maximize/Restore button to set the window at full or reduced size.

**Ruler:** The ruler contains movable margin markers.

**Next page and Previous page:** The Next and Previous page arrows display the next or previous page.

**Left, Center, Right, and Full justification:** Click Left, Center, Right or Full to select justification.

**Single, Double, Line-and-a-Half spacing:** Click Single, Double, or Line-and-a-Half to select spacing.
The Header, Body, and Footer

You can enter text in the body of the document, or in the header or footer areas. Text or graphics that you enter in the header or footer appear on each page of the document.

To see the header area, drag the scroll bar up to the top of the page.

GeoWrite automatically creates the header. Here you enter text or graphics that you want to appear at the top of each page.

To see the footer area, drag the scroll bar down to the bottom of the page.

You can add automatic page numbering and graphics, such as a logo or design elements, in the header or footer so that they appear on each page.

If you want a header or footer in your document, see “Adding a Header and Footer.”
Changing the Size of Your View

The View menu lets you change the magnification of the page within the window.

1. Open the View menu and click the push-pin icon so that the menu stays open.

2. Try the different levels of magnification. Reducing the view to 25% lets you preview the whole page before you print.

3. When you finish, close the pinned menu by double-clicking the Control button.

Correcting for Aspect Ratio

Some monitors, such as those that display Hercules and CGA graphics, have rectangular pixels rather than perfectly square ones (pixels are the small dots on your monitor that make up the display). These monitors have a rectangular aspect ratio which tends to elongate the image of your document, making it look stretched or squashed.

If you have a monitor with a rectangular aspect ratio, you can turn...
on the Correct for Aspect Ratio option. With this option on, your documents appear in their proper proportions and more closely resemble their printed result. Screen drawing is sometimes slower when this option is on, so you might want to use it only for previewing your document.

**To turn on the correct for aspect ratio option...**

Choose Correct for Aspect Ratio from the View menu. The option turns on and the document appears as if your monitor had square pixels.

If the Correct for Aspect ratio is dimmed, it is because your monitor already has square pixels and no correction is necessary.

**To turn off the correct for aspect ratio option...**

Choose Correct for Aspect Ratio from the View menu. The option turns off and the document redraws.

**Moving Between the Pages of a Document**

GeoWrite provides several ways to switch to a different page in your document. You can click the Page arrows to go to the next or previous page, use the GoTo Page command to move to a specific page, or switch back to a page you were working on by choosing it from the pages listed on the Window menu.

- To go to the next or previous page, click the arrow to the right or left of the Page indicator.

  Or,

- Choose the Previous Page or Next Page command from the Window menu.
• To see a specific page on the screen, choose the GoTo Page command from the Window menu. Type the number of the page you want and click OK.

• To quickly return to a page you have recently opened, choose it from the page list in the Window menu.

For more information, see "Using the Window Menu" later in this chapter.
Entering Text

**When you open** a new document, you see a blinking text cursor in the upper-left corner of the page. Text appears here when you begin to type.

**To enter text...**

1. Begin typing.
   
   At the right margin, words wrap automatically to the next line. You do not have to press `Enter`.

2. Erase a mistake with the `Backspace` key.

3. End paragraphs by pressing `Enter`.

   Pressing `Enter` starts a new line. Press `Enter` twice to create a blank line and move the text cursor down the page.

For more on how you enter text throughout GEOS, see “Entering and Editing Text” in Chapter 4, “The Professional Workspace.”

**Entering Special Characters**

See the Special Characters appendix to learn how to type special characters. Here is a short list of what you type to create frequently used characters.

<table>
<thead>
<tr>
<th>Press...</th>
<th>To get...</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Ctrl)+[]</td>
<td>a soft hyphen (-)</td>
</tr>
<tr>
<td>(Ctrl</td>
<td>Alt)+[8]</td>
</tr>
<tr>
<td>Shift</td>
<td>Ctrl</td>
</tr>
<tr>
<td>Ctrl</td>
<td>Alt]+[2]</td>
</tr>
<tr>
<td>Ctrl</td>
<td>Alt]+[R]</td>
</tr>
<tr>
<td>Ctrl</td>
<td>Alt]+[G]</td>
</tr>
</tbody>
</table>

You can place a special soft hyphen in a word by typing `Ctrl`+[-]. The soft hyphen remains invisible unless the whole word won’t fit at the end of a line.
You select text to indicate which text you want to change. Selected text is highlighted. Commands that you choose affect the selected text.

GeoWrite lets you select text by dragging or by clicking.

To select text...

- Select any text by dragging over it with the mouse button down.
  
  Or use these shortcuts to select a word, line, or paragraph:
  
  - Double-click a word to select it.
  - Triple-click to select a line.
  - Quadruple-click to select a paragraph.
  - Quintuple-click to select the contents of a page or column.

Note that if you hold down the mouse button after the last click and drag, you extend your selection to the next word, line, or paragraph.

Alternatively, you can use the \[\text{Shift}\]-click method to select any region of text.

- Click at the beginning of the selection, then hold down \[\text{Shift}\] and click at the end.

For more on selecting, see “Entering and Editing Text” in Chapter 4, “The Professional Workspace.”
After you select a word, phrase, or the entire document, you can make editorial changes.

The Edit menu contains three editing commands that you will use often: Cut, Copy, and Paste. Note that the keyboard accelerator appears next to the command on the menu.

For more information on editing, see “Entering and Editing Text” in Chapter 4, “The Professional Workspace.”

To cut, copy, or paste text...

1. Select the text to cut or copy.

2. Choose Cut or Copy from the Edit menu.

   Cut deletes the selection from the document and places a copy on the Clipboard for pasting. Copy leaves the text in the document and saves a copy on the Clipboard.

3. Click to position the text cursor where you want the text pasted, then choose Paste from the Edit menu.

   The contents of the Clipboard appear at the text cursor.

To insert text...

Click to position the text cursor where you want to insert new text and type the text.

Existing text is shifted to the right, making room for the text you insert.
To replace text...

- Replace text by first selecting it and then typing over it. The selected text disappears when you start to type.

Or,

- Press the \texttt{ins} key to switch from insert mode to overtype mode, and type. Existing text is erased as you type over it. Press \texttt{ins} again to return to insert mode.

To delete text...

1. Select the text you want to remove.

2. Either choose Cut from the Edit menu or press \texttt{Backspace} to delete the text.
Creating an attractive printed document involves personal choices about the style of text. GeoWrite makes it easy to try different looks.

You can select text and then choose between different fonts, font sizes, and special styles such as bold, italic, and underline. You can also color text, lighten it with a halftone, or adjust the character spacing for titles or headlines.

GeoWrite gives you sophisticated control over text formatting and a fast way to see your ideas.

Changing a Font

*Font* refers to the design of the characters such as the thickness and shapes of the lines. Some common fonts are:

Sans

Roman

Σψμβολ (Symbol)
In GeoWrite the fonts appear on the screen exactly as they will appear on the printed page.

You change the font by selecting text and

- Choosing a font from the Fonts menu

Or,

- Choosing the More Fonts command and selecting a font from the More Fonts dialog box

The Fonts menu lists the most commonly used fonts. More Fonts lists all the fonts currently installed on your system. When you select a font in the More Fonts dialog box, you see a sample of the font so you can preview the font before you apply it.

Working from the More Fonts dialog box is useful if you make font changes to different parts of the document. As with most of GeoWrite's dialog boxes, you can move back and forth between the dialog box and your document, selecting different text to change.

**To choose a new font...**

1. Select the text.

2. Choose a new font from the Fonts menu.

**To change fonts with the More Fonts command...**

1. Select the text.

2. Choose More Fonts from the Fonts menu.

3. Select a font from the list in the More Fonts dialog box. An example of the font you select is displayed below the list.
4. Click Apply to see the change in your document.
5. Click Close when you finish.

**Changing the Text Size**

A point is a measurement of the height of a character. One point is 1/72 of an inch, so 72 point type is one inch tall.

GeoWrite allows a broad range of text size—from 4 to 792 points. The maximum point size (792) prints one character to a page.

The Sizes menu contains the standard font sizes from 10 to 72 points. In addition, the Smaller and Larger commands let you make a gradual change in point size for selected text. You also have a Custom Size command that lets you enter the specific point size you want.

Scale text to any size.
To change text size...

1. Select the text.
2. Choose a size from the Sizes menu.
   To vary the size incrementally, choose the Larger or Smaller commands.

To change text to a custom size...

1. Select the text.
2. To specify a point size that is not listed on the menu, choose Custom Size.
3. In the Custom Size dialog box, click the Up or Down arrows or type a new size, then click Apply.
4. Click Close when you finish.

Changing the Character Spacing

The Sizes menu contains a Character Spacing command that lets you expand or compress the spaces between characters. Default spacing is zero, but you can set spacing from -100 up to 600. A negative number compresses text and causes the characters to overlap.

The ability to control the character spacing is particularly useful for titles, headings, flyers, and fine print.

Style is a matter of space

You can keep the dialog box open, and select and apply changes again and again.

Note that using a large negative value for character spacing can cause the overlapping characters to display incorrectly. If this occurs, choose the Redraw command from the Window menu.
To change character spacing...

1. Select the text.
2. Choose Character Spacing from the Sizes menu.
3. Click the Up or Down arrows, or type a new number for the Degree of Spacing.
4. Click Apply.
   
   A larger number expands text. A negative number compresses text.
5. Click Close.

Changing the Text Style

The Styles menu gives you a choice of seven styles for text.

You can apply more than one style to text at a time, such as bold and italic. Choosing Plain Text cancels any other styles.

For information on applying color to text, see “Using Color in GeoWrite” later in this chapter.
To change the text style...

1. Select the text.

2. Choose a style from the Styles menu.
**GeoWrite lets you** enter your choice of units of measure in most of the dialog boxes throughout the application. The default is usually inches but you can enter any of the following units—as long as you use the correct abbreviation.

<table>
<thead>
<tr>
<th>Units of Measure</th>
<th>Abbreviated</th>
<th>One Inch is</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inches</td>
<td>in or &quot;</td>
<td>1 inch</td>
</tr>
<tr>
<td>Picas</td>
<td>pi</td>
<td>6 pi</td>
</tr>
<tr>
<td>Points</td>
<td>pt</td>
<td>72 pt</td>
</tr>
<tr>
<td>Centimeters</td>
<td>cm</td>
<td>2.54 cm</td>
</tr>
<tr>
<td>Millimeters</td>
<td>mm</td>
<td>25.4 mm</td>
</tr>
<tr>
<td>Ciceros</td>
<td>ci</td>
<td>5.63 ci</td>
</tr>
<tr>
<td>European points</td>
<td>ep</td>
<td>67.57 ep</td>
</tr>
</tbody>
</table>

There are 12 (American) points in a pica.

Similarly, there are 12 European points in a cicero.
The page ruler borders the top of the window and is your guide in changing margins, indenting paragraphs, and setting tabs.

Normally, the page ruler shows you the current margins, indents, and tabs. When you select a range of text, however, the ruler turns gray and shows only those settings that are common to all the selected paragraphs.

Setting Your Tabs

Setting tabs is simply a matter of dragging the type of tab you want from the tab well and positioning it on the ruler. You clear tabs by dragging them off the ruler in any direction.

You have a choice of four types of tab:

↑ Left tab aligns text on the left.

↑ Right tab aligns text on the right.

↑ Center tab centers text at the tab location.

↑ Decimal tab aligns text around a decimal point.
Using the Ruler

See "More About Tabs" later in this chapter.

To set and clear tabs...

1. If necessary, choose Show Ruler Bottom from the Options menu so that the tab markers are visible.

2. Position the text cursor in the paragraph for which you are setting tabs, or select multiple paragraphs.

3. Drag a tab marker to the location you want on the ruler. Releasing the mouse button sets the tab.

4. Continue dragging tabs from the tab well to set as many tabs as you want.

To move a tab, drag it to a new position on the ruler.

To clear a tab, drag it off the ruler in any direction.
To copy a tab...

1. Create the first tab.

2. Hold down the [Ctrl] key and drag the tab to a new position on the ruler. The original tab stays in place. The copy is the same tab type and contains the same formatting as the original tab.

Changing Margins

You can isolate an important point or offset a long quote by narrowing the margins of a particular paragraph. You adjust the left and right margin markers on the ruler to change a paragraph’s margins. You indent the first line of a paragraph with the first line indent marker.

The individuals in this organization are all here for their own reasons. But every single one of us believes in the need for change. As our founder is fond of saying,

*If you believe something needs doing, do it!*

*So as a group, the purpose and goals of this organization are to:*

- Promote the status of electronic music combined with laser light worldwide

Note that the left margin marker is split into two halves. The top portion allows you to indent the first line separately from the left margin of the paragraph.

When you extend the first line to the left of the rest of the paragraph, you create an indentation referred to as a “hanging indent.” This
indentation is typically used for bulleted lists, numbered steps, and bibliographies. Dragging the first line indent marker to the left of the left margin marker creates this paragraph style. See "To create a hanging indent..." in this section.

**To change paragraph margins...**

1. Position the text cursor in the paragraph, or select multiple paragraphs that you want to change.

2. Hold down [Shift] and drag the left marker to a new position on the ruler.

3. Drag the right margin marker to reset the right margin.

If you want to change the margins for the entire document, choose Page Setup from the File menu. Otherwise, change paragraph margins with the margin markers on the ruler.

**To indent the first line only...**

1. Position the text cursor in the paragraph to be indented, or select multiple paragraphs.

2. Drag the left indent marker (upper half) to the correct position on the ruler.
To create a hanging indent...

1. Select the paragraph(s) you want to align with a hanging indent.

   A hanging indent sets the first line to the left of the rest of the paragraph.

2. Drag the left margin marker (the lower portion of the left markers) to the right. Leave the first line indent marker (the upper portion) in place.

   Indent marker is set farther out than the left margin.

   Text starts at indent position, but wraps at left margin position.

   - Promote the status of electronic music combined with laser light worldwide
   - Locate and encourage

Centering and Justifying Text

GeoWrite sets justification on a paragraph-by-paragraph basis. A paragraph may be several lines or only a few words—as long as it is separated from other text by pressing [Enter].

   Left justified text

   Right justified text

   Centered text

   Fully justified text

   This text is left justified. Notice how the text is evenly aligned along the left margin, but is ragged on the right. This is the most common justification for body text.

   This text is right justified. Notice how the text is evenly aligned along the right margin, but is ragged on the left. It is usually only used for a special effect.

   This text is center justified. Notice how each line is centered between the margins.

   This text is fully justified. Notice how each line is spaced to align evenly along both margins, except for the last line.
To center or justify text...

1. Choose Show Ruler Bottom on the Options menu to display the lower portion of the ruler if it is not showing.

2. Click a justification icon on the ruler:
   - Align Left aligns text evenly along the left margin.
   - Align Right aligns text evenly along the right margin.
   - Center justification centers the text between the paragraph's right and left margins.
   - Fully Justify aligns text evenly along both the left and right margins.

   The change affects the paragraph that the text cursor is in or any paragraphs that are selected when you click the icon.

Changing Line Spacing

You can choose Single, Double, or One-and-a-Half spacing settings by clicking the appropriate spacing icon on the ruler.

To change the line spacing...

1. If necessary, choose Show Ruler Bottom on the Options menu to see the line spacing controls.

2. Click the text cursor in the paragraph to be spaced or select multiple paragraphs.

3. Click one of the three line-spacing icons on the ruler:
   - Single spacing
   - One-and-a-half spacing
   - Double spacing

   For more information see “Setting Paragraph Spacing.”
In *typesetting terms*, line spacing is called *leading*.

In addition to the three standard line spacing controls available on the ruler (Single-, Double-, and One-and-a-Half), GeoWrite lets you customize the leading above, below, and within the paragraph by choosing the Paragraph Spacing command on the Ruler menu. This flexibility is useful for adding space before or after a heading, or for pulling lines of text closer together to fit in a column or small area.

You have a choice of setting Automatic or Manual leading:

- With Automatic leading, the largest font on the line is multiplied by the value you enter. You enter 2 for double-spacing, 3 for triple-spacing, and so forth.

- With Manual leading, you enter a specific leading value.

GeoWrite displays measurements in dialog boxes in inches as a default. Using the correct abbreviation, you can enter values in any of these units: in (inch), pi (pica), pt (point), cm (centimeter), mm (millimeter), ci (cicero), or ep (European point).
To set custom line spacing...

1. Position the text cursor in the paragraph you want to change.

2. Choose Paragraph Spacing from the Paragraph menu. Note that under Leading you have two choices: Automatic and Manual.


4. Click the arrows or type a value such as 3 in the Line Spacing box for triple-spacing.

   The normal line spacing (as determined by the largest font size on the line) is multiplied by this number. 1 is single-spacing, 2 is double-spacing, and so forth. You can enter a fractional value.

5. Click Apply.

6. Click Close.

To manually set the leading...


   The Manual option lets you enter a specific value rather than a multiple of the normal line spacing.

2. Click the arrows or type a new value in the Manual Leading box.

3. Click Apply.

4. Click Close.
To change the spacing above or below a paragraph...

1. Choose Paragraph Spacing from the Paragraph menu.

2. Click the arrows or type a value for Space on Top or Space On Bottom.

3. Click Apply.

4. Click Close.
In addition to setting and clearing tabs directly from the ruler, the Paragraph menu contains two commands, Default Tabs and Tab Attributes, that let you further refine your tabs:

- Use Default Tabs to change the default tabs.
- Use Tab Attributes to insert leaders or vertical lines for design and emphasis.

Changing the Default Tabs

GeoWrite sets tabs every one inch as the default for new documents. Note that default tab stops are marked by a small crosshairs below the numbers on the ruler.

To change the default tabs...

1. Choose Default Tabs from the Paragraph menu.
2. Click one of four options on the cascade menu: Half Inch, One Inch, Two Inches, or None.

Using Tab Leaders

Tab leaders automatically insert a line or a row of dots between the text and the leader tab. For example, leading dots are often used to
fill in the space between a table of contents entry and its page number, as the following example shows.

![Table of Contents Example]

**Chapter 5 - Using GeoWrite**

- What You Can Do With GeoWrite ........................................ 1
- Starting and Exiting GeoWrite ........................................... 2
- Opening a Document .......................................................... 3
- The GeoWrite Window .......................................................... 4
- The Header, Body, and Footer ............................................ 4
- Changing the Size of Your View ........................................ 5
- Moving Between the Pages of a Document ............................ 6

To set tab leaders...

1. Click the tab on the ruler. A small arrow appears beside it indicating that it is selected.

2. Choose Tab Attributes from the Paragraph menu or double-click the tab on the ruler.

3. Select either Dot or Line under Tab Leaders.

The options are dimmed when no tab is selected. The leader is associated with the tab that is selected.

4. Change the Tab Type if necessary.
5. Click Apply.

You can go back and forth between the GeoWrite document and the dialog box. You do not need to close the dialog box until you have verified that the tab works to your satisfaction. You can also keep the dialog box open and click different tabs on the ruler.

**Drawing Vertical Lines With a Tab**

The tab lines feature lets you draw vertical rules for tables and columns. You can also use tab lines to mark parts of a document that have changed or to simply add an interesting design element to a document.

**To draw tab lines...**

1. Click to select a tab on the ruler. The arrow indicates which tab you are formatting.

2. Choose Tab Attributes from the Paragraph menu.

3. Turn on the Tab Lines option. Note that a line appears next to the tab on the ruler to show that a line will be drawn at the position of this tab.
You can specify the width and the amount of spacing between the tab line and the text. These options become selectable as soon as you turn on Tab Lines.

4. Click the arrows next to Tab Line Width. You can vary the line width from 1 to 3 points.

5. Click the arrows to change the Tab Line Spacing value from 1 to 3 points.

6. Click Apply to see the tab line in your document.

The tab is now formatted to insert a vertical line in your document when you press [Tab] at this tab stop. Using this tab on several continuous lines creates a solid vertical line.

If your document has more than one column, you can add vertical rules between the columns in Page Setup.
Storing a Style

A style is all the character and ruler settings such as font, size, style, and indentation that you have applied to text. You can store a style, then use it as a shortcut to format new or existing text.

If, for example, you have formatted a heading in Roman font, 14 point bold, with character spacing set at 200 for a heading, you can save the style with the Store Style command on the Edit menu. When it is time to type another heading, you can then choose Recall Style from the Edit menu before typing the heading. The heading is automatically formatted correctly as you type.

To store a style...

1. Format text with the font, size, style, and ruler settings that you want.
2. With the text cursor anywhere in the text, choose Store Style from the Edit menu.

To recall a style...

1. Click to position the text cursor in the paragraph you want to restyle or select multiple paragraphs.
2. Choose Recall Style from the Edit menu.

When you choose Recall Style, GeoWrite applies the settings of the last style you stored. The style changes the current paragraph, the paragraph of any selected text, and new text that you type at this location.
**GeoWrite lets you** add borders to paragraphs of text for emphasis and design. A paragraph is any text that you separate from other text by pressing **Enter**. You have a choice of three types of borders:

- One Line
- Two Line
- Shadow (with imaginary light source placed at top left, top right, bottom left, or bottom right)

A paragraph can have any one of three types of borders.

In addition, the Custom Border command gives you great flexibility in designing the borders. Borders can be colored and halftoned. Combined with paragraph color, borders offer a wide range of interesting possibilities.

**To add a standard border to text...**

1. Position the text cursor in the paragraph you want to border, or select multiple paragraphs.
2. Choose Border from the Paragraph menu. A cascade menu appears. Choose a border from the cascade menu: One Line, Two Line, or Shadow Top Left.

To remove a border, choose None.

**Customizing Borders**

Choosing Custom Borders displays a dialog box that lets you refine the three standard borders. For example, you may want a thick line that appears only above and below the text, not on all four sides.

![Custom Border with thick lines above and below only](image)

The Custom Border dialog box presents options according to the border type that you select. For example, when you choose a Double border, you have the option of adjusting the width between the double lines.

**To customize a border...**

1. Choose Border from the Paragraph menu. Then choose Custom Border from the cascade menu that appears.

2. Choose a Border type: Normal, Shadow, or Double Line.

   The dialog box displays different options according to the border type you choose.
3. Turn on the Draw Inner Lines option if you want a line drawn when you press \texttt{Enter} within the border.

The default is to not draw inner lines so that you can press \texttt{Enter} to add blank lines inside the border.

4. Click to deselect any Sides that you do not want bordered.

5. Click the arrows if you want to adjust Border Width, Border Spacing, Shadow Width, or the Width Between Lines of a two-line border.

If you select the Shadow border, you can select the corner from which the shadow is cast (Shadow Anchor).

6. Click Apply to see the results in your document.

7. Make final adjustments to the border settings and click Close when you finish.

To apply a color or halftone to the border see “Using Color in GeoWrite.”
Creating a Table

A table presents data in rows and columns. You can use tab lines in conjunction with a border to build tables in your documents. Here are the basic steps to creating a table in GeoWrite.

To create a table...

1. Set tabs on the ruler where you want each column of text to begin. Use decimal tabs where appropriate for numeric data.

2. Add a tab where you want a vertical line drawn between the columns of data. Double-click the tab to open the Tab Attributes dialog box and turn Tab Lines on. Click Apply.

3. Enter the data in the columns of the table. Be sure to use the Tab key. The tabs you formatted with tab lines create the vertical line between each of the columns.

Some table entries are inevitably longer than others. Tab to the appropriate column for each entry.

4. Select the entire table and choose Border from the Paragraph menu. Choose a border from the cascade menu that appears, or create a custom border for the table.
GeoWrite offers extensive color capabilities for your documents. If you have a VGA or EGA display, you can choose from a palette of 16 colors and apply the color to text, to a paragraph background, or to a border.

<table>
<thead>
<tr>
<th>To color…</th>
<th>Choose…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Color from the Styles menu</td>
</tr>
<tr>
<td>Paragraph background</td>
<td>Paragraph Color from the Paragraph menu</td>
</tr>
<tr>
<td>A border</td>
<td>Border from the Paragraph menu, then choose Border Color from the cascade menu. Tab lines within a border are also colored when you color the surrounding border</td>
</tr>
</tbody>
</table>

In addition to the preset 16 colors, you can vary the concentration of red, green, and blue to create custom colors.

About Color on a Monochrome System

The color palette starts with black and ends with white.

On a monochrome monitor the 14 intervening colors appear as patterns which simply distinguish the buttons in the palette. You cannot apply any of these patterns to paragraph backgrounds or borders; they are only stand-ins for the colors. If you want patterned objects in your document, you can create them in GeoDraw and paste them in (see “Inserting Graphics” later in this chapter).

Colors always appear and print as black on a monochrome monitor or printer. For example, if you color a border red on a color monitor and the printer is not a color printer, the border appears red on the
screen but prints black. Conversely, the red border appears black on a monochrome monitor but prints red on a color printer.

White is an exception. White appears on the screen and on the printed page as white regardless of the color capabilities of your system. White type on a black background is always an option.

The Halftone controls, on the other hand, change the intensity of text, paragraph backgrounds, and borders on both color and monochrome monitors. Halftones also print on both color and black-and-white printers. Halftone screens the concentration of color (including black) to create a lighter or darker image. See "About Halftones" later in this section.

**Coloring Text, Paragraphs, and Borders**

Whether you choose a color for text, a paragraph background, or a border, a dialog box presents the color controls in the same way. Here is the Color dialog box that appears when you choose Color from the Styles menu for text.
To use color...

1. Select text or position the text cursor in the paragraph containing the border or background you want to color.

2. To color text, choose Color from the Styles menu.

   To color a paragraph background, choose Paragraph Color from the Paragraph menu.

   To color a border you have already created for this paragraph, choose Border from the Paragraph menu. Then choose Border Color from the cascade menu that appears.

3. Click to select the color of your choice.

4. To create a custom color, use the arrows to vary the amount of Red, Green or Blue from 0 to 255.

5. To lighten the concentration of color, change the Halftone setting to Light (15%), Medium (25%), or Dark (50%).

6. Click Apply to see the change in your document.

7. When you finish, click Close.

The color capabilities of GeoWrite are very useful even if you are limited to the screen (colors print out as black on a monochrome printer). You can, for example, mark important paragraphs in red, or enter changes for a colleague's review in blue.
Creating White-on-Black Text

You can add the sharp look of white type against a black background with the Paragraph Color option. To create white type,

- Set the text to white
- Set the paragraph background color to black

To create white-on-black text...

1. Select the text you want to change.
2. Choose Color from the Styles menu.
3. Click White on the color palette and click Apply.
   The selected text “disappears” (becomes white on white) until you add color to the paragraph background.
4. Choose Paragraph Color from the Paragraph menu.
5. Click the black square or other color on the color palette.
6. Click Apply.

The white type that you selected or that you type is now visible against the contrast of the background.

About Halftones

GeoWrite provides four Halftone settings that you can apply to text, borders, and backgrounds.

No halftone screening

Light

Medium

Dark

The four different halftone settings
Halftones change the concentration of color or black according to the following percentages:

The Halftone settings proportionately turn off the number of pixels that display the color or black on the screen. On the printed page, the number of dots of ink are screened according to these percentages.

<table>
<thead>
<tr>
<th>Halftone Setting</th>
<th>Concentration of Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Solid:</td>
<td>100%</td>
</tr>
<tr>
<td>Dark:</td>
<td>50%</td>
</tr>
<tr>
<td>Medium:</td>
<td>25%</td>
</tr>
<tr>
<td>Light:</td>
<td>15%</td>
</tr>
</tbody>
</table>

Halftones work with color and monochrome displays and printers. Halftone text is most effective with large fonts.

To apply halftones...

1. Select the text. Or position the text cursor in a paragraph if you want to apply a halftone to its border or background.

2. Choose one of the following commands:
   - Color from the Styles menu (for text)
   - Paragraph Color from the Paragraph menu
   - Border from the Paragraph menu and then Border Color from the cascade menu that appears

3. Select a Halftone setting: Solid (100%), Light (15%), Medium (25%), or Dark (50%).

4. Click Apply to see the change.

5. When you finish, click Close.
Logos, lines, and other graphic elements that you create in a drawing application such as GeoDraw can be pasted into your GeoWrite documents from the Clipboard or the Scrapbook.

When you paste a graphic into your document, the graphic appears at the position of the text cursor. The line of text expands to accommodate the height of the drawing. Once placed, you move the graphic as you do text—moving it forward on the line by pressing the Spacebar or moving it to the next line by pressing Enter. You can double-click to select it as you would a word of text, then use the Cut, Copy, and Paste commands to reposition it in the document.

Copying Graphics From GeoDraw

With the multitasking capabilities of the GEOS environment, you can work in both GeoWrite and GeoDraw at the same time, creating and copying graphic elements into your document. Once drawn, you can copy a logo or other artwork to the clipboard, return to GeoWrite, and paste it into your document. Or you can store it more permanently in a scrapbook and copy it into documents from there.
To switch to GeoDraw and copy a graphic...

1. If GeoDraw is not already running, choose Startup from the Express menu and choose GeoDraw from the cascade menu that appears.

2. Create a graphic element with the tools at hand (see Chapter 6, "Using GeoDraw"). Or choose Open from the File menu to access artwork in an existing GeoDraw document.

3. Select the graphic you want and choose Copy from the Edit menu.

4. Choose GeoWrite from the top of the Express menu.

5. Position the text cursor where you want the graphic to appear in the document.

6. Choose Paste from the Edit menu to insert the graphic.

   The line expands to the height of the graphic. You can insert text before or after the drawing.

Hiding Graphics

For a document that contains complex graphics, you may prefer to turn off the Draw Graphics option on the Options menu. This replaces graphics with a rectangular placeholder and speeds up scrolling.

To temporarily hide graphics...

Open the Options menu and click to deselect the Draw Graphics option.

To restore the hidden graphics, click Draw Graphics again.
Changing the Page Setup

**Page Setup lets** you specify the basic layout of your document. With this command you set the page, column, and margin settings.

The Page Setup settings include:

- Printed page size
- Portrait or landscape printing
- Number of columns
- Title page
- Alternating left and right margins for facing pages
- Page margins

You can open the Page Setup dialog box at any time to change the parameters of your document.

**To change Page Setup...**

2. Select one of the Page Sizes—Letter, Legal, Tabloid, or Small.

3. Select the Orientation for the page: Portrait (prints across the width of the page) or Landscape (prints across the length of the page).

4. Select the number of Columns.

   When you specify multiple columns (2, 3, or 4), the Spacing and Rule Width controls become selectable.

   The Spacing control lets you adjust the white space between columns from 0 to 1 inch. Change the Spacing by clicking the arrows or typing a new value.

   Rule Width adds a vertical rule between the columns. You can set the width of this line from 1 point (hairline) to 9 points.

   For more on multiple columns, see “Working With Columns” later in this chapter.

5. Click Yes for Alternate Left and Right Margins if you are creating facing pages. This lets you create a wider inside margin for binding or hole-punching double-sided pages. The Left and Right Margins options change to Inside and Outside when you click Yes.

   Note that the Alternate Left and Right Margins option also creates a separate, alternating header and footer for the right and left pages.

6. Click Yes if you want a Title Page inserted before the first page of your document. A title page contains no header or footer and is not included in the page numbering.

7. Set the Margins of your document by clicking the arrows or typing a value for Left (or Inside), Top, Right (or Outside), and Bottom.
GeoWrite sets the margins of new documents to 1 inch (72 points). You can enter the value in one of seven units of measure with the appropriate abbreviation (in, pi, pt, cm, mm, ci, or ep).

8. Click OK.

GeoWrite applies your Page Setup changes and displays the document window.
Creating a Title Page

When you select Title Page as part of Page Setup, GeoWrite automatically inserts a title page before page one of the document.

For example, you may want a cover page on the document that has headers and footers. Choosing the Title Page option suppresses the headers and footers, starting them on page one. Page numbering also starts automatically from page one, not from the title page.

To create a title page...

1. Choose Page Setup from the File menu.
2. Select Yes for Title Page and click OK.

The header and footer areas disappear from the title page and the page indicator on the ruler reads “Page: TP” when you are on the title page.

To go to the title page...

- Click the left arrow beside the page indicator on the ruler until you see the title page and the page indicator reads “Page: TP.”

Or,

- Choose GoTo Page from the Window menu, type “TP” and click OK.
To remove a title page...

1. Choose Page Setup from the File menu and select No for the Title Page option.

2. Click OK.
When you scroll to the very top of the page, you see a header area outlined and ready for text or graphics. GeoWrite automatically creates the header and footer areas as part of the page. Text and graphics that you enter here appear on all pages of the document.

The header occupies the area between the top margin of the document and the printing edge of the paper (1/4 inch or 18 points). The default header is 3/4 inch high.

Similarly, the footer is the area between the bottom margin and the printing edge of the page. You adjust the height of the header or footer by changing the Top or Bottom margin settings in the Page Setup dialog box.

A header and footer do not appear on a title page (see “Creating a Title Page” above).

To edit a header or footer...

1. Scroll to the top or bottom of the page so that the header or footer area is visible.

2. Click the text cursor in the header or footer area and type or change the text. You can also add a logo or graphic from the clipboard or Scrapbook.
If you have selected Alternate Left and Right Margins in Page Setup, the document has alternating headers and footers (one for the odd-numbered pages and one for the even-numbered pages). You must make changes on both an even- and odd-numbered page to have the changes appear on both left and right pages.

All of the ruler and text controls are available and operate in the same way in the header and footer area as in the body of the page. For example, you can align the header or footer text on the right by clicking the right justify icon on the ruler.

**To resize the header or footer area...**


2. To make the header area larger, increase the Top margin. The header automatically expands to fill the area between the top margin and the printing edge of the paper.

   To make the header area smaller, decrease the Top margin, thus shrinking the area available for the header.

   To make the footer area larger, increase the Bottom margin. The higher it goes, the taller the footer.

   To make the footer area smaller, decrease the Bottom margin.

**To remove the header or footer area...**


2. To remove the header area, decrease the Top margin to the lowest possible setting—0.25 inch (18 pt)—which leaves no room for the header area.

   To remove the footer area, decrease the Bottom margin to the lowest possible setting—0.25 inch (18 pt).
3. Click OK.

If the header or footer area contains text, the text reappears when you open the header or footer area back up.

**Inserting the Page Number**

Page numbers are usually placed in either the header or the footer so that they appear on each page. The Insert Page Number command on the Edit menu enters a page number that updates automatically as your document evolves.

If you have a title page, the page numbering skips the title page and starts appropriately on page one.

**To insert automatic page numbers...**

1. Click the text cursor in either the header or footer.

2. Choose the font, size, and style that you want from the appropriate menus.

   If you want to center the page number, click the center justify icon on the ruler. If there is other text in the header or footer, drag a center tab to the middle of the ruler and press [Tab] rather than centering the whole line.

3. Type a prefix if you wish, such as a dash or the word “Page” followed by a space.

4. Choose Insert Page Number from the Edit menu.

The page number appears at the text cursor and updates automatically according to the page.
**Adding Page Breaks**

**GeoWrite gives you** a true WYSIWYG (What You See Is What You Get) view of the document you are creating. With its page view, you can easily see where the end of a page or column occurs.

When the break does not occur naturally in the right place, you can force a page or column break by choosing the Insert Page Break command from the Edit menu.

**To insert a page break...**

1. Position the text cursor where you want the page or column break to occur.

2. Choose Insert Page Break from the Edit menu.

You can also press **Alt** + **Return** to insert a page break.

**To delete a page break...**

1. Position the text cursor at the top of the page or column that you started with a hard page break.

2. Press **Backspace** to delete the inserted page break. Text ref lows automatically between the columns or pages.

For example, if you inserted a page break so that a paragraph would start at the top of the next page and you later change your mind, position the text cursor before the first word of that paragraph and press **Backspace** to delete it.
Documents such as newsletters display text in columns. Using the Page Setup command, you can easily divide your document into evenly spaced columns—two, three, or four columns to the page. All pages are divided into columns.

The area for the text in each column is outlined with a dotted line. Empty columns are grey. You can adjust the spacing between the columns and the text, thus controlling the amount of white space between the columns. Lastly, you can add a vertical rule between the columns; the width of the rule is also adjustable.

To create multiple columns...

1. Choose Page Setup from the File menu.

2. Select 2, 3, or 4 under Columns.

   When you choose more than one column, the Spacing and Rule Width controls become selectable.

3. Change the Spacing between the columns by clicking the arrows or typing a new value from 0.175 to 1 inch.

The default is in inches but you can enter values in any unit using the correct abbreviation: in (inch), pi (pica), pt (point), cm (centimeter), mm (millimeter), ci (cicero), or ep (European point).
4. To add a vertical rule between the columns, click the arrows or type a new value from 1 (hairline) to 9 points (0.175 of an inch).

To delete the rule, set the Rule Width to 0 (zero).

5. Click OK to apply the changes to your document.

To add column breaks...

1. To start text at the top of a new column, position the text cursor where you want the text to break.

2. Choose Insert Page Break from the Edit menu. The text cursor moves to the top of the next column.

To delete column breaks...

1. Position the text cursor at the top of the column following the inserted column break. For example, if you have a column break before a heading and change your mind, position the text cursor before the first word of the heading.

2. Press [Backspace] to delete the column break. The heading and text automatically flow back into the available space in the previous column.
You can open multiple documents at a time with the Open command in the File menu and switch between them using the Window menu.

Here are the commands on the Window menu:

**Previous Page:** This command displays the previous page in the page order. The left Page arrow on the ruler is the shortcut for this command.

**Next Page:** This command displays the next page in the page order. The right Page arrow is the shortcut for this command.

**Go to Page:** This command takes you to a specific page.

**Redraw:** This command redraws the screen to remove any stray dots that may appear when the paragraph spacing is very tight.

**Full-Sized:** This command lets you view one full-sized page of the document at a time.

**Overlapping:** This command lets you view up to four of the most
recently used pages of open documents in separate overlapping windows.

The Window menu also lists all the open documents so that you can switch between them. You can also use the Overlapping command on this menu to place up to four pages of your current document in separate windows so you can view more than one page at a time.

For more on the Window menu, also see “Working With Documents” in Chapter 4, “The Professional Workspace”.

To switch to a different open document...

Either click a part of the document’s window that is visible, or choose the document name from the bottom of the Window’s menu.

To view more than one page at a time...

1. Choose the Overlapping command from the Window menu.

GeoWrite breaks out the pages of open documents into separate windows so that you can work with up to four pages at a time. The title bar at the top of each window shows you the document name and page number.
2. Resize and arrange the windows on your screen as you like. You can reduce the text from the View menu to preview the pages side-by-side.

To view documents one page at a time...

Choose the Full-Sized command from the Window menu.
**Using the Options Menu**

**The Options menu** gives you several options that let you tailor GeoWrite to your liking. The first three commands on the Options menu are:

**Draw Graphics:** Turn off this option to replace graphics with a placeholder for faster scrolling.

**Align Ruler With Page:** When this option is on, it aligns the ruler to the edge of the paper rather than to the left margin.

**Snap to Ruler Marks:** This option causes tabs and markers on the ruler to snap to the 1/8 inch marks on the ruler when moved.

The next four commands are toggles that show or hide the top ruler, the bottom ruler, the horizontal scroll bars, and the vertical scroll bars. These are followed by a global command, Show All or Hide All, that turns these four toggles all on or off.

The last option, Save Options, lets you save the settings of the Options menu.
The **Print command** opens a dialog box that lets you tailor printing for a fast draft or high quality final output. You can start and end printing at specific pages, and ask GeoWrite to collate the pages when printing more than one copy.

If you have more than one printer connected, you can select the one you want to use for this printing. You can also change other printer options, such as paper size and paper source.

**To print a document...**

1. If necessary, choose Page Setup from the File menu and choose a paper size and page orientation.
2. Click OK to close the Page Setup dialog box.
3. Choose Print from the File menu.
4. Select the Print Quality:
   - Select High to print at the highest resolution of your printer.
   - Select Medium to print at medium resolution (if the selected printer has this capability).
* Select Low to print at the low resolution for quick drafts.

5. Click Text Mode Only for faster printing at any print quality level. This option uses your printer's internal fonts and does not print your graphics. The printed output may be very different from what you see on the screen.

6. To print only a portion of the document, click From and enter the page number you want to start printing with. Enter the page numbers by clicking the arrows or typing the page numbers.

7. Enter the Number of Copies. If you want more than one, you can select the Collate option, which prints one copy at a time from beginning to end.

8. Click Print to start printing.

**To choose a different printer or paper size or paper source...**

1. Choose Print from the File menu.

2. Click the Change Options button in the Print dialog box.

3. To change printers, select a printer from the list.
The printer list shows the printers you chose when you installed GEOS. When your printer environment changes, choose Setup from the Express menu and choose the Preferences desk tool. The changes you make using the Preferences desk tool appear in the Print dialog box the next time you choose the Print command. See "The Preference Desk Tool" in Chapter 11, "Using the Desk Tools," for more details.

4. Select a Paper Size from the list of sizes.

You can override these choices by entering the Width and Height of your paper in the boxes below. Paper height can be as large as 34 inches. If you enter a width that is wider than your printer allows, GeoWrite uses the maximum supported size.

5. Select Tractor or Manual Feed as the Paper Source for this printing.

6. Click OK, then click Print in the Print dialog box.
The File menu contains two commands that let you save the current document to disk:

- Save: Use this command when you’re through with the document, want to make your changes permanent, or when you’re about to try something new and want to be able to Revert back to the current document.

- Save As: Use this command to save a copy of your document under a different name.

The first time you save, a dialog box appears for you to save the document.

You don’t actually have to save your document while you’re working on it. GeoWrite automatically safeguards your data as you go—in other words, it keeps a temporary “working” copy on hand. In the event of a power failure or other problem, your work isn’t lost even if you haven’t saved. You can set how frequently GeoWrite safeguards your documents using the Preferences desk tool. See “The Preferences Desk Tool” in Chapter 11, “Using the Desk Tools,” for more information.

To name and save a GeoWrite document...

1. Choose Save or Save As from the File menu. The Save As dialog box appears.

2. Go to the directory where you want to save the document.

   The Save dialog box shows you the files and subdirectories in your current directory. To go into a subdirectory, double-click its name or icon in the scrolling list.

3. Type a name for the document and click Save.
To save a copy of the GeoWrite document with a different name...

1. Choose Save As from the File menu. The Save As dialog box appears.

2. Go to the directory where you want to save the new document.

3. Type the new name for the document and click Save.

The title of the document at the top of the window changes to the new name. This means that your changes are saved into this new document from now on.

To save your changes as you work...

After you have named and saved the document once, choose Save from the File menu to save any additional changes as you work. It's a good idea to save after you make an important change.
To revert to the previously saved version...

If you start revising your document and don’t like the changes you’ve made, you can return to the last saved version by choosing Revert from the File menu.

The Close command closes the document and prompts you to save if changes have been made since you last saved.

To save your document as a DOS text file...

You can choose to save only the text portion of your document without saving the formatting and graphics. This file can then be used by other DOS programs, or with the Notepad application.

1. Choose Save Text File from the File menu. The Save As dialog box appears.

2. Change the drive or directory, if necessary. For detailed steps, see “To save and name a GeoWrite document…” earlier in this section.

3. Type a name for the DOS text file and click Save.
To close a GeoWrite document...

Choose Close from the File menu.

If you have made changes that you have not saved, you see a reminder to save.

Click Yes or press [Return] to save your work before closing.

The Close command only closes the current document. If you have more than one document open, you now see the window of the next open document.
GeoDex combines a card file with a phone auto-dialer. It’s ideal for keeping track of friends, relatives, and business contacts. Browsing, listing, and free-form search capabilities make finding a name quick and easy. You can also print lists of names and phone numbers, and if you have a modem you can use GeoDex as a phone dialer.

This chapter describes how to use the GeoDex application.
USING GEODEX

295 Starting and Exiting GeoDex
296 The GeoDex Window
298 Adding Cards
301 Flipping Through Cards
302 Making Changes
303 Dialing
307 Browsing
309 Searching
312 Printing
315 Saving a Document
317 Linking to GeoPlanner
319 Cutting and Pasting
Starting and Exiting GeoDex

You start and exit GeoDex from GeoManager, the same way that you start and exit all GEOS applications.

There are ways to start GeoDex other than those described in this section. For more information, see “Using Applications” in Chapter 4, “Using the Professional Workspace.”

To start GeoDex and open the standard address book...

- From the GeoManager WORLD directory, double-click the GeoDex icon. GeoDex starts, opening the standard address book.
- From another GEOS application, choose Startup from the Express menu. A cascade menu appears. Choose GeoDex from this second menu. GeoDex starts, opening the standard address book.

To start GeoDex and open a particular address book...

From the GeoManager DOCUMENT directory, double-click the icon of the GeoDex document you wish to open. GeoDex starts and automatically opens the document.

To exit GeoDex...

Choose Exit from the File menu.

If you’ve made changes to the address book since the last time you’ve saved, GeoDex asks you if you wish to save these changes. Click Yes to save your work or click No to ignore all the work you’ve done since the last time you saved. For information about saving address book documents, see “Saving a Document” later in this chapter.
The GeoDex Window

When you start GeoDex, the GeoDex window appears.

Letter tabs: Clicking a letter tab flips to the cards listed under that letter.

Address card: GeoDex stores information on cards. Each card has the person's name, address, and phone numbers.

Next and Previous card: Clicking these buttons flips to either the following or the preceding card. Cards are ordered alphabetically.

New card: Clicking New Card brings up a blank card for you to fill in.

Quick dial: Clicking this button provides a listing of your most often called and most recently called phone numbers for quick dialing.

GeoPlanner: Clicking this button searches for names in the GeoPlanner calendar.
The Address Card

Like an office card file, you record names and addresses on cards, one card for each person.

Index field: Each card has an index that GeoDex uses to alphabetize the cards. Normally you type the person’s last and first name here so that the cards are ordered by name. You can, however, enter anything you want here; for example, enter area codes instead of names to order the cards by area code.

Address area: Shows the person’s name and address. The address area scrolls to accommodate an address more than five lines long.

Phone number: Each card can store seven different phone numbers—Home, Work, Car, and Fax, along with three additional numbers that you can label as you wish. Only one number shows at a time.

Next and previous phone number: Since you can only see one phone number at a time, clicking the up and down arrows brings up the other numbers.

Dial: Clicking this button dials the number currently showing on the card.
Adding Cards

It's easy to put a new name into GeoDex.

To add a person...

1. Click New. A blank card appears.
2. In the index field, type the person's last name, then the first name, separated by a comma. For example:

   Taggert, William

Press Enter to copy the name down to the address area.

3. If you're satisfied with the name as it is, press Enter to move down and enter the address. To change the name, press Backspace to remove the current name, then type it correctly. Press Enter when you finish.

The cards are sorted by index. By entering something other than names in the index field, you can order the cards differently. For example, you can use area codes or zip codes as indexes.
4. Type the address, pressing [Enter] at the end of each line. You may enter the address in any format you wish. You may also make addresses as many lines as you like; the address area scrolls to accommodate long addresses.

5. Press [Tab] The text cursor moves into the telephone number area. Click the two arrow buttons to select the type of telephone number—home, business, fax, or car.

6. You may enter more than one telephone number. Click the arrows again to select another type of number.

GeoDex accepts phone numbers in almost any format. If you wish to use the dialing features, you must make sure that you enter the phone numbers into the address book with any special codes that you would dial on a regular telephone.

Here are some guidelines for entering phone numbers:

- Omit the area code for local numbers.
- For long distance calls, include the 1 and the area code as in this example:

  1-415-555-1212

- If the number needs a special dialing sequence—to access a long
distance service, for instance—be sure to enter this sequence before the regular number:

10288-1-202-555-1212

• Place a comma anywhere in the number where you want a brief pause in the dialing sequence. This is actually a modem feature; not all modems support it and different models delay for different amounts of time. Check your modem owner’s manual for more information about this feature.

• If there is a special number that you always dial before each number—such as an access code for an outside line—you can enter it in front of every number or have GeoDex automatically place it in front of every number by entering it in the Dialing Option window (see “Setting the Dialing Options” later in this chapter).

For instance, if you always dial a 9 before dialing the phone number, you could type it as part of the number, as in this example:

9, 555-1212

In this example, the access code is separated from the number by a comma. This not only makes the number more readable, but also pauses the dialing briefly to give the access code time to work.

You could leave both the access code and the comma off of the phone number and instead enter them in the Prefix box on the Dialing Options window. This is the best choice if you must dial the access code before all of the phone numbers.

• To make the phone numbers easier to read, separate the parts of the number with dashes (“-”) or spaces. You can also use parentheses, as in this example:

1 (415) 555-1212

1-415-555-1212
You can flip through cards in the GeoDex address book in much the same way that you flip through cards in an office card-file.

To flip through cards...

- Click the Next arrow to flip to the following card.
- Click the Previous arrow to flip to the preceding card.

Or,
- Press [PgUp] to flip to the following card.
- Press [PgDn] to flip to the previous card.

Cards are ordered alphabetically by their indexes. Flipping past the last card takes you to the first, and vice-versa.

To flip directly to a letter...

Click the letter you wish to see. Letters appear as index tabs at the top of the card. The first card stored under that letter appears.

If there are no cards stored under that letter, GeoDex shows a blank card.

Double-clicking an index tab switches to the Both view before flipping to that letter.
You can easily change and delete cards. If you change your mind, GeoDex comes with an Undo feature that restores the card to its original form.

To change the information on a card...

1. Flip to the card you wish to change. See “Flipping Through Cards,” earlier in this chapter, for information about finding a particular card.

2. Change the name and address the way you would change any text—select it with the mouse and replace it with the new text.

3. To change a phone number, first click the arrows to bring up the number. Then change the number the same way that you would normally change text.

For more information about editing text, see “Entering and Editing Text” in Chapter 4, “The Professional Workspace.”

To undo a change...

Choose Undo from the Edit menu. The card reverts back to its original form.

To delete a card...

1. Flip to the card you wish to delete.

2. Choose Delete from the Edit menu. The card is removed from the address book.

To undo a deletion...

Choose Undo from the Edit menu. The card is restored to the address book.
You can use GeoDex to dial your telephone. To do this you must have a Hayes-compatible modem sharing the same line as your regular telephone. The instructions that came with your modem should tell you how to set this up.

You also need to set up the modem with the Preference Manager before you can use it. For more information, see “The Preferences Desk Tool” in chapter 11, “Using the Desk Tools.”

Before you dial a number from within GeoDex, make sure that your telephone is not off the hook. Often the modem cannot dial the number correctly if the telephone is off the hook.

To dial a number on the current card...

1. Make sure that you telephone is properly hung up.

2. Click the small arrows to scroll to the appropriate phone number.

3. Click Dial. The Dialing dialog box appears, telling you that GeoDex is starting to dial the phone number.

   If your modem has a built-in speaker, you hear the dial-tone, the number being dialed, and the ringing signal.

4. As soon as the modem finishes dialing the number, pick up the telephone handset and click Talk in the dialog box. This resets the modem before it can give its loud connect tone.

   If you don’t click Talk quickly enough, the person answering will not be able to hear you speaking. Clicking Talk transfers the call from the modem to your telephone.
To Quick Dial a number...

1. Make sure that your telephone is properly hung up.

2. Click the Quick Dial button.

3. A dialog box appears with two sets of numbers, those most often dialed and those most recently dialed. Click the button showing the name and number you wish to dial.

<table>
<thead>
<tr>
<th>Most Frequently Called People</th>
<th>Most Recently Called People</th>
</tr>
</thead>
<tbody>
<tr>
<td>Carlson, Steve/HOME</td>
<td>Taggert, William/HOME</td>
</tr>
<tr>
<td>Taggert, William/HOME</td>
<td>Carlson, Steve/HOME</td>
</tr>
<tr>
<td>Farley, Roger/OFFICE</td>
<td>Otis, Joyce/HOME</td>
</tr>
<tr>
<td>Otis, Joyce/HOME</td>
<td>Farley, Roger/OFFICE</td>
</tr>
<tr>
<td>Horton, Ed/HOME</td>
<td>Baker, Emily/HOME</td>
</tr>
<tr>
<td>Jensen, Carl/HOME</td>
<td>Balt, Tony/HOME</td>
</tr>
<tr>
<td>Langley, Chuck/HOME</td>
<td>Docket, Linda/HOME</td>
</tr>
<tr>
<td>Baker, James/HOME</td>
<td>Horton, Ed/HOME</td>
</tr>
<tr>
<td>Long, Arnold/HOME</td>
<td>Jensen, Carl/HOME</td>
</tr>
<tr>
<td>Farley, Roger/HOME</td>
<td>Langley, Chuck/HOME</td>
</tr>
</tbody>
</table>

The Dialing dialog box appears, and you hear the modem dial the number.

4. As soon as the modem finishes dialing the number, pick up the telephone handset and click Talk in the dialog box. This resets the modem before it can give its loud connect tone.

The two speed-dial lists are continually updated. For example, as you click on a number in the Frequently Called list, the number may move up the list because it is gradually becoming the most frequently called number. It also moves to the top of the Recently Called list, since it is the last number called.
**Setting the Dialing Options**

GeoDex can automatically dial special numbers in front of every number dialed. You enter these special numbers in the Dialing Options dialog box.

![Dialing Options](image)

**Prefix:** If your phone system requires that you prefix all your phone numbers with a special access code, you can have GeoDex automatically dial this prefix for you. For example, assume that your phone system requires that you dial 9 before every phone number, and that you’ve entered “9,”. If the address card shows 555-1212 as the number, GeoDex actually dials

9, 555-1212

**Area Code:** You can also have GeoDex turn every phone number into a long-distance number, which is handy if take your computer outside of the local area code but still want to dial the local numbers you have on file. For example, suppose you lived in the 415 area code and took your computer with you on long trips. If you want to dial all your local numbers but don’t want to change every number to have an area code, you could enter “1-415-” in the Dialing Options dialog box. If the address card shows 555-1212 as the number, GeoDex would dial

1-415-555-1212

Note that you should enter the initial 1 as well as the area code. Also note that the Area Code field accepts long-distance codes up to ten characters long from other countries.
To set a dialing option...

1. Choose Dialing Options from the Options menu. The Dialing Options dialog box appears.

2. Turn the option on by clicking the check box next to the option.

3. In the box, enter the numbers GeoDex should dial.

4. Close the Dialing Options dialog box by double-clicking the Control button.

To turn off a dialing option...

Click in the check box to turn the option off. For example, to stop GeoDex from placing a prefix in front of every number, click the check box next to Prefix.
You can view your address book as a list of names, instead of as a collection of cards. This list is called the Browse View, and it shows only names and phone numbers.

Browse list: This list shows the index field of all the cards in the address book. You can scroll the list to view all the cards.

Phone numbers: Clicking a name in the list causes the phone numbers to appear here. To scroll through the different numbers, click the up and down arrows.

Dial: Clicking this button dials the number shown in the phone number box.
To switch between the Card View and the Browse View...

- If you’re in the Card View, choose Browse View from the View menu.
- If you’re in the Browse View, choose Card View from the View menu.

To see a person’s phone number...

1. Scroll the browse list until you find the person whose phone number you want to see.
2. Select the name by clicking it. A phone number appears in the phone number box.
3. Click the up and down arrows to see the different numbers.

To dial a phone number...

1. With the phone number showing in the Phone Number box, click Dial. The Dialing dialog box appears, telling you that GeoDex is starting to dial the phone number.
   
   If your modem has a built-in speaker, you will hear the dial tone, the number being dialed, and the ringing signal.
   
   2. As soon as the modem finishes dialing the number, pick up the telephone handset and click Talk in the dialog box. This resets the modem before it can give its loud connect tone.
   
   If you don’t click Talk quickly enough, the person will not be able to hear you speaking. Clicking Talk transfers the call from your modem to the telephone.
**GeoDex lets you** search for cards that contain a certain bit of text; for example, you could find all the cards containing the word “Smith.”

You search using the Both view, which combines the Browse and Card views together. On one side is the browse list, showing all the names in the address book, and on the other is the address card.

You can search for part of a word, a whole word, or many words. GeoDex looks for the text in all the parts of the card—in the index field, name, address, or the phone number areas. This means that you could search for “Sm,” and GeoDex would find names like Smith, Smithee, and Small, and also people who lived on Smith Street or in Smallville.

If this is too broad a search, you can limit the search to the index fields. Because these fields normally contains the person’s name, this is effectively a name-only search.

In the index fields, GeoDex looks only for precise matches. If you enter “smith” in the Search For field, GeoDex won’t consider cards containing “Smith” to match—it’s looking for a “smith” beginning with a small “s.”
**Search For:** GeoDex looks for a card containing the text entered in this field.

**Find Next:** Clicking this button finds the next card that contains the Search For text.

**Confine Search to Index:** Turning on this option limits the search to the index field on each card, effectively making the search a name-only search.

**Clear:** Turning on this option clears the Search For text and turns the Confine Search feature off.

---

**To switch between the Card View and the Both View...**

- If you're in the Card View, choose Both View from the View menu.
- If you're in the Both View, choose Card View from the View menu.

---

**To search for a particular card...**

1. Make sure that you are in the Both view.

2. In the Search For field, type the text you wish to find.

3. If you wish to limit your search to names only, turn on the Confine Search to Index option.

4. Click Lookup. The first card containing the text is shown, and the Lookup button changes to read Find Next.

5. Click Find Next to find the next card that also contains the text.

If GeoDex cannot locate any cards that contain the Search For text, a dialog box appears informing you that no cards were found.
To clear the search criteria...

Click the Clear button. The Search For field clears and the Confine Search to Index option turns off.
You can print the cards in your address book. Choosing Print from the File menu displays a dialog box that lets you enter the number of copies and print a fast rough draft or high-quality final output.

To print the address book...

1. Choose Print from the File menu. The Printer dialog appears.
2. Click Change Options to change printers, the page format, or the paper source. A dialog box appears.
• If you have more than one printer installed, choose a printer from the list.

If you need to update your printer configuration, see “The Preferences Desk Tool” in Chapter 11, “Using the Desk Tools.”

• Choose the desired page size from the list of sizes. You can also override these choices by entering the Width and Height of your paper in the boxes below.

• If your printer has several paper sources, select the Paper Source you want to use for this printing.

Click OK to accept the changed settings, or click Cancel to keep the previous settings. This returns you to the Print dialog box.

3. Select the Print Quality:
   • High—prints at the highest resolution of your printer.
   • Medium—prints at medium resolution (not available for some printers).
   • Low—prints at low resolution for quick drafts.

For the fastest printing, select the Low option.

4. Enter the Number of Copies you want.

5. Choose what you want to print:
   • Print All—prints the name, address, and the phone numbers from all the cards
   • Print Phones—prints two columns of names and phone numbers
   • Print Labels—prints names and addresses in a format suitable for mailing labels
6. If you're printing mailing labels, the Label Size option lists the two different sizes that you can print. Choose one of the two.

7. Click Print to start printing.
The File menu contains two commands that let you save the current address book document to disk:

- **Save**: Use this command when you’re through with the document, want to make your changes permanent, or when you’re about to try something new and want to be able to revert back to the current document.

- **Save As**: Use this command to save a copy of your document under a different name.

You don’t actually need to save your document while you’re working on it. GeoDex automatically safeguards your data as you go—in other words, it keeps a temporary “working” copy on hand. In the event of a power failure or other problem, your work isn’t lost even if you haven’t saved. You can set how frequently GeoDex safeguards your document using the Preferences desk tool. See “The Preferences Desk Tool” in chapter 11, “Using the Desk Tools,” for more information.

**To name and save a GeoDex document...**

1. Choose Save As from the File menu.

2. Go to the directory where you want to save the document.

   The Save dialog box shows you the files and subdirectories in your current directory. To go into a subdirectory, double-click its name or icon in the scrolling list.

3. Type a name for the document and click Save.
To save a copy of the GeoDex document with a different name...

1. Choose Save As from the File menu. The Save As dialog appears.

2. Go to the directory where you want to save the new document.

3. Type the new name for the document and click Save.

The title of the document at the top of the window changes to the new name. This means that your changes are saved into this new document from now on.

To save your changes as you work...

After you have named and saved the document once, choose Save from the File menu to save any additional changes as you work. It's a good idea to save after you make an important change.

To revert to the previously saved version...

If you start revising your address book and don't like the changes you've made, you can return to the last saved version by choosing Revert from the File menu.
**GeoDex can search** the GeoPlanner calendar for scheduled events containing a particular name or bit of text. If, for example, you were looking at the card for Andrew Wilson, and you wanted to find the time of your next meeting with him, GeoDex could scan the GeoPlanner calendar for events containing the name “Andrew Wilson.”

GeoDex expects the text that you’re searching for to match the text in the GeoPlanner calendar exactly. If you search for “Andrew Wilson,” you won’t get events containing the name “andrew wilson.” For this reason, you should be consistent in the way that you enter names into both GeoDex and GeoPlanner.

You must start GeoPlanner before you can use this searching capability.

---

**To find a calendar item for the person on the current card...**

1. Make sure that GeoPlanner is started. See Chapter 9, “Using GeoPlanner,” for information about starting it.

2. Select the text. This text could be the person’s name, part of the address, or just some bit of text.
3. Click the GeoPlanner button. The GeoPlanner window comes up, and the first event containing the selected text is shown in the Event window.

   If you want to find the next event also containing the name, click Find Next in the Search dialog box.

4. Click Cancel in the Search dialog box when you're done searching.

5. When you finish looking at the calendar, return to GeoDex by
   - Clicking anywhere inside the GeoDex window
   Or,
   - Choosing GeoDex from the Express menu.

As an example, suppose you're looking at Andrew Wilson's card and you want to find your next scheduled meeting with him. Select the last name, "Wilson," and click the GeoPlanner button. The GeoPlanner window comes up, and your next meeting with "Wilson" is highlighted.

If this isn't the event you're looking for—maybe this particular event is with another person named "Wilson"—click Find Next (in the Search dialog box) to find the next event with "Wilson" in it. And so on until you find the event you're looking for.
It's easy to cut or copy text from GeoDex and paste it into some other application. For a full explanation of cutting and pasting between applications, see “Cutting and Pasting” in Chapter 4, “The Professional Workspace.”

To move or copy text to another application...

1. Select the text you wish to move or copy.

2. From the Edit menu,
   - Choose Cut if you want to move the text. The text is removed from the address book and placed on the clipboard.
   - Choose Copy if you want to copy the text. A copy of the text is placed on the clipboard.

3. In the other application, click to position the cursor at the point where you want to place the text.

4. Choose Paste from the Edit menu to copy the text from the clipboard into the document.

The same technique works if you want to copy text in the opposite direction—from another application into GeoDex.

To Quick Copy or Quick Move text...

1. Select the text you wish to move or copy.

2. Position the pointer over the selected text. Use the right mouse button for both the Quick Copy and Quick Move:
   - To Quick Copy the text, press and hold down the right mouse button. The pointer changes to a Quick Copy pointer.
To Quick Move the text, press and hold down the right mouse button while simultaneously holding down the Alt key. The pointer changes to a Quick Move pointer.

3. Still holding the right mouse button (and Alt if you’re doing a Quick Move), move the pointer until it’s over the spot where you wish to insert the selected text.

4. Release the right mouse button. The text is copied or moved to the new location.
GeoPlanner gives you both a yearly calendar and an appointment book in one powerful application. View this year’s calendar and then switch to next year’s—or last year’s—with one click of the mouse button. Schedule appointments or meetings, and have GeoPlanner automatically remind you about the important ones. You can even schedule recurring events, like birthdays or weekly meetings.

This chapter describes how to use the GeoPlanner application.
USING GEOPLANNER

323 Starting and Exiting GeoPlanner
324 The GeoPlanner Window
325 Working With the Calendar Window
327 Working With Events
331 Setting the Alarm
333 Working With Repeating Events
343 Searching
344 Printing
348 Saving a Document
350 Changing Views
352 Customizing GeoPlanner
354 Cutting and Pasting
356 Linking to GeoDex
Starting and Exiting GeoPlanner

You start and exit GeoPlanner the same way that you start and exit all GEOS applications.

There are ways to start GeoPlanner other than those described in this section. For more information, see “Using Applications” in Chapter 4, “Using the Professional Workspace.”

To start GeoPlanner and open the standard date book...

- From the GeoManager WORLD directory, double-click the GeoPlanner icon. GeoPlanner starts, opening the appointment book.

Or,

- From another GEOS application, choose Startup from the Express menu. A cascade menu appears. Choose GeoPlanner from this second menu. GeoPlanner starts, opening the appointment book.

To start GeoPlanner and open a particular date book...

From the GeoManager DOCUMENT directory, double-click the icon of the GeoPlanner document you wish to open. GeoPlanner starts and automatically opens the document.

To exit GeoPlanner ...

Choose Exit from the File menu.

If you've made changes to the date book since the last time you've saved, GeoPlanner asks you if you wish to save these changes. Click Yes to save your work or click No to ignore all the work you've done since the last time you saved. For information about saving date book documents, see "Saving a Document" later in this chapter.
The **GeoPlanner window** appears when you start the application.

**Calendar window:** Click a day or drag to select a range of days to view or schedule events for them.

**Event window:** In GeoPlanner, something you schedule—such as an appointment or a meeting—is called an event. The Event window shows everything scheduled on the days selected in the Calendar window.

**Previous Day and Next Day Buttons:** Click these buttons to change the day shown in the Calendar and Event windows.
**The Calendar window** shows the calendar for a given year. It normally shows one month at a time, though you can have it show several months at once if you desire.

Today's date is always marked with a dark outline. The selected days are also marked with their own color. Days that have events scheduled on them are marked with a small triangle.

To see a particular month while in Single Month view...

Click the scroll bars on the Calendar view window until you reach the desired month.

To view different years...

Change the Year field at the top of the GeoPlanner window, either by clicking the little arrows or by typing in a new year. You can enter any year from 1900 to 9999 AD. The Calendar window immediately changes to show the calendar for that year.
The Event window, however, doesn’t change as you change years; it always shows the selected day, which doesn’t change as you change years. The Event window changes when you select a new day.

**To switch between the Full Year view and the Single Month view...**

Choose one of the two views, Full Year or Single Month, from the View menu. The Calendar window immediately changes to show the new view.

The Calendar window normally starts in the Single Month view.
You can use GeoPlanner as an electronic date book for tracking events in your daily schedule. You can also use it to automatically remind you when it’s time for important appointments.

A very useful feature of GeoPlanner is its ability to schedule events that happen over and over continuously. This feature is described in “Working With Repeating Events,” later in this chapter.

**Scheduling Events**

Scheduling events is simply a matter of selecting the appropriate day, entering the time of the event and then typing a brief description of the event.

**To schedule an event...**

1. In the Calendar window, click the square of the desired day. The day’s events appear in the event window. Check the date above the Event window to make sure that you clicked the correct day.


3. Type the time of the appointment or event, as in the following example:

   - 10:40 am
   - 4:50 pm
If the event has no particular starting time, leave the time area of the event blank.

4. Press [Tab]. The cursor moves into the description portion of the event line.

5. Type a description of the event. You may fill as many lines as you like.

6. When you do something else—such as selecting a different day or starting a new event—GeoPlanner automatically verifies that you typed the time correctly and stores the event.

To change an event...

Change the event the way that you'd change any regular text, by selecting text with the mouse and re-typing it. See “Entering and Editing Text” in Chapter 4, “The Professional Workspace,” for more information.

If you make a mistake while changing an event, choose Undo from the Edit menu to restore the event to its original form. Note that you cannot undo after you change the day displayed in the Event window or after you change or delete another event.

To remove an event...

1. Click the event to select it. GeoPlanner draws a box around the event to show that it has been selected.

2. Choose Delete Event from the Edit menu. The event is removed from the window.

You can change your mind and restore a deleted event by choosing Undo from the Edit menu. Note that you cannot restore a deleted event after you change the day displayed in the Event window or after you change or delete another event.
Viewing Events

The Event window shows the events scheduled for a particular day or group of days.

GeoPlanner provides several shortcuts for quickly viewing the scheduled events of one day, the entire week, or the entire month.

To view a day's event...

In the Calendar window, click the square of the desired day. The day's events appear in the Event window.

To view the next or previous day's events...

- Click the Next Day button to view the day following the currently selected day. The Event window changes to show the day.

Or,

- Click the Previous Day button to view the day preceding the currently selected day. The Event window changes to show the day.

To view events for a range of days...

In the Calendar window, drag the mouse to select the days you wish to view. The events scheduled for those days appear in the Event window.
The Next Day and Previous Day buttons move you forward and backward by the same number of days that you've selected. For example, if you select four days and click Next Day, GeoPlanner selects the following four days.

To quickly view today's events...
Choose Today from the Quick menu. The Event window shows the events scheduled for today.
GeoPlanner uses the computer's built-in date to determine today's date.

To quickly view this week's events...
From the Quick menu, choose This Week. The Event window lists all the events scheduled for this week.

To quickly view this weekend's events...
From the Quick menu, choose This Weekend. The Event window lists all the events scheduled for Saturday and Sunday.

To quickly view this month's events...
Choose This Month from the Quick menu. The Event window lists all the events scheduled for this month.
**GeoPlanner** has an alarm that you can use to remind you that it's time for an important appointment.

Alarms normally go off at time of the event, but you can set them to go off a few minutes early to give you some time to prepare.

**To turn on the alarm for an event...**

Click the bell icon next to the particular event. The bell darkens, indicating that the alarm is set.

When the alarm goes off, a tone sounds and a dialog box appears, showing the description for the event.

**To stop the alarm once it's gone off...**

- Click Off in the dialog box to turn off the alarm and make the box go away.

Or,

- Click Snooze to turn the alarm off temporarily—like pressing the Snooze button on a bedside alarm clock. After five minutes the alarm goes off again.

**To make the alarm go off earlier...**

1. Choose Alarm Settings from the Edit menu. The alarm settings box appears.
Setting the Alarm

2. Change the Time. This is normally set to the time of the event. Enter the time that you wish the alarm to go off. For example, if you were setting the alarm for a 10:00 am appointment and you wanted five minutes to get ready, you’d enter 9:55 am.

3. Click OK. The dialog box goes away.

You can set all alarms to go off early as part of their standard operation. See “Customizing GeoPlanner” later in this chapter, for more information about this.

To turn off the alarm for an event...

Click the bell icon again. It changes from solid to outline form, indicating that the alarm is turned off.

You can also turn the alarm on and off with the Alarm Settings dialog box. Click the event with the right mouse button to change the Alarm Settings.
GeoPlanner makes it easy for you to schedule events that happen regularly. For example, you might have a staff meeting every Tuesday at 9:30 am. Or maybe you need to pick up your children from school early on the first Thursday of each month.

GeoPlanner can only handle those events that repeat at regular intervals. It can't handle dates that repeat at odd intervals—say, a meeting that happens on the third Friday in June, September, and November.

Here are some examples of repeating events:

- Every January 5th until 1995
- Every Monday and Wednesday in the current year
- Every second Friday

Such events are marked with a large R in the Event window to indicate that they repeat. You also see all of them together in the Repeating Events dialog box.

You define events in the Repeating Event dialog box.
Frequency: This shows an event's cycle. The event can happen every week, once a month, or once a year.

Specify by: Monthly and yearly events can be listed one of two ways: by date—January 7th—or by the day of the week—second Friday in June.

Select Days: For a weekly event, use these settings to choose the days of the week that the event occurs.

Month: For a yearly event, use this setting to choose the month when the event occurs.

Day of Month: For monthly or yearly events scheduled by date, use this setting to choose the day of the month on which the event occurs. If it always occurs on the last day of the month, click Last.

Day of Week: For monthly or yearly events scheduled by day of week, use this setting to choose the day. For instance, if you always get paid on the second Monday of the month, you would create a Monthly event and choose Second and Monday in the Day of Week field.

Time: Time of day that the event happens. Leave it blank if the event has no scheduled time.

Description of event: This brief description appears in the event window on the days of the event.

Range of dates: This shows the date of the first occurrence of the event and the date of the last. If the event continues on indefinitely, click Forever.

Scheduling Repeating Events

You use the Repeating Events command to create, edit, and remove all repeating events.
To schedule a repeating event...

1. Choose Repeating Events from the Utilities menu. The Repeating Events dialog box appears.

2. Click New. The Repeating Events dialog box appears.

3. Set the different options. See "Setting Some Common Events," later in this chapter, for information about scheduling some common kinds of repeating events.

4. Click OK to schedule the new event.

5. Click Close to make the Repeating Events dialog box go away.

To change a repeating event...

1. Choose Repeating Events from the Utilities menu. The Repeating Events dialog box appears.

2. Click to select the event you want to change and then click Change. The Repeating Events dialog box appears.

3. Change the information in the dialog box.

4. Click OK when you finish.

5. Click Close to make the Repeating Events dialog box go away.

You normally change repeating events with the Repeating Events dialog box. If you instead alter a repeating event by editing it within the Event window, GeoPlanner doesn't change the repeating event. Instead, it turns the repeating event into a regular event on that day, which you then change.
If you change the repeating event later on, this event won’t change, because it is “cut off” from the original repeating event.

**To remove a repeating event...**

1. Choose Repeating Events from the Utilities menu. The Repeating Events dialog box appears.
2. Select the particular event you want to remove.
3. Click Delete. The event is removed from the window.

**Setting Some Common Events**

Most of the repeating events that you’ll want to schedule are probably similar to one of the following examples.

**To schedule an event that occurs weekly...**

Suppose that you meet with your employees every Wednesday at 3:30 pm.

1. Begin a new repeating event by choosing Repeating Events from the Utilities menu (see “Scheduling Repeating Events,” earlier in this chapter).
2. Click the Weekly button in the Repeating Event dialog box.
3. Where it says Select Days, click the day or days when the event occurs. In this case, click Wednesday, since your meeting is every Wednesday afternoon.

If you make a mistake, click the button again to turn it off and choose another.

4. In the Time of Event box, enter the time of the event: 3:30 pm
5. In the Event box, type a brief description of the event. For this event, enter

meeting with employees

6. If the event starts on a particular date and continues through to another date, enter those two dates into the Repeat From and To boxes. On the other hand, if the event goes on indefinitely, click Forever.

Since this is the case with your employee meetings, you click Forever.

7. Click OK to enter the event.

To schedule an event that occurs on a certain date each month...

Suppose that you always pay your rent on the 5th of the month.

1. Begin a new repeating event as described in “Scheduling Repeating Events,” earlier in this chapter.

2. Click the Monthly button.

3. Because you always pay on a certain day of the week, click Date in the Specify By field.
4. Choose the particular date by changing the Date in the Day of Month field. In this case, change the Date to 5, since you pay on the 5th of the month.

5. In the Time box, enter the time of the event. For this example, unless you have a specific time when you have to pay your rent, you can leave the Time box empty.

6. In the Event box, type a brief description of the event. For this event, enter
   
   Pay rent

7. If the event starts on a particular date and continues through to another date, enter those two dates into the Repeat From and To boxes. If the event goes on indefinitely, click Forever.
   
   Since you pay rent indefinitely, you click Forever.

8. Click OK to enter the event.

---

To schedule an event that occurs on a particular day each month...

Suppose you get your paycheck on the first Monday of the month.

1. Begin a new repeating event as described in “Scheduling Repeating Events,” earlier in this chapter.
2. Click the Monthly button.

3. Because you're always paid on a particular day of the week, click Day of week in the Specify By field.

4. Choose the particular day by changing the Day of Week. In this case, change it to be First and Monday, since you get paid on the first Monday of the month.

5. In the Time box, enter the time of the event. For this example, unless you have a specific time when you get paid, you can leave the Time of Event box empty.

6. In the Event box, type a brief description of the event. For this event, enter
   
   Get paycheck

7. If the event starts on a particular date and continues through to another date, enter those two dates in the Repeat From and To boxes. If the event goes on indefinitely, click Forever.

   Since you get your paycheck indefinitely, click Forever.

8. Click OK to enter the event.
To schedule an event that occurs on a certain date each year...

Suppose you want to mark someone’s birthday—May 25—in GeoPlanner.

1. Begin a new repeating event, as described in “Scheduling Repeating Events,” earlier in this chapter.

2. Click the Yearly button.

3. Since a birthday always happens on the same date, click Date in the Specify By field.

4. Change the Month to be the month when the event occurs. In this example, choose May.

5. Choose the particular date by changing the Day of Month. In this case, change the Date to 25.

6. For this example you can leave the Time of Event box empty.

7. In the Event box, type a brief description of the event. For this event, enter
   
   Michael’s Birthday

8. If the event starts on a particular date and continues through to another date, enter those two dates into the Repeat From and To boxes. If the event goes on indefinitely, click Forever.

   For this example, you click Forever.

9. Click OK to enter the event.
To schedule an event that occurs on a particular day each year...

Suppose you want to mark Thanksgiving—which always happens on the fourth Thursday of November—in GeoPlanner.

1. Begin a new repeating event, as described in “Scheduling Repeating Events,” earlier in this chapter.

2. Click the Yearly button.

3. Because Thanksgiving always falls on a Thursday, click Day of Week in the Specify By field.

4. Change the Month to the month when the event occurs. In this example, choose November.

5. Choose the particular day by changing the Day of Week. In this case, change it to Fourth and Thursday, since Thanksgiving always falls on the fourth Thursday of the month.

6. For this example you can leave the Time box empty.

7. In the Event box, type a brief description of the event. For this event, enter

   Thanksgiving
8. If the event starts on a particular date and continues through to another date, enter those two dates into the Repeat From and To boxes. On the other hand, if the event goes on indefinitely, click Forever.

For this example, you click Forever.

9. Click OK to enter the event.
**GeoPlanner lets you** search for events that contain a certain bit of text; for example, you could find all the events containing the word "Smith."

GeoPlanner looks for the text in the event description. You can search for part of a word, a whole word, or many words. This means that you could search for "Sm," and GeoPlanner would find appointments with Smith, Smithee, and Small.

However, GeoPlanner is case-sensitive. If you enter "smith" in the Search For field, GeoPlanner won't consider events containing "Smith" to match—it expects both of the words to match *exactly*.

**To search for an event containing some text...**

1. Choose Search from the Utilities menu. The Search dialog box appears.

2. In the Search For field, type the text you want to find.

3. Click Start Search. The first event containing the text appears selected in the event window.

4. Click Find Next to find the next event that also contains the text.

GeoPlanner starts the search with today's events and continues on through the list of future events. If it can't find the text in any of those events, it asks you if you want to search through past events, too.

If there are no more past or future events that contain the Search For text, a dialog box appears telling you that the search is complete.
You can use GeoPlanner to print your scheduled events or to print monthly or yearly calendars.

Choosing Print from the File menu displays the Printer dialog box, which lets you enter the number of copies and choose to print a fast rough draft or high quality final output.

To print something with GeoPlanner...

1. Choose Print from the File menu.
2. Click Change Options to change printers, the page format, or the paper source. The Change Options dialog box appears.
• If you have more than one printer installed, choose a printer from the list.

If you need to update your printer configuration, see “The Preferences Desk Tool” in Chapter 11, “Using the Desk Tools.”

• Choose the desired page size from the list of sizes. You can also override these choices by entering the Width and Height of your paper in the boxes below.

• If your printer has several paper sources, select the Paper Source you want to use for this printing.

• Click OK to accept the changed settings, or click Cancel to keep the previous settings. This returns you to the Print dialog box.

3. Select the Print Quality:

• High—prints at the highest resolution of your printer.

• Medium—prints at medium resolution (not available for some printers).

• Low—prints at low resolution for quick drafts.

For the fastest printing, select the Low option.
4. Click Text Mode Only for faster printing at any print quality level. This option uses the printer's internal fonts, so the printed output may not match what you see on the screen.

5. Enter the Number of Copies you want.

6. In the GeoPlanner Print Options, choose what you want to print:
   - Event Window—prints what’s in the event window.
   - Month—prints a calendar for one or more months.
   - Year—prints a calendar for the current year. No events are printed.

GeoPlanner prints according to the selected days in the calendar window. For example, to print a calendar for February, first select a day in February from the Calendar window. Then choose Print from the File menu and choose Month. The Will Print box says “February.”

7. Click Print to start printing.

**To change the page setup…**

You can use Page Setup to change the way GeoPlanner prints.

2. If you want to print a calendar that is larger or smaller than the printer's paper, choose one of the Document Sizes. If the Document Size is larger than the paper in the printer, GeoPlanner prints part of the calendar on one sheet, and part on another. You can then tape the two pages together to form a larger sheet.

3. To make the calendar print sideways on the page, choose landscape for the Orientation.

4. Click OK when you finish.
The File menu contains two commands that let you save the current date book document to disk: Save and Save As.

- Use Save when you finish with the document, want to make your changes permanent, or when you're about to try something new and want to be able to revert back to the current document.

- Use Save As to save a copy of your document under a different name.

The first time you save, a dialog box appears for you to name the document.

You don't need to save your document while you're working on it. GeoPlanner automatically safeguards your data as you go—in other words, it keeps a temporary "working" copy on hand. In the event of a power failure or other problem, your work isn't lost even if you haven't saved. You can set how frequently GeoPlanner safeguards your document using the Preferences desk tool. See "The Preferences Desk Tool" in Chapter 11, "Using the Desk Tools," for more information.

To name and save a GeoPlanner document...

1. Choose Save or Save As from the File menu. The Save As dialog box appears.
2. Go to the directory where you want to save the document.

The Save dialog box shows you the files and subdirectories in your current directory. To go into a subdirectory, double-click its name or icon in the scrolling list.

3. Type a name for the document and click Save.

**To save a copy of the GeoPlanner document with a different name...**

1. Choose Save As from the File menu. The Save As dialog box appears.

2. Go to the directory where you want to save the document.

3. Type the new name for the document and click Save.

The title of the document at the top of the window changes to the new name. This means that from now on your changes will be saved into this new document.

**To save your changes as you work...**

After you have named and saved the document once, choose Save from the File menu to save any additional changes as you work. It's a good idea to save after you make an important change.

**To revert to the previously saved version...**

If you start revising your date book and don't like the changes you've made, you can return to the last saved version by choosing Revert from the File menu.
**Changing Views**

**You control** the calendar and Event windows with the View menu.

**To select a view...**

Choose the desired view from the View menu. The view changes immediately.

You can choose between three different views:

**Calendar Only:** This view closes everything but the calendar window. Because the Event window is closed, you cannot view the events themselves, nor can you change them or add to them.

Despite this, the reminder feature continues to work for events that are already entered in GeoPlanner.

**Events Only:** This view closes everything but the Event window. You can still view, change, and delete events, but with no Calendar
window, you can only change the day shown by using the Next Day and Previous Day buttons.

**Both:** This is the standard view. It shows both the Calendar window and the Event window together.
You can customize some of the different features of GeoPlanner, including the way that it presents events in the Event window and the number of minutes that alarms go off ahead of the actual event.

You can save these preferences so that they still apply the next time you start GeoPlanner.

To set your preferences...

1. Choose Change Preferences from the Options menu. The preferences dialog box appears.
2. Set the different options.
3. Click OK to save your new preferences settings.

**Day Template:** This setting changes the way that GeoPlanner displays events in the Event window. When you turn on Day Template, the Event window shows the entire day broken down into small blocks of time (usually half-hour intervals), even if no events are scheduled. When Day Template is off, only the times with scheduled events show.
Show Empty Days: When you select a range of days in the Calendar window, the Event window shows all the events scheduled on all of the days. Normally the Event window lists only those days that actually have events scheduled. With this option turned on, the Event window lists every day in the range, even if that day has no events scheduled on it.

Start Time, End Time, and Interval: These three options control the Day Template. Start Time and End Time determine the range of the template—normally 8 am and 6 pm respectively. The Interval controls the amount of time between template entries, and is set to half an hour by default. This means that the day is marked off into half-hour blocks—8:00 am, 8:30 am, 9:00 am, 9:30 am, and so on.

Reminder Precedes Event: These settings change how far ahead of the event the alarm normally goes off. While they are initially set to zero, meaning that the alarm goes off at the time of the event, you can change them to minutes, hours, and even days before. This new setting takes effect for all events you enter from then on.

Note that this is only the default alarm time. You can set the actual time of the alarm when you turn the alarm on.

Startup As: You can control which of the two windows are open when you first start GeoPlanner. You can choose to have just the Calendar window open, just the Events window open, or both open.

To save your preferences...

Choose Save Preferences from the Options menu.

GeoPlanner doesn't associate the preferences settings with any particular date book document. When you save your preferences, they stay in effect even if you work with a different date book document.
It’s easy to cut or copy text from the date book and paste it into some other application. For a full explanation of cutting and pasting between applications, see “Cutting and Pasting” in Chapter 4, “The Professional Workspace.”

To move or copy text to another application...

1. Select the text you wish to move or copy.
2. From the Edit menu,
   • Choose Cut if you want to move the text. The text is removed from the date book and placed on the clipboard.

   Or,

   • Choose Copy if you want to copy the text. A copy of the text is placed on the clipboard.
3. In the other application, click to position the cursor at the point where you want to place the text.
4. Choose Paste from the Edit menu to copy the text from the clipboard into the document.

The same technique works if you want to copy text in the opposite direction—from another application into the date book.

To Quick Copy or Quick Move text...

1. Select the text you wish to move or copy.
2. Position the pointer over the selected text. Use the right mouse button for both the Quick Copy and Quick Move:
• To Quick Copy the text, press and hold down the right mouse button. The pointer changes to a Quick Copy pointer.

Or,

• To Quick Move the text, press and hold down the right mouse button while simultaneously holding down the Alt key. The pointer changes to a Quick Move pointer.

3. Still holding the right mouse button (and Alt if you’re doing a Quick Move), move the pointer until it’s over the spot where you wish to insert the selected text.

4. Release the right mouse button. The text is copied or moved to the new location.
GeoPlanner can search the GeoDex address book for cards containing a particular name or bit of text. For example, say you are scheduled to meet with Andrew Wilson and you want to call him to confirm the meeting. You can search GeoDex for the card with the name “Wilson” on it. When you find it, you can use the phone numbers on it to call him.

GeoPlanner expects the text that you’re searching for to match the text in the GeoDex address book exactly. If you search for “Andrew Wilson,” you won’t get cards containing the name “andrew wilson.” For this reason, you should be consistent in the way that you enter names into both GeoPlanner and GeoDex.

You must start GeoDex before you can use this searching capability.

To find the address card for a name in the Events window...

1. Make sure that the GeoDex application is started. See Chapter 8, “Using GeoDex,” for information about opening the address book.

2. Select the person’s last name, or some other bit of text that you wish to locate.

3. Choose GeoDex Lookup from the Utilities menu. The GeoDex window appears and shows the first card containing the selected text.
If you want to find the next GeoDex card also containing the text, switch to the Search view (choose Search View from the View menu) and click Lookup.

4. When you finish looking at the address book, return to GeoPlanner by
   • Clicking anywhere inside the GeoPlanner window

   Or,
   • Choosing GeoPlanner from the Express menu.

As an example, take the earlier case where you are scheduled to meet with Andrew Wilson and you want to call him to confirm the meeting. Select the last name, “Wilson,” and choose GeoDex Lookup from the Utilities menu. The GeoDex window appears with the card for Wilson displayed. All you need to do is scroll to the correct phone number.

If this is the card for a different Wilson, you could switch to the Search view and continually press Lookup until the correct card appears.
With GeoComm you can easily communicate with other computers, information services, and bulletin board systems. GeoComm makes telecommunications straightforward and efficient.

The first part of this chapter shows you how to start the application and begin a communications session. The remainder of the chapter describes GeoComm's many features and explains how to use them to send and receive information.
USING GEOCOMM

361 What You Can Do With GeoComm
362 Starting and Exiting GeoComm
363 The GeoComm Window
366 Setting Parameters
371 Starting and Ending Communications
373 Working On-line
378 Saving Information
382 Sending and Receiving Files
386 Showing Line Status
387 Using Scripts
Telecommunication is the exchange of information between two or more computers. These computers might be sitting at opposite ends of a table, or they might be located at opposite ends of the continent. The systems might exchange data through a simple cable spanning the length of a room or over a telephone line connecting New York to San Francisco.

Computers can communicate with each other over telephone lines using devices called modems. Your modem translates all the text you type into sounds, which then travel over the telephone line to another modem that translates the sounds back into text for the other computer.

GeoComm lets you process the information you send and receive in many different ways. You can

- Scroll back to see information which has already scrolled off the top of the window.
- Save any portion of data received to disk or to the clipboard.
- Send and receive files using the XMODEM protocol.
- Create and run scripts to automate as little or as much of your sessions as desired.
Starting and Exiting GeoComm

You start and exit GeoComm the same way that you start and exit all GEOS applications.

There are ways to start GeoComm other than those described in this section. For more information, see “Using Applications” in Chapter 4, “The Professional Workspace.”

To start GeoComm...

- From the GeoManager WORLD directory, double-click the GeoComm icon. The GeoComm window appears.

- From another GEOS application, choose Startup from the Express menu. A cascade menu appears. Choose GeoComm from this second menu. The GeoComm window appears.

If GeoComm does not know which particular settings to use with your computer and modem, the Protocol Settings dialog box appears, reminding you to set the parameters. For instructions on doing this, see “Setting Parameters,” later in this chapter. To select default settings for your computer, see “The Preferences Desk Tools” in Chapter 11, “Using the Desk Tools.”

To exit GeoComm...

Choose Exit from the File menu.
The GeoComm window displays information you are sending and receiving.

**Cursor**: When the cursor is solid, the GeoComm window is active; whatever you type is sent to the computer you are communicating with. See "Working On-line" later in this chapter for more information. When the cursor is hollow, the GeoComm window is not active. Before you can send data by typing, you must click the GeoComm window.

**Current Screen**: The window displays incoming and outgoing data.

**Resize Borders**: Dragging a resize border at the edges of the window changes the window size. This affects the number of lines and columns that can be displayed.

You can change the number of lines and columns displayed in the window as well as the size of the text in the window to make it easier to see or fit in a smaller area of the screen.
**To change the size of the window...**

Use the resize borders to make the window larger or smaller. The window redraws to its new size.

Alternately, you may directly set the number of lines and columns in the window:

1. Choose Window Size from the View menu. The Window Size dialog box appears, displaying the current number of lines and columns.

   ![Window Size Dialog Box]

2. Adjust the number of Window Lines by clicking the arrow buttons or typing a new number.

3. Adjust the number of Window Columns by clicking the arrow buttons or typing a new number.

4. Click Apply. The window redraws to the size you specified.

5. Click Close. The dialog box closes.

You can have up to 80 columns and 24 lines. On some computer screens, this would make the GeoComm window bigger than the entire screen. In these cases, the maximum number of lines is adjusted down.
To make the text large...

Choose Large Font from the View menu. The window redraws in a large font.

GeoComm attempts to maintain the same number of lines and columns, but if the window would be too big to fit on the screen, the number of lines and columns are automatically reduced.

To make the text small again...

Choose Small Font from the View menu. The window redraws in a small font.
Computer systems display, store, and transfer data in many different ways. In order to communicate with other systems, you must set GeoComm to accommodate the peculiarities of the particular system you are calling.

There are three types of settings:

- Protocol — settings for transmitting and receiving data
- Terminal — settings for displaying and interpreting data
- Modem — settings for your particular modem

These settings are described in the following sections.

**Protocol Settings**

GeoComm transfers data to and from remote systems using various protocol settings, such as baud rate and parity. The protocol settings of the two systems must match.

Each time you start a GeoComm session, your protocol settings default to the settings defined by the Preferences desk tool. See “The Preferences Desk Tool” in Chapter 11, “Using the Desk Tools.” However, you can change the protocol settings for the current session with the Protocol dialog box.

<table>
<thead>
<tr>
<th>Protocol Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Modem Port:</strong></td>
</tr>
<tr>
<td>Com1</td>
</tr>
<tr>
<td><strong>Baud Rate:</strong></td>
</tr>
<tr>
<td>300</td>
</tr>
<tr>
<td><strong>Data Bits:</strong></td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td><strong>Parity:</strong></td>
</tr>
<tr>
<td>None</td>
</tr>
<tr>
<td><strong>Stop Bits:</strong></td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td><strong>Handshake:</strong></td>
</tr>
<tr>
<td>Software (XON/XOFF)</td>
</tr>
</tbody>
</table>
**Modem Port**: Set Modem Port to the particular socket on the back panel of your computer where your modem is plugged in.

**Baud Rate**: The baud rate is the maximum speed at which data is transmitted between your computer and the remote system. Set Baud Rate to correspond with the remote system you are calling.

**Data Bits, Parity**, and **Stop Bits**: These settings define exactly how data is formatted for transfer. Data Bits defines how many bits in the stream of data exchanged between computers contain meaningful information. Parity is used for error-checking during transmission. Stop Bits are one to two bits which indicate the end of a character in the stream of data exchanged. All three of these settings must match those of the receiver.

**Handshake**: Choosing Software(XON/XOFF) allows GeoComm to monitor the flow of data from the remote system, pausing and restarting the remote computer if necessary. If you turn this option off, you risk losing portions of incoming data.

**To set protocol settings...**

2. Change the options in the window.
3. Click Apply when you finish.
4. Click Close to close the window.

**Terminal Settings**

Sometimes the remote system you call expects you to use a certain type of terminal; it assumes that your computer understands certain codes and sequences of text. To communicate, your computer must speak the same language as the remote system. GeoComm provides
a language translator in the form of terminal simulation options. By choosing one of these simulation options, you can properly display data received from the remote system. Because GeoComm simulates most popular terminals, it is often possible to find one that the remote computer can accommodate.

You set the terminal settings with the Terminal dialog box.

**Terminal Type:** GeoComm simulates a variety of terminals: TTY, VT52, VT100, WYSE50, ANSI, IBM3101, TVI950. Normally you use a standard TTY ("teletype"). When you connect to a system expecting some other type of terminal, select the appropriate entry in the list. GeoComm then simulates that particular type of terminal.

Contact the computer service you use for a list of supported terminals.

**Duplex:** The Duplex setting controls the direction of the flow of data between computers. Full duplex is analogous to a two-way street; data can flow in both directions at the same time. Half duplex is like a one-way street; data can only flow in one direction at a time. If the characters you type appear twice on the screen, select Full duplex. If they don't appear at all, choose Half duplex.
Wrap Lines at Edge: This option controls how GeoComm deals with lines of text that are too long to fit in the window. Turning on this option causes GeoComm to split these long lines into shorter lines that fit within the window. When the option is off, GeoComm doesn't display the part of the line that doesn't fit in the window.

If you're capturing the text to a DOS file, the entire long line is captured correctly, even if it doesn't display in the window.

Auto Linefeed: This option replaces each incoming carriage return with a carriage return and a linefeed. If each new line displayed on your screen overwrites previous lines, turn on Auto Linefeed. If all lines are double spaced, turn off Auto Linefeed.

To set terminal settings...

1. Choose Terminal from the Options menu. The Terminal dialog box appears.
2. Change the options in the dialog box.
3. Click OK when you finish. The dialog box disappears.

Modem Settings

In order to communicate with other systems over the phone lines, you must have a modem attached to your computer. GeoComm assumes that you have a Hayes-compatible modem (a modem which understands the commands common to the Hayes brand). If you don't have such a modem, then these settings are irrelevant. The Quick Dial option and Scripts won't work either.

You change the modem settings with the Modem Dialog box.
**Setting Parameters**

![Modem Settings](image)

**Phone Type:** If you choose Touch Tone, GeoComm uses tones — the familiar beeps your telephone generates — to dial numbers. If you choose Rotary, GeoComm uses clicks to dial numbers. Set the phone type to agree with the type of service on your telephone line.

**Modem Speaker:** You can use your modem’s built-in speaker to eavesdrop on the telephone line activity. Choose one of the settings:

- **On Until Connect** keeps the speaker on while dialing and waiting for the other modem to answer.
- **On Unless Dialing** turns the speaker on only while waiting for the other modem to answer.
- **Always On** keeps the speaker on at all times.
- **Always Off** keeps the speaker completely off.

**Speaker Volume:** This setting controls the volume of your modem’s speaker.

---

**To set modem settings...**

1. Choose Modem from the Options menu. The Modem dialog box appears.
2. Change the options in the dialog box.
3. Click OK when you finish. The dialog box disappears.
Once you have adjusted the GeoComm window to a size you are comfortable with and have set the parameters for your computer, you may start telecommunications with another computer.

If the two computers are already connected, just start typing. Otherwise, you will want to dial a number with your modem.

To dial a number...

1. Choose Quick Dial from the Dial menu. The Quick Dial dialog box appears.

2. Type the phone number you wish to dial.
3. Click Dial. GeoComm dials the number.

GeoComm accepts numbers in almost any format. Here are some guidelines for entering phone numbers:

- Omit the area code for local numbers.
- For long distance calls, include the 1 and the area code, as in this example:

  1-415-555-1212

- If the number needs a special dialing sequence — to access a long distance service, for instance — be sure to enter this sequence before the regular number:

  10288-1-202-555-1212
• Place a comma anywhere in the number where you want a brief pause in the dialing sequence. For example, if you need to dial an access code for an outside line, type it as part of the number:

   9, 555-1212

The access code is separated from the number by a comma. This briefly pauses the dialing to give the access code time to work.

Quick dialing works only if you own a Hayes-compatible modem. If you have a different type of modem, you must manually dial numbers. Consult your modem’s documentation for more information.

To hang up the phone...

1. If you’re logged onto the other computer, log off of the computer in the normal way.

2. Choose Hang Up from the Dial menu. A dialog box appears, asking you if you’re sure you want to break the connection. If you click Yes, the modem hangs up the phone line, closing the connection.
When you have established communications with another computer and are exchanging information, you are considered to be on-line with that computer. When you are not connected to another computer, you are off-line.

While you are on-line, the information exchanged between you and the remote computer system appears within the GeoComm window. Whatever you type into the window at the cursor is sent to the remote computer. The response you receive is displayed at the cursor as well.

**Sending Prepared Text**

Rather than typing directly to the remote system, you may wish to

- Compose a message off-line, which lets you edit it before sending the message.
- Send text from other applications or from other parts of the GeoComm window.
- Send the contents of DOS text file.

Sending prepared text is like having the computer automatically type in to the window whatever it is you are sending. In fact, if you were to watch from the other computer, it would look like an extremely fast typist were sending you things. Remember that problems like a bad telephone line could cause random gibberish in the received file.

You can compose a message off-line in the Message window and let GeoComm automatically type in the contents of the window for you. You might use this feature to write and send a short electronic mail message.
You can copy text to the clipboard from other documents, then paste the text into GeoComm. GeoComm automatically types the contents of the clipboard into the window when you paste. You might use this to send an excerpt from a report or a letter.

You can also send a DOS text file, in which case GeoComm automatically types in the contents of the file for you. You might do this if you would like to include a conference report in an electronic mail message or if you are sending a memo to someone in Boston. Note that you can only send DOS text files (like those you create with the Notepad desk tool), not GEOS documents (such as you produce with GeoWrite or other similar applications).

To compose a message off-line...

1. Choose Message from the View menu. The Message window appears.

2. Enter the message you wish to send. You may edit the message using basic text editing procedures. See “Selecting and Editing Text” in Chapter 4, “The Professional Workspace.”

3. Click Send. The message in the window is sent to the other computer via the GeoComm window.

You may continue to send messages in the same way as long as the Message window is open.

**To send the contents of the clipboard...**

1. Cut or copy the text you wish to send. The text is placed on the clipboard.

2. If you are in another application, choose GeoComm from the Express menu. The GeoComm window reappears.

3. Choose Paste from the Edit menu. The contents of the clipboard are sent to the other computer.

**To type from a DOS text file...**

1. Choose Type From Text File from the File menu. The Type From Text File dialog box appears.

2. Locate and select the text document you want to send.

3. If the remote computer requires linefeeds after every carriage return, make sure the End Lines With CR/LF option is on.

To see if you must use this option, contact the computer service you are using.
4. Click Type. A status window appears, showing you which file is being transmitted. The contents of the file are typed to the screen.

If you would like to stop the transfer, click Stop in the status window.

**Scrolling Through Data**

When the GeoComm window fills with text, it starts to scroll upward. The top line of text goes out the top, and the incoming line of text comes in at the bottom. As the lines of text go out the top of the window they are placed in a special place called the "scroll-back buffer." You can view this holding area by scrolling the window back down with the vertical scroll bar. It has room for about 175 lines of text; when it fills up, it removes the oldest lines—so it always contains the *latest* 175 lines of text.

You can save the scroll-back buffer into a DOS text file if you want to keep it. For more information, see “Capturing Text” later in this chapter.
To scroll through the scroll-back buffer...

Use the scroll bar to view lines which have scrolled past the top of the screen.

Move the scroll bar all the way to the bottom to see the currently active screen again.
You may wish to save some portion of the information displayed in the GeoComm window. It does not matter whether the data on-screen was sent or received; you can save any text you see in the window.

To copy text to the clipboard...

1. With the mouse, select the text you wish to copy.
2. Choose Copy from the Edit menu. The selected text is copied to the clipboard.

You may now paste the new contents of the clipboard wherever you wish, such as into a document in another application.

Saving Full Screens of Data

As you send and receive data, it slowly fills up the current screen. Once the current screen is full of information, the oldest data is moved into the scroll-back buffer to make room for the newest. You learned how to look at the scroll-back buffer in “Working On-Line,” earlier in this chapter. You can save all of the information contained in the current screen as well as the information in the scroll-back buffer.

To save the current screen and scroll-back buffer to a file...

1. Choose Save Buffer from the File menu. The Save Buffer dialog box appears.
2. Use the directory listing to locate the directory where you want to save the resulting file.

3. Enter a name for the file. This name should be in DOS format—one to eight characters, optionally followed by a period and an extension of up to three more characters.

Here are some examples of DOS file names:

SOMETEXT.TXT
ADOSFILE
LETTER.2

4. Turn on Screen Only if you want to save the current screen.

Turn on Scroll-Back Buffer if you would like to save what has scrolled past the top of the screen.

Turn on Scroll-Back Buffer and Screen if you would like to save everything which has been sent or received.

5. Click OK. The data is written to the DOS file.
Capturing Text

If you know ahead of time that you want to store data as you receive it, you can route it directly into a text file as it comes in. You decide when to start and stop recording the data.

To capture text to a file...

1. Choose Capture to Text File from the File menu. The Capture to Text File dialog box appears.

   Select the appropriate disk drive and directory...

   ...and enter the name for the new file

2. Locate the directory in which you want to save the file.

3. Enter a name for the file. This name should be in DOS format—one to eight characters, optionally followed by a period and an extension of up to three more characters. The default file name is CAPTURE.TXT.

Here are some examples of DOS file names:

   SOMETEXT.TXT
   SESSION
   NOTE.2
4. Turn on End Lines With CR/LF if you want the file to have linefeeds after every carriage return. You normally leave this option turned on.

5. Click Capture. The Capture Status window appears. Anything you send or receive is recorded on disk.

6. Click Done in the Capture Status window when you finish.
A large portion of telecommunications involves sharing files between computers. You can send and receive text files such as monthly reports and electronic mail messages, as well as applications like games and utilities.

You learned several ways to send and receive text in previous sections. In those cases, GeoComm either typed messages and files for you, or saved whatever you saw on the screen. XMODEM is different; it's a method of sending and receiving files piece by piece, making sure that each piece is transferred properly. If any of those portions are received with an error, perhaps because of a noisy phone line, then that particular piece is retransmitted. Almost all file transfers via XMODEM are error-free.

Both computers must be using XMODEM for file transfer. If the receiver is using XMODEM, don't use the DOS text file transfer discussed earlier. On the other hand, if the receiver is expecting only text, don't send with XMODEM.

You can use XMODEM to send text files. You might wish to use XMODEM rather than the DOS text file transfer if your file is large or if you've encountered errors trying to send it using the DOS text file transfer. You can also use XMODEM to send binary files, such as GEOS documents.

**Sending Files Using XMODEM**

Sending a file using XMODEM is straightforward. Once you start the XMODEM transfer, GeoComm takes over and does all the work.
To send a file with XMODEM...

1. Prepare the remote system to receive a file using XMODEM. Be sure to specify whether you are sending a text or a binary (non-text) file.

   The method used to do this varies from computer service to computer service. For instructions, contact the computer service you are using.

2. Choose Send XMODEM from the File menu. The Send XMODEM dialog box appears.

   Select the disk drive and directory containing the file
   Select the file
   Choose a packet size for data transfer
   Click to send

3. Locate and select the file you want to send.

4. Choose 1K Blocks if the remote computer accommodates 1K Blocks and if the telephone line is a relatively good connection. Otherwise, choose 128 Bytes. If you don’t know which is appropriate, choose 128 Bytes.

5. Click Send. The Send Status window appears, showing you which file you are sending and errors encountered during the send.

   If you want to stop sending the file, click Cancel in the Send Status window.
Receiving Files

You receive files in much the same way as you send them.

To receive a file with XMODEM...

1. Prepare the remote system to send a file using XMODEM.
   The method used to do this varies from computer service to computer service. For instructions, contact the computer service you are using.

2. Choose Receive XMODEM from the File menu. The Receive XMODEM dialog box appears.

   ![Receive XMODEM dialog box]

3. Locate the directory in which you would like to save the file.

4. Enter a name for the file. This name should be in DOS format—one to eight characters, optionally followed by a period and an extension of up to three more characters.

   Here are some examples of DOS file names:
   
   SOMETEXT.TXT
   DOWNLOAD
   EXCERPT.2
5. Choose the Text option if you are receiving a DOS text file. Select the Binary option if you are receiving a binary file, such as a GEOS document or an application file.

6. Choose CRC if the remote system can accommodate CRC (Cyclic Redundancy Check). Choose Checksum if the remote system doesn't allow CRC. CRC is a more sophisticated error-checking protocol than Checksum, although either should result in error-free file transfers. If you're not sure which to use, choose Checksum.

7. Click Receive. The Receive Status window appears, showing the file you are receiving and errors encountered during the receive.

If you want to stop receiving the file, click Cancel in the Receive Status window. If the Cancel button becomes disabled (grey), then the file transfer can't be interrupted.
Naturally, any sort of connection between two computers is not going to be perfect; transmission errors are bound to occur. GeoComm provides a facility to monitor those errors. You can use this feature to help verify that you have configured your protocol settings properly.

To show line status...

Choose Show Line Status from the Options menu. The Show Line Status window appears.

This window monitors errors on the serial line, updating its display each time a read, write, frame, or parity error is encountered.

To reset line status counters...

Click Reset Counters while the Show Line Status window is open. The four error counters reset to zero.

To close the Show Line Status window...

Click Close in the Show Line Status window. The window disappears.

GeoComm continues to monitor errors even if you have closed the Show Line Status window.
Using Scripts

Through the use of scripts, GeoComm can automate many aspects of your communications tasks. For example, you can write a script to automatically log on to an information service or to perform some repetitive task.

Several sample scripts are included with GeoComm. You may also create your own scripts.

To run a script...

1. Choose Scripts from the Dial menu. The Scripts dialog box appears.

2. Locate and select the script you would like to run.

3. Click Run. The Script Display window appears, showing the progress of the script.
You may stop a script by clicking Stop in the Script Display window.

To create a script...

1. Use the Notepad desk tool or another DOS file editor to create a text file containing your script. For a description of scripting commands, see “The Scripting Language,” later in this chapter.

2. Save the file under a name with up to eight characters. Append .MAC to the end of the file name. For example, MYSCRIPT.MAC would be an appropriate file name.

3. Place the script file in the GEOWORKS\GEOCOMM directory. When you return to GeoComm, you can run the new script from the Scripts dialog box.

The Scripting Language

Scripts resemble simple programs, and in fact you can use them to “program” GeoComm to perform common tasks for you, such as logging on to an information service.

Here is a description of all the commands in the scripting language. You must enter all the commands in upper case, like so: CLEAR. Labels can be in upper or lower case, but you must be consistent. If you have a label defined as :GoHere, you must refer to it the exact same way in a GOTO statement: GOTO GoHere.

In the descriptions that follow, the words that you must replace are enclosed in angle brackets (“<>”). Do not type the brackets themselves.

:<label>

Any line beginning with a colon is treated as a label. Use the GOTO command to jump to a label line.
:ABORT

GeoComm will GOTO this special label if the user clicks Stop in the Script Display window. The word "ABORT" must be all uppercase.

BELL

This command makes a beep sound to alert the user.

CLEAR

This command clears the Script Display window.

COMM <baud-databits-parity-stopbits-duplex>

This command sets the communication settings. For more detailed information, refer to Setting Parameters earlier in this chapter.

baud: 300, 1200, 2400, 4800, 9600, 19200
data bits: 5, 6, 7, 8
parity: N, O, E, M, S
stop bits: 1, 1.5, 2
duplex: HALF, FULL

For example, if you're using a 2400 baud line with eight data bits, no parity, and one stop bit, you would put the following command in your script:

COMM 2400-8-N-1-FULL

DIAL <number>

This dials the number given using tone or pulse dialing (see the TONE and PULSE commands later in this section).
To make your script dial a 9 to connect you to an outside line, and then dial 555-1212, you would put the following command in your script:

```
DIAL 9,555-1212
```

**END**

This stops the script, returning control to the user (but doesn’t GOTO to the :ABORT label).

**GOTO <label>**

This causes GeoComm to go to the line starting with “:<label>”.

For example, the command

```
GOTO StartLoop
```

would make GeoComm start running the part of your script that begins with the line

```
:StartLoop
```

**MATCH <text> GOTO <label>**

**PROMPT <number>**

Use the MATCH and PROMPT commands together when you want GeoComm to wait for the other computer to send a certain bit of text.

The MATCH command makes GeoComm look for <text> in the output of the other computer. The <text> must be enclosed in double quotes. You may also look for an [Enter] by appending “,CR”. You can specify more than one MATCH command before the PROMPT command.

The PROMPT command causes GeoComm to pause for a certain period of time while waiting for output from the remote computer to satisfy one of the MATCH commands. When a match is found,
GeoComm does a GOTO to the given label. On the other hand, if no match is found within the specified time period, GeoComm “falls through” and runs the command following the PROMPT command.

The time is given in sixtieths of a second. You must have both the MATCH commands and the PROMPT command, and the MATCH commands must directly precede the PROMPT command.

For example, to make GeoComm wait for up to sixty seconds (3600 sixtieths of a second) while waiting for the other computer to either ask for a password or say that no login is possible, you could put the following lines in your script:

```plaintext
MATCH "Password?",CR GOTO DoPassword
MATCH "System unavailable" GOTO IsBusy
PROMPT 3600
```

**PAUSE <number>**

Causes GeoComm to pause for a certain amount of time before continuing with the script. The <number> must be in units of sixtieths of a second. If you omit the number, GeoComm pauses for one second.

For example, to make GeoComm pause for one minute (60 seconds), you would use this command:

```plaintext
PAUSE 3600
```

**PORT <port>**

Makes GeoComm use the given COM port to communicate with the other computer.

If your modem is connected to COM port 2, for example, you would use this command:

```plaintext
PORT 2
```
PRINT <text>

This command displays the <text> in the Script Display window. The text is *not* sent to the other computer.

If you wanted your script to show the message “Sending password…” when it transmits a password, you would put the following command in your script:

```
PRINT “Sending password...”, CR, CR
```

PULSE

This command causes GeoComm to use pulse dialing when it dials a phone number (for telephone lines without tone dialing service).

SEND <text>

This command sends the <text> to the remote system.

For example, to send the word “password” followed by an Enter to the other computer, you would put the following line in the script:

```
SEND “password”, CR
```

TERM <terminal type>

This command makes GeoComm emulate a certain type of terminal. The <terminal type> must be one of these types: TTY, VT52, VT100, WYSE50, ANSI, IBM3101, TVI950.

For example, to make GeoComm emulate a standard TTY terminal, you would put this command in your script:

```
TERM TTY
```

This command causes GeoComm to use tone dialing when it dials a phone number.
The GEOS desk tools include the Preferences desk tool, the Calculator, the Notepad, and the Scrapbook. The desk tools are applications that help you with small, specific tasks, such as configuring your system, doing calculations, editing DOS files, or saving often-used text or graphic scraps.

This chapter describes each desk tool and what it can do for you.
Contents

Using the Desk Tools

395 Starting and Exiting a Desk Tool
396 The Preferences Desk Tool
413 The Calculator Desk Tool
424 The Notepad Desk Tool
433 The Scrapbook Desk Tool
You start and exit a desk tool the same way that you start and exit all GEOS applications.

There are ways to start a desk tool other than those described in this section. For more information, see “Using Applications” in Chapter 4, “Using the Professional Workspace.”

To start a desk tool...

- From the GeoManager WORLD directory, double-click the desired desk tool icon: Preferences, Calculator, Notepad, or Scrapbook. The desk tool starts, opening a default document if appropriate.

- From another GEOS application, choose Startup from the Express menu. A cascade menu appears. Choose the desk tool you want from this second menu. The desk tool starts, opening a default document if appropriate.

To exit a desk tool...

Choose Exit from the File menu. The desk tool goes away.
The Preferences Desk Tool

The Preferences desk tool helps you tailor GEOS to work with your particular computer system. You use it to adjust various hardware options like printer and modem settings, and software options like how often GEOS applications automatically safeguard open documents.

The Preferences Window

When you start the Preferences desk tool, the Preferences window appears.

The Preferences window contains buttons that you click to change different groups of options.
**The Preferences Desk Tool**

<table>
<thead>
<tr>
<th>Button</th>
<th>Changes...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Look and Feel</td>
<td>The size of the text in menus and dialog boxes, and how often GEOS applications safeguard open documents</td>
</tr>
<tr>
<td>Date and Time</td>
<td>The computer's internal date and time settings</td>
</tr>
<tr>
<td>Background</td>
<td>The picture that fills the workspace background</td>
</tr>
<tr>
<td>Printer</td>
<td>The brand of printer you're using and the port to which it's connected</td>
</tr>
<tr>
<td>Computer</td>
<td>The type of additional memory present in your computer and other internal hardware options</td>
</tr>
<tr>
<td>Video</td>
<td>The type of video monitor you're using and the screen blanking interval</td>
</tr>
<tr>
<td>Mouse</td>
<td>The brand of mouse you're using, its responsiveness, and how quickly you have to click to do a double click.</td>
</tr>
<tr>
<td>Modem</td>
<td>The port, speed, and protocol options for your modem</td>
</tr>
<tr>
<td>GEOS</td>
<td>Internal GEOS options (not normally changed)</td>
</tr>
</tbody>
</table>

**Changing the Date and Time**

Your computer has a built-in clock that tracks both the date and time. You use the Date & Time dialog box to change the built-in clock.

![Date & Time Dialog Box]

**Enter today's date**

**Enter the current time**
To change the date and time...

1. Click Date & Time. The Date & Time dialog box appears.
2. Change the date. You may enter the date in one of two ways:
   5/25/90
   Or,
   10/29/1990
3. Change the time. Enter the new time in 12-hour format, and enter am or pm along with the time:
   10:25 am
   9:46 pm
4. Click OK to update the built-in clock, or click Reset to leave the date and time unchanged.

Changing Look and Feel Options

You can change the size of the GEOS system text—the text that appears in menus, menu bars, window title bars, and dialog boxes. You can also change how often applications safeguard open documents by saving temporary copies of them.

You change these options with the Look & Feel dialog box.
To change the size of the GEOS system text...

1. In the Preferences window, click Look & Feel. The Look & Feel dialog box appears.
2. Choose small, medium, or large GEOS system text. Underneath the settings is some sample system text, so you can see how each of the choices look.
   
   Your new setting won’t take effect until you exit GEOS and start it again.
3. Click OK, or click Reset to leave the options unchanged.

To change document safeguarding...

1. In the Preferences window, click Look & Feel. The Look & Feel dialog box appears.
2. Turn the document safeguard feature on or off by clicking On or Off.
3. Set the interval between safeguards by entering a new Time in minutes.
4. Click OK, or click Reset to leave the options unchanged.
   
   New safeguard options take effect immediately.

Changing the Workspace Background

You can fill the workspace’s background—the grey area underneath all the windows—with a picture.
To change the workspace background...

1. In the Preferences window, click Background. The Background dialog box appears.

2. Select the name of the background picture that you want from the Backgrounds Available list.

3. Select the way you want to place the background on the screen.
   - Upper-left corner: The left edge of the picture is placed against the upper left edge of the screen.
   - Center of screen: The picture is centered on the screen. If it is smaller than the screen, then the surrounding area is filled with the regular grey background.
   - Tiled to fill screen: The picture is repeated across and down the screen, covering the screen the way tiles cover a wall.

4. Click Apply to make the current picture your workspace background. The background immediately changes.

5. If you don't like the background picture, choose another and click Apply.

6. Click Close when you finish.
Changing the Mouse

You can change the speed with which the pointer moves across the screen and how fast you must click to do a double-click.

You can also change the brand and model of mouse that you use with GEOS.

You change these options with the Mouse dialog box.

To change the mouse responsiveness...

1. In the Preferences window, click the button labeled Mouse. The Mouse dialog box appears.

2. Choose a Double-Click Speed, which controls how quickly you must click the mouse to do a double-click. Setting this option to Fast means that you must do the two clicks very quickly.

   The new speed takes effect immediately. Double-click the Test button to try out the setting; it flashes and beeps when you’ve clicked fast enough.

3. Choose a Mouse Acceleration. This changes how far the pointer moves when you quickly move the mouse.
At the Slow setting, the pointer always moves the same distance as the mouse. At the Fast setting, however, the pointer moves much farther when you move the mouse quickly (though the pointer continues to move only the same distance when you move the mouse slowly). A short, quick mouse movement can take the pointer all the way across the screen.

After changing, move the mouse around to see how it feels.

4. Click OK when you finish, or click Reset to leave the options unchanged.

**To change the mouse configuration...**

When you replace your mouse with a different brand or model, you need to change the Mouse Configuration settings as well. You can also change the Mouse Configuration by running GEOS Setup again (see "Installing GEOS" in the Quick Start manual).

1. In the Preferences window, click the button labeled Mouse. The Mouse dialog box appears.

2. In the Mouse Configuration section, click Change. Another dialog box appears.

3. Choose one of the brands from the list of brands.
4. If you’re using a serial mouse, choose the Serial Mouse Port where you’ve connected it.

5. Change the Number of Mouse Buttons so that it correctly shows the number of buttons you have on your mouse.

6. Click OK when you’re finished. The dialog box closes, leaving you at the Mouse dialog box again.

7. In the Mouse dialog box, click OK.

When you click OK, a dialog box appears asking you if you wish to restart GEOS so that the change can take effect immediately. Clicking Restart GEOS will exit GEOS and start it again.

The mouse configuration change does not take effect until you exit GEOS and start it again. At that time you have an opportunity to verify that you’ve chosen the correct type of mouse. Should the type turn out to be incorrect, you can correct the configuration at that time.

**Changing Printers**

Before you can print anything you need to configure GEOS to work with your printer. GEOS also needs to know what communication port you’ve connected the printer to.

You change the printer configuration using the Printer dialog box.
To install a new printer...

You need to install at least one printer before you can print anything. If you want, you can even install several different printers if you have more than one connected to your computer.

1. In the Preferences window, click Printer. The Printer dialog box appears.

2. Click Install New. A second dialog box appears.

3. From the Printer list, click to select the brand name of the printer you wish to install. Scroll the list to see all the choices.

4. From the Port list, click to select the communication port where you've connected the printer. Each port corresponds to a socket at the back of the computer—although not all computers have a socket for every port in the Port list.

   As a rule of thumb, most parallel printers plug into LPT1, while most serial printers plug into COM1.

5. If you've chosen one of the serial ports from the Port list (COM1, COM2, COM3, or COM4), click COM Port Options to configure the serial port to match your printer.

6. Normally the Printer Name box contains the brand name of the printer and the port where it's connected. This is the text that shows up when you use the Print command of an application. You can change this text to say anything you like.
For example, you could change the Printer Name to a more descriptive nickname:

Fast Laser Printer
Andrew's Dot Matrix Printer

7. Click OK. The dialog box closes, leaving you at the Printer dialog box again. The printer that you've just installed is visible in the Printers Installed list.

8. Click Close to close the Printer dialog box.

To change a printer's configuration...

When you change a printer's configuration, you can change the brand of printer, the communication port where it's connected, and the assigned Printer Name.

1. In the Preferences window, click Printer. The Printer dialog box appears.

2. From the Printers Installed list, click the name of the printer you wish to configure and then click Edit. A second dialog box appears.

3. Change one or more of the three items in the dialog box—the brand of printer, the communication port, and the assigned Printer Name.
4. Click OK when you're finished. The dialog box closes and the Printer dialog box shows again. If you've changed the Printer Name, the new name shows in the Installed Printer list.

5. Click Close to close the Printer dialog box.

**To delete a printer from the list of printers...**

1. In the Preferences window, click Printer. The Printer dialog box appears.

2. From the Printers Installed list, click the name of the printer you wish to delete from the list.

3. Click Delete. A dialog box appears asking you if you want to delete the printer. If you still want to, click OK to actually delete the printer.

4. The printer is removed from the list of Installed Printers.

5. Click Close to close the Printer dialog box.

**To print a test page on a printer...**

You can print a test page on any of the installed printers to make sure you've configured them correctly.

1. In the Preferences window, click Printer. The Printer dialog box appears.

2. From the Printers Installed list, click to select the name of the printer on which you want to print the test page.

3. Click Test. The selected printer should immediately begin printing a test page. If nothing happens or gibberish prints out, you should check the printer's switches and perhaps change its configuration by clicking Edit.

4. Click Close to close the Printer dialog box when you're done.
Changing Modem Options

Before you can use your modem, you need to identify the communication port where the modem is connected, and you need to change the port's Speed and Format options.

To change modem options...

1. Click Modem. The Modem dialog box appears.

2. Choose which serial port has the modem plugged into it—usually COM1, unless you have a serial mouse, in which case it's usually COM2. Make sure it isn't the same one where you plugged a serial mouse.

3. Click Speed and Format Options to change the transmission speed (Baud rate), parity, stop bits, and protocol. A second dialog box appears.
4. Change the options to match your modem. Click OK when you're finished. The dialog box closes, leaving you at the Modem dialog box again.

5. Click OK, or click Reset to leave the options unchanged.

**Changing the Video Options**

GEOS needs to know the type of monitor that's connected to your computer. When you change the type of monitor, you need to change the Video option settings, or run the Setup program again (see "Installing GEOS" in the Quick Start manual).

The monitor change does not take effect until the next time you start GEOS. At that time you run a series of tests so that you can verify that you've chosen the correct type of monitor.

You can have GEOS blank the screen automatically to prevent images from "burning in". When you leave an image at the same place on your screen for a long time, there's a possibility that the image may become "burned" into the screen—you see a ghost outline of the picture even when the video screen is completely turned off. The image has been literally burned into the surface of the screen.

To prevent burning in, GEOS can automatically turn off the picture when you don't work with your computer for a while. When you move the mouse or press a key, it turns the picture back on. In addition to turning this feature on and off, you can set how long GEOS waits before blanking the picture.

You use the Video dialog box to change all these things.
The Preferences Desk Tool

Use these options to change the configuration of your video adapter. Use the Automatic Screen Blanking feature to extend the life of your monitor.

Automatic Screen Blanking

Screen Blanking: On Off

Time (minutes): 15

Type of video adapter

Current adapter: MCGA (Multi-Color Graphics Array)

Change...

To change the type of monitor...

1. Click Video in the Preferences window. The Video dialog box appears.

2. Choose a new type of monitor from the list of monitor types.

3. Click OK when you finish, or click Reset to leave the options unchanged.

When you click OK, a dialog box appears asking you if you wish to restart GEOS so that the change can take effect immediately. Clicking Restart GEOS exits GEOS and starts it again.

The monitor change does not take effect until you exit GEOS and start it again. At that time you have an opportunity to verify that you’ve chosen the correct type of monitor. Should the type turn out to be incorrect, you can correct the monitor type at that point. Note that no matter which choice you make, GEOS can still function; if your monitor won’t work with the current type setting, GEOS ignores your setting and uses a more appropriate one.

To turn automatic screen blanking on or off...

1. Click Video in the Preferences window. The Video dialog box appears.
2. Turn the Screen Blanking setting On to have GEOS automatically blank the screen after you leave your computer alone for a period of time.

   Turn Screen Blanking Off to keep GEOS from blanking the screen.

3. In the Time box, enter the length of time in minutes your computer must be idle before GEOS blanks the screen.

4. Click OK when you're finished, or Reset to leave the options unchanged.

The screen blanking option takes effect immediately.

**Changing Computer Options**

If your computer has more than 640K, GEOS can make use of the additional memory. It can also work with any unusual serial and parallel port configurations.

You change these options with the Computer dialog box.
To use more than 640K of memory...

1. Click Computer in the Preferences window. The Computer dialog box appears.

2. Choose the types of additional memory that you have installed in your computer:
   - Expanded memory: If you have an original PC or XT, you have expanded memory.
   - Extended memory: If you have an AT (286 machine) or a 386 machine, you probably have extended memory. You may also have expanded memory.
   - Managed extended: If you have a file called HIMEM.SYS, you have managed extended memory.

You may select more than one of the options. If you don’t know which types you have, consult with your computer dealer.

3. Click OK when you finish, or click Reset to leave the options unchanged.

To change the interrupt levels of the serial and parallel ports...

1. Click Computer in the Preferences window. The Computer dialog box appears.

2. Change the interrupt levels of the various serial and parallel ports. You shouldn’t change these settings unless you’re very familiar with the inside workings of the PC.

3. Click OK when you finish, or click Reset to leave the options unchanged.
Changing GEOS Internal Options

You should not change any GEOS internal options unless directed to do so by an authorized customer service technician. Incorrectly changing any of these options can seriously degrade the performance of GEOS and possibly even prevent GEOS from functioning at all.
The Calculator desk tool works much like a simple hand-held calculator. You can add, subtract, multiply and divide, calculate percentages, and use memory. And when you finish, you can paste your results into any other documents in other applications.

The Calculator Window

When you start the Calculator, a window appears with the Calculator in it:

**Parentheses:** Changes the order of operations. When you use parentheses, the quantity inside the parentheses is evaluated before anything else in the calculation. For more information, see "Order of Operations" later in this chapter.

**Delete button:** Acts like a backspace key to erase the last digit in a number.
C/CE button: Clears the displayed number. If clicked twice, this clears everything, including any calculations in progress.

Doing Calculations

Instead of pressing buttons as you would with a normal calculator, with the Calculator desk tool you use the mouse to click the Calculator buttons, or press the corresponding keys on the keyboard. The table below shows how to use both the mouse and the keyboard.

<table>
<thead>
<tr>
<th>Function</th>
<th>With the mouse, click:</th>
<th>On the keyboard, press:</th>
</tr>
</thead>
<tbody>
<tr>
<td>digits 0 through 9</td>
<td>0 through 9</td>
<td>0 through 9</td>
</tr>
<tr>
<td>decimal point</td>
<td>.</td>
<td></td>
</tr>
<tr>
<td>add</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>subtract</td>
<td>−</td>
<td>−</td>
</tr>
<tr>
<td>multiply</td>
<td>×</td>
<td>* or X</td>
</tr>
<tr>
<td>divide</td>
<td>+</td>
<td>/</td>
</tr>
<tr>
<td>equals</td>
<td>=</td>
<td>= or Enter</td>
</tr>
<tr>
<td>change sign</td>
<td>±</td>
<td>N</td>
</tr>
<tr>
<td>clear</td>
<td>C/CE</td>
<td>C</td>
</tr>
<tr>
<td>delete</td>
<td>Del</td>
<td>Backspace</td>
</tr>
<tr>
<td>store in memory</td>
<td>STO</td>
<td>S</td>
</tr>
<tr>
<td>display memory</td>
<td>RCL</td>
<td>R</td>
</tr>
<tr>
<td>add to memory</td>
<td>STO+</td>
<td>T</td>
</tr>
<tr>
<td>percent</td>
<td>%</td>
<td>%</td>
</tr>
<tr>
<td>parentheses</td>
<td>( )</td>
<td>( )</td>
</tr>
</tbody>
</table>
You can also use keys on the numeric keypad, but first make sure that [Num Lock] is on.

For example, to calculate 7×349:

<table>
<thead>
<tr>
<th>Click or Press</th>
<th>Display shows</th>
</tr>
</thead>
<tbody>
<tr>
<td>7</td>
<td>7</td>
</tr>
<tr>
<td>×</td>
<td>7</td>
</tr>
<tr>
<td>3, 4, 9</td>
<td>349</td>
</tr>
<tr>
<td>=</td>
<td>2443</td>
</tr>
</tbody>
</table>

**The Error Indicator**

When the Calculator cannot handle a calculation, the word “Error” appears. This can happen when the result is greater than 2,147,483,647 or less than −2,147,483,648. This also happens if you divide by zero.

When “Error” is displayed, click C/CE to clear it.

**Order of Operations**

When you do calculations involving more than two numbers, be aware that the Calculator may not do your calculation in the exact order you entered it. The Calculator follows a specific order of operations: quantities in parentheses first, then multiplication and division, then addition and subtraction. Arithmetic functions with the same precedence are performed left to right.
To illustrate, calculate \((3+4)\times6\).

<table>
<thead>
<tr>
<th>Click or Press</th>
<th>Display shows</th>
</tr>
</thead>
<tbody>
<tr>
<td>(</td>
<td>nothing</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>+</td>
<td>3</td>
</tr>
<tr>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>)</td>
<td>7</td>
</tr>
<tr>
<td>\times</td>
<td>7</td>
</tr>
<tr>
<td>6</td>
<td>6</td>
</tr>
<tr>
<td>=</td>
<td>42</td>
</tr>
</tbody>
</table>

You need the parentheses because the Calculator follows the normal order of operations. This is what happens without the parentheses:

<table>
<thead>
<tr>
<th>Click or Press</th>
<th>Display shows</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>+</td>
<td>3</td>
</tr>
<tr>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>\times</td>
<td>4</td>
</tr>
<tr>
<td>6</td>
<td>6</td>
</tr>
<tr>
<td>=</td>
<td>27</td>
</tr>
</tbody>
</table>

The Calculator multiplies the 4 and 6 first, since multiplication and division take precedence over addition and subtraction. It then adds the 3.

**Using the Memory**

With the Calculator's built-in memory, you can save the result of a calculation. In fact, you can save any number you wish to use again and then click a single key to reuse it. You can also use the memory to keep a running total of your calculations.
To store the displayed number...

Click STO or press 5. The number on the display is stored in memory.

To recall the number from memory...

When you want to use the stored number in a calculation, click RCL or press B. The number appears on the display. You can then use this number in a calculation.

To add to the number in memory...

If you want to add the number showing on the display to the number stored in memory, click STO+ or press T. The sum is stored in memory.

This is handy for keeping a running total of the results of your calculations.

To clear memory...

1. Enter a zero.

2. Click STO or press 5.

Cutting and Pasting

It's easy to cut or copy numbers from the Calculator and paste them into some other application. For a full explanation of cutting and pasting between applications, see “Cutting and Pasting” in Chapter 4, “The Professional Workspace.”
To move or copy numbers to another application...

1. Select the displayed numbers that you wish to copy.

2. From the Edit menu,
   - Choose Cut if you want to move the numbers. The numbers are removed from the Calculator and placed on the clipboard.
   - Choose Copy if you want to copy the numbers. A copy of the numbers is placed on the clipboard.

3. In the other application, click to position the cursor at the point where you want to place the numbers.

4. Choose Paste from the Edit menu to copy the numbers from the clipboard into the document.

The same technique works if you want to copy numbers in the opposite direction—from another application into the Calculator.

To Quick Copy or Quick Move numbers...

1. Select the displayed numbers you wish to move or copy.

2. Position the pointer over the selected numbers. Use the right mouse button for both the Quick Copy and Quick Move:
   - To Quick Copy the numbers, press and hold down the right mouse button. The pointer changes to a Quick Copy pointer.
   - To Quick Move the numbers, press and hold down the right mouse button while simultaneously holding down the Alt key. The pointer changes to a Quick Move pointer.

3. Still holding the right mouse button (and Alt if you’re doing a Quick Move), move the pointer until it’s over the spot where you want to insert the selected numbers.

4. Release the right mouse button. The numbers are copied or moved to the new location.
Changing Options

With the Options menu you can customize the Calculator by setting the number of decimal places you want displayed, and by setting the Calculator to Standard operation or Reverse Polish Notation (RPN). RPN is the style used by Hewlett-Packard calculators.

To switch to RPN operation...

Choose RPN from the Options menu. The Standard Calculator is replaced with the RPN Calculator.

To switch to Standard operation...

If you want to switch back to the original Calculator, choose Standard from the Options menu.

To set the number of decimal places...

1. Choose Decimal Places from the Options menu. The Decimal Places dialog box appears.

2. Set the number of decimal places. You can choose from 0 to 8 decimal places.

3. Click OK.

When displayed, numbers are rounded to the number of places you specify, but this does not change the actual values being used for calculations.
For example, if you set the number of decimal places to two, the Calculator shows all your results rounded to two decimal places on the display. This means that 1.275 appears as 1.28 on the display but still has the value of 1.275 when used as part of a calculation.

**Using the RPN Calculator**

If you prefer to use HP-style calculators which use Reverse Polish Notation (RPN), you can switch to the RPN Calculator. RPN is simply a different way to enter calculations—first, you enter both numbers, then you click the arithmetic function.

The buttons on the RPN Calculator work the same way as those on the Standard Calculator, with only a few differences:

**Enter Button:** Click this button to separate one number from the next number. Normally, you put in the first number, click Enter, put in the second number, then click an arithmetic function.

**Exchange Button:** Click this button to exchange the number in the
display with the last number entered. This is useful in switching the order of numbers to be subtracted or divided.

**C/CE Button:** Click this button to clear a number from the Calculator if you haven’t yet clicked Enter. If clicked twice, this clears everything, including any calculations in progress.

All the RPN Calculator buttons are activated by the same keys on the keyboard as the Standard Calculator. The one addition is the Exchange Key, which can be activated by pressing $\equiv$.

**To do RPN calculations...**

1. Click the digits of the first number.
   - Click Del if you if you want to delete the last digit you typed.
   - Click ± to change the sign if needed.

2. Click Enter to separate the first number from the next number.

3. Click the digits of the second number. Do not click Enter this time.

4. Click the arithmetic function you want: +, −, ×, or ÷. The result is displayed.
   
   You can use this result as the first number in another calculation.

Don’t click Enter after putting in the second number. If you do, the second number is used twice in the operation you click.

These examples demonstrate how to use RPN:

**Example 1:** Calculate $-3 + 10$

<table>
<thead>
<tr>
<th>Click or Press</th>
<th>Display shows</th>
</tr>
</thead>
<tbody>
<tr>
<td>3, ±</td>
<td>-3</td>
</tr>
<tr>
<td>Enter</td>
<td>-3</td>
</tr>
<tr>
<td>1, 0, +</td>
<td>7</td>
</tr>
</tbody>
</table>
You can always use the result of one calculation as the first number in the next one.

With RPN, a calculation is performed in the order you entered it, as illustrated in the following example.

Example 2: Calculate \((3+4)\times6\)

<table>
<thead>
<tr>
<th>Click or Press</th>
<th>Display shows</th>
</tr>
</thead>
<tbody>
<tr>
<td>3, Enter</td>
<td>3</td>
</tr>
<tr>
<td>4, +</td>
<td>7</td>
</tr>
<tr>
<td>6, (\times)</td>
<td>42</td>
</tr>
</tbody>
</table>

Notice that, unlike the Standard Calculator, there is no need for parentheses with the RPN Calculator. If the problem was \(6\times(3+4)\), you would still start within the parentheses and work out.

The following example demonstrates the use of the Exchange key.

Example 3: Calculate \(6+[5-4\times(3+2)]\)

<table>
<thead>
<tr>
<th>Click or Press</th>
<th>Display shows</th>
</tr>
</thead>
<tbody>
<tr>
<td>3, Enter</td>
<td>3</td>
</tr>
<tr>
<td>2, +</td>
<td>5</td>
</tr>
<tr>
<td>4, (\times)</td>
<td>20</td>
</tr>
</tbody>
</table>

At this point, the 20 on the display must be subtracted from 5. However, the 20 is already in the Calculator, and the numbers will be in the wrong order for the subtraction. You can continue by entering the 5 and using the Exchange key:

<table>
<thead>
<tr>
<th>Click or Press</th>
<th>Display shows</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>(x&lt;&gt;y)</td>
<td>20</td>
</tr>
<tr>
<td>(-)</td>
<td>-15</td>
</tr>
</tbody>
</table>

Reverse the order of the numbers and subtract to get \(5-4\times(3+2)\).
Then finish the calculation with:

<table>
<thead>
<tr>
<th>Click or Press</th>
<th>Display shows</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>6</td>
</tr>
<tr>
<td>x&lt;&gt;y</td>
<td>-15</td>
</tr>
<tr>
<td>+</td>
<td>-0.4</td>
</tr>
</tbody>
</table>

The next example shows how to use the memory.

Example 4: Store a 5, then use the recalled value to calculate 7+5, then add the result to memory.

<table>
<thead>
<tr>
<th>Click or Press</th>
<th>Display shows</th>
</tr>
</thead>
<tbody>
<tr>
<td>5, STO</td>
<td>5</td>
</tr>
<tr>
<td>7, Enter</td>
<td>7</td>
</tr>
<tr>
<td>RCL</td>
<td>5</td>
</tr>
<tr>
<td>+</td>
<td>12</td>
</tr>
<tr>
<td>STO+</td>
<td>12</td>
</tr>
</tbody>
</table>

Now if you click RCL, the sum of 17 is displayed.
The Notepad desk tool is a simple text editor. Unlike GeoWrite, it works with DOS text (ASCII) files which do not include any formatting instructions. This makes the Notepad desk tool ideal for creating and editing DOS files—for example, you can use it to change your AUTOEXEC.BAT file quickly and easily. You can also use the Notepad to quickly jot down simple notes that don’t require the full font and formatting power of GeoWrite.

The Notepad Window

When you start the Notepad, it automatically opens the NOTES.TXT document in a window. If NOTES.TXT does not exist in the GEOS DOCUMENT directory, the Notepad creates it for you.

Using the Notepad

The Notepad is easy to use. You create, edit, and save a Notepad document the same way you do any document, but there are no rulers and no complicated formatting commands to learn. See Chapter 4, "The Professional Workspace," for information on working with documents and editing text.
Although the Notepad may seem a lot like GeoWrite, keep in mind these differences between the two applications:

<table>
<thead>
<tr>
<th>The Notepad</th>
<th>GeoWrite</th>
</tr>
</thead>
<tbody>
<tr>
<td>Can only have one document open at a time</td>
<td>Allows multiple documents</td>
</tr>
<tr>
<td>Works only with DOS files</td>
<td>Works only with GEOS documents</td>
</tr>
<tr>
<td>No document safeguarding</td>
<td>Safeguards your documents</td>
</tr>
<tr>
<td>No choice of fonts</td>
<td>Variety of fonts</td>
</tr>
<tr>
<td>No rulers, paragraph formatting or text justification</td>
<td>Variety of formatting options</td>
</tr>
</tbody>
</table>

This manual sometimes refers to Notepad files as documents because editing DOS files in the Notepad is much the same as editing GEOS documents in GeoWrite. It is important to realize, though, that the files you create and edit in the Notepad are DOS files, which have no fonts or special formatting. They are not interchangeable with the GEOS documents you create with GeoWrite.

**Changing the Text Size**

You can change the size of all the text while you're working in the Notepad; you can make it larger to make the text easier to see, or smaller to fit more text on the screen.
To change the text size...

Choose the size you want from the Sizes menu.

The sizing feature is provided only as an on-screen convenience. Each time you choose a size, that size of text is used in the entire Notepad window until you change the size again or exit the Notepad.

Printing

You can print a Notepad file. Choosing Print from the File menu in the Notepad window displays the Printer dialog box, which lets you enter the number of copies and choose to print a fast rough draft or high quality final output.

To print the current document...

1. Choose Print from the File menu in the Notepad window.

2. Click Change Options to change printers, the paper size, or the paper source. A dialog box appears.
• If you have more than one printer installed, choose a printer from the list.

If you need to update your printer configuration, see “The Preferences Desk Tool” earlier in this chapter.

• Choose the desired page size from the list of sizes. You can also override these choices by entering the Width and Height of your paper in the boxes below.

• If your printer has several paper sources, select the Paper Source you want to use for this printing.

Click OK to accept the changed settings, or click Cancel to keep the previous settings. This returns you to the Print dialog box.

3. Select the Print Quality:

• High—prints at the highest resolution of your printer.

• Medium—prints at medium resolution (not available for some printers).

• Low—prints at low resolution for quick drafts.

For the fastest printing, select the Low option.

4. Click Text Mode Only for faster printing at any print quality level. This option uses the printer's internal fonts, so the printed output may not match what you see on the screen. You may only want to use this when speed is the priority.
5. Enter the Number of Copies you want.
6. Click Print to start printing.

**Saving a Document**

The File menu contains two commands that let you save the current Notepad file to disk: Save and Save As.

- **Save**: Use Save when you finish with the document, want to make your changes permanent, or when you're about to try something new and want to be able to Revert back to the current document.

- **Save As**: Use Save As for saving a copy of your document under a different name.

The first time you save, a dialog box appears for you to name the document.

Unlike most GEOS applications, the Notepad does not support document safeguarding because it works with DOS files, not GEOS documents. This means there is no temporary "working" copy in which your present unsaved changes are stored. So, to protect your document, be sure to save whenever you make important changes.

**To name and save a Notepad document...**

1. Choose Save or Save As from the File menu.
2. Go to the directory where you want to save the document.
   
   The Save dialog box shows you the files and subdirectories in your current directory. To go into a subdirectory, double-click its name or icon in the scrolling list.
3. Type a name for the document and click Save.
Follow the DOS naming conventions when you save a Notepad document, since it is a normal DOS text file, not a GEOS document. You can have up to eight alphanumeric characters with an optional three-character extension. An extension consists of a period, followed by up to three alphanumeric characters. Typical extensions are .TXT for text files, and .BAT for batch files. Here are some typical names you might use for your Notepad files:

NOTETOME
DOTHIS.BAT
LETTER.2

To save a copy of the Notepad document with a different name...

1. Choose Save As from the File menu.
2. Go to the directory where you want to save the document.
3. Type the new name for the document and click Save.

The title of the document at the top of the window changes to the new name. This means that your changes are saved into this new document from now on.

To save your changes as you work...

After you have named and saved the document once, choose Save from the File menu to save any additional changes as you work. It's a good idea to save after you make an important change.

To revert to the previously saved version...

If you start revising your Notepad document and don't like the changes you've made, you can return to the last saved version by choosing Revert from the File menu.
Opening and Closing Documents

With the Notepad, you can only have one file open at a time. So, you must close the current file to switch to a different document. See the section “Working with Documents” in Chapter 4, “The Professional Workspace,” for more information on opening, closing, and saving documents.

To create a new document...

1. Choose Close from the File menu to close the current document.

   A dialog box may appear, asking you if you want to save changes you’ve made since the last time you saved. Click Yes to save, or No to ignore the changes.

2. Choose New from the File menu. The Notepad opens a new document, which is temporarily named NOTES until you save it. The Notepad will then ask you for a new name.

To open a different document...

1. Choose Close from the File menu to close the current document.

   A dialog box may appear, asking you if you want to save changes you have made since the last time you saved. Click Yes to save, or No to ignore the changes.

2. Choose Open from the File menu. You see the Open dialog box, which you use to choose directories and files to open.

   - Click Read-Only if you just want to look at a file without changing it. This prevents you from accidentally making changes to a file.

3. Open the desired document as usual by selecting the file and clicking Open, or by double-clicking the file. The document appears in the Notepad window.
To close a document...

Choose Close from the File menu.

If you've made changes since the last time you saved, the Notepad asks you if you want to save the changes. Click Yes to save them, or click No to ignore all your work since the last time you saved. Click Cancel to keep working on the same document.

Cutting and Pasting

It's easy to cut or copy text from the Notepad and paste it into some other application. For a full explanation of cutting and pasting between applications, see "Cutting and Pasting" in Chapter 4, "The Professional Workspace."

To move or copy text to another application...

1. Select the text you wish to move or copy.

2. From the Edit menu,
   - Choose Cut if you want to move the text. The text is removed from the Notepad and placed on the clipboard.
   - Choose Copy if you want to copy the text. A copy of the text is placed on the clipboard.

3. In the other application, click to position the cursor at the point where you want to place the text.

4. Choose Paste from the Edit menu to copy the text from the clipboard into the document.

The same technique works if you want to copy text in the opposite direction—from another application into the Notepad.
To Quick Copy or Quick Move text...

1. Select the text you wish to move or copy.

2. Position the pointer over the selected text. Use the right mouse button for both Quick Copy and Quick Move:
   - To Quick Copy the text, press and hold down the right mouse button. The pointer changes to a Quick Copy pointer.
   - To Quick Move the text, press and hold down the right mouse button while simultaneously holding down the Alt key. The pointer changes to a Quick Move pointer.

3. Still holding the right mouse button (and Alt if you’re doing a Quick Move), move the pointer until it’s over the spot where you wish to insert the selected text.

4. Release the right mouse button. The text is copied or moved to the new location.
**The Scrapbook Desk Tool**

**Items you cut** or copy to the clipboard remain on the clipboard only until the next cut or copy operation replaces them, so the clipboard is just a temporary storage place. However, if you want to use certain items again and again, you can use the Scrapbook desk tool to take them off the clipboard and put them into permanent storage as a page in a Scrapbook document. When you want to use something you’ve stored, simply open the Scrapbook, flip to the page you want, and cut or copy to the clipboard. From there you can paste into another document.

You can keep a single Scrapbook document with lots of pages. Or you can create as many Scrapbook documents as you want, such as one for each project.

**The Scrapbook Window**

When you start the Scrapbook desk tool, its window appears with a Default Scrapbook open and ready for use. If no Default Scrapbook document exists in the GEOS DOCUMENT directory, then the Scrapbook desk tool creates a new Default Scrapbook.
Viewing window: The contents of the current page appear in the viewing window. If no pages exist, then this area is empty.

Scroll bar: If the contents of a page are larger than the viewing window, the scroll bar lets you scroll the page to see different parts.

Next and Previous: Click these buttons to flip between pages.

Name field: You can give the contents of each page a name.

Go to Page: Click this button to view a list of pages by name. You can select from this list and go directly to that page.

**Working With Scraps**

It is easy to add a page to the Scrapbook. You simply cut or copy text or graphics from one document and paste them into the Scrapbook. Whatever you paste becomes a new page in the Scrapbook document. When you want to use something you've saved, you can open the Scrapbook, flip to a page, and cut or copy whatever you want to another document.

See "Cutting and Pasting" in Chapter 4, "The Professional Workspace," for more information on using the clipboard.

**To flip through pages of the Scrapbook...**

Click Next to flip to the next page in the Scrapbook. If you are on the last page, clicking Next flips you around to the first page.

Click the Previous button to flip to the previous page in the scrapbook. If you are on the first page, clicking Previous flips you around to the last page.
To add to the Scrapbook...

1. Within an application, cut or copy text or graphics to the clipboard in the normal manner. See “Cutting and Pasting” in Chapter 4, “The Professional Workspace.”

2. Switch to the Scrapbook desk tool. If the Scrapbook is not already running, start it now.

3. If you want to place the contents of the clipboard on a particular page, flip to that page and choose Paste from the Edit menu. A new page is inserted in front of the current page, and the contents of the clipboard are pasted there.

   If you want to place the contents of the clipboard on a new page at the end of the Scrapbook, choose Paste at End from the Edit menu. A new page is added to the end of the Scrapbook document, and the contents of the clipboard are pasted there.

To cut or copy from the scrapbook to another application...

1. Flip to the page whose contents you wish to cut or copy.

2. Choose Cut or Copy from the Edit menu.

   - The Cut command moves the contents of the page to the clipboard, removing the page from the Scrapbook.

   - The Copy command copies the contents of the page to the clipboard and leaves the page intact.

3. Switch to the application and click to put the insertion point at the place you wish to paste what you cut or copied, then choose Paste from the Edit menu. The contents of the clipboard appear in the document.

To remove a page...

1. Flip to the page you want to delete.
2. Choose Delete from the Edit menu. The page is removed from the Scrapbook document. The contents of the page are not placed on the clipboard.

If you accidentally remove a page you wanted to keep, you can get it back by choosing Revert from the File menu. The Revert command restores to the last saved version of the Scrapbook.

**To name the contents of a page...**

1. Flip to the page whose contents you want to name.

2. In the Name field, type text to describe the contents of the page. You may type up to 32 characters, including spaces and punctuation.

**To browse through names and go to a specific page...**

1. Click the Go to Page button. The Go to Page dialog box appears. Inside the dialog box is a list of all the pages in the Scrapbook arranged by page number.

2. Scroll the list if necessary, then, in the list, click to select the page you want to view.

3. With the page selected, click View Page. The Scrapbook window flips to that page.
You can also double-click a page in the list to select and view that page in one step.

4. You can leave the dialog box open while you work in the Scrapbook, or you can close it at any time by clicking Close.

**Working With Scrapbook Documents**

A Scrapbook document consists of pages of scraps. Like other documents, a Scrapbook document exists as a file on your disk.

Whenever you start the Scrapbook, a special Scrapbook document named “Default Scrapbook” opens automatically. If this file cannot be found in the DOCUMENT directory, a new Default Scrapbook is created there.

Because the Scrapbook stores its pages in documents, you can use commands on the File menu as you would with other applications. You can save the current Scrapbook under its current name (using Save) or under a new name (using Save As). You can close a document (using Close) and open a new one (using New). If you start changing the Scrapbook and then decide you liked the old version better, you can go back to the last saved version of the Scrapbook with the Revert command.

**To save the current Scrapbook...**

Choose Save from the File menu. If this is the first time you have saved a document, you are asked to give it a name.

**To save a copy of the Scrapbook under a different name...**

1. Choose Save As from the File menu. A dialog box appears.

2. Use the directory listing to locate the directory where you would like to save the copy of the document.
3. Enter a name for the document.

4. Click Save. A copy of the Scrapbook is saved under the new name.

To revert to the last saved version...

Choose Revert from the File menu. The Scrapbook restores to its last saved version.

To create a new Scrapbook...

1. Choose Close from the File menu to close the current Scrapbook.

   A dialog box may appear, asking if you wish to save any changes. Follow the directions in the dialog box.

2. Choose New from the File menu. The Scrapbook creates a new document named Default Scrapbook. If Default Scrapbooks already exist, then new documents are called Default Scrapbook 1, Default Scrapbook 2, and so on. There are no pages in the new document.

To open a different Scrapbook...

1. Choose Close from the File menu to close the current Scrapbook.

   A dialog box may appear, asking if you wish to save any changes. Follow the directions in the dialog box.

2. Choose Open from the File menu. A dialog box appears.

3. Go to the drive and directory where the desired Scrapbook is located.

4. Select the Scrapbook you want to open.

5. Click Open. The desired Scrapbook appears.
Scrapbook Hints and Tips

Here are a few things you can do with the Scrapbook desk tool that may not be apparent when you first start using it:

• Change the Default Scrapbook file that opens when you first start the Scrapbook.

• Keep more than one Scrapbook open at a time, each with a different document.

• Cut and copy pages between scrapbooks.

To change the Default Scrapbook...

1. Exit the Scrapbook desk tool.
2. Switch to GeoManager.
3. In the DOCUMENT directory, rename the Default Scrapbook to something else.
4. Also in the DOCUMENT directory, find the Scrapbook document you want to be the default and rename it Default Scrapbook (spell and capitalize the name exactly as it is here).

The next time you start the Scrapbook desk tool, the new Default Scrapbook automatically opens.

To keep more than one Scrapbook open at a time...

You can start as many copies of the Scrapbook desk tool as you want, either from the GeoManager or from the Express menu. You can open a different Scrapbook document in each of the running versions.

When you start another version of the Scrapbook, a dialog box may appear, advising you that the Default Scrapbook document is already being used. Click OK, then open another Scrapbook document by choosing Open from the File menu.
See “Using Applications” in Chapter 4, “The Professional Workspace,” for more information on starting applications and managing multiple applications in the workspace.

**To cut or copy between two Scrapbooks…**

1. Start the Scrapbook desk tool twice so that two versions are running in the workspace. In each of the running versions, open a different Scrapbook document.

2. In one of the Scrapbooks, flip to a page you want to cut or copy.

3. Cut or copy the contents of the page to the clipboard as usual.

4. In the other Scrapbook, flip to where you want to paste the contents, then paste as usual.

5. Continue in this way until you have cut or copied as many pages as you want.
The DOS Programs screen offers a quick way to run DOS programs and batch files at the press of a button. You can create as many buttons as you want, one for each DOS program and batch file you use, and you can give each button its own picture and title.

If you set up buttons for yourself and the other people who use your computer, you can use the DOS Programs screen as a graphical program launcher. You may never need to type DOS commands again.

Before you attempt to set up buttons, though, you should make sure that you're familiar with the concepts described in Chapter 4, "The Professional Workspace."
Using the DOS Programs Screen

443 Entering and Exiting the DOS Programs Screen
444 Creating a Button
447 Changing and Deleting Buttons
448 Using Buttons
450 Creating and Editing Batch Files
You enter the DOS Programs screen by clicking a button on the Welcome screen. When you finish with the DOS Programs screen, you can exit and return to the Welcome screen.

To enter the DOS Programs screen...

On the Welcome screen, click the DOS Programs button. The DOS Programs screen appears.

The first time you enter the DOS Programs screen, it has only one button, labeled “Enter DOS.”

The “Enter DOS” button lets you temporarily enter DOS. Once in DOS, you can invoke normal DOS commands. Type exit and press Enter to leave DOS and return to the DOS Programs screen.

To exit the DOS Programs screen...

Click the Exit button in the upper left corner of the DOS Programs screen. The Welcome screen reappears.
Creating a Button

By creating a button, you can use your favorite DOS programs without leaving GEOS. But you should not attempt to create buttons unless you’re completely familiar with the concepts and techniques presented in Chapter 4, “The Professional Workspace.”

To create a new button...

1. Choose Create New Button from the Options menu. A dialog box appears, asking you to select a DOS file for the new button.

2. In the file list, find the file you wish to use with the button:
   - If you see the file you want, click to highlight it.
   - Click or press the scroll arrows at the top and bottom of the scroll bar to see more of the list.
• Double-click a directory in the file list to open that directory and view its contents.

• Click the Up Directory button to close the current directory and move up to the previous directory.

• Click the Change Drive button to view the contents of another disk.

3. Click to select the file you wish to use. The file is highlighted to indicate the selection.

4. With a file highlighted, click Use This File. The Select File dialog box goes away and is replaced by the Button Settings dialog box.

5. Change the button's settings in the dialog box as desired (see below).

6. Click OK. The dialog box closes and the new button appears.

All the settings for a button can be changed from the Button Settings dialog box. You first see the Button Settings dialog box when you create a new button and, thereafter, when you want to change a button's settings.
**Button Appearance:** The Button Appearance area shows the picture that appears on the face of the button and the text that also goes with it. You can edit the text to change the name of the button, and you can choose a different picture by clicking Change Picture.

**DOS File for Button:** Each button can have a unique DOS file that runs when you press the button. You can run a .COM file, a .EXE file, or a .BAT file. The file runs exactly as if you had typed a command from the DOS prompt. For example, if you select the CHKDSK.COM file for a particular button, the DOS CHKDSK command runs when you press that button. You can click Change File to change the DOS file to run.

**Command Line Options:** Many DOS programs accept options when you type them at the DOS prompt. For example, when using the CHKDSK command you can pass options such as “/f” to fix errors and “/v” to display the name of each file as it goes. You have three possible settings for command line options with each button.

- **No Command Line Options:** Use this setting when you don’t want to send any command line options.

- **Ask for Options Each Time:** Use this setting if each time you press the button you want a dialog box to appear and ask for options you want to use.

- **Specify Options Now:** Use this setting when you want to use the same options every time.
**Once you have** created a button, you can change its settings or delete it at any time.

**To change a button's settings...**

1. Choose Change Button Settings from the Options menu. A dialog box appears, listing all the buttons by name.

2. In the list, click to select the name of the button with settings you wish to change.

3. With the button name selected, click Change Settings. The Button Settings dialog box appears, showing the settings for the button.

4. Change the button's settings in the dialog box as desired. See "Creating a Button," earlier in this chapter, for an explanation of the different settings.

5. Click OK. The dialog box closes and the button appears with its new settings.

**To delete a button...**

1. Choose Delete Button from the Options menu. A dialog box appears, listing all the buttons by name.

2. Click to select the name of the button you want to delete.

3. With the button name selected, click Delete Button. The dialog box closes and the button no longer appears.
Using Buttons

Each button you create gets added to the DOS Programs screen. By clicking a button, you can run the program or batch file associated with the button.

If you add more buttons than will fit on the screen (the exact number depends on your monitor and video card), paging arrows appear at the bottom of the screen. The paging arrows let you flip from page to page to see different buttons. If a paging arrow is disabled, you are already viewing the last page in that direction.

To use a button...

1. Find the button you wish to use. If there are additional screens of buttons, click the Next and Prev arrows at the bottom of the screen to see additional screens.
2. Click the button for the program you wish to run. The screen clears. After a few moments, the DOS file runs. When the DOS file finishes running (if you run a program, you may need to quit it), you are returned to GEOS.

If you set the Ask for Options Each Time option, a dialog box appears so that you can enter some options for the program.

The DOS program runs. When it finishes (you may need to quit it), you are returned to GEOS.

If you run the DOS file COMMAND.COM, which gives you the standard DOS prompt, type exit to return to GEOS.
A batch file is a sequence of DOS commands contained in a text file. If you work with batch files, there is a quick and easy way to create and edit them without leaving GEOS. If you want to know more about batch files, refer to your DOS User’s Reference.

**To create a new batch file...**

1. Choose Create Batch File from the Options menu. A dialog box appears, asking you to specify a name for the batch file and directory in which to create the file.

2. In the dialog box, switch to the drive and directory where you want to create the batch file.
   - Click or press the scroll arrows at the top and bottom of the scroll bar to see more of the list.
   - Double-click a directory in the file list to make it the current directory.
   - Click the Up Directory button to close the current directory and move up to the previous directory.
   - Click the Change Drive button to change disks.
3. Type a name for the batch file, up to eight characters in length. Only valid characters for DOS file names are accepted. The file is automatically given a .BAT extension.


5. To edit text in the Batch File Text dialog box
   - Type text. Characters appear at the text cursor. Press Enter at the end of each line.
   - Erase characters by pressing Backspace to backspace.
   - Reposition the text cursor by clicking between characters or pressing the arrow keys.

See “Entering and Editing Text” in Chapter 4, “The Professional Workspace,” for more information on editing text.

6. Use the scroll bar to scroll the text up or down.

See “Using Windows” in Chapter 4, “The Professional Workspace,” for more information on scrolling text.

7. When you finish editing, click Save. The batch file saves to disk under the name you specified.
To edit an existing batch file...

1. Choose Edit Batch File from the Options menu. A dialog box appears, asking you to specify a name for the batch file and a directory in which to create the file.

2. In the dialog box, find the batch file you wish to edit:
   - Click or press the scroll arrows at the top and bottom of the scroll bar to see more of the list.
   - Double-click a directory in the file list to make it the current directory.
   - Click the Up Directory button to close the current directory and move up to the previous directory.
   - Click the Change Drive button to change disks.

3. Click to select the file you wish to edit. The file is highlighted.

4. With the file you want to edit selected, click Edit. The Batch File Text dialog box appears.
5. To edit text in the Batch File Text dialog box:

- Position the text cursor by clicking between characters or pressing the \[\rightarrow \leftarrow \uparrow \downarrow \] keys.

- Type text. Characters appear at the text cursor. Press \[\text{Enter}\] at the end of each line.

- Erase characters by pressing \[\text{Backspace}\].

- Use the scroll bar to scroll the text up or down.

See "Using Windows" in Chapter 4, "The Professional Workspace," for more information on scrolling text.

See "Entering and Editing Text" in Chapter 4, "The Professional Workspace," for more information on editing text.

6. When you finish editing, click Save. The batch file saves to disk under the same name.
## Appendices, Glossary, and Index

<table>
<thead>
<tr>
<th>Page</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>457</td>
<td>Appendix A — Software Ethics</td>
</tr>
<tr>
<td>458</td>
<td>Appendix B — Special Characters</td>
</tr>
<tr>
<td>464</td>
<td>Glossary</td>
</tr>
<tr>
<td>475</td>
<td>Index</td>
</tr>
</tbody>
</table>
Thank you for purchasing GEOS. We hope you enjoy using GEOS and its family of products. Tell your friends. Show it off. But please, don’t make copies of it except for your personal backup copies.

Copying software hurts everyone. It hurts the legitimate user, who ends up paying for those who use illegal copies. It hurts those who use illegal copies themselves: they receive no customer support, no documentation, and no product updates. And small companies like ours may suffer most of all. We work hard to bring you exciting and innovative products, but every theft makes it that much harder to stay in business.

As an individual user, you have the right to make a backup copy for archival purposes. A school or a company should purchase as many software packages as it will need. To be safe, purchase one package for each computer to remove the incentive to illegally copy software.

Thank you…
There are a number of special characters you can use in many GEOS applications. These characters do not appear on your keyboard, but can be used by pressing certain combinations of keys. Some of the more useful characters are foreign language accents, foreign currency symbols, and mathematical symbols. You can use these in virtually any GEOS application. GeoWrite, GeoDraw, and GeoPlanner all recognize special characters. They appear on the screen and on paper when you print normally (do not choose the Text Mode Only option). GeoDex will display special characters on the screen, but will not print them out. You cannot use special characters as part of a filename or directory name, or in Notepad documents, since DOS does not recognize these characters.

To type a special character...

1. Look up the character you want to enter in the following tables.

2. Press the combination of keys indicated. A plus sign (+) between two groups of keys means hold the first set of keys down while pressing the second. The word “then” between two groups of keys means release the first set of keys before pressing the second. The special character appears in the document at the position of the cursor.

Accented Language Characters:

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>Á</td>
<td>uppercase A acute accent</td>
<td>Ctrl + E then Shift + A</td>
</tr>
<tr>
<td>Ä</td>
<td>uppercase A dieresis accent</td>
<td>Ctrl + U then Shift + A</td>
</tr>
<tr>
<td>À</td>
<td>uppercase A grave accent</td>
<td>Ctrl + - then Shift + A</td>
</tr>
<tr>
<td>Â</td>
<td>uppercase A circumflex accent</td>
<td>Ctrl + I then Shift + A</td>
</tr>
<tr>
<td>Ä</td>
<td>uppercase A tilde accent</td>
<td>Ctrl + N then Shift + A</td>
</tr>
<tr>
<td>Char</td>
<td>Name</td>
<td>Keys</td>
</tr>
<tr>
<td>------</td>
<td>---------------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>À</td>
<td>uppercase a ring accent</td>
<td>Shift Ctrl Alt + A</td>
</tr>
<tr>
<td>á</td>
<td>lowercase a acute accent</td>
<td>Ctrl Alt + E then A</td>
</tr>
<tr>
<td>ä</td>
<td>lowercase a dieresis accent</td>
<td>Ctrl Alt + U then A</td>
</tr>
<tr>
<td>à</td>
<td>lowercase a grave accent</td>
<td>Ctrl Alt + ̀ then A</td>
</tr>
<tr>
<td>â</td>
<td>lowercase a circumflex accent</td>
<td>Ctrl Alt + ì then A</td>
</tr>
<tr>
<td>â</td>
<td>lowercase a tilde accent</td>
<td>Ctrl Alt + ñ then A</td>
</tr>
<tr>
<td>â</td>
<td>lowercase a ring accent</td>
<td>Ctrl Alt + A</td>
</tr>
<tr>
<td>Ç</td>
<td>uppercase C cedilla accent</td>
<td>Shift Ctrl Alt + C</td>
</tr>
<tr>
<td>ç</td>
<td>lowercase c cedilla accent</td>
<td>Ctrl Alt + C</td>
</tr>
<tr>
<td>É</td>
<td>uppercase E acute accent</td>
<td>Ctrl Alt + E then Shift + E</td>
</tr>
<tr>
<td>Ê</td>
<td>uppercase E dieresis accent</td>
<td>Ctrl Alt + U then Shift + E</td>
</tr>
<tr>
<td>Ë</td>
<td>uppercase E grave accent</td>
<td>Ctrl Alt + ̀ then Shift + E</td>
</tr>
<tr>
<td>Ê</td>
<td>uppercase E circumflex accent</td>
<td>Ctrl Alt + ì then Shift + E</td>
</tr>
<tr>
<td>é</td>
<td>lowercase e acute accent</td>
<td>Ctrl Alt + E then E</td>
</tr>
<tr>
<td>ë</td>
<td>lowercase e dieresis accent</td>
<td>Ctrl Alt + U then E</td>
</tr>
<tr>
<td>è</td>
<td>lowercase e grave accent</td>
<td>Ctrl Alt + ̀ then E</td>
</tr>
<tr>
<td>ë</td>
<td>lowercase e circumflex accent</td>
<td>Ctrl Alt + ì then E</td>
</tr>
<tr>
<td>Í</td>
<td>uppercase I acute accent</td>
<td>Ctrl Alt + E then Shift + I</td>
</tr>
<tr>
<td>Ì</td>
<td>uppercase I dieresis accent</td>
<td>Ctrl Alt + U then Shift + I</td>
</tr>
<tr>
<td>Í</td>
<td>uppercase I grave accent</td>
<td>Ctrl Alt + ̀ then Shift + I</td>
</tr>
<tr>
<td>Ì</td>
<td>uppercase I circumflex accent</td>
<td>Ctrl Alt + ì then Shift + I</td>
</tr>
<tr>
<td>í</td>
<td>lowercase i acute accent</td>
<td>Ctrl Alt + E then I</td>
</tr>
<tr>
<td>ï</td>
<td>lowercase i dieresis accent</td>
<td>Ctrl Alt + U then I</td>
</tr>
<tr>
<td>ï</td>
<td>lowercase i grave accent</td>
<td>Ctrl Alt + ̀ then I</td>
</tr>
<tr>
<td>ï</td>
<td>lowercase i circumflex accent</td>
<td>Ctrl Alt + ì then I</td>
</tr>
<tr>
<td>Ñ</td>
<td>uppercase N tilde accent</td>
<td>Ctrl Alt + N then Shift + N</td>
</tr>
<tr>
<td>ñ</td>
<td>lowercase n tilde accent</td>
<td>Ctrl Alt + N then N</td>
</tr>
<tr>
<td>Ó</td>
<td>uppercase O acute accent</td>
<td>Ctrl Alt + E then Shift + O</td>
</tr>
<tr>
<td>Õ</td>
<td>uppercase O dieresis accent</td>
<td>Ctrl Alt + U then Shift + O</td>
</tr>
<tr>
<td>ò</td>
<td>uppercase O grave accent</td>
<td>Ctrl Alt + ̀ then Shift + O</td>
</tr>
<tr>
<td>Char</td>
<td>Name</td>
<td>Keys</td>
</tr>
<tr>
<td>------</td>
<td>-------------------------------</td>
<td>-----------------------------------------</td>
</tr>
<tr>
<td>Ø</td>
<td>uppercase O circumflex accent</td>
<td>Ctrl Key then Shift + O</td>
</tr>
<tr>
<td>Ð</td>
<td>uppercase O tilde accent</td>
<td>Ctrl Key then Shift + O</td>
</tr>
<tr>
<td>Ø</td>
<td>uppercase O slash</td>
<td>Shift + Ctrl Key + O</td>
</tr>
<tr>
<td>å</td>
<td>lowercase o acute accent</td>
<td>Ctrl Key + E then Shift + O</td>
</tr>
<tr>
<td>ö</td>
<td>lowercase o dieresis accent</td>
<td>Ctrl Key + U then Shift + O</td>
</tr>
<tr>
<td>ò</td>
<td>lowercase o grave accent</td>
<td>Ctrl Key + then Shift + O</td>
</tr>
<tr>
<td>ò</td>
<td>lowercase o circumflex accent</td>
<td>Ctrl Key + I then Shift + O</td>
</tr>
<tr>
<td>ø</td>
<td>lowercase o tilde accent</td>
<td>Ctrl Key + N then Shift + O</td>
</tr>
<tr>
<td>¡</td>
<td>lowercase o slash</td>
<td>Ctrl Key + O</td>
</tr>
<tr>
<td>Ú</td>
<td>uppercase U acute accent</td>
<td>Ctrl Key + E then Shift + U</td>
</tr>
<tr>
<td>Ü</td>
<td>uppercase U dieresis accent</td>
<td>Ctrl Key + U then Shift + U</td>
</tr>
<tr>
<td>Û</td>
<td>uppercase U grave accent</td>
<td>Ctrl Key + then Shift + U</td>
</tr>
<tr>
<td>Û</td>
<td>uppercase U circumflex accent</td>
<td>Ctrl Key + I then Shift + U</td>
</tr>
<tr>
<td>û</td>
<td>lowercase u acute accent</td>
<td>Ctrl Key + E then Shift + U</td>
</tr>
<tr>
<td>ü</td>
<td>lowercase u dieresis accent</td>
<td>Ctrl Key + U then Shift + U</td>
</tr>
<tr>
<td>û</td>
<td>lowercase u grave accent</td>
<td>Ctrl Key + then Shift + U</td>
</tr>
<tr>
<td>û</td>
<td>lowercase u circumflex accent</td>
<td>Ctrl Key + I then Shift + U</td>
</tr>
<tr>
<td>Ÿ</td>
<td>uppercase y dieresis accent</td>
<td>Ctrl Key + U then Shift + Y</td>
</tr>
<tr>
<td>ŷ</td>
<td>lowercase y dieresis accent</td>
<td>Ctrl Key + U then Shift + Y</td>
</tr>
<tr>
<td>AÉ</td>
<td>uppercase AE dipthong</td>
<td>Shift + Ctrl Key + I</td>
</tr>
<tr>
<td>æ</td>
<td>lowercase ae dipthong</td>
<td>Ctrl Key + I</td>
</tr>
<tr>
<td>OE</td>
<td>uppercase OE dipthong</td>
<td>Shift + Ctrl Key + Q</td>
</tr>
<tr>
<td>òe</td>
<td>lowercase oe dipthong</td>
<td>Ctrl Key + Q</td>
</tr>
<tr>
<td>ı</td>
<td>dotless i</td>
<td>Shift + Ctrl Key + I</td>
</tr>
<tr>
<td>ß</td>
<td>German double s</td>
<td>Ctrl Key + S</td>
</tr>
<tr>
<td>ø</td>
<td>ordmasculine</td>
<td>Ctrl Key + O</td>
</tr>
<tr>
<td>a</td>
<td>ordfeminine</td>
<td>Ctrl Key + S</td>
</tr>
</tbody>
</table>
### Typographical:

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>†</td>
<td>dagger</td>
<td>Ctrl + T</td>
</tr>
<tr>
<td>‡</td>
<td>double dagger</td>
<td>Shift + Ctrl + T</td>
</tr>
<tr>
<td>$</td>
<td>section</td>
<td>Ctrl + 6</td>
</tr>
<tr>
<td>¶</td>
<td>paragraph</td>
<td>Ctrl + 7</td>
</tr>
<tr>
<td>®</td>
<td>registered trademark</td>
<td>Ctrl + R</td>
</tr>
<tr>
<td>©</td>
<td>copyright</td>
<td>Ctrl + G</td>
</tr>
<tr>
<td>™</td>
<td>trademark</td>
<td>Ctrl + 2</td>
</tr>
<tr>
<td>•</td>
<td>bullet</td>
<td>Ctrl + 8</td>
</tr>
<tr>
<td>·</td>
<td>centered period</td>
<td>Shift + Ctrl + 0</td>
</tr>
<tr>
<td>◊</td>
<td>lozenge</td>
<td>Shift + Ctrl + V</td>
</tr>
</tbody>
</table>

### Punctuation:

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>?</td>
<td>question down</td>
<td>Shift + Ctrl + /</td>
</tr>
<tr>
<td>!</td>
<td>exclamation down</td>
<td>Ctrl + 1</td>
</tr>
<tr>
<td>...</td>
<td>ellipsis</td>
<td>Ctrl + ;</td>
</tr>
<tr>
<td>-</td>
<td>non-breaking space</td>
<td>Alt + Spacebar</td>
</tr>
<tr>
<td>-</td>
<td>soft hyphen</td>
<td>Ctrl + -</td>
</tr>
<tr>
<td>_</td>
<td>en dash</td>
<td>Ctrl + -</td>
</tr>
<tr>
<td>—</td>
<td>em dash</td>
<td>Shift + Ctrl + -</td>
</tr>
<tr>
<td>&quot;</td>
<td>typographer’s open quotes</td>
<td>Ctrl + I</td>
</tr>
<tr>
<td>&quot;</td>
<td>typographer’s close quotes</td>
<td>Shift + Ctrl + I</td>
</tr>
<tr>
<td>‘</td>
<td>open single quote</td>
<td>Ctrl + 1</td>
</tr>
<tr>
<td>’</td>
<td>close single quote</td>
<td>Shift + Ctrl + 1</td>
</tr>
<tr>
<td>&quot;</td>
<td>double quote low</td>
<td>Shift + Ctrl + ;</td>
</tr>
<tr>
<td>’</td>
<td>single quote low</td>
<td>Shift + Ctrl + L</td>
</tr>
</tbody>
</table>
### Appendix B — Special Characters

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>«</td>
<td>opening guillemot</td>
<td>Ctrl Alt + /</td>
</tr>
<tr>
<td>»</td>
<td>closing guillemot</td>
<td>Shift Ctrl Alt + /</td>
</tr>
<tr>
<td>&lt;</td>
<td>opening single guillemot</td>
<td>Shift Ctrl Alt + &lt;</td>
</tr>
<tr>
<td>&gt;</td>
<td>closing single guillemot</td>
<td>Shift Ctrl Alt + &gt;</td>
</tr>
</tbody>
</table>

### Currency & Numeric:

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>¢</td>
<td>cent</td>
<td>Ctrl Alt + 4</td>
</tr>
<tr>
<td>£</td>
<td>pound sterling</td>
<td>Ctrl Alt + 3</td>
</tr>
<tr>
<td>¥</td>
<td>yen</td>
<td>Ctrl Alt + Y</td>
</tr>
<tr>
<td>☗</td>
<td>general currency</td>
<td>Shift Ctrl Alt + 4</td>
</tr>
<tr>
<td>₤</td>
<td>florin</td>
<td>Ctrl Alt + F</td>
</tr>
<tr>
<td>/</td>
<td>fraction</td>
<td>Shift Ctrl Alt + 3</td>
</tr>
<tr>
<td>°</td>
<td>degree</td>
<td>Shift Ctrl Alt + 8</td>
</tr>
<tr>
<td>‰</td>
<td>per thousand</td>
<td>Shift Ctrl Alt + 5</td>
</tr>
</tbody>
</table>

### Mathematical:

Not all these characters appear in every font. Use Symbol font if you are having trouble displaying these characters.

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>≠</td>
<td>not equal</td>
<td>Ctrl Alt + ≠</td>
</tr>
<tr>
<td>≈</td>
<td>approximately equal</td>
<td>Ctrl Alt + ≈</td>
</tr>
<tr>
<td>≤</td>
<td>less than or equal</td>
<td>Ctrl Alt + ≤</td>
</tr>
<tr>
<td>≥</td>
<td>greater than or equal</td>
<td>Ctrl Alt + ≥</td>
</tr>
<tr>
<td>±</td>
<td>plus/minus</td>
<td>Shift Ctrl Alt + ±</td>
</tr>
<tr>
<td>÷</td>
<td>division</td>
<td>Ctrl Alt + ÷</td>
</tr>
</tbody>
</table>
## Appendix B — Special Characters

### Char Name Keys

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>∞</td>
<td>infinity</td>
<td>Ctrl Alt + 5</td>
</tr>
<tr>
<td>∫</td>
<td>integral</td>
<td>Ctrl Alt + B</td>
</tr>
<tr>
<td>¬</td>
<td>logical not</td>
<td>Ctrl Alt + L</td>
</tr>
<tr>
<td>√</td>
<td>radical</td>
<td>Ctrl Alt + V</td>
</tr>
<tr>
<td>Π</td>
<td>Pi</td>
<td>Shift Ctrl Alt + P</td>
</tr>
<tr>
<td>π</td>
<td>pi</td>
<td>Ctrl Alt + P</td>
</tr>
<tr>
<td>Δ</td>
<td>Delta</td>
<td>Ctrl Alt + J</td>
</tr>
<tr>
<td>µ</td>
<td>mu</td>
<td>Ctrl Alt + M</td>
</tr>
<tr>
<td>∂</td>
<td>partial diff</td>
<td>Ctrl Alt + D</td>
</tr>
<tr>
<td>Ω</td>
<td>Omega</td>
<td>Ctrl Alt + Z</td>
</tr>
<tr>
<td>Σ</td>
<td>Sigma</td>
<td>Ctrl Alt + W</td>
</tr>
</tbody>
</table>

### Accents:

<table>
<thead>
<tr>
<th>Char</th>
<th>Name</th>
<th>Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>'</td>
<td>acute</td>
<td>Ctrl Alt + E then Spacebar</td>
</tr>
<tr>
<td>^</td>
<td>circumflex</td>
<td>Ctrl Alt + I then Spacebar</td>
</tr>
<tr>
<td>'</td>
<td>grave</td>
<td>Ctrl Alt + O then Spacebar</td>
</tr>
<tr>
<td>‾</td>
<td>dieresis</td>
<td>Ctrl Alt + U then Spacebar</td>
</tr>
<tr>
<td>~</td>
<td>tilde</td>
<td>Ctrl Alt + N then Spacebar</td>
</tr>
<tr>
<td>'</td>
<td>macron</td>
<td>Shift Ctrl Alt + W</td>
</tr>
<tr>
<td>‾</td>
<td>breve</td>
<td>Shift Ctrl Alt + Z</td>
</tr>
<tr>
<td>.</td>
<td>dot accent</td>
<td>Shift Ctrl Alt + D</td>
</tr>
<tr>
<td>.</td>
<td>caron*</td>
<td>Shift Ctrl Alt + S</td>
</tr>
<tr>
<td>.</td>
<td>ring accent</td>
<td>Shift Ctrl Alt + R</td>
</tr>
<tr>
<td>.</td>
<td>cedilla*</td>
<td>Shift Ctrl Alt + E</td>
</tr>
<tr>
<td>.</td>
<td>Hungarian umlaut*</td>
<td>Shift Ctrl Alt + U</td>
</tr>
<tr>
<td>.</td>
<td>ogonek*</td>
<td>Shift Ctrl Alt + Y</td>
</tr>
</tbody>
</table>

*These characters are available, although they do not appear in the manual.
accelerator: See keyboard accelerator.

active window: Describes the one open window that responds to keystrokes and commands. The active window has a highlighted title bar to distinguish it from the other open windows. Click in a window to make it the active window.

appliance: A simplified, easy-to-use version of a GEOS application. For example, there are appliance versions of the Calculator, Notepad, GeoDex, and GeoPlanner. Start an appliance by clicking the Appliance button on the Welcome screen.

application: A computer program that lets you do a particular kind of work, such as word processing or drawing. GeoWrite, GeoDraw, and GeoManager are just a few examples of applications.

Apply button: Applies the current settings in a dialog box without closing the box.

ASCII text file: A file containing only characters from the American Standard Code for Information Interchange 8-bit character set.

aspect ratio: Refers to the shape of the pixels on your monitor. Certain monitors, such as Hercules or CGA, have rectangular pixels instead of perfectly square ones. These monitors have a rectangular aspect ratio which elongates the image of your document, making it look stretched or squashed. Choosing Correct for Aspect Ratio from the View menu in GeoWrite and GeoDraw makes the document display in its proper proportions.

baud rate: The speed at which data is transmitted from a source to a destination, usually from one computer to another through a modem. When using modem applications such as GeoComm, the baud rate you set must match the baud rate used by the remote computer or service you connect to.

Cancel button: Cancels all changes made to the settings in a dialog box and closes the box.

carriage return: A carriage return is a non-printing ASCII character that moves the cursor or printer head back to the beginning of the line. On some terminals, an explicit line feed is also needed to move the cursor down to the next line, but there are other terminals which automatically generate a line feed with each carriage return. In GeoComm, set Auto Linefeed accordingly. See also line feed.

cascade menu: An additional menu that opens when you choose a cascade item from a menu. Cascade items on a menu are marked with a right-facing arrow.

Character Spacing: Command on the Sizes menu in GeoWrite that lets you adjust the spacing between characters, called kerning. The kerning on selected text can be made smaller or larger by choosing Character Spacing.
**check box:** A small square box used to turn options on and off in menus and in dialog boxes. Click a check box to turn it alternately on or off. The check box darkens when it's on. A check box can be turned on or off independently from other check boxes.

**cicero:** Unit of measure. Also known as a European pica, there are 5.63 ciceros to an inch.

**click:** To position the mouse pointer over an object or at a specific location and quickly press and release the mouse button. Clicking usually selects an object or places a cursor at the location indicated by the pointer.

**clipboard:** The holding area for what you last cut or copied. Items on the clipboard can be pasted into almost any GEOS document.

**CGA (Color Graphics Adapter):** One of the first display boards for the IBM PC. It has a maximum graphics resolution of 640 by 200 pixels with only two colors, and displays at most 80 columns by 25 lines of text.

**Control button:** The Control button appears in the upper left hand corner of a window. Clicking it brings up the Control menu which allows you to maximize, minimize, restore, and close the window. Double-clicking it closes the window.

**CR:** See carriage return.

**cursor:** A marker displayed on the screen that indicates the place where the next action will take place, often where the next character typed on the keyboard will appear. A cursor is often a blinking vertical line or a solid block. The mouse pointer is sometimes referred to as a cursor. Compare pointer.

**default button:** The default button in a dialog box is marked with a double border to indicate that it is the safest or most logical choice. You can press Enter to choose the default button.

**desk tool:** A GEOS application that is designed to do a small, highly specific task. These applications include the Preferences desk tool, the Calculator, the Notepad, and the Scrapbook.

**dialog box:** A box displayed by an application to display information or a warning, or to request you to provide information or set some options.

**dimmed:** Buttons and menu items that appear in grey instead of black, and cannot be chosen. There are some options and menu items that are not available until you first perform some other action; for example, the paste command is dimmed until you first cut or copy something.

**directory:** A listing of files and subdirectories that are stored together. Directories help to organize your files if you create a different directory to hold each group of related files.
Using GeoManager, you can display the directory structure of your disk as a tree, with subdirectories branching off of their parent directories. See also subdirectory, parent directory, root directory.

document: Whatever information you create, modify, view, or save with an application is called a document. All documents are files. See also file.

DOCUMENT directory: The directory where GEOS applications look for default documents, and where GEOS applications save documents unless you specify otherwise.

document safeguarding: Refers to GEOS updating a "working" copy of the changes you make to an open document but have not yet saved. This feature is provided so that if a power surge or outage occurs, very little of your work is lost. You can set how often GEOS safeguards your documents by using the Preferences desk tool.

DOS: Commonly used to refer to Microsoft Disk Operating System (MS-DOS), an IBM PC operating system. When you are in DOS, the DOS prompt appears at the left side of the screen indicating that the computer is waiting for input from you. The DOS prompt usually consists of the letter of the active drive, followed by a greater-than sign (>).

double-click: To position the pointer over an object or at a specific location and then click twice rapidly. Double-clicking with the left mouse button opens a file or a directory, or starts an application.

download: To transfer files or information from one computer to another, or from a computer to a peripheral device such as a printer. Use GeoComm to download files to or from your computer.

dpi (dots per inch): Unit used to measure the resolution of a printer. The more dots per inch, the better the resolution.

drag: To position the mouse pointer at a certain location, press and hold down the mouse button, move the mouse, then release the button. Dragging is used for moving and resizing objects, and also selecting a region or group of objects.

driver: A piece of software used to control communications between a computer and a peripheral device such as a printer, modem, or mouse.

EGA (Enhanced Graphics Adapter): A video display board capable of producing a high resolution monochrome or color display.

expanded memory: Memory in addition to the first 640K used by MS-DOS, that conforms to the Lotus-Intel-Microsoft Expanded Memory Specification (LIM EMS). GEOS usually detects and makes use of this additional memory. You
can also use the Preferences desk tool to make sure that GEOS knows that your computer has extended memory.

**Express menu:** The menu that lets you quickly switch between running applications, start any application, or exit to DOS. The Express menu button appears only on the active window.

**Extended memory:** Memory in addition to the first 640K used by MS-DOS, that is not readily accessible to MS-DOS or MS-DOS applications. GEOS usually detects and makes use of this additional memory. You can also use the Preferences desk tool to make sure that GEOS knows that your computer has extended memory.

**File:** A document or application that has been given a name. All GEOS documents are stored as files.

**File attributes:** A characteristic of a file, such as read-only or archived, which can be viewed and changed using GeoManager.

**File list:** A scrollable list that lets you open directories and files.

**FILENAME.EXT:** An example of the DOS format for filenames, where the filename can be up to eight alphanumeric characters, with an optional period and an extension of up to three characters. All DOS files and directories must conform to this format.

**Folder:** The icon that represents a directory.

**Font:** A graphic design for all the characters, numbers, and symbols in the alphabet. A font usually comes in different sizes and type styles such as bold or italic.

**Format:** (1) The appearance of the text in a document, including all tabs, line and character spacing. (2) To prepare a disk so information can be stored on it. Formatting a disk erases any information that may have been on it.

**Function key:** Any of the keys at the top of the keyboard, [F1] through [F10]. You can often use these keys to perform special actions, such as [F3] to exit.

**GEOS:** Pronounced “GEE-ose”, rhymes with “close.” A graphical environment operating system that lets you run applications and manage your disks by clicking and moving icons with your mouse. Provides windowing and multitasking. See also operating system.

**Handshaking:** The go-ahead signals that control the flow of information sent between two computers when using a communications program such as GeoComm. XON/XOFF is the standard handshaking method. See also XON/XOFF.

**Hercules Graphics Card (HGC):** A high resolution graphics card for monochrome displays.
**high density disk:** A disk that is capable of being formatted to hold more information than the standard low density disks. A 3 1/2-inch high density disk can hold 1.44M of data, and a 5 1/4-inch high density disk can hold 1.2M. A high density disk can also be formatted at low density.

**hourglass pointer:** The symbol that the mouse pointer changes to when you must wait for the computer to perform an operation.

**I-beam pointer:** The symbol that the mouse pointer changes to when you can use the mouse to place a cursor in text or select text.

**IBM AT:** Introduced after the PC and XT, with a new 16-bit data bus. Great performance from GEOS on this computer.

**IBM PC:** The original IBM personal computer, with an 8-bit data bus. GEOS runs.

**IBM PC-compatible:** A computer from a non-IBM manufacturer that can run the same software that the IBM PC does. GEOS runs on any IBM PC-compatible computer.

**IBM XT:** An improvement on the original IBM PC, but still with an 8-bit data bus. Good performance from GEOS on this computer.

**IBM PS/2:** The latest in IBM's personal computer line, with a 32-bit data bus. Expect great performance from GEOS on this computer.

**icon:** An image that graphically represents an object, a concept, or a message. Screen icons typically represent files, directories, and applications that you can select, open, or run.

**insert mode:** The normal mode for entering text. Characters are inserted after the cursor and the existing characters are moved over to make room for the new characters. Press [ins] to switch between insert mode and overtype mode. Compare overtype mode.

**insertion cursor:** A blinking vertical line that marks the place where the next character typed on the keyboard will be inserted; indicates that you are in insert mode. Compare overtype cursor.

**interrupt level:** A number indicating the importance of an interrupt (an electronic attention-getter sent to the microprocessor) that also indicates which device is interrupting and what device handler should be used.

**justification:** The horizontal placement of lines of text relative to the edges of the rectangle in which the text is drawn. Text can be left, right, center, or fully justified.

**kerning:** The spacing between two particular characters. The kerning on selected text can be made smaller or larger by choosing Character Spacing from the Sizes menu in GeoWrite.
leading: Pronounced “LEDD-ing”. The vertical spacing between the descending edge of one line of text and the ascending edge of the next line of text. You can adjust the automatic leading to be a multiple of the font size, or you can set manual leading to be a fixed measurement. Choose Paragraph Spacing from the Paragraph menu in GeoWrite. Compare line spacing.

line feed: A line feed is a non-printing ASCII character that moves the cursor or print head down to the next line. Some terminals automatically generate a line feed with each carriage return. In GeoComm, set Auto Linefeed accordingly. See also carriage return.

LF: See line feed.

LIM-EMS: See expanded memory.

line spacing: The vertical distance between two lines of type measured baseline to baseline. Set your line spacing on by clicking the appropriate icon on the ruler in GeoWrite. Compare leading.

low density disk: A $3\frac{1}{2}$-inch low density disk can only hold 720K of data, and a $5\frac{1}{4}$-inch high density disk can only hold 360K. A low density disk can only be formatted at low density; it is not capable of being formatted at high density.

managed extended memory: Memory in addition to the first 640K used by MS-DOS, that is managed by a program. A program, often named HIMEM.SYS, controls how the extra memory is used. GEOS can make use of this additional memory if you use the Preferences desk tool to indicate that your computer has managed extended memory.

maximize: To expand the active window to fill the whole screen. Maximize a window by clicking the Maximize/Restore button in the upper right hand corner that contains a big rectangle, or choose Maximize from the Control menu.

menu: A list of commands or choices grouped under a single name.

menu bar: A horizontal bar near the top of a window, displaying the names of all the menus of an application.

minimize: To shrink the active window to an icon on the workspace. Minimize a window by clicking the Minimize button in the upper right hand corner that contains a tiny square, or choose Minimize from the Control menu.

mnemonic: A combination of keystrokes that quickly chooses a command from a menu without using the mouse.

modem: A peripheral device that links your computer to other computers and information services using the telephone lines.

Motif: A user interface standard developed and promoted by the Open Software Foundation. See also user interface.
MS-DOS: See DOS.

multitasking: A process that allows a computer to perform two or more tasks during a given period of time. This makes it possible for the user to open and run many applications at the same time.

nonbreaking space: The ASCII character that looks like a space but acts like a nonblank character for the purposes of word wrap and selection.

OK button: Applies the current settings in a dialog box and closes the box.

on-line: Currently connected to and under the control of the computer. Used to refer to equipment such as printers and disk drives, information storage media such as disks, and the information they contain. Also refers to information services you connect to.

operating system: (1) A program that organizes the actions of the parts of the computer and its peripheral devices. (2) Low-level software that controls a computer by performing such basic tasks such as input/output, memory management, and interrupt handling.

optional hyphen: See soft hyphen.

overtype mode: An alternate method of entering text. Like a typewriter, any character you type replaces any existing character under the cursor. Press ins to switch between insert mode and overtype mode. Compare insert mode.

parent directory: For any given directory, the directory in which it is contained. In other words, the directory immediately above the given directory in the hierarchical tree.

pathname: The complete name of a document beginning with the name of the disk, the names of any subdirectories it may be in, and the name of the document. Backward slashes (\) separate all the parts of a pathname. It’s called a pathname because it describes the route to the document. For example, C:\GEOS\DOCUMENT\Letter_to_Mom is the pathname for the file Letter_to_Mom in the DOCUMENT subdirectory of the GEOS directory on drive C.

PCX File Format: The file format for images created with PC Paintbrush. GeoDraw can import .PCX files.

peripheral device: An additional piece of hardware used with a computer. Peripherals include printers, video monitors, disk drives, and modems.

pica: Unit of measure. There are 6 picas to an inch.

pixel: Short for picture element, pixels are the small dots that make up your screen.
point size: The height of a printed character in points. There are 12 points to a pica, and 72 points to an inch. Font sizes are given in points.

pointer: A small shape on the screen that follows the movement of the mouse. Usually an arrow, the pointer can also be an hourglass, an I-beam, or crosshairs.

press: To hold down the mouse button. Used in the action of dragging to resize or move objects, or to select objects.

print spooler: A program that tracks of all the documents you have printed, and feeds them to the printer.

Professional Workspace: An electronic “desktop” where you can work with powerful GEOS applications such as GeoWrite, GeoDraw, GeoPlanner, and many others.

push-pin: An item at the top of a menu that allows the menu to be “pinned” so it stays open and can be moved around the workspace.

quick copy: To quickly copy a text selection by positioning the pointer over the selection, holding down the right mouse button, moving the pointer to the location where you wish to insert the text, and releasing the mouse button. Does not work in GeoDraw.

quick move: To quickly move a text selection by positioning the pointer over the selection, holding down the right mouse button and the [Alt] key at the same time, moving the pointer to the location where you wish to insert the text, and releasing the mouse button. Does not work in GeoDraw.

radio button: A small diamond button (on EGA or VGA monitors) or a small round button (on monochrome monitors) used to turn options on and off in menus and in dialog boxes. Click a radio button to turn it alternately on or off. The radio button darkens when it’s on. Just like the preset radio station buttons in your car, only one radio button in a group of radio buttons can be on at one time.

read-only: A file attribute that protects a file from being modified. A read-only file can only be viewed, and any changes to the file will not be saved by the computer. You can use GeoManager to turn a file’s read-only attribute on or off.

Reset button: Resets the settings in a dialog box to their original values without closing the box.

restore: To return the active window to its previous size after you have enlarged it to fill the whole screen. Restore a window by clicking the Maximize/Restore button in the upper right hand corner of the title bar, or choose Restore from the Control menu.

Revert: Command that lets you drop all the changes you have made to a document but haven’t yet saved. Choosing Revert from the File menu causes the document to change back to the version you last saved.
**RGB**: Stands for Red, Green, Blue. Combining different intensities of these three color signals creates all the colors available on your display. You can create custom colors by specifying different intensities of red, green, and blue.

**root directory**: The first-level directory of any disk. The root directory is created when you first format a disk, and then you can create files and subdirectories in it. The symbol used to specify the root directory is a backward slash (\).

**safeguarding**: See document safeguarding.

**Save**: Command that makes permanent all the changes you have made to a document. Choosing Save from the File menu causes the current version of a document to be recorded on disk.

**Save As**: Command that lets you save the current version of a document under a different name. This new document is kept open so you can continue editing.

**scroll bars**: The bars that appear at the right and bottom edges of a window. A scroll bar contains scroll arrows you can click to scroll your view up or down in small steps, and a slider against a grey paging area to represent where you are in relation to your entire document.

**select**: To highlight objects or text in order to indicate the items your next action should affect. You usually select items by clicking on them or dragging a selection box around them.

**selection**: The highlighted objects or text that will be affected by your next action.

**soft hyphen**: A special hyphen character that prints only if it breaks a word at the end of a line; otherwise, it is invisible. You can place a soft hyphen in a word by typing [Ctrl]+-. The soft hyphen remains invisible unless the whole word won't fit at the end of a line.

**software**: A collective term for the programs and applications you run on a computer.

**spacing**: See line spacing or character spacing.

**style**: A set of stylistic variations applied to text. Styles include bold, italic, underline, and other variations. More than one style can be applied to a single selection of text. Text with no style variations applied is called plain text.

**subdirectory**: A directory contained within another directory.

**tab**: An automatic stop that you set in a word processing application to create columns for tables. There are four types of tabs: right justify, left justify, center justify, and decimal.
**text cursor:** A marker indicating where the next character you type on the keyboard will appear in the text. The insertion cursor and the overtype cursor are both examples of a text cursor. See **insertion cursor** and **overtype cursor**.

**text field:** An area in which you can enter and edit text. In dialog boxes, the small boxes you can type in are text fields.

**text file:** See **ASCII text file**.

**TIFF:** A graphic image file format, often used for image scanner output. Short for Tagged Image File Format. GeoDraw can import .TIF files.

**title bar:** The horizontal bar at the top of a window containing the name of the window. On many windows, contains the name of the application and the open document where applicable. Also contains the Control, Express, Minimize, and Maximize/Restore buttons.

**track kerning:** Adjusts the character and word spacing uniformly over a range of text. The kerning on selected text can be made smaller or larger by choosing Character Spacing from the Sizes menu in GeoWrite.

**TSR software:** Short for terminate-and-stay-resident, these are programs loaded into memory that stay available for use even when another application is active. Some examples of TSR's are screen blankers, Sidekick, and some disk caching routines. GEOS is not able to run with some TSR's. If you have trouble with GEOS and you also have TSR's running, try removing the TSR's from your AUTOEXEC.BAT or CONFIG.SYS files, reboot, and run GEOS again.

**UI:** See **user interface**.

**Undo:** Command on some Edit menus that allow you to undo your last editing change such as a cut, paste, delete, or style change. You must choose Undo immediately after you make the change you want to undo; if you have done some typing or other action since then, Undo will not be available.

**user interface:** The entire set of rules and conventions by which the computer system communicates with the user. May change with different software. For example, GEOS uses the Motif user interface.

**VGA (Video Graphics Adapter):** A graphics card that works with either a color monitor or a black-and-white gray-scale monitor. IBM's primary graphics standard for the PS/2 line of machines.

**volume label:** The name you give a disk to identify it. You can change the volume label on a disk by choosing Rename Disk from the Disk menu in GeoManager.
**Welcome screen:** The screen that first greets you when you run GEOS. From the Welcome screen, you can decide to work with the Appliances, DOS programs, or the Professional Workspace.

**window:** A rectangular area on your screen in which you view an application or a document. Most windows can be moved, resized, and shrunk to an icon.

**workspace:** The background area on top of which all the windows appear in the Professional Workspace. You can move windows around anywhere on the workspace.

**XMODEM:** A file transfer protocol used to send and receive files in discrete packets. XMODEM checks for transmission errors after each packet is sent and received.

**XON/XOFF:** A communications protocol that tells a computer to start or stop sending data by sending either an XON or an XOFF, which are ASCII characters.
A

A drive 40, 84
See also floppy disk
abbreviations for units of measure See measurements
ABORT label 389
acceleration, mouse See mouse accelerators
access (phone) code 300, 305, 372, 390
accident
changes See saving, automatic
damage to something important 6
actions
box 66
See also buttons, commands, and tasks
active
directory 122, 125-126
windows 46-47, 87, 363
actual size 167
adding
borders See borders
buttons 448
cards (address) 298-300
column breaks 280
footers See footers
headers See headers
items to a group 93, 121
to a selection 121
memory 410
objects to a selection 182
to calculator memory 414
page breaks 278
people to the address book 298
to number in memory (calculator) 417
to scrapbook 435
Address area 297
Address book 41, 295
appliances 32
cards 296-301
printing See printing
saving See saving
See also GeoDex
adjusting
hardware options See preferences
desk tool
range 98-99
software options See preferences
desk tool
text selection 101
alarm (in GeoPlanner) 331-332, 353
align
left/right 250
ruler with page (command) 284
alternating left/right margins 270
always
off modem setting 370
on modem setting 370
a.m. (in appointment times) 328
angle brackets 388
ANSI terminals 368
appearance, button 446
Applications 4, 22-23, 27-33
applications 41-42
definition of 24, 39
DOS See DOS
e enlarging 74-76
exiting See exiting
file 385
fonts and keys See fonts
maximizing 76
minimizing 75
names of See names
removing from memory See exiting
restoring (from enlarged size) 76
restoring (from icon) 75
shrinking 74-75
starting 46, 72-73, 133-134
switching between 45-46, 74, 134
using 72-76
See also Professional Workspace
Apply button 67, 69, 364
applying color 202
appointment 324
See also GeoPlanner
architectural drawing 41
archive files 129, 144
area
address 297
code 297
properties box 195
arranging objects within a stack 210-211
arrow
down See down arrows
keys See cursor movement keys
paging See paging
pointer See pointer
right-facing (menu) See cascade
menus
scroll See scrolling
up See up arrows
See also next and previous
ASCII files See DOS text files
Ask for Options Each Time 446
aspect ratio 167, 231-232
assigned printer 405
AT machine (286 or 386) 411
attributes
DOS file See changing
tab See tabs
auto linefeed 369
AUTOEXEC.BAT files 424
automatic
blanking of screen 408-409
log on to information service 387
page numbering 230, 277
paragraph spacing See leading
phone dialer See dialer, phone
saving See saving
automating communications sessions 361
automobile phone number 297
auto-repeat action of mouse button 17
available printers, list of See list

B

B drive 40, 84
See also floppy disk
background
workspace 39, 397-399
backslash (\) 118
Backspace key 7, 69, 96, 234
bar
horizontal scroll See scrolling
information 116
menu See menu bar
scroll See scrolling bar
title See title bar
vertical scroll See scrolling
.BAT file extension 429, 444
batch files See files
baud rate 367, 389, 407
beep sound 65, 389
beginning of
column (adj ust to) 101
column (select to) 100
communications session See starting
GeoComm
line (adjust to) 101
line (delete to) 101
line (move to) 100
line (select to) 100
page (adj ust to) 101
page (select to) 100
paragraph (adj ust to) 101
paragraph (select to) 100
session See starting GeoComm
text (move to) 100
word (delete to) 101
word (select to) 100
BELL command 389
bell icon 331
binary files 382, 385
birthdays See repeating events
bits
data See data bits
stop See stop bits
black
and white monitors See monochrome monitors
background with white text 266
blank address card 296
blanking, screen See screen
blinking vertical line See text cursor
block cursor 96
body of document 230
bold text 238
borders
colored 263
corner See corner border
creating for text See creating horizontal See horizontal border
resizing 45-46, 363
text See creating
thick See thick border
vertical See vertical border
Both View 309, 351
boxes
action 66
check See check box
dialog See dialog box
information 66
properties See properties boxes
question 66
warning 66
brackets, angle 388
brand
modem See modem
mouse See mouse
printer See printer
breaks
column 280
page 278
browsing
through address book 307-308
through menus See menus
through scrapbook 436
View 307-308
buffer, scroll-back 376-379
bullet
hollow 234
bulletin board services, communicating with See GeoComm
burning in 409
busy pointer See hourglass pointer
buttons 12
appearance 446
Appliances See Appliances
Apply See Apply button
Cancel See Cancel button
C/CE 414, 421
Change disk See changing
Change Options See changing
Changing 447
Close See Close button
Close Directory See directories
Control See Control button
creating See creating/new, buttons
Default See Default button
delete 413
deleting 447
Dial 297
dimmed See dimmed buttons
directory See directory, Document, and World
Document directory See Document directory
DOS file for 446
DOS Programs See DOS Programs
Drive 117
Enter (on calculator) 420
Exchange (on calculator) 420
Exit See Exit button
Express See Express button
floppy disk See floppy disk
full-sized 118
groups of See radio buttons
hard disk See hard disk
Help See help
light grey See dimmed buttons
Maximize See Maximize button
Minimize See Minimize button
mouse 13-18, 403
name on 445
Next Card See address book
Next Day See next
Next Page See paging
No See No button
OK See OK button
overlapping 118
paging 20-21
picture on 445
preferences 397
Previous Card See address book
Previous Day See previous
Previous Page See paging
Professional 24
push 67
radio See radio buttons
Reset See Reset button
Restart See restart
Restore See Restore button
settings 445, 447
Stop See Stop button
Up Directory See directories using 448
with ellipses See ellipses
World directory See World directory
Yes See Yes button
bytes free/used (number of) See number of

C

c drive 40, 84
See also hard disk
calculator
appliance 31
desk tool 413-423
calendar 33, 327
only view 350
printing See printing events
window 324
See also GeoPlanner
Cancel button 67, 69, 71, 383, 385
canceling
move operation 140
quick copy/quick move 106
capturing
status window 381
text 380-381
car phone number 297
card
address See address cards
view 307-308
carriage return 369, 375
cascade menus 57-59
c/ce button 414, 421
center
justification See justification
tab See tabs
text 249-250
centimeters (cm) 70, 244
CGA graphics monitors 167, 231-232
change bars See vertical lines
changing
active directory 125-126
address cards 302
alarm settings 332
AUTOEXEC.BAT files 424
background 397-399
buttons 447
calculator options 419-420
color space 241-242
colors 89, 195-202
computer options 397, 410-411
date 397-398
day shown on calendar 33
default scrapbook 439
directories 78-79
disks 84
documents See editing and saving
DOS file attributes 144-145
drives 78-79
events 328, 335-336
file 446
font for text 203-204, 238-240
GeoManager options 154-155
GeoPlanner preferences 352-353
GEOS internal options 397, 412
interrupt levels 411
line color 197-198
line spacing 250
line width 197-198
look and feel 397-399
margins See margins
modem port, speed, and protocol 397, 407-408
monitor 397
month shown on calendar 33
mouse 397, 401-403
names in address book 298
number of pages to print 108
options button 110
page setup 270-272
paper size/source 108-111
paragraph margins 248
paragraph spacing 253
pattern 197-198
picture 445
port for printer 397
print quality 108
printers 107-111, 397, 403-406
programs 445
repeating events 335
safeguard interval 397-399
screen blanking interval 397
selections 69
settings for buttons 447
sign in calculation 414
size of text in menus/dialog boxes 397-399
size of view 166-167, 231
size of window 364
styles 195-202
text font 203-204
text justification 208-209
text size 204-207, 240-241, 425
text style 207, 242-243
time 397-398
type of monitor 409
video options 397, 408-410
viewing options 128, 350
width of line 197-198
window size 364
workspace background 397-399
year shown on calendar 33, 324-325
characters
writing See characters
Copy See copying
deleting See deleting text
drawing See drawing
ing See entering text
height 240
selecting within a text object 183-184
spacing 238, 241-242
special 234
See also text
check box 53-55, 68
Checksum 385
CHKDSK.COM command/file 446
choosing
an Application 29
commands See commands
fonts 239
from menus 55-60, 62-64
See also buttons, dialog box, and selecting
ci (abbreviation for ciceros) See ciceros
ciceros (ci) 70, 244
circle
drawing 174-175
pointer 13
slash symbol 65
tool 169, 174-175
cleaning up documents 43
clearing
command 389
memory 417
numbers displayed on calculator 414, 421
Search For text 310
tabs 246
clipping 14, 16, 55-56, 397, 401-403
Clipboard 103-105, 194, 268, 319-320, 361
sending contents of 374-375
clock, computer's built-in 397
Close button 21, 67
closed shapes 172
closing
dialog box See dialog box
directories See directories
documents See documents
GeoManager 156
help 21
menus 56
notepad document 430
pinned menus 61
properties boxes 197
Show Line Status window 386
toolbox 166
windows 45-47, 52, 76
See also exiting
cm (abbreviation for centimeter) See centimeter
code
access See access code
area See area code
zip See zip code
collapsing
all directories within a branch 152-153
directories in tree See directories
window to an icon 46
collate 108, 217, 286
colors (in scripting language) 388
color 172, 179, 195-202, 238
and monochrome monitors 263-264
changing See changing
monitors 54-55, 196
using in GeoWrite 263-267
columns
adjusting to 101
breaks between 280
data See data tables
maximum number of in GeoComm window 364
number of on page 270-272
selecting 100, 235
working with 279-280
.COM files 444
COM1 to COM4 404
COMM command 389
command line options 445-446
Index

commands
Align Ruler with Page 284
BELL 389
CHKDSK.COM 446
choosing 18, 53
CLEAR 389
Close See closing
COMM 389
Copy See copying
Custom Borders See custom
Cut See cutting text
Delete See deleting
DIAL 389
DOS See DOS
Draw Graphics 284
Duplicate See copying
ingesting 236
END 390
Exit See exiting
file menu 85
Full-Sized See full sized
GOTO (line) 390
GoTo Page See GoTo Page
command
listing See menus
MATCH 390
More Fonts See More Fonts
command
Move See moving
new See documents
Next Page See paging
Open See opening
Overlapping See overlapping
Page Setup See page
Paste See pasting text
PAUSE 391
PORT 391
Previous Page See paging
PRINT 216-218, 285-287, 392
PROMPT 390
PULSE 392
Redraw See Redraw
Revert See Revert command
Save See saving
Save As See saving
script 388-392
SEND 392
Size See size
Snap to Ruler Marks See Snap to
Ruler Marks
TERM 392
commas (in phone numbers) 300, 372
common events, setting 336-337
communication
port See port
session See GeoComm
composing messages off-line 374-375
compressing
directory display 132
text 241-242
computer
date 397
internal options 397, 410-412
memory 397
time 397
concentration of color 201, 263, 265
configuration
mouse 402-403
system See preferences desk tool
printer 396-412
Confine Search 310
Confirm
Deletes option 142, 154
Read Only 154
Replace 154
connected line tool 169, 172-174
contents
displaying for disks/directories See
displaying
continuous mouse action 17
Control
button 45, 53, 65
key (Crl!) 7
menu 45, 76
controlling multiple documents See
multiple documents
copies
number of 108, 217, 286
temporary working See saving,
a automatic
copying
between scrapbooks 440
disks 148-149
documents See documents
files 91, 137-142
graphics from GeoDraw into
GeoWrite 268-269
notepad document text 431
numbers from calculator 417-418
objects 192-193
scraps 435
tabs See tabs
text 30, 103-106, 236, 354-355, 374-
381
to disk See saving
copyright symbol © 234
corner border 50
correcting
for aspect ratio See aspect ratio
See also changing
counters
error 386
reset on Show Line Status window
386
Courier font 238
CRC (Cyclic Redundancy Check) 385
creating/new
batch files 450-453
borders for text 259-261
buttons 441, 444-446
directories See directories
documents 41, 77-78
DOS files 424
hanging indents 249
images 169-180
notebook document 430
scrapbook 438
script 388
tables 262
title pages 273-274
CR/LF option 375, 381
crosshairs 171, 254
Ctrl key See control key
current
directory 122
disk 83
document 86
page See paging
pathname 84
screen 363
cursor
blinking See text cursor
block, solid 96
dotted selection 70
flashing (text) 95
hollow 363
insertion 102
movement keys (arrows) 62, 96
overtype 102
solid block 96, 363
text See text
See also pointer
curved pointer 171
custom
borders 259-261
calculator options 419-420
colors 263
GeoPlanner features 352-353
line spacing 252
paper size 110
text font 204

Appendices, Glossary, and Index
text size 206-207, 241

cutting
  between scrapbooks 440
  notepad text 431
  numbers from calculator 417-418
  objects 194
  scraps 435
  text 30, 41, 103-106, 319-320, 354-355
  See also pasting text

Cyclic Redundancy Check (CRC) 385

cutting through options 68

daily schedule 327-330

damaging important information 6

dark
  concentration of color 267
  outline  See outline

dash, cm 234

dashed lines 197-198

data
  bits 367, 389
  files  See documents
  See also information

date
  book  See GeoPlanner
  computer's internal 397
  event  See events
  last modified  See sort by
  today's  See today's date

days
  empty 353
  last 334
  month for events 334
  range of  See range
  template 352
  week for events 334

decimal
  places to display in calculator 419-420
  tab  See tabs

decision  See choosing and dialog box
decreasing
  numbers 68
  See also enlarging
decrementing numbers  See decreasing

default
  alarm time 353
  button 66, 68

choice for dialog box 19

column width 279

document 77-78

default alarm time 353

doi ntr ead er 275

d校外 monitored, No 117, 142-143
description of event 334
deselecting items 90-94, 121
desktop
  calculator 31
  calendar 33
  electronic 35
destination
  directory  See directories
  disks  See disks
details, names and  See names
dial
  button 297
  command 389
  menu 571, 387
  quick  See Quick dial

dialer, phone 32, 296

dialing
  option window 300
  options 305-306

phone numbers 303-307

dialog box 19, 38, 65-71, 364
  size of text 397-399

diamond-shaped markers 55
differences between GeoWrite and
  Notepad

different document, file, disk, directory
  See changing
dimensions (paper size) 110

dimm'd (light grey)
  buttons 21
  menu options 53, 55

direct manipulation 14, 18
directories
  active  See active
  changing  See changing
  closing  84, 126-127
  collapsing in tree 151-153
  compressing display 132
  copying  137-142
  creating  136-137
  current  See current
  definition of 118
  deleting  See deleting
destination 80-81, 84, 137
  displaying contents of 39
  Document  See document
  DOS 444
  duplicating  See duplicating
  expanding in tree 151-153
  get information about 145-146
  list of 122
  managing  See managing
  moving 137-140
  opening  See opening
  parent  See parent directories
  pathname 116-118
  previous 117
  renaming  See renaming
  root 118, 151
  selecting  See selecting
  sequence of contents 130-131
  source 137
  tree 151-153
  Up button 78-79, 84, 117, 124
  WORLD 39-42

disks
  changing  See changing

Index
Index

copying 148-149
copying to See saving
current 83
destination 148-149
displaying contents of See displaying
drive See drives
duplicating 148-149
floppy 39
formatting 147-148
hard 39
lists of 83
managing 147-150
menu 147, 149-150
name 147
RAM/ROM 117
renaming 149-150
source 148-149
displaying
contents of disks/directories 39-40, 84, 132
data See setting, terminal
decimal places in calculator 419-420
directory tree for another disk 153
Help 21
information See windows and get info
memory 414
menus 45
progress of scripts 387
documents
body See body of document
changing See editing
cleaning up 43
closing 82-83, 88, 221, 291
copies of 79
copying See copying and editing
creating 41, 77-79
current 86
default 77-78
definition of 41
deleting See editing and deleting
directory 39-42, 72, 79-84, 118-123, 226
editing 41
footer See footers
GEOS 382, 425
header See headers
listing See files
managing 39-40
moving See editing and moving
multiple 86-88, 212-213, 425
naming 80-81, 136, 219, 348
new/untitled 77-79
opening See opening
pages (moving between) See paging
printing See printing
recovering last version of 82
safeguarding See saving, automatic
saving See saving
selecting 78-79
side-by-side 213
single 425
size 347
switching See switching
windows 77-88
working with 77-88
See also starting
DOS
applications 25, 214-215
commands, invoking 25, 113
exiting See exiting to DOS
file attributes See changing
file for buttons 446
files 40, 117, 290, 369
naming conventions 117, 136, 429
Programs area/button/screen 4, 23, 25, 135, 441-453
returning to See returning to DOS
starting GEOS from 11
text file 290, 373, 382, 375-376, 424
See also saving
dotted leader line See tabs
margin lines 164
outline 186, 279
selection cursor 70
double
clicking 16-17
spacing See leading
down arrows 67-68
draft (text only) 108
dragging 55-57
day on the calendar 329
group of items 91-92, 120
item on the screen 18, 138
multiple items See dragging, a
group of items
objects to move 185-191
objects to select 182-183
option, setting 18187
range of text 96-97
resize borders 47, 363
tabs See tabs
text to select 235
title bar 45, 47
to wastebasket See deleting
See also moving
drawing 41
application See GeoDraw
area 164
circles 174-175
connected lines 173-174
graphics (command) 284
inner lines (for borders) 261
lines 172-174
polygons 176-177
rectangles 175-176
vertical lines with a tab See tabs
drives (disk) 40
changing See changing
displaying contents of 117
duplex setting 368, 389
duplicating
command 89, 91
directories 141-142
disks 148-149
files 141-142
See also copying
earlier alarm 331
edges
window 49
See also borders
editing
batch files 135, 450-453
documents 41
DOS files 424
footers 275-276
headers 275-276
menu 104, 236, 418
text 68-69, 95-102, 179, 203-209, 236-237
See also cutting, copying, pasting, and changing
editor, text See notepad
EGA monitors See monitors and color electronic
datebook See calendar
desktop See Professional Workspace
mail message 373
ellipses 67
elongated image See aspect ratio
em dash 234
empty days, showing 353
end

column (adjust to) 101
column (select to) 100
command 390
key 100-101
line (adjust to) 101
line (delete to) 101
line (move to) 100
line (select to) 100
page (adjust to) 100
page (select to) 100
paragraph (adjust to) 101
paragraph (select to) 100
task in progress See Stop button
text (move to) 100
time for template 353
word (delete to) 101
word (select to) 100

enlarging
applications See Maximize button
windows See Maximize button
See also magnification

entering
button (calculator) 420
characters See entering text
date 398
DOS 25
DOS Programs screen 443
measurements 70
phone numbers 371
professional workspace See professional workspace
special characters 234
text 30, 69, 95-102, 178-180, 234
time 398
See also starting
ep (abbreviation for European points) See European points
erasing See deleting
error
checking 367, 385, 386
indicator 415
Escape (Esc) key 69, 71
European points (ep) 70, 244
events—33, 325-330
common 336-337
only view 350-351
printing See printing
repeating 333-342
searching See searching
window See windows
See also GeoPlanner
exchange button (calculator) 420
.EXE files 444

exiting
Appliances 29
applications 76, 88
button 23, 26
desk tools 395
DOS 25
DOS Programs screen 443
GeoComm 362
GeoDex 295
GeoManager 156
GeoManager 323
GEOS to DOS 23-26, 43-46
GeoWrite 226
Help 21
Professional Workspace 24, 43-44
expanding
all directories within a branch 152-153
directories in tree See directories
level of directory 152
memory 411
text 241-242
Express button/menu 43, 45, 53, 73, 161, 357
extending memory 411
extension, file See files, extension

F

F2 key 44
fast mouse See mouse
FAX phone number 297
feel, look and 397-399
field
index See index field
text See text field
files
application See application
archive See archive
attributes (DOS) See changing
.BAT 444
batch 135, 429, 441, 450-453
binary See binary
CHKDSK.COM 446
.COM 444
copying 137-141
data See documents
deleting See deleting
DOS See DOS
duplicating See duplicating
.EXE 444
extension 40, 117, 136, 429
GEOS 40, 117
get information about 145
hiding See hiding
icon 117
importing See importing
lists of 78, 83-85, 444
managing See managing
menu 77-89, 107, 145, 214, 348
moving 137-140
name of 117, 136
number of See number of
on disk drive 40
opening See starting
PC Paintbrush 214
read only See read only
receiving See GeoComm
renaming See renaming
selecting See selecting
sending See GeoComm
show new (update directory display) See rescaning drives
system See system
text See text and DOS
TIFF 214
filling in
objects with color/pattern 199-200
text fields See entering text and text field
Find
address card for name in Events window 356
Next (address card) 309
See also searching
flashing text cursor 95
flipping
between address cards 32, 301
between pages See paging
objects 190
floppy disk
buttons 39, 84, 117
flow control 367
folders 40, 78, 117
See also directories
fonts
and keys application 234
choice of 425
definition of 238
menu 239
more (command) See More Fonts
option 203
print 107

481
<table>
<thead>
<tr>
<th>Index</th>
</tr>
</thead>
</table>

sizes of 238-241, 365  
standard 203-204  
text 203-204, 238-240  
footers 230, 275-277  
forever (continuous event) 334  
formatting  
date 398  
disks 147-148  
instructions 225, 424  
options 425  
page See printing  
text 238-243  
time 398  
frame error 386  
freehand object rotation 189  
freeing up memory 72  
See also exiting  
frequency of event 334  
full  
duplex 368  
justification See justification  
sized button/mode/command 86-87, 118, 122-123, 229, 281  
year on calendar 326  

GoTo  
line command 390  
page command 231-232, 273, 281, 434  
Graphical  
program launcher See DOS Programs screen  
User Interface (GUI) 37  
graphics  
application See GeoDraw  
drawing 284  
inserting 268-269  
monitors See monitors  
sharing 103  
grey/grey  
buttons See dimmed buttons  
ruler See ruler  
text See halftones  
groups  
of buttons See radio buttons  
of days on calendar 329  
of items, selecting See selecting  
GUI (Graphical User Interface) 37  

graphics 269  
portions of document 51  
toolbox 164  
high-density disks See disks  
highlighted  
days See events  
document names 78  
menu items 56  
selection See selecting  
text (reverse color) 96, 235  
title bars 47  
HIMEM.SYS file 411  
hints See tips  
holding down mouse buttons See pressing  
hollow  
bullet 234  
cursor See cursor  
home  
key 100-101  
phone number 297  
horizontal  
border 50  
scroll bar See scrolling  
hourglass pointer 13  
how to  
exit GEOS 26  
start GEOS 11  
use manual 6-7  
use mouse 13-18  
H-P calculators See Hewlett-Packard calculators  
hyphen, soft 234  

H  
half duplex 368  
halftones 264, 266-267  
See also colors  
halting See canceling  
handles, object 170  
hanging indents See indents  
hanging up the phone 372  
hard disk  
button 39, 117  
hardware options, adjusting See preferences desk tool  
harming your computer 24  
Hayes-compatible modem See modems  
headers 230, 275-277  
heavy outline 10, 33  
height  
character See character field (paper size) 110  
Help button/window 20-21, 23  
Helvetica font 238  
Hercules graphics monitors 167, 231-232  
Hewlett-Packard calculators 419  

I  
i box 66  
l-beam pointer/tool 13, 171, 178  
IBM3101 terminals 368  
icons 3, 39-40  
collapsing windows to See Minimize button  
definition of 40  
file 117  
folder 117  
moving 75  
restoring applications from 75  
viewing contents of directory as 128  
wastebasket See wastebasket  
images  
creating 169-180
definition of 169
importing See importing
preview area 214
importing
images (from DOS application) 214-215
in (abbreviation for inches) See inches
inches (in) 70, 244
compared to other units of measure 244
increasing
numbers 68
See also enlarging
incrementing numbers See increasing numbers
indents 245-249
index
field 297, 307, 310
tabs (letters for address cards) 301
information
bar 116
box 66
displaying See dialog box, screens, and windows
services, communicating with See GeoComm
insert
key (INS) 101-102
mode 101-102
inserting
graphics 268-269
leaders 254
page breaks 278
page numbers 277
text 236
installed printers, list of See list
installing
GEOS 1
printers 404-405
instructions, how to use 7
interface See introduction to GEOS and Motif
internal
computer options See computer
date 397
fonts (print) 107, 286
GEOS options 397, 412
hardware options 397
time 397
interpreting data See setting, terminal interrupt
file transfer 385
levels 410-411
interval
between template entries 353
saving See saving, automatic screen blanking 397, 408-410
introduction
to GEOS 1-5
to this manual 6-7
italic text 238
item order (sorting in directory) See directories

J

justification
settings 229
text 208-209, 249-250, 425

K

keyboard
accelerators 61-62, 236
editing 99-102
navigating with 62-64
using to respond to dialog box 70-71
keys
application See fonts
arrows 62
Backspace 7
calculator 31
Control (Ctrl) 7
cursor movement 62
Escape (Esc) 69
F2 45
fonts and (application) See fonts
groups of 7
how represented in this manual 6-7
plus (+) 7
Shift 7
See also buttons

L

labels
mailing See mailing labels
scripting language 388-392
LAN device 40, 117
landscape orientation setting 168, 270
language
scripting 388-392
translator 368
large font 365
last
modified, date/time See sort by saved version of document, recovering See Revert command
layout of document See page setup
leaders, inserting tab 254-255
leading 251-253
leaving See exiting
LED display See Calculator left
justification See justification margin See margins
mouse button 13-14
tab See tabs
legal-sized pages 271
length of
document 51
file name 80, 117
names See names
slider 51
letter 41
as mnemonics 62
sized pages 271
tabs (for addresses) 32, 296, 301
light grey buttons See dimmed buttons
lightening colors See concentration of color
linefeed
auto 369
required after carriage return 375
lines
adjusting to 101
color of 197-198, 263
deleting 101
drawing 172-174
indents See indents
maximum number of in GeoComm window 364
properties box 195
selecting 98, 100, 235
spacing settings 229, 250
status 386
tool 169, 172
vertical 256-257
width of 197-198
linking
GeoDex to GeoPlanner 317-318, 356-357
Index

magnification levels 166-167, 231
mailing labels 313
making changes See changing
managing
directories 39, 136-146
disks 39, 147-150
documents 39
extended memory 411
files 136-146
windows 53
See also GeoManager
manipulation
direct See direct manipulation

of objects 169
manual
how to use 6-7
paper feed 110, 287
paragraph spacing See leading
margin
changing 247-249
lines 164
markers See ruler
paragraph 248
setting 270-272
match command 390
Maximize button 45-46, 74-76, 87, 229
maximum
number of lines in GeoComm
window 364
resolution (print) 108
speed of transmission 367
measurements
abbreviations for units of 70
entering 70
units of 70
meeting, scheduling on calendar See events
memory
adding number to 417
calculator 414
clearing calculator 417
computer 397, 410-411
freeing up if system is slow See exiting
loading into from disk See starting
recalling from calculator 417
remove from See exiting
storing documents in See saving
storing numbers displayed in calculator 417
using calculator 416-417
menus 5
bar 45, 53, 398
browsing through 18, 56, 62-64
cascade See cascade menus
choosing from See choosing from menus
closing See closing
Control See Control menu
definition of 53
dial See dial
disk 147
Edit See editing
Express See Express button/menu
File menu See File menu
Fonts See fonts
Modify See modifying
name 45, 53
navigating with keyboard 62-64
Open from the File See Open from the File
opening See opening
Options See options
pinning See pinning menus
Quick 330
ruler 254
sample 53
secondary See cascade menus
size of text in 397-399
sort by See sort by
styles 243
text See text
using 53-64
Utilities See Utilities
View See viewing
Window See windows
messages, electronic mail See electronic mail messages
middle mouse button 13-14
millimeters (mm) 70, 244
Minimize button 45-46, 74-76, 133, 155
minus (-) sign 151
mm (abbreviation for millimeters) See millimeter
mnemonics 62-64
model See brand
modems 300, 303, 366
options, changing 407-408
port 367, 397, 407-408
protocol 397, 407-408
settings 369-370
speaker 370
speed 397, 407-408
See also GeoComm
modified, last (date/time) See sort by
modifying
menu 188
See also editing
monitors 54, 196
changing 397, 408-410
type 409
See also CGA and Hercules
monochrome monitors 53, 196
and color 263-264
month
day of 334
event 334
events during 330
on calendar 325
See also GeoPlanner

484
more
   fonts command 239-240
   than one See multiple
most often/recently called phone
   numbers See list
Motif (graphical user interface) 37
mouse
   acceleration 401-402
   brand 397, 401-403
   buttons 13-14
   changing 397, 401-403
   how to use 13-18
   responsiveness 397, 401-403
moving
   backward through text 100
   between document pages See
      GoTo page command and
      paging
cursor 100
directories See directories
   files See moving
   forward through text 100
   handle 170
icons 75
information between scrapbooks
   440
mouse 15
notepad text 431
numbers from calculator 418
objects
   arranging within a stack 210-211
copying 192-193
definition of 169
deleting 194
flipping 190
handles 170
modifying See editing
nudging 188
overlapping See stacking
pasting 192-193
resizing 185-191
rotating 188-189
selecting See selecting
stacking See stacking
off-line 373-377
often called phone numbers See list
one at a time See single
on-line 373-377
opaque pattern 199-200
Open
   from the File menu 73, 78-79
   option/command 83, 281
   Software Foundation 37
opening
   address book 295
date book 323
directories 78-79, 84, 118, 122-126
documents 78-86, 134, 161-163,
   226-228, 281
files See starting
   menus 43-44

N
names
   adding See adding
   and addresses See Address Book
   and details 129
   applications 136
   bar See menu bar
   batch file 451
   button 445
   changing See changing
current disk 83
directory 136
disks 147
documents See documents
   DOS files 136, 429
   field 434
   file See files
   menu See menu name
   notepad document 428-429
   only (contents of directory as
      icons) 129
   path See pathname
   printer 405
   script 388
   searching for See searching
   sort by See sort by
   volume 83
navigating menus with keyboard See
   menus
newsletters 279
next
   card 32, 296
day 324, 329
   page See paging
   phone number 297
   word 101
   year 325
nickname (for printer) 404
No
   button 67
   Command Line Options 446
Notepad
   appliance 4, 30
   desk tool 135, 424
   versus GeoWrite 424
NOTES.TXT document 424
nudging objects 188
number of
   buttons that fit on screen 448
   bytes used/free 116
   characters See names
   columns 270

O
objects
   arranging within a stack 210-211
copying 192-193
definition of 169
deleting 194
flipping 190
handles 170
modifying See editing
nudging 188
overlapping See stacking
pasting 192-193
resizing 185-191
rotating 188-189
selecting See selecting
stacking See stacking
off-line 373-377
often called phone numbers See list
OK button 67
one at a time See single
on-line 373-377
opaque pattern 199-200
Open
   from the File menu 73, 78-79
   option/command 83, 281
   Software Foundation 37
opening
   address book 295
date book 323
directories 78-79, 84, 118, 122-126
documents 78-86, 134, 161-163,
   226-228, 281
files See starting
   menus 43-44
multiple documents 87
notepad document 430
parent directories See parent
directories tree window
properties boxes 195-196
scrapbook 438
standard address book 295
standard date book 323
tree window 152
windows See starting
See also pinning menus
operations, order of 415
options 19
   binary 385
calculator 419-420
changing See changing
command line 445
computer internal 397, 410-411
dialing 305-306
formatting 425
GEOS See GEOS
hardware, adjusting See preferences
desk tool
internal See computer
look and feel See look and feel
menu 154-155, 245, 284, 352, 419
modern 407-408
preferences 397
software, adjusting See preferences
desk tool
terminal simulation See terminal
simulation options
text 385
video 408-410
See also dialog box, commands, and menus
order
   address card 297
directory item See directories
operations 415
organization of this manual 6-7
orientation of page 168, 216, 270-272, 285
outline
   dark 325
dotted 186, 279
heavy 10, 33
rectangular, of window 48
See also borders
oval See circle
overlapping
   command 281
objects See stacking
windows (mode) 39, 86, 122-123
overwriting text 82, 102
   See also Read Only and insert
   mode
parity 367, 389
   error 386
pasting
   between scrapbooks 440
   notepad text 451
   numbers from calculator 417-418
   objects 192-193
   scraps 435
text 30, 103, 236, 354-355, 374
   See also cutting text
pathname 83-84, 116-118
patterns 89, 195-202
PAUSE command 391
PC
   computer 411
   Paintbrush files (PCX extension) 214
permanent
   changes See saving
deletions See wastebasket
options 155
storage 433
phone
   dialer See dialer, phone
   numbers 297
type 370
pi (abbreviation for picas) See picas
picas (pi) 70, 244
picture on button 445
   See also icon
pinning menus 59-61, 231
pixels
   definition of 188, 231
   rectangular See aspect ratio
Planner appliance 33
plug, modem See modem port
plus (+)
   key 7
   sign 151
p.m. (in appointment times) 328
pointer 3, 12, 13
   arrow 169, 181
circle and slash 13
hourglass 13
I-beam 13
moving on the screen 14-15
pressing an item 17-18
rotate 169, 181
slash and circle 13
pointing 14-15
points (pt) 70, 244
   European See European points
polygon tool 169, 176-177

P

packet size for data transfer 383
page
   breaks 278
down See paging
   facing 270
margins See margins
numbering See numbers
orientation See orientation
print See printing
ruler See ruler
selecting 98, 100, 235
setup 216, 270-272, 279-280
size 168, 270
title 270-274
up See paging
paging 20-21, 30, 33
   area 50-51
arrows 229
GoTo command See GoTo Page
command
Next Page command 281
Previous Page command 281
scrapbook entries 433-434
paper
   size See size
   source See source
paragraphs
   adjusting to 101
borders 259-261
colored background 263
formatting 425
margins See margins
selecting 98, 100, 235
spacing See leading
parallel printers 404
parameters
   setting in GeoComm 366
parent directory 117-118, 124
parentheses
   around mnemonics 62
to change order of operations 413, 422
Index

Port
command 391
modem 367, 397, 407-408
mouse 403
printer 397, 403-404
portrait orientation setting 168, 270-272
positioning the text cursor 95
power outage/failure See saving
preferences
desk tool 396-412
GeoPlanner 352-353
prefix
GeoPlanner 300, 305
pressing
mouse button See clicking
pointer/an item 17-18
preview area (of image) 214
previous
card 32, 296
day 324, 329
directory 117
page See paging
phone number 297
saved version of document See
Revert command
word 101
year 325
PRINT command 216-218, 285-287, 392
printable area of page 164
printers
brand of 397, 403-406
changing 403-406
configuration 403-406
deleting 406
identifying 107
installing 404-405
list of installed/available See list
name 405
parallel 404
port See port
serial 404
printing
address book 312-314
all cards 313
documents 216-218
Event window 363
events 344-347
general description 107-111
GEOS 5
labels 313
month on calendar 346
Notepad 30, 426
page setup See page setup
phones 313
portion of document 217, 286
quality 108, 217, 285-286
scheduled events 344-347
sideways See orientation
(landscape)
test page on printer 406
year on calendar 347
problems See dialog box
See also Troubleshooting in
appendices
Professional
button 24
Workspace 4, 22, 24, 35-111
programs See applications and DOS
prompt command 390
properties boxes 195-197
protocol
settings See setting
XMODEM See XMODEM
pt (abbreviation for points) See points
pulse
command 392
dialing 389
push
buttons 67
pin icon See pinning menus

Q

 quadruple-clicking See clicking
quality, print See printing
question mark symbol 66
Quick
 copy 105-106, 319-320, 354-355, 418, 432
dial 296, 304, 369, 371
menu 330
move 105-106, 319-320, 354-355, 418, 432
Start Guide 1
 quintuple-clicking See clicking
 quitting See exiting

R

R on Event window See repeating
events
radio buttons 53-55, 68
RAMdisk 40, 117
range
 adjust 98-99
days/dates in GeoPlanner 324, 329-330, 334
deselect 99
items, selecting 92-94
pages to print 108-109, 286
replace 99
text, selecting 97-99
rate, baud See baud rate
ratio, aspect See aspect ratio
read
error 386
only 78, 129, 144, 154, 430
recalling
number from memory (calculator) 417
text style See style
receiving
information/files 361, 366, 382-385
status window 385
recently called phone numbers See list
recovering
deleted item 142
last saved version of document 82
rectangle tool 169, 175-176
rectangular aspect ratio 167
recurring events See repeating events
reduced size
of drawing 166-167
of windows See Maximize button
and Minimize button
reformatting disks See disks
registered trademark symbol (R) 234
regular events See repeating events
releasing the mouse button See clicking
reminder precedes event 353
remote computer systems See
GeoComm
removing
events 328, 336
headers/footers 276-277
pages of scrapbook 435-436
title pages 274
See also closing, deleting, and
exiting
renaming
disks See disks
files/directories 143-144
reopening toolbox 166
repeating events 333-342
replacing
files 154
range of text 99
Index

text 237
reports 41
rescanning drives 150
Reset
  button 67
  counters on Show Line Status window 386
reshaping objects 185-191
resizing
  borders 45-46, 363
  footers 276
  headers 276
  windows 45, 48-50
resolution, maximum print See printing quality
responding to dialog boxes See dialog box
responsiveness of mouse See mouse
restarting
  GeoManager 156
  GEOS 403
Restore button 45-46, 76
restoring
  applications to original size 75, 76
  events 328
  original document See Revert command
retrieving
  files/directories from Wastebasket 40
returning to
  Appliances screen 32
  DOS 23-26, 43-46
  original document size 167
  Welcome screen 24, 29, 43, 46, 443
reverse
  colors (highlighting) 89, 96
  image text (white on black) 266
  Polish Notation on calculator (RPN) 419-420
Revert command 77, 82-85, 220, 288, 349
right
  justification See justification margin
  mouse button 13-14, 18
  tab See tabs
ROMdisk 40, 117
root directory See directories
rotary phone 370
rotate
  objects 188-189
  pointer See pointer
rough draft, printing See draft
rounding figures in calculations See decimal places
rows of data See tables
RPN (Reverse Polish Notation) on calculator 419-420
rule, width of 271, 279
ruler 229, 244-250, 424
  commands 284
  menu 254
running
  application programs 40
  batch programs
  DOS programs See DOS Programs scripts 387-388
  total 416
safeguard feature See saving, automatic
safer choices 19, 68
sample
  Address Book screen 32
  address card 297
  calculations 416
  Calculator window 31, 325
  dialog box 19, 65
  DOS Programs screen 25
  entries for units of measure 70
  event scheduling 330-342
  GeoComm window 363
  GeoDex window 296
  GeoDraw window 164
  GeoManager screen 39, 116
  GeoPlanner window 324
  GeoWrite window 229
  help window 20
  manual page 7
  menu 53
  Notepad screen 30, 424
  Page Setup dialog box 270
  Planner screen 33
  Preferences window 396
  RPN calculations 421-423
  scrapbook 433
  scripts 387
  Welcome screen 12
saving
  address book 315-316
  as DOS text file 290
  automatic 78-83, 288, 348, 397-399, 425
  batch files 451, 453
changes as you work 52, 220, 289, 349, 429
current screen 378-379
data received to Clipboard 361
date book 548-549
documents 45, 80-85, 219-221, 288-290, 315-316
full screens of data 378
GeoPlanner preferences 353-355
information in GeoComm 378-381
interval See saving, automatic
note 424, 428-429
options 155, 284
previous version See Revert command
scrapbook documents 437-438
settings on Options menu 284
with Save/Save As option 79-85, 219-221, 288, 348, 428
scanning See browsing and viewing
scheduling events See events
Scratch pad 268, 433
screens
  Address Book 32
  blanking interval 397, 408-410
  Calculator 31
  Choosing an Appliance 29
  current 363
  DOS Programs 25, 441-453
  GeoManager 39
  Notepad 30
  only option in saving 379
  Planner 33
  Professional Workspace 39
  Welcome 3, 9-26
  See also windows
scripts in GeoComm 361, 369, 387-392
scrolling 69, 229, 284
  addresses 299, 307
  arrow 50-51, 444
  bar 50-52, 117, 229-230, 284, 434
  buffer 376-379
  continuously 51
  data in GeoComm window 376-377
directly to a particular position 52
directories 83
documents 78
events 324
files 83
groups 83
total at a time 52
help 20-21
information in GeoComm list 68
double 229
line 229, 250
line-and-a-half 229
paragraph See leading
single 229
speaker
modem 370
volume 370
specifying
by date/day 334
options now 446
See also selecting
speed
clicking 401-403
dial lists See list
modem 397, 407-408
transmission 367
splitting long lines 369
stacking
objects 170-171, 210-211
windows 39, 45
standard calculator operation (versus
RPN) 419
start of (moving, selecting, adjusting
and deleting to)
columns See beginning of
lines See beginning of
pages See beginning of
paragraphs See beginning of
words See beginning of
starting
Appliances 23, 29
applications 72-73, 133-134
communications 371-372
desk tools 395
DOS programs 135
DOS Programs screen 443
GeoComm 362
GeoDex 295
GeoDraw 161
GeoPlanner 323
GEOS 11
GeoWrite 226
notepad 424
time for day template 353
startup as 353
status
time for day 386
Receive See receiving
Send See sending
steps in this manual 6
stop
bits 367, 389
button 67
receiving file 385
sending file 383
stopping
alarm once it's gone off 331
script 388
See also exiting and turning on/off
storing
applications 41
documents See saving
graphics 103
number displayed on calculator
417
permanently 433
style of text 258
temporarily 433
text 103
to memory 414
stretching objects 190
styles 195-202
menu 243
recalling 258
storing 258
text 238, 242-243
subdirectory 118, 151
subtracting items
from a group 93
from a selection 121
summary of
copying text 105
file menu 85
GEOS See introduction
moving text 105
quick copy 106
quick move 106
switching
applications 45-46, 74, 134
back to full-sized document
window 87
between Card View and Browse
View 308
between full-year and single-month
views 326
between GeoWrite and GeoDraw
to copy graphics 269
between insert and overtype 102
between single and multiple
directories 118, 122-123
between standard and RPN
calculator operation 419
documents 88, 212-213, 281
items between on and off 54
pages See paging
See also changing and flipping
symbols
text, GEOS See GEOS
Index

text
adjusting selection 101
borders 259-261
capturing 380
centering 249-250
color in 263
compressing 241-242
copying See copying
cursor 66, 95, 100, 178, 234
cutting See cutting text
deleting See deleting text
DOS file See DOS and saving
editing See editing text
title
bar 45, 398
page See page
today's
date 33, 325
events 330
tone
dialing 389
sound See alarm
toolbox for drawing 164-165, 169, 171, 178
tools, desk See preference desk tools
total, running 416
touch-tone phone 370
tractor feed 110, 287
type
registered (R) 234
symbol (TM) 234
trace
data files between computers See GeoComm
information between programs 104
items to and from clipboard 104
translator, language 368
transmitting information/files See sending
transparent pattern 199-200
tree, directory See directories
triangle 33, 325
triple
clipping See clipping
spacing See leading
TTY (teletype) terminals 368
turning on/off
alarm See alarm
Appliances 29
aspect ratio option 167, 231-232
automatic screen blanking 409-410
options 155, 306
radio buttons 54-55
Snap to Ruler Marks 245
toggles for Options menu 284
See also exiting and starting
TVI950 terminals 368
.TXT file extension 429
types of
memory 397
monitors 397, 408
phones 370
pointers 13
printer 397
terminals See terminal types
typing See See entering

U
underlined
mnemonics 62
text 238
undoing
changes 6, 67, 82, 302, 328
deletions 142, 302, 328
See also Restore
units of measure 70, 244
unless dialing modem setting 370
unpinning menus See pinning menus
until connect modem setting 370
untitled
disk 83
document See documents
up arrow 67-68
updating
configuration See configuration
directory display 150
information See changing and saving
Up Directory button See directories
user interface See introduction to GEOS and Motif
Use This File 445
using
Appliances See Appliances
applications 72-76
buttons 448-449
clipboard 103-105
color in GeoWrite 263-267
data files/documents 40
directory tree 151-153
file lists 83-85
manual 6-7
memory (calculator) 416
menus 53-64
more memory 411
mouse See mouse
notepad 424
Options menu 284
RPN calculator 420
ruler 245
scripts 387-392
tab leaders 254-255
Window menu 281-283
windows 45

Times font 238
tips for

491
Utilities menu 335, 356

V

variety of fonts 425
formatting options 425
vertical border 50
line (blinking) See text cursor
lines with a tab 256-257
rule between columns 280
scroll bar See scrolling
VGA monitors See monitors and color video
options 408-410
See also monitors
viewing
address book 307-308
calendar 325, 350-351
directories 123
documents one page at a time 283
events 329-330, 350-351
files in a directory 118
Help pages 21
menu 130-131, 166-167, 231, 350, 364
multiple directories 118
multiple pages 282
options 128
search information See searching
single directories 118
size See changing
window 434
volume name 83
VT52 terminals 368
VT100 terminals 368

What You See Is What You Get (WYSIWYG) 3, 225, 278
white on black text 266
space on page 279
width
of lines 197-198
of paper 110
of rules See rule
windows
active See active windows
calculator 413-414
calendar 324-326
capturing status 381
closing See closing windows
collapsing See Minimize button
columns 364
definition of 20, 39, 45
Dialing Option 300
enlarging See Maximize button
event 324, 350
full-sized See full-sized
GeoComm 363-365
GeoDex 296
GeoDraw 164
GeoManager 38, 42, 116-118
GeoPlanner 324
GeoWrite 229-233
Help 20-21
lines 364
list See list window
menu 86, 122, 281-283
moving See moving windows
notepad 424
opening See starting
overlapping See overlapping
Preferences 396
Receive status 385
resizing See resizing windows
scriptbook 433
Script Display 387
sending status 383
Show Line status 386
size See resizing windows
stacking See stacking windows
title bars See title bars
using 45
viewing 434
See also screen
word processing See GeoWrite
words
adjusting to 101
deleting 101
selecting 98, 100, 235
work phone number 297
working
copy (temporary) See saving, automatic
on-line 373-377
with Calendar window 325-326
with columns 279-280
with documents 77-88
with events 327-350
with multiple documents 212-213
with repeating events 333-342
with scrapbook documents 437
with scraps 434
Workspace
background See background, workspace
definition of 24
Professional See Professional Workspace
World directory 39-42, 118, 123, 161, 226
wrapping lines at the edge 369
write error 386
WySE50 terminals 368
WYSIWYG (What You See Is What You Get) 3, 225, 278

X

XMODEM
method of file transfer 382-3845
protocol 361
XT computer 411

Y

year
calendar See calendar
next See next
previous See previous
yearly events 334
Yes button 67

Z

zip codes 298
Product Development
Jim DeFrisco
Doug Fults
Tony Requist
Gene Anderson
Brian Chin
Dennis Chow
Adam de Boor
Eric E. Del Sesto
Dave Durran

Special Thanks To
Keva Beckley
Paul Bergmann
Rose Gerald
Jim Goldberger
Leland Llevano
Angie McKenna

Brian Dougherty
Michael Eggers
Roger Flores
Chris Hawley
Clayton Jung
Ted Kim
Steven Kuo
Tony Liphart
Matthew Loveless
David Navas

Don Reeves
Steve Scholl
Emily Sun
Cheng Tan
Mike Vargas
John Wedgwood
Andrew Wilson
Jon Witort

Keith Mills
Tom Morgan
Mike O'Donnell
Henri Ormond
Greg Orr
Dennis Rowland
Dan Sicotte

Robert Siegel
Clive Smith
Rosemary Teal
Michelle Vieira
Gail Wade-Adams
Carl Williamson

Additional Documentation
Services
Lasselle-Ramsay Publication Services