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About this manual 

The OrCAD Capture for Windows 
User's Guide contains the procedures 
you need to work with Capture. To help 
you learn and use Capture efficiently, 
this manual is organized by tasks, 
beginning with the most common 
schematic design tasks (parts one and 
two), and moving on to more advanced 

CMRlJN ! ::::' 

Capture features (parts three and four). Many of the procedures described in this 
manual are also covered in the online tutorial, Learning Capture. 

_Iclxl 

Before you begin 

Before you can use Capture, you must install Microsoft Windows on your computer, 
then install Capture. For information on installing Windows, see your Windows 
documentation. 

To install Capture, follow the installation instructions that accompany Capture. 

Symbols and conventions 

The keyboard 

OrCAD printed documentation uses a few special symbols and conventions. 

• The keys on your keyboard may not be labeled exactly as they are in this 
manual. All key names are shown using small capital letters. For example, the 
Control key is shown as CTRL; the Escape key is shown as ESC. 

• Keys are frequently used in combinations or sequences. For example, SHIFT+Fl 
means to hold down the SHIFT key while pressing Fl. ALT, F, A, means to press 
and release each of these keys in order: first ALT, then F, then A. 

• Arrow keys is the collective name for the UP ARROW, DOWN ARROW, LEFT 
ARROW, and RIGHT ARROW keys. 

• To choose a command from a menu, you can use the mouse or press a key 
combination. For example: from the File menu, choose Open (ALT, F, o). 
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About this manual 

Text 

• Text you are instructed to type is shown in bold. For example, if the manual 
instructs you to type * .dsn, you type an asterisk, a period, and the lowercase 
letters dsn. The text you type is usually shown in lowercase letters, unless it 
must be typed in uppercase letters to work properly. 

• Placeholders for information that you supply (such as filenames) are shown in 
italic. For example, if the manual instructs you to type cd directoryname, you 
type the letters cd followed by a space and the name ofa directory. For 
example, for a directory named CIRCUITS, you would type cd circuits. 

• Examples of syntax, netlist output, and source code are displayed in monospace 
font.Forexample:/N0001 U1(8) U2(1);. 
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Capture basics 

Part One contains the basic information you need to get started in Capture. It gives 
you an overview ofthe structure and work environment of Capture, and describes 
how to open and save projects. Part One includes these chapters: 

Chapter 1: Getting started describes how to start Capture. 

Chapter 2: The Capture work environment describes the things you'll need to know 
to find your way around in Capture. It shows the windows you'll see in Capture: the 
project manager, the browse window, the schematic page editor, the part editor, the 
text editor, and the session log. It also introduces you to the toolbar and tool palettes, 
and general concepts such as selecting and editing objects, and undoing and 
repeating actions. 

Chapter 3: Starting a project shows how to open a project and work with the 
schematic folders and schematic pages in a project. It also shows how to save a 
project or an individual schematic page. 

Chapter 4: Setting up your project 
describes how to customize the 
working environment specific to 
your system, how to create default 
settings for new projects, and how to 
override default settings in existing 
projects. 

Chapter 5: Printing and plotting 
describes how to print and plot your 
design. 

Part One 





Chapter 1 

Getting started 

This chapter describes how to start OrCAD Capture for Windows. 

Starting Capture 

The Capture installation process puts Capture in the ORCADWIN folder, and adds 
OrCAD Design Desktop and Capture to the Programs menu (available from the Start 
button). 

To start Capture 

If Windows is not running, type win at the DOS prompt, then perform these steps: 

1 From the Start menu, choose Programs. The Programs menu displays. 

2 From the OrCAD Design Desktop menu item, choose Capture. 

The Capture session frame 

Once you start Capture, you see the Capture session frame. You do all your 
schematic design and processing within this window. 

~i~ 0 rCAD Capture for 'Windows I!!I~ i3 
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Part 1 Capture basics 

The minimized Session Log icon in the lower left portion of the Capture session 
frame is the session log. The session log provides information about everything you 
have done. in the current Capture session. Detailed information about this-and the 
other windows in Capture-is given in chapter 2. 

In Capture, each design that you open is in a separate window. You may open as 
many designs in as many windows as your computer's resources can handle. If you 
want to work with three schematic pages, orwith three parts, each is available in its 
own window. If you need to work simultaneously with several designs, you can 
open them all, and each will have its own project manager window. 

Depending on which type of window you have active (an active window is one 
whose title bar is highlighted), certain buttons on the toolbar and certain items on the 
menus may be unavailable, since you perform tasks and use tools based upon the 
type of window that is active. Also, the menus and menu choices vary, depending on 
which type of window is active. 
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Chapter 2 

The Capture work environment 

This chapter describes the things you need to know to find your way around in 
Capture. It shows the windows you'll see in Capture: the project manager, the 
browse window, the schematic page editor, the part editor, the text editor, and the 
session log. It also introduces you to the toolbar, tool palettes, and general Capture 
concepts such as selecting and editing objects, and undoing and repeating actions. 

The project manager 

You use the project manager to collect and organize all the resources you need for 
your project. These resources include schematic folders, schematic pages, part 
libraries, parts, VHDL files, and output reports such as bills of materials and netlists. 

Fb Note A project doesn't actually contain all the resources. It merely "points to" 
the various files that the project uses. For this reason, be sure you don't move or 
delete any files referenced by a project. If you do, the project won't be able to find 
them. 

iii DESIGN1 "~Ei 

r. .bogical . (". Eh.l'$ical 

LJ File I ?~.. Hierarchy 1 
I::;:; LJ Design Resources 

· .ri] design1 
· [+;13:1 SCHEMATlC1 

if: LJ Design Cache 
iLJ Library 

· LJ Outputs 
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Part 1 Capture basics 

Project manager folders 

The project manager provides a graphical display of a project's resources by 
grouping them into appropriate folders, as described below. 

• The Design Resources folder shows a design folder with the design's schematic 
folders and schematic pages, and a Design Cache folder that shows all the parts 
used on the schematic pages. Any schematic folders or schematic pages that you 
create are automatically added to the design folder within the Design Resources 
folder, but you can also add other files or information using the Project 
command on the Edit menu. For example, you can add an existing VHDL file to 
the design folder and later attach the models within that VHDL file to 
hierarchical blocks on a schematic page. 

m See For information about hierarchical designs, see Chapter 6: Design 
structure. 

• The Library folder (in the Design Resources folder) shows the schematic part 
library files you've added to the project using the Project command on the Edit 
menu. 

• The Outputs folder shows the output of Capture's processing tools. Generally, 
these files include bill of materials reports and technology-specific netlists. 
Capture adds the appropriate files to this folder as each is created. 

Each project may have only one design, but may have multiple libraries. The design 
may consist of any number of schematics or VHDL models, but it must have a single 
root module. The root module is defined as the top level of the design. That is, all 
other modules in the design are referenced within the root module. 

! Tip The root schematic folder for a design has a backs lash in its folder icon. 
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Chapter 2 The Capture work environment 

Within the project manager, you can expand or collapse the structure you are seeing 
by double-clicking on a folder, or by clicking on the plus sign or minus sign to the 
left of a folder. A plus sign indicates that the folder has contents that are not 
currently visible; a minus sign indicates that the folder is open and its contents are 
visible, listed below the folder. 

Each project you open has its own project manager window. You can move or copy 
folders or files between projects by dragging them from one project manager 
window to another (as well as to and from Windows Explorer). To copy rather than 
move items, press and hold the CTRL key while you drag them. If you close a project 
manager window, you close the project. 

In the project manager's File tab, double-clicking on a schematic folder opens it and 
displays icons for each schematic page within the schematic folder. Then, if you 
double-click on a schematic page icon, the schematic page opens in a schematic page 
editor window. Or, ifthe page is already open, its window becomes active. 

Fb Note If a schematic page is open, you cannot drag its icon to a different 
location. 

A design can consist of a single schematic page within a single schematic folder, or a 
number of schematic pages within a number of schematic folders. A schematic 
folder "contains" schematic pages in a relationship similar to the relationship 
between a directory and the files it contains. Files are contained in a directory; 
schematic pages are contained in a schematic folder. 

A schematic page provides a graphical description of the electrical connectivity ofa 
design. It is made up of parts, wires, and other electrical symbols. A schematic page 
may also contain borders, title blocks, text, and graphics. 

Fb Note The project manager is also used to manage libraries and the parts they 
contain. This is covered in detail in Chapter 11: About libraries and parts. 

Any schematic folders or schematic pages you have selected within an active project 
manager window limit the scope of various commands, such as the Find and Browse 
commands on the project manager's Edit menu, the Print command on the project 
manager's File menu, and the various tools on the Tools menu. 
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Part 1 Capture basics 

Project manager tabs-File and Hierarchy 

The project manager provides two ways to display a project's resources. 

If you choose the File tab, the 
project manager displays all the 
project's folders, schematic folders, 
and schematic pages. 

If you choose the Hierarchy tab, the 
project manager displays the 
hierarchical relationship among the 
project's schematic folders and 
schematic pages. 

Design Resources 
.~ .\fulladd.dsn 

i~l·l!l FULLADD 
, : .. ~ FULLADD.SCH 

L~JL:J HALFADD 
! '.15n HALFADD.SCH 

. [+1 CJ Design Cache 
:···CJ Library 

File tab. 

iii fulladd I!II~ Ei 

;' '~~f~,~~r~~~~~' 
, F::+ IQj FULLADD 4-

[3.1Qj HALFADD_A (HALFADD.SCH) .' 
. '1Qj U1 (74LS08) 

.. 1Qj U1 (74LS08) 
, .. 1Qj U1 (74LS08) 

IQj U2 (74LS04) 
, .. 1Qj U2 (74LS04) 
i.,,1Qj U3 (74LS32) 

±J.1Qj HALFADD_B (HALFADD.SCH)~, 

Hierarchy tab. 

m See For information about hierarchical designs, see Chapter 6: Design 
structure. 
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Chapter 2 The Capture work environment 

Project manager options-Logical and Physical 

Projects can display in dther logical mode or physical mode, corresponding to the 
Logical option and Physical option in the project manager. Each of these modes 
offers a unique method for interpreting your design. 

In logical mode, a part may be 
referenced multiple times in the design 
hierarchy; however, only one instance 
ofthat part exists. For example, in the 
picture at right, there are three 
instances ofUl in HALFADD A and 
three instances of U 1 in 
HALF ADD _ B. Any editing changes 
you make to parts instances apply to 
the part occurrences as well. 

iii fulladd Il!lIiI E3 
r. .bogical r Ehysical 

CJ File ~~a Hierarchy 

t::::·1Q) FULLADD 
'::::flQ) HALFADD_A (HALFADD.SCH) 

.IQ) Ul (74LS08) 
· .. IQ) Ul (74LS08) 

IQ] U1 (74LS08) 
' .. IQ] U2 (74LS04) 

· .. IQ] U2 (74LS04) 
· .. IQ] U3 (74LS32) 

.IQ] HALFADD_B (HALFADD.SCH) 

'IQ] U1 (74LS08) 
, .. IQ] U1 (74LS08) 

.. IQ] U1 (74LS08) 
.. IQ] U2 (74LS04) 
.IQ] U2 (74LS04) 

; .. IQ] U3 (74LS32) 

IQ] U3 (74LS32) 

Logical mode. 
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Part 1 Capture basics 

In physical mode, a part is duplicated 
each time it is referenced in the design 
hierarchy. That is, a copy of it is 
created each time it occurs in the 
design hierarchy. For example, the 
three instances ofUl in logical mode 
(in the previous picture) have now 
changed to three occurrences (UlA, 
UlB, and UlC) in HALFADD_A and 
three occurrences in HALF ADD_B. 
Notice, also, that the icons for the 
occurrences are grayed out. This 
serves as a visual reminder that any 
editing changes you make to parts in 
physical mode only apply to the part 
occurrences: the editing changes do 
not apply to the part instances. 
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FULLADD 
~,.Ia! HALFADD_A [HALFADD.SCH] 

L.1a! U1A [74LSOB] 
!.Ia! U18 [74LSOB] 

'Ia! U1 C [74LSOB] 
"Ia! U2A [74LS04] 

; ... Ia! U28 [74LS04] 

'Ia! U3A [74LS32] 
B--Ia! HALFADD_8 [HALFADD.SCH] 

, .. Ia! U1A [74LSOB] 
•... Ia! U18 [74LSOB] 
: IQ} U1C [74LSOB] 
: ... Ia! U2A [74LS04] 
: .. Ia! U28 [74LS04] 

: . "IQ} U3A [74LS32] 
..... Ia! U38 [74LS32] 

PhYSical mode. 



Chapter 2 The Capture work environment 

Part instances and part occurrences 

A part instance is a part as it exists in logical mode. Since the part instance may be 
referenced in one or more schematic pages, any change you make to a part instance 
affects each schematic page that refers to that part instance. For flat and simple 
hierarchical designs, this is straightforward: each part instance has a unique 
reference designator and set of associated properties that apply each time the part 
instance is referenced. 

In a complex hierarchy, a part instance that is referenced more than once in the 
design will only have one reference designator and set of properties assigned to it, 
regardless of the number of times it is referenced. This presents a problem when you 
need to create a netlist for use with Layout or some other board layout tool. Physical 
mode provides a method to uniquely annotate each occurrence of a part instance. 
Hence, part occurrence refers to a particular instantiation of a part instance in the 
netlist. 

rn See For information about simple and complex hierarchical designs, see 
Chapter 6: Design structure. 

RJ Note You cannot change design connectivity while in physical mode. Any 
changes to design structure must be performed in logical mode. In physical mode, 
you can only edit properties for part occurrences. 
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Part 1 Capture basics 

When to use physical mode 

Physical mode is typically necessary for PCB designs where all parts must be 
assigned unique reference designators and properties. In fact, in nearly all cases, the 
only time you should use physical mode is when you update part references or 
properties, or create a netlist for a PCB design that has a complex hierarchical design 
structure. For FPGA designs, or for PCB designs that use a flat or simple· 
hierarchical structure, use logical mode at all times. 

The following table summarizes the mode you should use for your design asa 
function of the structure and the type ofthe design. 

Design structure For FPGAlCPLD For PCB designs, 
designs, use mode: use mode: 

Flat design Logical Logical 

Simple hierarchy Logical Logical 

Complex hierarchy Logical Physical 

Even if your PCB design employs a complex hierarchy you should use physical 
mode only when you are processing your design (updating references, creating a 
netlist, updating properties, creating a bill of materials or cross reference report, 
swapping gates or pins, or assigning part packages). Use logical mode to perform 
design entry for your PCB design then, when you want to begin processing your 
design, switch to physical mode. 

There is one additional case that requires you to use physical mode: when you cross 
probe your Capture schematic with its corresponding board layout in Layout. 

1m See For more information about cross probing your schematic with a board 
layout, see Chapter 18: Using Capture with OrCAD Layout for Windows. 

Project manager pop-up menus 

There are a number of pop-up menu commands available in the project manager 
window. Using the commands on these pop-up menus, you can open a file or 
schematic page, or edit and view the properties of the currently selected item. For 
information on each pop-up menu command, refer to Capture's online help. 
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Chapter 2 The Capture work environment 

The browse window 

The browse window displays the items that are found using either the Browse 
command or the Find command from the project manager's Edit menu. Both the 
Browse and Find commands apply to all the schematic folders and schematic pages 
you select in the project manager. 

If you double-click on one of the items in the first column ofthe browse window, 
the schematic page that contains that item displays in the schematic page editor 
window, with the item selected. 

lID FULLADD DSN . BROWSE I!!!I~ E3 
Reference 

haffadd A 
haffadd=B 
U1A 74LS32 C:\()\'PTU ... 

You can sort the browse results using the buttons along the top of the browse 
window. When you choose one of the buttons, the rows of information in the browse 
window are reordered alphabetically based on the information in the column you are 
sorting. Each type of browse provides a different set of sort buttons. For example, 
the sort buttons provided for parts are part reference, part value, source part, source 
library, schematic page, and schematic folder, but the sort buttons provided for nets 
are net alias name, net name, schematic page, and schematic folder. 

Once the sort results display, you can adjust the column widths by dragging the 
vertical lines between the column names to the left or right. You can close or 
minimize the browse window using the standard Windows buttons in the upper right 
comer of the window. 
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Part 1 Capture basics 

The schematic page editor 

The schematic page editor window is used to display and edit schematic pages. You 
can place parts, wires, buses, and draw graphics. The schematic page editor has a 
tool palette that you can use to draw and place everything you need to create a 
schematic page. You can print from within the schematic page editor. 

CARRYJN c::;; 

)( C=>'~--­
Y C=>'~-__ 
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The part editor 

Chapter 2 The Capture work environment 

The part editor window is used to create and edit parts. 

----i~'D" -----i 2 i : ... ~ .... -.. -
~~N_··.···· • 7, : 

. {VoIlue} ------

~ ... :.' 
.... /.;; 

From the View menll of the part editor you can choose either Part or Package. In 
Part view you can: 

• Create and edit parts and symbols, then store them in new or existing libraries. 

• Create and edit power and ground symbols, off-page connector sytpbols, and 
title blocks. 

• Use the tool palette's electrical tools to place pins on parts, and its drawing tools 
to draw parts and symbols. (See Part editor tool palette later in this chapter.) 

Package view shows you the entire package. You can edit the properties of the entire 
package, such as part reference, prefix, part alias, and so on. You cannot edit 
individual parts in this view, but you can select individual parts to edit by double­
clicking on them. 

W See also See Chapter 11: About libraries and parts for complete definitions of 
parts and packages. See Chapter 12: Creating and editing parts for a complete 
description of the part editor. 
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Part 1 Capture basics 

The text editor 

Use the text editor to create or view VHDL files or other text files within Capture. 
VHDL keywords and comments are displayed in the colors you specifY in the Text 
Editor tab in the Preferences dialog box (from the Options menu, choose 
Preferences). 

LIBRARY IEEE; 
USE IEEE.stdJogic_1164.all; 
ENTITY FOE IS PORT ( 

o : IN stdJogic; 
E : IN stdJogic; 
ClK: IN stdJogic; 
C : IN stdJogic; 

To create a new VHDL file in the text editor 

~ From the File menu, choose New, then choose VHDL File. A blank VHDL file 
displays in the text editor. 

To open a VHDL file in the text editor 

1 From the File menu, choose Open, then choose VHDL File. The Open VHDL 
File dialog box displays. 

2 Select a file, then choose the OK button. 

or 

1 In the project manager, select a VHDL file. 

2 From the pop-up menu, choose Edit. 

m See For more information on editing VHDL files in the text editor, see 
Capture's online help. 

16 OrCAD Capture for Windows User's Guide 



Chapter 2 The Capture work environment 

The session log 

The session log lists the events that have occurred during the current Capture ses­
sion, including messages resulting from using tools. To display context-sensitive 
help for an error message, put the cursor in the error message line in the session log 
and press Fl. 

The ruler along the top displays in either inches or millimeters, depending on which 
measurement system (U.S. or Metric) is selected in the Windows Control Panel. You 
can add tab settings to the ruler by clicking in the ruler bar, drag the tabs to different 
positions, or remove them by dragging them down into the session log window. 
Your tab settings are saved and used each time you start Capture. 

It Session Log 1!Il!] EJ 

* ... 
* Bill Of Materials 
* 
""':lA.U ;tlJ::U 'kJd .. U .JtlJdo:lAl:ht:tt:tAtA'UtottA.U Jolt t:tAt:t"':t:tAtAJ::t A:lA:t:tAAAAAAAA ... :t:tAA 

Performing BOM. 
BOM Done. 

... 

You can search for information in the session log using the Find command on the 
Edit menu. You can also save the contents of the session log to a file, which is useful 
when working with OrCAD's technical support staffto solve technical problems. 
The default filename is SESSION.TXT. 

~ Tip To clear the session log, choose Clear Session Log from the Edit menu, or 
use the CTRL +DEL shortcut key combination. 
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The toolbar 

Capture's toolbar is dockable (that is, you can select an area between buttons and 
drag the toolbar to a new location) and resizable, and displays tooltips for each tool. 
By choosing a tool button, you can quickly perfonn a task. If a tool button is 
dimmed, you can't perfonn that task in the current situation. 

Some of the tools operate only on what you have selected, while others give you a 
choice of either operating on what is selected or expanding the scope to the entire 
project. The table below summarizes the tools on the toolbar. The tasks that these 
tools perfonn are described throughout this manual. 

Tool Name 

:jtJ New 

Open 

Save 

c!j 
. ~ Print 

. 1J Cut 
. . 

. ~ Copy 

. !lj Paste 

BJ Undo 
._'." 

. £1 Redo ... ~; 

.~ Zoom In 

~ Zoom Out 

Description 

Create a new document based on the active document. 
Similar to the New command on the File menu. 

Open an existing project or library. Similar to the Open 
command on the File menu. 

Save the active schematic page or part. Equivalent to the 
Save command on the File menu . 

Print the active schematic page or part. Equivalent to the 
Print command on the File menu . 

Remove the selected object and place it on the Clipboard. 
Equivalent to the Cut command on the Edit menu . 

Copy the selected object to the Clipboard. Equivalent to the 
Copy command on the Edit menu . 

Paste the contents of the Clipboard at the cursor. Equivalent 
to the Paste command on the Edit menu. 

Undo the last command perfonned, if possible. Equivalent 
to the Undo command on the Edit menu . 

Redo the last command perfonned, if possible. Equivalent 
to the Redo command on the Edit menu . 

Zoom in to see a closer, enlarged view. Equivalent to 
choosing Zoom and In from the View menu. 

Zoom out to see more of your document. Equivalentto 
choosing Zoom and Out from the View menu. 

Tools on the Capture toolbar (page 1 of 2). 
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Tool Name 

Zoom Area 

Zoom All 

Chapter 2 The Capture work environment 

Description 

Specify an area of the schematic page or part to enlarge to 
fill the entire window. Equivalent to choosing Zoom and 
Area from the View menu. 

View the entire document. Equivalent to choosing Zoom 
and All from the View menu. 

Update Part Assign part references to parts on the selected schematic 
References pages. Equivalent to the Update Part References command 

EJ. Gate and 
Pin Swap 

. 1j Design 
Rules 
Check 

:~ Create 
Netlist 

EU Cross . :S:~<~.:.; Reference 

~ Bill of 
; .. , Materials 

. ~ Project 
Manager 

, I Help 
-!J Topics 

on the Tools menu. . 

Back annotate the selected schematic pages. Equivalent to 
the Gate and Pin Swap command on the Tools menu . 

Check for design rules violations on the selected schematic 
pages. Equivalent to the Design Rules Check command on 
the Tools menu. 

Create a netlist for the selected schematic pages. Equivalent to 
the Create Netlist command on the Tools menu. 

Create a cross reference report for the selected schematic 
pages. Equivalent to the Cross Reference command on the 
Tools menu. 

Create a bill of materials report for the selected schematic 
pages. Equivalent to the Bill of Materials command on the 
Tools menu . 

Display a project manager window for the active document, 
providing an overview of project contents. Equivalent to 
choosing a project manager window by number from the 
Window menu. 

Open online help. Equivalent to the Help Topics command 
on the Help menu. 

Tools on the Capture toolbar (page 2 of 2). 

Displaying or hiding the toolbar 

You can hide the toolbar, then display it again when you need it. 

To display or hide the toolbar 

~ From the schematic page editor's View menu, choose Toolbar (ALT, v, T). 

or 
From the part editor's View menu, choose Toolbar (ALT, v, T). 
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The tool palettes 

Capture has two tool palettes: one for the schematic page editor window and one for 
the part editor window. Both tool palettes are dockable (that is, you can click on an 
area between buttons and drag a tool palette to a new location) and resizable, and 
display tooltips that identify each tool. While the drawing tools on the two tool 
palettes are identical, each tool palette has different electrical tools. After you choose 
a tool (and, in the case of some tools, after you respond to the tool's dialog box), you 
press the right mouse button to display a context-sensitive pop-up menu. 

The schematic page editor tool palette 

The first group of tools on the tool palette are electrical tools, used to place 
electrical-connectivity objects. The second group of tools are drawing tools, used to 
create graphical objects without electrical connectivity. 

The tools on the schematic page editor tool palette are described in the table below. 
For descriptions of how to use the electrical tools, see Chapter 7: Placing, editing, 
and connecting parts and electrical symbols. For descriptions of how to use the 
drawing tools, see Chapter 8: Adding and editing graphics and text. 

Tool . Name 

Select 

Part 

Wire 

Net Alias 

Description 

Select objects. This is the normal mode. 

Select parts from a library for placement. Equivalent to 
the Part command on the Place menu. 

Draw wires. Press SHIFT to draw non-orthogonal (not a 
multiple of 90°) wires. Equivalent to the Wire 
command on the Place menu. 

Place aliases on wires and buses. Equivalent to the Net 
Alias command on the Place menu. 

Tools on the schematic page editor tool palette (page 1 of 2). 
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Tool 

.±J 

;L:2,1 1fB 

•... :."'.' ..... '.:1 16 

:.
' :.:. ,:.';"0,: .. , •.··•· .. ···1 
.2J 
'. :" i .. .i~. :'. :·f·.·. :~ 

Name 

Bus 

Junction 

Bus Entry 

Power 

Ground 

Hierarchical 
Block 

Hierarchical 
Port 

Hierarchical 
Pin 

Off-Page 
Connector 

No Connect 

Line 

Polyline 

Rectangle 

Ellipse 

Arc 

Text 

Chapter 2 The Capture work envir,onment 

Description 

Draw buses. Press SIDFT to draw non-orthogonal buses. 
Equivalent to the Bus command on the Place menu . 

Place junctions. Equivalent to the Junction command 
on the Place menu. 

Draw bus entries. Equivalent to the Bus Entry 
command on the Place menu. 

Place power symbols. Equivalent to the Power 
command on the Place menu. 

Place ground symbols. Equivalent to the Ground 
command on the Place menu. 

Place hierarchical blocks. Equivalent to the 
Hierarchical Block command on the Place menu. 

Place hierarchical ports on schematic pages. Equivalent 
to the Hierarchical Port command on the Place menu. 

Place hierarchical pins in hierarchical blocks. Equivalent 
to the Hierarchical Pin command on the Place menu. 

Place off-page connectors. Equivalent to the Off-Page 
Connector command on the Place menu. 

Place no-connect symbols on pins. Equivalent to the No 
Connect command on the Place menu. 

Draw lines. Equivalent to the Line command on the 
Place menu . 

Draw polylines. Press SHIFT to draw non-orthogonal 
poly lines. Equivalent to the Polyline command on the 
Place menu. 

Draw rectangles. SHIFT constrains to a square. Equiva­
lent to the Rectangle command on the Place menu. 

Draw ellipses. SHIFT constrains shape to a circle. 
Equivalent to the Ellipse command on the Place menu. 

Draw arcs. Equivalent to the Arc command on the 
Place menu. 

Place text. Equivalent to the Text command on the 
Place menu. 

Tools on the schematic page editor tool palette (page 2 of 2). 

OrCAD Capture for Windows User's Guide 21 



Part 1 Capture basics 

The part editor tool palette 

The fIrst group of tools on the part editor tool palette are electrical tools, used to 
place pins and IEEE symbols. The second group of tools are drawing tools, used to 
create graphical objects without electrical connectivity. 

The tools unique to the part editor tool palette are described in the table below. The 
drawing tools are described in the previous section Schematic page editor tool 
palette. 

For infonnation on how to use the electrical tools, see Chapter 12: Creating and 
editing parts. For infonnation on how to use the drawing tools, see Chapter 8: 
Adding and editing graphics and text. 

Tool Name 

IEEE 
Symbol 

Pin 

Pin Array 

Description 

Place IEEE symbols on a part. Equivalent to the IEEE 
Symbol conunand on the Place menu. 

Place pins on a part. Equivalent to the Pin conunand on 
the Place menu. 

Place multiple pins on a part. Equivalent to the Pin 
Array conunand on the Place menu. 

Tools on the part editor tool palette. 

Displaying or hiding a tool palette 

Like the toolbar, you can hide a tool palette, then display it again when you need it. 

To display or hide a tool palette 

~ From the schematic page editor's View menu, choose Tool Palette (ALT, Y, p). 
or 
From the part editor's View menu, choose Tool Palette (ALT, Y, p). 
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The status bar 

Left field 

Center field 

Right field 

The status bar is located at the bottom of the Capture session frame, and reports on 
current actions, number of items selected,. zoom scale, and pointer location. 

Displays descriptions of selected tools or menu items, prompts, or the current status. 

Displays the number of items selected in the schematic page editor or part editor. 

Fb Note When a session log or a project manager window is active, the center field 
of the status bar doesn't display. 

Displays the current scale and pointer location (such as: Scale=50% X=10.0 Y=5.0). 
The location in the schematic page editor is measured in either inches or millimeters, 
depending on the Units settings in the Page Size tab in the Schematic Page 
Properties dialog box. The location in the part editor is measured in grid units. 

Displaying or hiding the status bar 

You can hide the status bar, then display it again when you need it. 

To display or hide the status bar 

~ From the schematic page editor's View menu, choose Status Bar (ALT, v, s). 
or 
From the part editor's View menu, choose Status Bar (ALT, v, s). 
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Using help and the online tutorial 

Capture's online help includes information to help you become familiar with 
Capture. You can access help from the menu bar in the session frame, by choosing 
the Help button in a dialog box, or by pressing F 1. 

Topics include: 

• Explanations and instructions for common tasks. 

• Descriptions of menu commands, dialog boxes, tools on the toolbar and tool 
palettes, and the status bar. 

• Netlist format samples, error messages, and glossary terms. 

• Reference information. 

• Product support information. 

You can get context-sensitive help for an error message by placing your cursor in the 
error message line in the session log and pressing FI. 

Capture's online tutorial takes you through a series of self-paced, interactive lessons. 
You can practice what you've learned by going through the tutorial's specially 
designed exercises. 

Using the Accessories menu 

You can use extensions to the OrCAD-supplied functionality of Capture if you 
purchase software developed by associates of Or CAD. These associates create .DLL 
files that address specific Capture functionality, such as customized netlisting. The 
associates configure their .DLL files so that they are listed as menu choices on the 
Accessories menu, available in either the project manager window or the schematic 
page editor window, once you install a third-party extension. OrCAD's Enterprise 
Edition software displays commands in this menu. 

24 DrCAD Capture for Windows User's Guide 



Chapter 2 The Capture work environment 

Selecting and deselecting objects 

Once you select an object, you can perfonn operations on it, including moving, 
copying, cutting, mirroring, rotating, resizing, or editing. You can also select 
mUltiple objects and edit them, or group them into a single object. Grouping objects 
maintains the relationship among them while you move them to another location. 

Wi See You can edit the properties of a group of objects using the spreadsheet 
editor. See Using the spreadsheet editor to edit properties in this chapter. 

This section describes different ways to select individual objects and groups of 
objects in both the schematic page editor and the part editor. 

To select an object 

I:!:> Position the pointer on the object and click the left mouse button. The object 
displays in the selection color. 

~ Tip To change the selection color: from the Options menu, choose Preferences, 
then choose the Colors tab. Click the left mouse button over the Selection color. 
Select a new color from the color palette window, choose the OK button to 
dismiss the color palette, then choose the OK button to dismiss the dialog box. 

To select multiple objects 

I:!:> For each object to select, position the pointer on the object and press CTRL while 
you click the left mouse button. Every object in the selection set displays in the 
selection color. 

~ Tip To select a part, click within the part itself. To select a graphical object, 
click on an outside edge of the object (it is easier to do this if you zoom in). 

To select all objects in an area 

1 From the tool palette, choose the selection tool. 

2 Click on an area where there are no objects or parts to deselect any items that 
may be selected. Move the pointer to one comer of the area to select. Press and· 
hold the left mouse button while you drag the mouse to the opposite comer, then 
release the left mouse button. Every object in the selection set displays in the 
selection color. 

~ Tip You can control whether the selection set includes all objects intersected by 
your selection rectangle or only those objects entirely inside the selection 
rectangle. From the Options menu, choose Preferences, then choose the Select tab. 
Select one of the Area Select options, then choose the OK button. 
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To select all objects on a schematic page or part 

~ From the Edit menu, choose Select All. All objects display in the selection 
color. 

Fb Note The selection set behaves as ifit is one object, so that you can move, copy, 
cut, delete, mirror, or rotate the entire selection set. Be aware, however, that the 
Select All command also selects the title block on the schematic page. If you copy 
or move the selection set, you could create a duplicate title block, or inadvertently 
move the title block off the schematic page. 

To deselect objects 

~ Click on an area where there are no objects. Selected objects become deselected. 
Note that a part occupies a rectangular area encompassing all its graphics. This 
means that a part may occupy a larger area than is initially apparent. 

To remove one object from a selection set 

~ Place the pointer over the object, press CTRL, and click the left mouse button. 

Fb Note To select from objects stacked atop one another, position the pointer over 
the stack of objects and press the TAB key while you click the left mouse button. 
This cycles through the objects in the stack. 

Grouping objects 

Use the Group command on the Edit menu to group multiple objects into one 
selectable object. This is a convenient way to maintain the relationship among 
several objects while moving them to another location. You can nest groups, 
meaning a group can contain other groups as well as objects. The Group command is 
only available when multiple objects are selected. 

Fb Note Objects remain grouped until you ungroup them or close all windows on 
the schematic page or part that contains them. 

To group multiple selected objects 

1 Select the objects you want to group, as described in the previous section. 

2 From the Edit menu, choose Group. You can move the objects as a group. 

3 When you are through manipulating the objects as a group, you can ungroup 
them. From the Edit menu, choose Ungroup. 
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Each object has a set of properties, and you can edit the value associated with each 
property. For some objects (parts, packages, hierarchical blocks, pins, nets, and 
buses), you can add your own user-defined properties. 

Fb Note You cannot add user-defined properties to graphic objects, bookmarks, 
IEEE symbols, no-connect symbols, net aliases, power and ground symbols, off­
page connectors, or bus entries. 

Properties can be used to store information, such as a part's value or reference. They 
can also be used to define the appearance of an object. For example, properties are 
used to define the color, line weight, and fill of graphic objects. 

For some objects-such as wires, buses, lines, ellipses, rectangles, and so on-you 
can edit the object's size and shape by clicking on it and dragging its resize handles. 

Editing properties 

Capture uses properties to describe objects. A property consists of a property name 
(for example, Part Value or Part Reference) and a property value (for example, 
TIP3! C or Q2). 

m See For a sample listing showing property names and property values, see 
Capture's online help topic Bill of Materials sample report file. Each type of 
object (text, wire, and so on) has its own set of properties. For information about 
editing specific properties of an object, see Capture's online help topic Editing 
properties. 

To edit an object's properties 

1 Double-click on the object. A dialog box containing properties for the object 
displays. 

2 Edit the properties, then choose the OK button. 

or 

1 Click on the object to select it. 

2 From the Edit menu, choose Properties (ALT, E, I). A dialog box containing 
properties for the object displays. 

3 Edit the properties, then choose the OK button. 
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Using the spreadsheet editor to edit properties 

The properties of a group of objects can be edited using the spreadsheet editor. In the 
spreadsheet editor, you can edit: 

• Multiple parts 

• Pins on parts 

• Hierarchical ports 

• Hierarchical pins 

• Wires 

• Buses 

• Nets 

• Off-page connectors 

• DRC markers 

• Bookmarks 

• A set of objects selected from the Browse window 

To edit an object's properties using the spreadsheet editor 

1 Select the group of objects, as described earlier in this chapter. 

2 From the Edit menu, choose Properties (ALT, E, I). Note that if the objects in the 
selection set are not ofthe same type, the Properties command is unavailable. 

The spreadsheet editor displays. You can use the spreadsheet editor to: 

• Click the left mouse button to select a cell for copying or pasting. Double­
click to select the cell for editing. 

• Click on a row or column heading to select the entire row or column. 

• With one or more cells selected, press and hold the SHIFT key while you 
click on an adjacent cell to extend the selection set. 

• Choose the New button to display the New Property dialog box. Enter the 
property name. If you want all members of the current selection set to have 
a particular value, enter the value also. 

3 Choose the OK button to close the spreadsheet editor. 

~ Tip To assign a cell's value to all ofthe cells within the same column in the 
spreadsheet editor, select a cell's value, choose Copy, select the entire column, and 
choose Paste. 
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Adding user-defined properties 

You can add user-defined properties to electrical objects. For example, if you want 
to include the name of the supplier, you create a user-defined property for the 
information. You can add as many user-defined properties as you like, edit them as 
described in the section Editing properties, make them visible or invisible using the 
Display Properties dialog box (choose the Display button in the User Properties 
dialog box), and remove them if you no longer need them. 

Fb Note You cannot add user-defined properties to graphic objects, bookmarks, 
IEEE symbols, no-connect symbols, net aliases, power and ground symbols, off­
page connectors, or bus entries. 

If you add a user-defined property to one part in a homogeneous package (multiple 
parts that are graphically identical), all parts in the package inherit the property and 
its value. If you add a user-defined property to one part in a heterogeneous package 
(multiple parts that are graphically different or contain different numbers of pins), 
the other parts in the package are not affected. You can also edit properties on 
multiple-part packages, in which case the changes appear on every part in the 
package, and on every part instance. You cannot add user-defined properties to 
packages. 

To add a user-defined property 

1 Select an object. 

2 From the Edit menu, choose Properties. An appropriate dialog box, such as the 
Edit Part dialog box, displays. 

3 Choose the User Properties button. The User Properties dialog box displays. 

4 Choose the New button. The New Property dialog box displays. 

5 Enter a name and a value for the new property, then choose the OK button three 
times to close all the dialog boxes. 

You can include a user-defined property in a netlist or a Bill of Materials report by 
specifying its property name, in curly braces, in a combined property string. 

m See For information about using combined property strings, see Capture's 
online help. 
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Moving and resizing graphic objects 

Before you can move or resize a graphic object, you must first select it. A selected 
object has resize handles that you use to change the size of the graphical object. 

To resize and move objects 

1 Select the object to resize or move. 

2 To resize the object, press the left mouse button on a resize handle, and drag the 
handle until the object is the size you would like it. Release the mouse button. 
or 
To move the object, press the left mouse button anywhere on the object-except 
on a resize handle-and drag the object until it is where you want it. Release the 
mouse button. 

3 To deselect the object, click in an area where there are no parts or objects. 

m See also For descriptions of other ways to manipulate objects, see Chapter 8: 
Adding and editing graphics and text. 

Undoing, redoing, and repeating an action 

You use the Undo command to undo your action. To repeat an edit action, use the 
Repeat command. For example, you might move a selected object five grid units, 
then realize you also need to move a different object the same distance. Select the 
second object, then from the Edit menu, choose the Repeat command. You can use 
the Undo, Redo, and Repeat commands with the following actions: 

• Placing objects 

• Deleting objects (except for the Repeat command) 

• Copying objects 

• Moving objects 

• Resizing objects 

• Rotating objects 

• Mirroring objects 

To undo an action 

~ From the Edit menu, choose Undo. 

To undo an Undo command 

~ From the Edit menu, choose Redo. 
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To repeat a command 

1 Perform the command once. 

2 From the Edit menu, choose Repeat. 

~ Tip You can use the Repeat command to align objects or to quickly create 
repetitive structures such as buses. 

To repeat a place operation 

1 Place an object on a schematic page. 

2 Press CTRL and drag the object to a new location. This creates a copy of the 
object. Leave the object selected. 

3 From the Edit menu, choose Repeat. The pointer repeats the relative move in 
step 2 and an additional object is placed. 
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Starting a project 

All the schematic folders and schematic pages in a design, as well as libraries, 
VHDL files, and output reports for a project are stored in a single file that has an 
.OPJ extension. A project contains one or more schematic folders, in which one or 
more schematic pages are stored. A project also contains a design cache, which is 
like an embedded library-it contains a copy of all the parts and symbols used on the 
schematic pages. 

Fb Note Parts reside in a library the same way schematic pages reside in schematic 
folders. Symbols and title blocks also reside in libraries. A project can use any 
number of libraries, and a library can be included in any number of projects. 
However, a project may have only one design (.DSN). 

Creating new designs, libraries, and VHDL files 

You can create new designs, libraries, and VHDL files. 

To create a new design 

1 From the File menu, choose New, then choose Design. 

2 The design opens in the project manager and a new schematic page displays. 

To create a new library 

1 From the File menu, choose New, then choose Library. 

2 The library opens in the project manager and a Library Cache folder is added to 
the project manager. 

m See For information on how to create parts for inclusion in a library, see 
Chapter 12: Creating and editing parts. 

To create a new VHDL file 

1 From the File menu, choose New, then choose VHDL File. 

2 The VHDL file opens in Capture's text editor. 

DrCAD Capture for Windows User's Guide 33 



Part 1 Capture basics 

To create a VHDL file and add it to a project 

1 From the project manager's Design menu, choose New VHDL File (ALT, D, v). 
The file opens in the text editor, and a dialog box asking if you want to add the 
file to the project displays. 

2 Choose the Yes button. The Save As dialog box displays. 

3 Select a directory for the file and supply a filename. By default, the VHDL file's 
name is VHDLn.VHD (where n is an integer). 

4 Choose the Save button. The file is saved and put into the project's Design 
Resources folder. 
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Opening files 

You can open an existing design, library, project, or VHDL file. 

~ Tip The four files that were last opened are listed at the bottom of the File menu. 
To open one of these files, select it from the File menu. 

To open an existing design 

1 From the File menu, choose Open, then choose Design. The Open Design dialog 
box displays. 

2 Select a design (.DSN) or type a name in the File name text box, then choose the 
Open button. The design opens in the project manager. 

To open an existing library 

1 From the File menu, choose Open, then choose Library. The Open Library 
dialog box displays. 

2 Select a library (.OLB) or type a name in the File name text box, then choose 
the Open button. The library opens in the project manager. 

To open an existing project 

1 From the File menu, choose Open, then choose Project. The Open Project dialog 
box displays. 

2 Select a project (.OPJ) or type a name in the File name text box, then choose the 
Open button. The project opens in the project manager. 

To open an existing VHDL file 

1 From the File menu, choose Open, then choose VHDL File. The Open VHDL 
File dialog box displays. 

2 Select a VHDL file (.VHD) or type a name in the File name text box, then 
choose the Open button. The VHDL file.opens in Capture's text editor. 

DrCAD Capture for Windows User's Guide 35 



Part 1 Capture basics 

Working with files in a project 

Using the project manager, you can add or delete project files. 

To add a file to your project 

1 In the project manager, select the folder to which you want to add a file. 

2 From the Edit menu, choose Project (ALT, E, R). The Add File to Project Folder 
dialog box displays. 

3 Select the file you want to add and choose the Open button. The file is added to 
the project. 

Or 

~ Drag the file from the Windows Explorer into the folder in the project manager. 

R:J Note You can also add files to your project interactively. When you create a 
design using the New command on the File menu, it is placed in the project 
manager's Design Resources folder. Note, however, that your project can include 
only one design (.DSN) file. If you try to add a second .DSN file to your project, 
the Overwrite dialog box displays, asking if you want to replace the existing design. 

To delete a file from a project 

1 In the project manager, select the file you want to delete. 

2 Press the DELETE key. The file is removed from the project. 
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Saving projects, designs, and libraries 

When the project manager window is active, you can save a new or existing project, 
design, or library. The Save command saves all open documents referenced by the 
project, as well as the project itself. 

The Save As command saves files depending on what you have selected in the 
project manager. 

• 

• 

a 

If one or more designs or libraries are selected, you are prompted to save each 
file in turn. 

Ifno top-level folders (Design Resources or Outputs) are selected, and items 
other than designs or libraries are selected, the Save As command is 
unavailable. 

Ifno designs or libraries are selected in the project manager, you are prompted 
to save the project. 

m See To protect your work in the event of a system crash or power outage, you 
can enable Autosave, and set the interval at which your design, library, or VHDL 
file is saved. For information about the Autosave option, see Setting miscellaneous 
options in Chapter 4. 

To save a new design or library 

With the design or library selected in the project manager, from the File menu, 
choose Save (ALT, F, s). The Save As dialog box displays. 

2 Enter a name for the design or library in the File name text box, specifY a 
location, then choose the Save button. 

The design or library is saved, and the project manager remains open. 

Fb Note If you choose Save when a schematic page window is active, only that 
page's design is saved, not the entire project. However, when you attempt to close 
the project, a dialog box asks if you want to save any project files that have been 
edited but not yet saved. 

To save an existing project 

~ From the File menu, choose Save (ALT, F, s). 

The project is saved, and remains open in the project manager. 
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Closing a project 

When the project manager window is active, you can close a project without quitting 
Capture, or you can close and save your project as you quit. 

To close a project 

~ From the project manager's File menu, choose Close Project (ALT, F, c). 

When you close a project, a dialog box displays, asking if you want to save your 
changes. 

To quit Capture 

~ From the project manager's File menu, choose Exit (ALT, F, x). 

When you choose the Exit command, a dialog box displays, asking if you want to 
save your changes. 
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Setting up your project 

Capture provides different levels of configuration. Using commands on the Options 
menu, you can: 

• Customize the working environment specific to your system (using 
Preferences). 

a Create default settings for new designs (using Design Template). These settings 
stay with the design even if it is moved to another system with different 
preferences. 

• Override settings in individual designs (using Design Properties) or individual 
schematic pages (using Schematic Page Properties). 

Regardless of which Capture window is active, the Options menu has a Preferences 
command and a Design Template command. In addition, the Options menu contains 
commands specific to the current active window. For example, the project manager's 
Options menu contains the Design Properties command, while the schematic page 
editor's Options menu contains the Schematic Page Properties command. 

The settings in the Preferences dialog box determine how Capture works on your 
system, and persist from one Capture session to the next because they are stored in 
the Capture initialization (.INI) file on your system. If you pass projects to others, 
they won't inherit your Preferences settings. This means that you can set colors, grid 
display options, pan and zoom options, and so on to your liking and be assured that 
your settings will remain, even if you work on a project created on another system. 

The Design Template dialog box determines the default characteristics of all the 
projects created on your system. Because a new project inherits characteristics from 
the current Design Template settings, it's a good idea to check the settingS before 
you create a new project. . 

Once you begin working on a project, you can customize its particular characteristics 
by choosing Design Properties from the Options menu when you are in the project 
manager, or Schematic Page Properties when you are in the schematic page editor. 
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Defining your preferences 

The options that you define in the tabs of the Preferences dialog box affect how 
Capture works with your projects. 

• ColorslPrint. Set up colors for objects such as off-page connectors, hierarchical 
blocks and ports, text, title blocks, and so on, and specifY which objects will be 
printed or plotted. You can also change the background color and the color of 
the grid. 

• Grid Display. Select dots or lines for your grid, and whether to display or print 
your grid. You can select whether to have your pointer snap to grid as you place 
objects. You can set these options independently for the schematic page editor 
and the part editor. 

• Pan and Zoom. Define how you want autoscrolling to work, and what the 
zoom factor should be. You can set these options independently for the 
schematic page editor and the part editor. 

• Select. Define whether you want to select objects enclosed by a selection 
rectangle or objects intersecting a selection rectangle, the maximum number of 
objects to display at high resolution while dragging, and whether to show the 
tool palette. You can set these options independently for the schematic page 
editor and the part editor. 

• Miscellaneous. Define the default fill, line style and width, and color for 
graphic objects, define the font used in the project manager and session log, 
render TrueType fonts with strokes (for printing and plotting), and set whether 
to autos ave your project and how often. In addition, you can enable intertool 
communication, which is the method that Capture uses to communicate with 
other OrCAD software, such as OrCAD Layout for Windows. 

• Text Editor. Define which (if any) VHDL keywords are highlighted, and the 
font and tab settings used within the text editor. 
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Defining colors/print options 

You control the color in which different schematic page objects display by using the 
ColorslPrint tab in the Preferences dialog box. 

Fb Note The color that you select for Title Block is also the color used for borders 
and grid references. 

If an object's Print box is checked, the object is printed or plotted. Clicking on a 
check box toggles its check mark on or off. Objects are always displayed on your 
screen, regardless of the setting of their check boxes. 

Preferences EJ 
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To define an object's color 

1 From the Options menu, choose Preferences (ALT, 0, p), then choose the 
ColorslPrint tab. 

2 Click on the color of an item. The color palette window opens. 

3 Select a new color. Choose the OK button to dismiss the color palette. 

4 Choose the OK button. 

Fb Note The color that you select for Graphics defines the color for lines, 
polylines, and arcs drawn in the schematic page editor, and for all graphics drawn 
in the part editor. If you change the Color option in the Miscellaneous tab, then 
rectangles, ellipses, and closed polyline shapes that you draw in the schematic 
page editor are created in that color. Lines, polylines, and arcs, however, are 
drawn in the color you chose for Graphics in the ColorslPrint tab. 
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Controlling the grid 

You can control whether Capture displays or prints a grid independently in the 
schematic page editor and the part editor, and whether the grid uses dots or lines. 
You can also specifY whether the pointer snaps to grid in each editor. 

fii'~ Caution If you disable the Pointer snap to grid option while you are drawing, 
be sure to enable it before you place electrical objects. Otherwise, your part pins 
may be placed off-grid, making it difficult to connect them properly. 

To control the grid 

1 From the Options menu, choose Preferences (ALT, 0, p), then choose the Grid 
Display tab. 

2 For the schematic page editor and the part editor, specifY: 

• Whether to display the grid, print the grid, or both. 

• Whether the grid uses dots or lines. 

• Whether the pointer snaps to grid as you place objects. 

3 Choose the OK button. 

~ Tip You can also show or hide the grid using the Grid command on the View 
menu in the schematic page editor or the part editor. 
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Setting pan and zoom 

When you have an object attached to the pointer and you move the pointer near the 
edge of the window while holding the left mouse button down, the display changes 
to a different region of the document. This change is called panning. The display 
automatically pans only if you have an object attached to the pointer and you hold 
the left mouse button down; otherwise, you must use the window's scroll buttons to 
view a different region of the document. You configure the percent by which the 
display changes using the Auto Scroll Percent setting. 

When you zoom in or out, the view changes by the zoom factor. You can define pan 
and zoom settings for the schematic page editor and the part editor. 

Preferences ~ 

,Schematic Page Editor 
I.' . 

I: Zoom Factor. 
i 
;. Auto S,CloB Percent 

'1. ... :.... 

! 
r-· .. I 

rPartilhdSymbol Editor 

zoOm faclor: 

15i : •. mm;.Jj'm_;~:~:;~~~:r ··ml~.m.J. 

To configure zoom factor and auto scroll percent 

1 From the Options menu, choose Preferences, then choose the Pan and Zoom tab. 

2 For the schematic page editor and the part editor, set these options: 

• Zoom Factor. Enter a number to indicate the magnification or reduction of 
the objects shown in the window when you zoom in or zoom out. 

• Auto Scroll Percent. Enter the percent of the window's horizontal or 
vertical dimension by which the display will scroll. 

3 Choose the OK button. 
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Defining selection options 

You can specify whether objects are selected when the selection border intersects 
them or if the objects are selected only when they are completely enclosed in the 
selection area. You can also change the maximum number of objects displayed at 
high resolution while dragging, and set tool palette visibility in both the schematic 
page editor and the part editor. 

To define selection options 

1 From the Options menu, choose Preferences (ALT, 0, p), then choose the Select 
tab. 

2 For the schematic page editor and the part editor, set these options: 

• Area Select. Specify whether to select objects that are intersecting the 
selection border or only objects that are fully enclosed by the selection 
border. 

• Maximum number of objects to display at high resolution while 
dragging. If you drag more objects than you specify here, you will see 
rectangular placeholders for the objects as you drag them. 

• Show Palette. Select this check box to make the tool palette visible; 
desdect it to make the tool palette invisible. 

3 Choose the OK button. 
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Setting miscellaneous options 

You can specifY the default fill, line style and width, and color for graphic objects, 
define the font used in the project manager and session log, render TrueType fonts 
with strokes (for printing and plotting), and set whether to autosave your project and 
how often. In addition, you can enable intertool communication, which is the method 
that Capture uses to communicate with other OrCAD software, such as OrCAD 
Layout for Windows. 

Fb Note You can change the fill style, line style and width, and color on graphic 
objects on an individual basis once they are drawn on a schematic page. Select the 
object, then from the Edit menu, choose Properties. For specific instructions, see 
Chapter 8: Adding and editing graphics and text. 

m See For information about intertool communication between Capture and 
Layout, see Chapter 18: Using Capture with OrCAD Layoutfor Windows. 

For information about intertool communication between Capture and Simulate, see 
Chapter 19: Using Capture with OrCAD Simulatefor Windows. 

The text rendering options affect how text on a schematic page appears on your 
screen, and how it is printed or plotted. The Render True Type fonts with strokes 
option displays text as a series oflines, connected to resemble the outlines of the 
corresponding True Type letters or numbers they represent. Enabling the Fill text 
option causes the text outlines to be filled in. 

~ Tip The Render TrueType fonts with strokes opt~on produces text that is printed 
or plotted quickly, but is not as aesthetically pleasing as TrueType text. For this 
reason, you may want to enable the option when you print or plot drafts of your 
schematic pages, then disable the option when you print or plot the final versions 
of your schematic pages. 

To protect your work in the event of a system crash or power outage, you can enable 
Autosave, and set the interval at which your design, library, or VHDL file is saved. 
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To set miscellaneous options 

1 From the Options menu, choose Preferences (ALT, 0, p), then choose the 
Miscellaneous tab. 

2 For the schematic page editor and the part editor, set these options: 

• Fill Style. Select the fill pattern to be used when drawing rectangles, 
ellipses, and closed shapes drawn with the polyline tool. 

• Line Style and Width. Select the line style and width used for lines, 
polylines, rectangles, ellipses, and arcs. 

3 For the scl1ematic page editor, set this option: 

• Color. Select the color used for rectangles, ellipses, and closed polylines. 

Fb Note The Default color is the color defined in the Graphics box in the 
ColorslPrint tab in the Preferences dialog box. 

The color for lines, polylines, and arcs drawn in the schematic page editor is 
defined in the Graphics box in the ColorslPrint tab in the Preferences dialog box. 

4 Set the following options: 

• Project Manager and Session Log. Select a font for display text in the 
project manager and session log. If you select this option, a standard 
Windows dialog box for font selection displays. Select a font, style, and 
size from the dialog box, then choose the OK button. 
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• Text Rendering. Select whether to enable rendering True Type fonts with 
strokes and, if so, whether to fill the strokes. 

• Autosave. Select whether to autosave your project and, if so, the interval 
between saves. You can specifY any interval between 1 minute and 720 
minutes. When the time interval is up, any design, library, or VHDL file in 
your project that hasn't been saved, or has been modified since the last 
save, is saved as a temporary file (with an .ASP extension) in the 
WINDOWS/TEMP/AUTOSAVE directory. When you close your project 
normally, the IAUTOSAVE directory and temporary files are deleted. In 
cases of power outages or system crashes, however, the temporary files are 
saved. When you restart Capture, it loads the auto saved files, showing 
"Restored" in their title bars. You must use the Save As command and 
provide a filename to have an autosaved file overwrite the original file. 

• Intertool Communication. Select whether to enable intertool 
communication (also known as lTC), so that you can test and display 
design information using other OrCAD software (such as Layout) in 
conjunction with Capture. 

S Choose the OK button. 
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Setting text editor options 

Capture's text editor options include automatic highlighting ofVHDL keywords, 
comments, or quoted strings. You can also set the font, the tab spacing, and enable 
or disable the highlighting feature. 

To set text editor options 

1 From the Options menu, choose Preferences (ALT, 0, p), then choose the Text 
Editor tab. 

2 Set these options: 

• Syntax Highlighting. Select the color to use to highlight VHDL keywords, 
comments, and quoted strings. You can choose a different color for each. 

• Current Font Setting. Choose the Set button to change the font setting for 
the text editor to values other than those displayed. 

• Tab Spacing. Set the tab spacing for the text editor. 

3 Check the Highlight Keywords, Comments, and Quoted Strings option to have 
those VHDL items highlighted in the text editor. The colors used to highlight 
these items are the ones set in the Syntax Highlighting group box. 

4 Choose the OK button. 
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Setting up your project template 

The options that you define in the Design Template dialog box are the default 
settings for all new projects, and for schematic pages you add to an existing project. 
You can override some of these options for individual projects or schematic pages. 
Some of the things you can define in the Design Template dialog box are: 

II Fonts. You can define the fonts for schematic page objects that contain text, 
such as part references and values. 

II Title Block. You can specify the text to appear in title block fields, as well as 
the path and filename of the library containing the title block. This affects new 
projects, as well as new schematic pages in existing projects. 

II Page Size. You can specify whether inches or millimeter~ are used as the unit of 
measure, the width and height of a schematic page, and the spacing between 
pins. 

II Grid Reference. For horizontal and vertical grid references, you can set the 
number of grid references to display in either direction, whether the grid 
references are alphabetic or numeric, whether they increment or decrement 
across the schematic page, and how wide grid reference cells are. You can also 
make the border, grid references, and title block visible or invisible. This affects 
new projects, as well as new schematic pages in existing projects. 

II Hierarchy. For hierarchical blocks and part instances that have their Primitive 
property set to Default, you can specify if you want Capture to treat each as 
primitive (cannot descend into attached schematic folders) or nonprimitive (can 
descend into attached schematic folders). 

II SDT Compatibility. You can specify which Capture properties map to which 
SDT part fields when saving a project in SDT format. 
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Setting up fonts for new projects 

You can define the fonts assigned to the text associated with different schematic 
page objects in new designs. The fonts specified here do not affect existing designs. 

R:J Note To change the fonts for an existing project, use the Fonts tab in the Design 
Properties dialog box. You can access this dialog box by choosing Design 
Properties from the project manager's Options menu. 

To assign fonts used for new designs 

1 From the Options menu, choose Design Template (ALT, 0, D), then choose the 
Fonts tab. 

2 Click the left mouse button on the font of an item. A standard Windows font 
dialog box displays. 

3 Select a font, font style, and size. Choose the OK button to dismiss the font 
dialog box. 

4 Choose the OK button. 

R:J Note The default fonts were selected for optimal compatibility with SDT. 
Changing these fonts may result in less optimal text sizes for translated projects. 
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Defining title block information 

There are two types oftitle blocks: default and optional. 

• You specifY the information that goes into the default title block in the Title 
Block tab of the Design Template dialog box. Capture places a default title 
block in the lower right comer of each schematic page (if a library and title 
block name are specified), and places the information you enter in the text fields 
in the Title Block tab into the title block. This information is also used in reports 
created by the commands on the Tools menu. This affects new projects, as well 
as new schematic pages in existing projects. You can set the default title block 
to be visible or invisible on an existing schematic page by changing the setting 
in the Grid References tab in the Schematic Page Properties dialog box. 

• You can place any number of optional title blocks anywhere on the schematic 
page using the Title Block command on the Place menu. Optional title blocks 
display information that you define as property values for the title block symbol. 

Capture provides default title block symbols in the CAPSYM.OLB library. One such 
title block is shown below. The text shown in curly braces acts as property text 
placeholders. You can specifY the value by double-clicking on the text and 
supplying a value. You can control the visibility by selecting or deselecting the 
Visible check box in the Display Properties dialog box. 
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To choose a title block and define the text it contains 

1 . From the Options menu, choose Design Template (ALT, 0, D), then choose the 
Title Block tab. 

2 In the Text group box, enter the information you want to appear in the title 
block. 

3 In the Symbol group box, enter the path and filename of the library containing 
the title block, and enter the name of the title block. 

4 Choose the OK button. 

~ Tip You can create custom title blocks and store them in a library using the New 
Symbol command from the project manager's Design menu. If you specify the 
name of the custom library and title block in the Symbol group box of the Design 
Template's Title Block tab, then the custom title block appears in the lower right 
comer of each schematic page. See Capture's online help for specific instructions. 
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Setting the schematic page size for new projects 

For new projects, you can specify the default unit of measure, the default width and 
height of schematic pages, and the spacing between pins. The value you enter in the 
Pin-to-Pin Spacing text box defines how close together pins are placed in the part 
editor. It also defines the grid spacing (the space between grid dots or grid lines). 

RJ Note You can select a different unit of measure or page size (A, B, C, D, E, and 
Custom if the unit of measure is Inches; or A4, A3, A2, AI, AO, and Custom if the 
unit of measure is Millimeters) for individual schematic pages in existing projects 
using the Page Size tab in the Schematic Page Properties dialog box (choose 
Schematic Page Properties from the schematic page editor's Options menu). 

DeSign Template E3 

To set up the schematic page size 

1 From the Options menu, choose Design Template (ALT, 0, D), then choose the 
Page Size tab. 

2 In the Units area, select the default unit of measure for new projects. This 
setting only affects the schematic page editor, not the part editor. 

ff7r. Caution Changing from Inches to Millimeters resets the page sizes to their 
defaults; therefore, if you make any changes to the standard page size dimensions, 
then change the units, the page size changes are not translated between the two 
types of units. 

OrCAD Capture for Windows User's Guide 53 



Part 1 Capture basics 

3 Select the default schematic page size for new projects. For each schematic page 
size (A, B, C, D, E, and Custom if the unit of measure is Inches; or A4, A3, A2, 
AI, AO, and Custom if the unit of measure is Millimeters) you can specifY the 
width and height. The values that you enter in the Width and Height text boxes 
become the dimensions for each page size. You cannot change these dimensions 
for individual schematic pages, although you can select a different page size. 

4 In the Pin-to-Pin Spacing text box, specifY the default spacing between pins. 
The value you enter in this text box defines how close together pins are when 
you place them on a part in the part editor. It also defines the grid spacing (the 
space between grid dots or grid lines). You cannot change this value for existing 
projects or individual schematic pages. 

5 Choose the OK button. 
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Defining the grid reference 

You set grid references to display either horizontally or vertically, whether they are 
alphabetic or numeric, whether they increment or decrement across the schematic 
page, and the width oftheir cells. You can also make the border, grid references, and 
title block visible or invisible on the screen and on schematic pages you print. The 
settings affect new projects and new schematic pages in existing projects. 

Fb Note You can change these settings for existing schematic pages. Choose 
Schematic Page Properties from the schematic page editor's Options menu, then 
choose the Grid Reference tab in the Schematic Page Properties dialog box. 
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To define the grid reference 

1 From the Options menu, choose Design Template (ALT, 0, D), then choose the 
Grid Reference tab. 

2 Specify the number of grid references, whether they are alphabetic or numeric, 
whether the grid references increment (Ascending) or decrement (Descending) 
across the schematic page, and how wide the grid reference cells are. 

3 For the border, title block, and grid reference, select Displayed to have the item 
display on the screen or Printed to have the item appear on schematic pages you 
print. Select ANSI grid references to display the grid references in accordance 
with ANSI standards (see the glossary entry ANSI). 

4 Choose the OK button. 
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Defining the default hierarchy option for new projects 

For hierarchical blocks and part instances that have their Primitive property set to 
Default, you can specify if you want Capture to treat each as primitive (cannot 
descend into attached schematic folders) or nonprimitive (can descend into attached 
schematic folders). The Primitive and Nonprimitive options in the Hierarchy tab of 
the Design Template dialog box only affect new projects. 

Fb Note You can change this option for existing projects using the Hierarchy tab in 
the Design Properties dialog box. You can access this dialog box by choosing 
Design Properties from the project manager's Options menu. 

Note that this setting affects how the options on the Tools menu process projects. 

To define the default hierarchy option 

1 From the Options menu, choose Design Template (ALT, 0, D), then choose the 
Hierarchy tab. 

2 For hierarchical blocks and parts, select Primitive or Nonprimitive. All 
hierarchical blocks and part instances that have their Primitive property set to 
Default will use the setting selected here. 

3 Choose the OK button. 
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Setting up compatibility with OrCAD's Schematic Design Tools 

You can specify which properties Capture stores in the eight SDT part fields when 
saving a project in SDT format. 

Fb Note You can also use the fields for mapping netlists that use part field 
information. For information on creating these types ofnetlists and the cpmbined 
property strings they require, see Capture's online help. 

In the dialog box shown below, the part fields listed on the left are SDT's part fields. 
The text boxes on the right are used to specify which of Capture's properties map to 
the part fields in SDT. The options in the SDT Compatibility tab of the Design 
Template dialog box only affect new projects. 

Fb Note To change the part field to property mapping for existing projects, use the 
SDT Compatibility tab in the Design Properties dialog box (from the project 
manager's Options menu, choose Design Properties). 
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To set up compatibility with OrCAD's Schematic Design Tools 

1 From the Options menu, choose Design Template (ALT, 0, D), then choose the 
SDT Compatibility tab. 

2 For each SDT part field, specify the Capture property to be placed in the part 
field when you save a Capture project in SDT format. 

3 Choose the OK button. 
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Changing properties of existing projects 

When you create a new project, it uses the options defined in the Design Template 
dialog box. You can set the options on existing projects using the Design Properties 
dialog box (from the project manager's Options menu). The options are: 

• Fonts. You can define the fonts for schematic page objects that contain text, 
such as part references and part values. 

• Hierarchy. You can specify hierarchical blocks and part instances whose 
Primitive property is set to Default be treated as primitive (cannot descend into 
attached schematic folders) or nonprimitive (can descend into attached 
schem~tic folders). . 

• SDT Compatibility. You can specify which Capture properties map to which 
SDT part fields when saving a project in SDT format. 

• Miscellaneous. You can view the project name, root schematic folder name, 
creation time, and modification time. Also, if you need to see the power pins on 
a schematic page for documentation or debugging purposes, you can display 
them on the screen. 

W See You can override other Design Template options (page size and grid 
reference) using the Schematic Page Properties dialog box. For further information, 
see Changing properties of existing schematic pages. 

Assigning fonts 

Fonts are assigned to new projects using the Fonts tab in the Design Template dialog 
box. You can change fonts for individual projects using the Fonts tab in the Design 
Properties dialog box (choose Design Properties from the project manager's Options 
menu). See Setting up fonts for new projects in this chapter for more information. 

Defining hierarchy 

The behavior for hierarchical blocks and part instances whose Primitive property is 
set to Default (whether to act as primitive or nonprimitive) is defined for new proj ects 
using the Hierarchy tab in the Design Template dialog box. You can change this 
behavior for individual projects using the Hierarchy tab in the Design Properties 
dialog box (choose Design Properties from the project manager's Options menu). See 
Defining the default hierarchy option for new projects in this chapter for more 
information. 
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Using Capture with SDT 

The mapping of Schematic Design Tools to Capture properties for new projects is 
defined using the SDT Compatibility tab in the Design Template dialog box. You 
can change this mapping for individual projects using the SDT Compatibility tab in 
the Design Properties dialog box (choose Design Properties from the project 
manager's Options menu). See Setting up compatibility with DreAD's Schematic 
Design Tools in this chapter for more information. 
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Viewing invisible power pins without isolating them 

Nonnally, power pins are invisible, and thus global. Selecting the Display Invisible 
Power Pins (for documentation purposes only) option in the Miscellaneous tab will 
display the pin~ on the screen, and they will still be considered global. However, you 
can only view the power pins-you cannot connect to them. 

Fb Note To be able to connect wires and other electrical objects to power pins, you 
must make them visible on the part or instance. Select the part and then, from the 
Edit menu, choose Properties. Select the Power Pins Visible option and choose the 
OK button. If you connect a wire or other electrical object to a power pin made 
visible by this method, that pin is isolated from the global net. 

DeSign Properties l3 

Fonts I Hierarchy I SDT Compa6biiiy . Miscel~oU$1 

Design Name: 

Root Schematic Name: 

Creation Time: 

Modiication Time: 

C:\tAPTURE\SAMPLES\FUUADD.DSN 

ThuJun 1l817:4ll:141995, 

Wed Mar 27 07:46:521996 . 

r Qisplay IfwisiJle Power Pins Uor documentation purposes onlY) 

OK· I' Cancel ·1 •. . f.o~ply Help 

To view invisible power pins without isolating them 

1 From the project manager's Options menu, choose Design Properties (ALT, 0, 
R), then choose the Miscellaneous tab. 

2 Select the Display Invisible Power Pins option. 

3 Choose the OK button. 
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Changing properties of existing schematic pages 

When you add a new schematic page, the options defined in the Design Template 
dialog box are used. You can override these options on existing schematic pages by 
using the options in the Schematic Page Properties dialog box. You access this 
dialog box by choosing Schematic Page Properties from the schematic page editor's 
Options menu. The options in the Schematic Page Properties dialog box are: 

• Page Size. You can specify the unit of measure and the page size. 

• Grid Reference. You can set the number of horizontal or vertical grid 
references to display, whether the grid references are alphabetic or numeric, 
whether they increment or decrement across the schematic page, and how wide 
the grid reference cells are. You can also make the border, grid references, and 
title block visible or invisible. 

• Miscellaneous. You can view information about the schematic page, such as 
creation time, modification time, and page number. 

m See You can override other Design Template options (fonts, hierarchy, and 
SDT compatibility) using the Design Properties dialog box. For further 
information, see Changing properties of existing projects. 

Changing page size 

F or existing schematic pages, you can change the unit of measure from Inches to 
Millimeters or select a different page size. Since the width and height for each page 
size (except Custom) and the pin-to-pin spacing are set in the Design Template Page 
Size tab, you cannot change these particular items in the Schematic Page Properties 
Page Size tab. You can access the Schematic Page Properties dialog box by choosing 
Schematic Page Properties from the schematic page editor's Options menu. See 
Setting the schematic page size for new projects in this chapter for more information. 

Setting up new grid references 

Horizontal and vertical grid references for new schematic pages are set up in the 
Grid Reference tab of the DesignTemplate dialog box. You can change these 
settings for existing schematic pages using the Grid Reference tab in the Schematic 
Page Properties dialog box (choose Schematic Page Properties from the schematic 
page editor's Options menu). See Defining the grid reference in this chapter for 
more information. 

OrCAD Capture for Windows User's Guide 61 



Part 1 Capture basics 

Viewing miscellaneous schematic page properties 

The Miscellaneous tab in the Schematic Page Properties dialog box displays the 
creation time and the last modification time of the schematic page, as well as the 
page number. 

To view miscellaneous schematic page properties 

1 From the schematic page editor's Options menu, choose Schematic Page 
Properties (ALT, 0, E), then choose the Miscellaneous tab. 

2 When you are done viewing the information, choose the OK button. 
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ChapterS 

Printing and plotting 

To send output to a printer, a plotter, or an encapsulated PostScript® file, you use 
the standard Windows Print Setup, Print Preview, and Print dialog boxes. 

Fb Note Capture can send output to any print driver that Windows supports. For 
additional infonnation on print drivers, see the Windows docwnentation. 

The printing commands can be accessed from the File menu in the project manager, 
the schematic page editor, or the part editor. You can print schematic pages, parts, or 
packages. 

Configuring a printer or plotter 

~ From the File menu, choose the Print Setup command. Select an appropriate 
printer or plotter, or change the printer settings, then choose the OK button. 

m See To install and remove printers and plotters, and to set additional printing 
options, see the Windows docwnentation regarding the Windows Control Panel. 
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Printing or plotting schematic pages 

You can print or plot a schematic page, or several schematic pages, from the proj ect 
manager. With the schematic page editor active and open to a specific schematic 
page, you can create a print or a plot of that schematic page. 

To print or plot a schematic page or pages 

1 Activate the schematic page editor window for the page you want to print. 
or 
In the project manager, select the schematic page or pages. 

2 From the File menu, choose Print (ALT, F, p). The Print dialog box displays. 

3 Select the scale, print offsets, print quality, number of copies, and whether to 
print to file. 

4 Choose t!J.e OK button to send the image to the output device. 

Printing or plotting parts or packages 

With the part editor active and open to a specific part or package, you can create a 
print or a plot of that part or package. You can also print a library part from the 
project manager. 

To print or plot a part or package 

1 Select the part or package you want to print in the schematic page editor. 
or 
Select the library part in the project manager. 

2 From the right mouse button pop-up menu in the schematic page editor, choose 
Edit Part. The part appears in the part editor. 

3 From the part editor's View menu, choose Part to print a part or choose Package 
to print a package. 

4 From the File menu, choose Print (ALT, F, p). The Print dialog box displays. 

5 Select the scale, the print quality, and the number of copies. 

6 Choose the OK button to send the image to the output device. 
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Printing or plotting text editor windows 

With the text editor window active, you can create a print or a plot of the window. 

To print or plot a text editor window 

1 From the File menu, choose Print (ALT, F, p). The Print Range Selection dialog 
box displays. 

2 Select whether to print highlighted text or the entire file. 

3 Choose the OK button to send the image to the output device. 

Previewing printer or plotter output 

Using the Print Preview command, you can preview your schematic page, part, or 
package output to check its appearance before you commit it to paper. 

To preview a schematic page 

1 From the File menu, choose Print Preview (ALT, F, v). The Print Preview dialog 
box displays. 

2 Specity the values in the dialog box, then choose the OK button. The Print 
Preview display window opens with a display of your schematic page, part, or 
package. 

3 Use the Previous page and Next page buttons to look at other printer pages. 

4 To zoom in, move the magnifier pointer to a specific area and click the left 
mouse button. 

S Choose the Close button to close the Print Preview window. 
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Scaling printer or plotter output 

You can manually scale, or have Capture automatically scale, printer output and 
plots to fit the paper size you choose. 

To scale a print or a plot 

1 From the File menu, choose Print (ALT, F, p). The Print dialog box displays. 

2 Select one of the three options in the Scale box. 

• The Scale to paper size option scales each schematic page to fit a single 
sheet of paper (as configured in the printer driver). 

• The Scale to page size option scales each schematic page to the sheet size 
you select in the Page size area. The sheet size is configured in the Page 
Size tab in the Design Template dialog box. 

• The Scaling option scales your schematic page to a factor of your choice. 
The acceptable range off actors is 0.1 to 10.0; up to three decimal places are 
allowed. 

3 If you select the Scale to page size option in step 2, the Page size area becomes 
available. Select a sheet size. This results in multiple sheets of paper if you 
select a sheet size larger than your printer paper. 

4 Choose the OK button to send the image to the output device. 
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Special considerations for plotting 

Many plotters do not support bitmaps directly. If you are sending Capture output to a 
plotter, your bitmaps may not be plotted. 

Plotter pen colors 

The plotter driver maps your color choice to the closest available pen color as 
established in your plotter driver configuration. See your plotter's driver setup and 
documentation for more details. 

m See The plotter setup dialog boxes are only accessible from the Windows 
Control Panel. See the Windows documentation regarding the Windows Control 
Panel. 

Many plotters do not have drivers that ship with Windows. If you do not see the 
plotter you are looking for in the list of available drivers, contact your plotter 
manufacturer and ask for a Windows driver. If your plotter emulates HPGL, an 
alternative solution is to use the HPGL driver. 
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Creating designs 

Part Two contains information relating to schematic design tasks. It provides 
instructions for setting up your design environment, adding parts and graphics to 
your design, using macros, and navigating ~ound in your design. Part Two includes 
these chapters: 

Chapter 6: Design structure describes how to customize the working environment 
specific to your system, how to create default settings for new designs, and how to 
override default settings in individual designs. 

Chapter 7: Placing, editing, and connecting parts and electrical symbols describes 
how to place and edit parts and symbols. It also describes how to connect the 
elements of your design using hierarchical blocks, hierarchical ports, off-page 
connectors, wires, and buses. 

Chapter 8: Adding and editing graphics and text describes the drawing tools you can 
use to add text and a variety of graphic shapes to your design. 

Chapter 9: Using macros describes 
how to create and run macros. 

Chapter 10: Changing your view of a 
schematic page describes how to 
view specific areas of a schematic 
page using the Zoom command. It 
also describes jumping to different 
locations within a schematic using 
the Location, Reference, and 
Bookmark commands. 

Part Two 





Chapter 6 

Design structure 

Many schematic designs can fit on one schematic page. Some designs, however, are 
too large for even the biggest page, and even if a complex design could fit on one 
page, there are good reasons for dividing it: 

• To fit at full scale on your printer's page. 

• To partition a design so that several people can work on it at once. 

• To develop the design using a top-down approach. That is, you may want to 
begin with a block diagram in which each block represents a major function and 
then construct more detailed diagrams for each ofthe blocks. 

• To organize your design by functional parts. 

Capture offers two ways of handling mUltiple-page designs: flat designs and 
hierarchical designs. 
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Flat designs 

Flat designs are practical for small designs with few schematic pages. A flat design 
is a structure in which the output lines of one schematic page connect laterally to the 
input lines of another schematic page in the same schematic folder through objects 
called off-page connectors. A flat design has no hierarchy (no hierarchical blocks, 
hierarchical ports, hierarchical pins, or parts with attached schematic folders). 

All schematic pages in a flat Schematic Page A Sohemmlo Page B Schematic Page C 

design are contained within 

" ~ 1 I· " ~ 1 I· a single schematic folder, « « 

and are on a single level, as 
shown at right. Flat design. 

SiIice you must manage all 
of the interconnections between the pages of a flat design using the names assigned 
to the off-page connectors, it is best to keep a flat design relatively small. 

In the project manager, a flat design displays 
as shown at right. 

SCHEMATlC1 
:IQI C1 (7UF) 
:IQI C2(1.5UF) 

:IQI R1 (15K) 

"IQI R2(10K) 
... IQI U1 (74ACT374) 

72 OrCAD Capture for Windows User's Guide 



Chapter 6 Design structure 

Hierarchical designs 

Instead of a flat design, you can create symbols on schematic pages that represent 
other schematic folders. These symbols are called hierarchical blocks. The layered 
arrangement created by placing schematic folders inside schematic pages is called a 
hierarchy. Any schematic page can contain hierarchical blocks (or parts with 
attached schematic folders) that refer to other schematic folders, and this nesting 
structure can be many levels deep. The schematic folder at the top ofa hierarchy, 
which directly or indirectly refers to all other schematic folders in the project, is 
called the root schematic folder. In the project manager, the root schematic folder 
has a backslash in its folder icon. The root schematic folder, as well as any other 
schematic folder, can contain as many schematic pages as are necessary. 

Simple hierarchical designs 

A one-to-one 
correspondence 
between hierarchical 
blocks (or parts with 
attached schematic 
folders) and the 
schematic folders they 
reference is called a 
simple hierarchy. The 
picture at right is an 
example of a simple 
hierarchy. 

In a simple hierarchy, 
each hierarchical block 
or part with an attached 

Schematic D 

Schematic A 

Schematic B Schematic C 

Schematic E Schematic F 

schematic folder represents a unique schematic folder. 
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In the project manager, a simple 
hierarchical design displays as shown at 
right. 
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Complex hierarchies 

A many-to-one correspondence between hierarchical 
blocks (or parts with attached schematic folders) and the 
schematic folders they reference is called a complex 
hierarchy. In the picture at right, schematic A references 
schematic B three different times. These references can be 
via hierarchical blocks or parts with attached schematic 
folders. 

Schematic A 

• 

In the project manager, a complex 
hierarchical design displays as shown 
at right. 

Schematic B 

iil.iiI complex.opj ROO EJ 
r. .Logical r Eh.l'slcal 

LJ File?~" Hierarchy 

t=i IQI SCHEMATIct>. 
IQI Hl (SCHEMATICB) 

IQI H3 (SCHEMATICC) 
IQI U2 (PARTB) 

F}' IQI U3 (HPART A) 
IQI U 1 (PARTX) 

:.IQI U 2 (PARTY) 

IQI U1(PARTA) 
I'>·IQI H2 (SCHEMATICD) 

I~j IQI Hl (SCHEMA TlCE) 
.IQI Ul (PARTC) 

... IQI U2 (PARTD) 

B·IQI H2 (SCHEMATICE) 
i"..1QI U 1 (PART C) 
i.1QI U2 (PARTD) 
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Connecting schematic folders and schematic pages 

In Capture, you connect schematic folders and schematic pages by extending nets 
between them using hierarchical blocks (or parts with attached schematic folders), 
hierarchical ports, hierarchical pins, and off-page connectors. Hierarchical blocks (or 
parts with attached schematic folders), hierarchical ports, and hierarchical pins carry 
signals between schematic folders and schematic pages, while off-page connectors 
carry signals between schematic pages within a single schematic folder. 

m See also For information about placing hierarchical blocks, hierarchical ports, 
hierarchical pins, and off-page connectors, see Chapter 7: Placing, editing, and 
connecting parts and electrical symbols. 

Hierarchical blocks 

Hierarchical blocks (or parts with attached 
schematic folders) refer to child schemat­
ics in a design, providing vertical 
(downward-pointing) connection only. 
Hierarchical pins in a hierarchical block, 
and hierarchical ports outside a hierarchi­
cal block, act as points of attachment for 
any connections between the hierarchical 
block and other electrical objects in an attached schematic folder. The picture at right 
shows hierarchical pins (X, Y, SUM, and CARRY) within a hierarchical block, and 
a hierarchical port (CARRY_IN) outside a hierarchical block. 

A part with an attached schematic folder functions like a hierarchical block, and pins 
on a part with an attached schematic folder function like hierarchical pins within a 
hierarchical block. You can use either method to define a hierarchy. The only 
difference between the methods is that a part with an attached sehematic folder can 
be reused. You can attach a schematic folder that is external to a project to a 
hierarchical block, but be aware that you won't be able to use any of Capture's tools 
to make changes to the external design. 

f/i~ Caution If you attach a schematic folder that is external to a project to a 
hierarchical block, be sure to include the schematic folder when you give the 
project to another engineer or to a board fabrication house. Attached schematic 
folders external to a project are not carried along automatically when you copy or 
move a schematic folder to another project. Only the name of the attached 
schematic folder is carried along. For this reason, you should copy all attached 
schematic folders into your project if you want your project to be "portable." 

Fb Note Before you create or resize a hierarchical block, make sure the Snap to grid 
option is turned on (from the schematic page editor's Options menu, choose 
Preferences). If the hierarchical block is off grid, then hierarchical pins inside it are 
also off grid-even if you change the Snap to grid setting before you place them­
and it may be difficult to connect to these off-grid hierarchical pins. 
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Hierarchical ports 

Hierarchical pins 

Hierarchical ports, such as those 
shown in the picture at right, are 
placed outside hierarchical blocks to 
provide vertical (upward-pointing) 
and lateral connections. 

A hierarchical port connects vertically 
to a like-named hierarchical pin inside 
a hierarchical block, and connects 
laterally to like-named nets, 

I DESIGNl - PAGEl I!!I~ EJ 

r.~~~=~> PORTBOTH-L PORTBOTH·R <:::::~>.1 

,.<~::~~] PORTLEFT·L PORTLEFT·R <::: ::J 
rC:::::::] PORTNO·L PORTNO·R :::::::]: 
'!):::~~> PORTRIGHH PORTRIGHT·R 'y .- .. ~ 

hierarchical ports, and off-page connectors within the same schematic folder. 

Hierarchical pins, such as the four 
shown in the picture at right, provide 
vertical (downward-pointing) 
connection only. 

Hierarchical pins are connected by 
name to hierarchical ports on 
schematic pages in an attached 
schematic folder. You can think of 
hierarchical pins as bringing a net 

8 DESIGNl - PAGEl I!!I~ EJ 

hie.rarchical block 

{\!I1"e} 

"up" from an attached schematic folder into the hierarchical block, but not out onto 
the schematic page. 

Off-page connectors 

Off-page connectors provide 
connection between schematic pages 
within the same schematic folder. An 

I DESIGNl - PAGEl I!!I~EJ 

off-page connector is connected by 
name to other off-page connectors 
within the same schematic folder. 
Like-named off-page connectors in 
different schematic folders are not 
connected. Capture's symbol library 
CAPSYM.OLB contains two types of 

m:(OFFPAGELEFT.L 

off-page connectors, shown in the picture at right. 

OFFPAGELEFT.R(¢ 
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An example: creating a simple hierarchy 

As described earlier in this chapter, you connect schematic folders and schematic 
pages by extending nets between them using off-page connectors, hierarchical ports, 
hierarchical pins, and hierarchical blocks. Off-page connectors carry nets between 
schematic pages within a single schematic folder. Hierarchical blocks, hierarchical 
ports, and hierarchical pins carry nets between schematic folders, which need not be 
in the same design. 

The rest of this section contains an example of how to use off-page connectors, 
hierarchical ports, hierarchical pins, and hierarchical blocks to create a simple 
hierarchy. 

m See also For information about placing hierarchical blocks, hierarchical ports, 
hierarchical pins, and off-page connectors, see Chapter 7: Placing, editing, and 
connecting parts and electrical symbols. 

This figure shows two schematic 
folders (Sch. A and Sch. B), each with 
two schematic pages. The schematic 
folder marked with a backslash (\) is 
called the root schematic/older. 

To establish the hierarchy with 
schematic folder A "above" schematic 
folder B: 

1 Place a hierarchical block on 
schematic page 1. 

2 In the Place Hierarchical Block 
dialog box, specify options in the 
Implementation group box to 
attach schematic folder B. 
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To carry a net between schematic folder 
A and schematic folder B: 

1 Select the hierarchical block on 
schematic page 1 and place a hier­
archical pin named "X" inside it. 

The hierarchical pin is a point of 
attachment for electrical 
connections between the 
hierarchical block and other objects 
on schematic page 1. 

2 Place a hierarchical port named X 
on schematic page 3 .• 

The hierarchical port is a point of 

Chapter 6 Design structure 

Sch.Pg.3 Sch. Pg. 4 

attachment for electrical connections between schematic page 3 and other 
schematic pages within schematic folder B. It is connected by name to the 
hierarchical pin inside the hierarchical block on schematic page 1. 

Hierarchical ports generally carry a net 
"up" through a hierarchy. In a root 
schematic folder, they usually represent 
external signals, such as a hierarchical 
block in another project. 

The two hierarchical ports added to 
schematic folder A are electrically 
connected to each other by the name "Y," 
so any electrical objects (such as power or 
ground symbols) on schematic pages 1 
and 2 named Yare part of the net named 
Y. You could make one or both ofthese 
hierarchical ports off-page connectors 
without affecting the electrical 
connections. 
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To connect the schematic pages in 
schematic folder B, place an off-page 
connector named X on schematic 
page 4. Any like-named electrical 
objects on schematic pages 3 and 4 are 
now part of a single net named X. 

To connect the X nets in schematic 
folder B and the Y nets in schematic 
folder A, you cannot simply rename 
one set of objects to match the other set 
of objects. Remember, the hierarchical 
pin X inside the hierarchical block on 
schematic page 1 does not bring net X 
out onto schematic page 1. You must 
physically connect hierarchical pin X 
to net Y in order to join the two nets. 

In the illustration at right, the Y nets on 
schematic pages 1 ando2 have become 
X nets because of the physical 
connection made between schematic 
page 1 's hierarchical block and the net formerly named Y. 
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Placing, editing, and connecting parts 
and electrical symbols 

Chapter 7 

Capture includes libraries containing parts, power symbols, and ground symbols. 
You can place instances of these objects on a schematic page. Once you have placed 
a part, you can edit its appearance, properties, or location. Once you have placed a 
power or ground symbol, you can rotate it or edit its name. 

This chapter contains information about placing and editing these objects. It also 
explains how to connect these objects using wires and buses. 

51! CMOSCPU DSN - POWER SCH f!I~m 

.... 

f-t4V 
D4 

~ IN<IOOl r ill!-I --"' __ -<->-------c::JBACKUP 
4V lN400l 

G~D 

dlJ··· ........ ' 
~ .~ 
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Capture also includes symbols used to establish connectivity between schematic 
pages. You use off-page connectors to connect signals between schematic pages 
within a schematic folder. You use hierarchical blocks, hierarchical ports, and 
hierarchical pins to connect signals from one schematic folder to another, or from an 
attached schematic folder. 

Wires and buses are used to conduct signals between parts and electrical objects. 
N~ts are made up of one or more wires that represent the net; a bus represents 
multiple signals or nets. 
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Placing and editing parts 

Capture includes libraries with over 20,000 parts that you can use on your schematic 
pages. In addition, you can create your own parts. 

m See For infonnation about creating your own parts, see Chapter 12: Creating 
and editing parts. ' 

A library part has apackage view, which corresponds to the actual physical object 
that could be placed, for example, on a printed circuit board. The package view 
identifies the physical pin numbers and how many logical objects (for example, parts 
or devices) are contained within the package. 

~ 
{Wlue} 
~ 

{Wlue}. 

The different parts that make up a package can be identical in their graphic 
appearance and electrical connectivity (homogeneous) or they can be dissimilar in 
their graphic appearance or electrical connectivity (heterogeneous). 
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In addition to the package view, a library part has a part view, which is a graphical 
representation used to define a single, logical, electrical object whose electrical 
connectivity is represented by pins . 

.. FULLADD DSN - 74LS32_0 II!!!I~EJ 

~ 
..... . 

1 • : 
• : 3 

2 : • . . 
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Each part has a set of properties that contain information-such as part value and 
reference designator-used by layout or simulation tools. In addition, you can create 
your own unique part properties to carry information relevant to your application. 

Parts have pins that define the part's electrical connectivity. Pins carry information 
in properties that define the characteristics of each pin. This information includes the 
pin's name, number, shape (clock, dot, dot-clock, line, short, or zero length), type 
(3-state, bidirectional, input, open collector, open emitter, output, passive, or power), 
width (scalar or bus), and visibility. The pin type is used by the Design Rules Check 
command on the Tools menu to check conformance to basic electrical rules. 

! Tip A part doesn't have to have pins. If a part doesn't have pins, it is listed in a 
bill of materials report, but doesn't appear in a netlist. This is useful if you want to 
show hardware-such as screws, nuts, or washers-in a bill of materials report. 

A primitive part is a basic part without any underlying hierarchy. A nonprimitive 
part is a part that has an underlying hierarchy, such as an attached schematic folder 
or VHDL code. Placing a nonprimitive part adds all the schematic pages that are part 
of the attached schematic folder to your project, making it easy to add levels of 
hierarchy to your project. You can see these additional schematic pages in physical 
mode, but not in logical mode. . 
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Placing parts 

You select parts from libraries and place them on schematic pages using the Part 
command on the Place menu, or using the part tool on the schematic page editor tool 
palette. 

To place a part 

1 From the schematic page editor's Place menu, choose Part (ALT, P, p). 
or 
Choose the part tool on the schematic page editor's tool palette. 

The Place Part dialog box displays. 

2 Select a part from the list that displays. 
or 
In the Part text box, type the name of the part. If you aren't sure of the name of 
the part, enter wildcard characters to constrain the list of parts, then choose the 
OK button. Valid wildcard characters are an asterisk (*) to match multiple 
characters and a question mark (?) to match a single character. 

After you type the name of the part to place, choose the OK button. All parts in 
the libraries (listed in the Libraries list box) that match the part name are listed 
in the box below the Part text box. When you select a part from this box, its 
graphic image displays in the preview box. 

~ Tips You can add more libraries to the Libraries list box by choosing the Add 
Library button. Capture displays a standard Open dialog box that you can use to 
locate a library to add to the list. 

You can remove a library from the Libraries list box by selecting it and choosing 
the Remove Library button. 

You can switch between the Normal view of a part and the Convert view of a part 
by choosing the appropriate option in the Graphic section. 

If your part is a package that contains multiple parts, you can use the Part drop­
down list in the Packaging area to select which part in the package to view, after 
you've selected a part from the list that displays. 

3 When you have located the part you want to place, choose the OK button. 

An image of the selected part is attached to your pointer. You can press the right 
mouse button to display a pop-up menu with commands that you can use to 
change the attributes of the part before you place it. You can mirror the part 
horizontally or vertically, rotate the part, or edit the part's properties. 

RJ Note All schematic page objects have right mouse button pop-up menus. These 
menus are context sensitive, displaying commands appropriate for the selected 
object. For information about pop-up menu commands, see Capture's online help. 
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4 Move to the location on your schematic page where you want to place the part, 
then click the left mouse button. This places an instance of the part on your 
schematic page. (You can place multiple instances of the part by clicking the left 
mouse button at each location where you want an instance of the part.) 

5 When you are done placing instances of the selected part, choose End Mode 
from the right mouse button pop-up menu, or press ESC. 

Place Part dialog box 
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Part Specifies the name of the part. If you aren't sure of the exact name of the 
part, you can enter wildcard characters to constrain the list of parts, then choose the 
OK button. Valid wildcard characters are an asterisk (*) to match mUltiple characters 
and a question mark (?) to match a single character. The names of all parts in the 
selected libraries that match the wildcard appear in the Part list box. 

Part list Lists the names of all parts in the selected libraries that match the name 
entered in the Part text box. If more than one library is selected, the part name is 
followed by a slash (I) and a library name. When you select a part in this list, its 
name displays in the Part text box, and its graphic displays in the preview box. 

Libraries Lists the library names currently available. All parts in the selected 
libraries that match the Part text box display in the Part list. To select more than one 
library, pres; CTRL while you click the mouse. 

Graphic You can choose the view of the part: Normal or Convert. Some parts 
have a Convert view that is used for things such as a DeMorgan equivalent of a part. 

Packaging Parts per package indicates the number of parts in the package you 
are editing. Part indicates which part of a multiple-part package you are placing. 
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Preview box Displays the graphic of the selected part. 

Add Library Displays a standard Open dialog box that you can use to locate a 
library and add it to the Libraries list. 

Fb Note If you select an SDT 386+ or SDT Release IV library from the dialog box 
that displays when you choose Add Library, Capture automatically translates the 
file after you specify the name of the new Capture library. 

Remove Library Removes the selected libraries from the Libraries list. 

Edit Part Opens a part editor window for the selected part, and a project manager 
window for the part's library. 
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You can move a part on a schematic page by selecting it and dragging it to a new 
location. You can use the Rotate or the Mirror command from the Edit menu. You 
can use the part editor to change the part's physical appearance, and you can edit the 
part's properties. When you edit a part on a schematic page, your edited part differs 
from the part in the library and exists only in your project; the only way to place 
another copy of the part you edited is to use the Copy command from the Edit menu. 

W See also For more information about editing parts, see Chapter 12: Creating 
and editing parts. 

To edit the physical appearance of a part, select it, and either choose Part from the 
Edit menu or choose Edit Part from the right mouse button pop-up menu. This opens 
the part in a part editor window. After you finish editing the part and choose Save, 
you're given a choice of updating the single instance, or updating all instances in the 
project. If you update only the single instance, Capture creates a new part in the 
design cache. If you update all instances, Capture replaces the library part in the 
design cache with your edited part. 

To edit the properties of a part, select the part on the schematic page, and either 
choose Properties from the Edit menu, or choose Edit Properties from the right 
mouse button pop-up menu. You can also double-click on the part. This displays the 
Edit Part dialog box, which is described below. 

Edit Part dialog box 

Part Value Specifies the part value name. By default, the part value is set to the 
name of the part if you don't specify a part value in the library. 
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Part Reference Specifies the part reference. 

Primitive Default indicates that the part uses the setting in the Hierarchy tab of 
the Design Properties dialog box. Yes indicates that the part is primitive. No 
indicates that the part is nonprimitive. 

Graphic Indicates whether the part you are editing is in Normal view or in 
Convert view. 

Packaging Parts per package indicates the number of parts in the package you 
are editing. Part indicates which part of a mUltiple-part package you are editing. 

PCB Footprint The PCB physical package name to be included for this part in 
the netlist. 

Power Pins Visible Specifies the visibility of the part's power pins. 

m See For information on power pin visibility and how it affects a global net, see 
Capture's online help. 

User Properties Displays a dialog box that you can use to edit the part's 
property names and their respective property values. 

Attach Implementation Displays a dialog box that you can use to attach a 
schematic folder, VHDL entity, netlist, or project, thus creating a hierarchy. 

~!:. Caution An attached schematic folder or other file external to the project or 
library is not stored with the project or library. If you copy or move the project or 
library to a new location, you must also move or copy the attached object to keep 
them together. In addition, you may need to edit the path to the attached schematic 
folder or file if you move the project to a new location with a different directory 
structure. 
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Placing and editing power and ground symbols 

You can place power and ground symbols, and you can edit their names before or 
after placing them. You can also edit the text associated with the symbols. The name 
of a power symbol is the name of the global net that is created. 

Placing power and ground symbols 

Power and ground symbols are placed 
on a schematic page using the Power 
command or Ground command on the 
Place menu, or using the power tool or 
ground tool on the tool palette. Power 
and ground symbols are selected from 
libraries the same way parts are 
selected from libraries. 
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1 From the schematic page editor's Place menu, choose Power (ALT, P, 0). 
or 
Choose the power tool on the schematic page editor's tool palette. 

The Place Power dialog box displays. 

....•.. ~ 

2 In the Symbol text box, type the name of the symbol to place. If you aren't sure 
of the exact name of the symbol, you can enter wildcard characters to constrain 
the list of symbols, then choose ENTER. Valid wildcard characters are an asterisk 
(*) to match multiple characters and a question mark (?) to match a single 
character. All power symbols in the libraries selected in the Libraries list box 
that match the name of the power symbol are listed in the box below the Power 
Symbol text box. When you select a symbol from this box, its graphic image 
displays. 

~ Tips You can add more libraries to the Libraries list box by choosing the Add 
Library button. Capture displays a standard Open dialog box that you can use to 
locate a library to add to the list. 

You can remove a library from the Libraries list box by selecting it and choosing 
the Remove Library button. 

You can assign a name (such as +5, GND, +5VDC, -12VDC, VSS, or VEE) by 
typing it in the Name text box. You can also assign a name after the power symbol 
is placed. 
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3 When you have located the power symbol you want to place, choose the OK 
button. An image of the power symbol is attached to your pointer. You can 
press the right mouse button to display a pop-up menu with commands to 
change the attributes of the power symbol before you place it. You can mirror 
the power symbol horizontally or vertically, or rotate it. 

R:J Note All objects that you can place on a schematic page have right mouse 
button pop-up menus. These menus are context sensitive, meaning they display 
commands that are appropriate for the selected object. For information about the 
commands on a pop-up menu, see Capture's online help. 

4 Move the pointer to the location on your schematic page where you want the 
power symbol and click the left mouse button. This places the power symbol on 
your schematic page. 

You can place multiple instances of the power symbol by clicking the left 
mouse button each place you want an instance of the symbol. 

5 When you are done placing power symbols, choose End Mode from the right 
mouse button pop-up menu, or press ESC. 

R:J Note You can create custom power, ground, and other symbols for hierarchical 
ports, off-page connectors, title blocks, and power objects by using the New 
Symbol command from the Design menu in the project manager window. For 
information on how to use this command, see Capture's online help. 

To place a ground symbol 

Follow the instructions in the previous section, To place a power symbol, but 
substitute the Ground command or the ground tool in the appropriate places. 
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Place Power or Place Ground dialog box 

The Place Power and Place Ground dialog boxes are identical, except that each 
displays the last power or ground symbol you placed. This figure shows the Place 
Power dialog box. 

Place Power 13 

Symbol Specifies the name of the power or ground symbol in the library. If you 
aren't sure of the exact name of the symbol, you can enter wildcard characters to 
constrain the list of symbols, then choose the OK button. Valid wildcard characters 
are an asterisk (*) to match multiple characters and a question mark (?) to match a 
single character. The names of all symbols in the selected libraries that match the 
wildcard appear in the Symbol list box. 

Symbol list Lists the names of all symbols in the selected libraries that match the 
name entered in the Symbol text box. If more than one library is selected, the symbol 
name is followed by a slash (I) and a library name. When you select a symbol in this 
list, its name displays in the Symbol text box, and its graphic displays in the preview 
box. 

Libraries Lists the library names currently available. Select the libraries from 
which to select power or ground symbols. All symbols in the selected libraries that 
match the Symbol text box display in the Symbol list. To select more than one 
library, press CTRL while you click the mouse. 

Preview box Displays the graphic of the selected symbol. 

Add Library Displays a standard Open dialog box that you can use to locate a 
library and add it to the Libraries list. 

Remove Library Removes the selected libraries from the Libraries list. 

Name Assigns a name-such as +5, GND, +5VDC, -12 VDC, VSS, or VEE-to 
the symbol. 
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Editing power and ground symbols 

You can change the name of a power or ground symbol by selecting the symbol on 
the schematic page, and either choosing Properties from the Edit menu, or choosing 
Edit Properties from the right mouse button pop-up menu. You can also double-click 
on the symbol. This displays a dialog box in which you can edit the name, then 
choose the OK button. 

You can also edit the display properties of the text associated with the power or 
ground symbol. Select only the text of the symbol, then either choose Properties 
from the Edit menu, or choose Edit Properties from the right mouse button pop-up 
menu. You can also double-click on the text. This displays a Display Properties 
dialog box. Once you have finished editing the properties, choose the OK button. 
You can also use this dialog box to edit the name of the symbol. 

You cannot assign user properties to power or ground symbols. 
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Placing and editing no-connect symbols 

A no-connect symbol (shown as an "X" attached to a pin) causes unused pins to be 
ignored by reports (such as Design Rules Check and netlists) that show unconnected 
pins. If a pin is connected, the no-connect symbol doesn't affect the pin. 

Placing no-connect symbols 

No-connect symbols are placed on a schematic page using the No Connect command 
on the Place menu, or using the no-connect tool on the schematic page editor's tool 
palette. 

To place a no-connect symbol 

1 From the schematic page editor's Place menu, choose No Connect (ALT, P, c). 
or 
Choose the no-connect tool on the schematic page editor's tool palette. 

2 Position the mouse over the pin and click the left mouse button. The end of the 
pin changes from a square (unconnected) to an X (not connected). 

Editing no-connect symbols 

No-connect symbols cannot be deleted using DELETE. To remove a no-coimect 
symbol, place another no-connect symbol on top of the existing no-connect symbol. 
You can temporarily override a no-connect symbol by attaching a wire to the pin, 
but if you delete the wire, you'll again be able to see the no-connect symbol. 
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Placing and editing hierarchical blocks 

Hierarchical blocks (or parts with attached schematic folders) refer to child 
schematic folders in a project, providing vertical (downward-pointing) connection 
only. Hierarchical pins in a hierarchical block, and hierarchical ports outside a 
hierarchical block, act as points of attachment for any electrical connections between 
the hierarchical block and other electrical objects in an attached schematic folder. 

A part with an attached schematic folder fimctions like a hierarchical block, and pins 
on a part with an attached schematic folder fimction like hierarchical pins within a 
hierarchical block. You can use either method to define a hierarchy. The only 
difference between the two methods is that a part with an attached schematic folder 
can be reused. 

Placing hierarchical blocks 

You create hierarchical designs using 
hierarchical blocks to represent child 
schematic folders. When you create a 
hierarchical block, you specify the name of 
the child schematic folder that the 
hierarchical block represents. Once you've 
created the hierarchical block, you place 
hierarchical pins inside it to connect it to 
hierarchical ports on the child schematic folder's schematic pages. 

Fb Note If the child schematic folder you specify as the hierarchical block's 
attached schematic folder already exists, Capture automatically adds hierarchical 
pins to the hierarchical block that match the corresponding ports on the schematic 
pages in the child schematic folder. If the child schematic folder doesn't yet exist 
and you place the hierarchical block and choose Descend Hierarchy from the right 
mouse button pop-up menu, Capture creates a new schematic folder and creates a 
new schematic page containing hierarchical ports that match the hierarchical pins 
in the hierarchical block. 

W See also For information on connecting hierarchical designs using hierarchical 
blocks, hierarchical ports, and hierarchical pins, see Connecting schematic folders 
and schematic pages in Chapter 6: Design structure. 
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To place a hierarchical block 

1 From the schematic page editor's Place menu, choose Hierarchical Block 
(ALT, P, H). 
or 
Choose the hierarchical block tool on the schematic page editor's tool palette. 

The Place Hierarchical Block dialog box displays. 

2 In the Reference text box, type the name of the hierarchical block. 

3 Accept the Primitive setting of Default, or choose Yes or No. (See Primitive on 
the next page for more information.) 

4 Ifnecessary, choose the User Properties button, add or change property names 
and their associated values in the dialog box that displays, then choose the OK 
button. 

5 Specify the type of implementation. (See Place Hierarchical Block dialog box 
on the next page for a description of implementation types.) 

6 Specify the name of the attached schematic folder, VHDL entity, netlist, or 
project. 

7 Specify the path and filename of the attached schematic folder, VHDL entity, 
netlist, or project. 

8 Choose the OK button to close the Place Hierarchical Block dialog box. 

9 Draw the hierarchical block. Press the left mouse button, drag the mouse to 
draw a rectangle, and release the mouse button when the rectangle is the desired 
size. Click on an open space on the page to deselect the block. 

m See Once you've placed a hierarchical block, you must place hierarchical pins 
inside it, then name the pins so that they connect to like-named hierarchical ports in 
the schematic pages in the child schematic folder. See Placing hierarchical pins later 
in this chapter. 
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Place Hierarchical Block dialog box 

Reference The name of the hierarchical block. 

Primitive Default indicates that the part uses the setting in the Hierarchy tab of 
the Design Template dialog box. Yes indicates that the part is primitive. No indicates 
that the part is nonprimitive. 

User Properties Displays a dialog box that you can use to edit the part's 
property names and their respective property values. 

Implementation Type Specifies the type of implementation from one of the 
following: 

• Schematic View. Indicates that the attached implementation is a schematic 
folder. Capture will automatically generate the appropriate hierarchical pins for 
the block based on the schematic ports. 

• VHDL. Indicates that the attached implementation is a VHDL entity. Capture 
will automatically generate the appropriate hierarchical pins for the block based 
on the port declarations in the VHDL entity. 

• EDIF. Indicates that the attached implementation is an EDIF netlist. If your 
design includes EDIF implementations for hierarchical blocks, you must specifY 
the hierarchical pins for the block; Capture will not generate them from the 
EDIF netlist. 
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• Project. Indicates that the attached implementation is a programmable logic 
project. You must specify the hierarchical pins for the block; Capture will not 
generate them. 

Implementation Name Specifies the name of the attached schematic folder, 
VHDL entity, netlist, or project for the hierarchical block. 

Path and filename Specifies the path and filename of the attached schematic 
folder, VHDL entity, netlist, or project for the hierarchical block. 

Fb Notes If you specify a library or project that you haven't yet saved to disk, 
Capture creates the library or project in the directory specified by your TEMP 
environment variable. 

Attaching an implementation does not automatically add that file, project, or 
schematic folder to the project. You must specifically add the implementation to 
the project with the Project command (on the Edit menu). 

~~ Caution An attached schematic folder or other file external to the project or 
library is not stored with the project or library. If you copy or move your project 
or library to a new location, you must also move or copy the attached file, to keep 
them together. In addition, you may need to edit the path to the attached schematic 
folder or file if you move your project to a new location with a different directory 
structure. 
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Editing hierarchical blocks 

You can edit a hierarchical block after it is placed. Select the hierarchical block and 
do one of the following: 

• Double-click on it. 

• Choose Properties from the Edit menu. 

• Choose Edit Properties from the pop-up menu. 

Each of these methods displays the Edit Hierarchical Block dialog box, in which you 
can change the block's reference, choose among the options in the Primitive group 
box, or modify the attached schematic folder's name or path. If you choose the User 
Properties button in the Edit Hierarchical Block dialog box, the User Properties 
dialog box displays, in which you can modify existing yser properties or add new 
ones. 

You can also edit the display properties ofthe text associated with the hierarchical 
. block. Select the text of the hierarchical block and do one of the following: 

• Double-click on it. 

• Choose Properties from the Edit menu. 

• Choose Edit Properties from the pop-up menu. 

Each of these methods displays the Display Properties dialog box, in which you can 
edit the visibility, color, font, or rotation of the text of the hierarchical block. 

You can click on a hierarchical block and move it to another location, or you can 
drag its selection handles to resize it. You can also use the Mirror or Rotate 
commands to change the appearance of the block. 
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Placing and editing hierarchical ports and hierarchical pins 

WI See For information on how hierarchical designs are connected using 
hierarchical blocks, hierarchical ports, and hierarchical pins, see Connecting 
schematic folders and schematic pages in Chapter 6: Design structure. 

Placing hierarchical ports 

You place hierarchical ports on 
schematic pages in child schematic 
folders, then name the ports so that 
they connect to like-named 
hierarchical pins inside hierarchical 
blocks on schematic pages in parent 
schematic folders. 

"5J!DESIGNI-PAGEl 1!!!I~f3 

Hierarchical ports also connect to 
like-named hierarchical ports, and to 

s:::=> 

3CJ 

rrr::=J 

1C> 

PORTBOTH·L 

PORTLEFT·L 

PORTNO·L 

PORTRIGHT·L 

PORTBOTH·R 

PORTLEFT·R 

PORTNO·R 

PORTRIGHT·R 

·C~ 
,. 

CJl: 

C=:§ 

c::::::::>c'dJ····· .... 
. '. '~ .. ;f; 

off~page connectors with the same name, on schematic pages within the same 
schematic folder. 
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To place a hierarchical port 

~ Tip You can place a hierarchical port anywhere on a schematic page. A 
hierarchical port connects to like-named hierarchical ports and off-page 
connectors on schematic pages in the same schematic folder, and connects to like­
named hierarchical pins inside hierarchical blocks in parent schematic folders. 

1 From the schematic page editor's Place menu, choose Hierarchical Port 
(ALT, P, I). 

The Place Hierarchical Port dialog box displays. 

2 Select one or more libraries from those listed in the Libraries field, or use the 
Add Library and Remove Library buttons to change what is listed in the 
Libraries field and select one or more libraries. 

3 In the list below the Symbol text box, select the type of the hierarchical port. 
The selection's name appears in the Symbol text box and its graphic displays in 
the preview box. 

4 Type in the name for the hierarchical port. The name is added to the attached 
net, and is used to determine which like-named hierarchical pins and 
hierarchical ports the port connects to. 

S When you have specified the characteristics of the hierarchical port, choose the 
OK button. The Place Hierarchical Port dialog box closes. 

6 You can now place the hierarchical port anywhere on the schematic page. If you 
want to move the port, you can select it and drag it to another location after you 
place it. 
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Place Hierarchical Port dialog box 
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Symbol Specifies the hierarchical port symbol to use. If you aren't sure of the 
exact name of the symbol, you can enter wildcard characters to constrain the list of 
symbols, then choose the OK button. Valid wildcard characters are an asterisk (*) to 
match multiple characters and a question mark (?) to match a single character. The 
names of all symbols in the selected libraries that match the wildcard appear in the 
Symbol list box. 

Symbol list Lists the names of all symbols in the selected libraries that match the 
text entered in the Symbol text box. If more than one library is selected, the symbol 
name is followed by a slash (I) and a library name. When you select a part in this list, 
its name displays in the Symbol text box, and its graphic displays in the preview 
box. 

Libraries Lists the library names currently available. Select the libraries from 
which to select symbols. All symbols in the selected libraries that match the Symbol 
text box display in the Symbol list. To select more than one library, press CTRL while 
you click the mouse. 

Preview box Displays the graphic of the selected symbol. 

Name Specifies the symbol's name. This name is used to determine which like­
named hierarchical ports the port will connect to. 

Add Library Displays a standard Open dialog box that you can use to locate a 
library and add it to the Libraries list. 

Remove Library Removes the selected libraries from the Libraries list. 
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Placing hierarchical pins 

You place hierarchical pins inside hierarchical blocks on schematic pages in parent 
schematic folders. You name the hierarchical pins to correspond to hierarchical port 
names on schematic pages in child schematic folders. 

~,~ Caution Since it may be difficult to connect to hierarchical pins that are off­
grid, you should be aware of the following situation: 

• Ifthe Pointer snap to grid option in the Grid Display tab of the Preferences 
dialog box is not selected, any hierarchical pins you place in a hierarchical 
block may not snap to grid. 

To place a hierarchical pin 

~ Tip You can only place a hierarchical pin within the boundaries of a hierarchical 
block. A hierarchical pin connects to any like-named hierarchical port on the 
schematic pages in the schematic folder you attached to the hierarchical block. 

1 Select a hierarchical block. 

2 From the schematic page editor's Place menu, choose Hierarchical Pin. The 
Place Hierarchical Pin dialog box displays. 

3 In the Name text box, type in a name for the hierarchical pin. This name, which 
is also the net name, is used to determine which like-named hierarchical ports 
the pin will connect to. 

4 From the drop-down list box under Type, select a pin type for the hierarchical 
pin. 

5 In the Width group box, select either Scalar or Bus. 

6 Choose the User Properties button to display a dialog box where you can add or 
change property names and their associated values. When you've finished 
editing the hierarchical pin's properties, choose the OK button. 

7 Choose the OK button to close the Place Hierarchical Pin dialog box. 

8 Position the hierarchical pin within the hierarchical block and click the left 
mouse button to place the pin. 
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Place Hierarchical Pin dialog box 

Place HIerarchIcal Pm E3 

Name Specifies the hierarchical pin's name. 

Type Specifies the type of pin. 

Width Specifies whether the pin is Scalar or Bus. 

User Properties Displays a dialog box that you can use to edit the pin's property 
names and their respective property values. 

Editing hierarchical ports and hierarchical pins 

Fb Note You can create custom power, ground, and other symbols for hierarchical 
ports, hierarchical pins, off-page connectors, title blocks, and power objects by 
using the New Symbol command on the Design menu in the project manager 
window. For information on how to use this command, see Capture's online help. 

You can edit a hierarchical port or hierarchical pin after it is placed by selecting it 
and choosing Properties from the Edit menu, choosing Edit Properties from the right 
mouse button pop-up menu, or double-clicking on it. This displays a dialog box that 
lets you change the information for Name and Type. Once you have finished editing 
the information in the dialog box, choose the OK button. 

You can edit the display properties of the text associated with a hierarchical port by 
selecting the text of the port, and choosing Properties from the Edit menu, choosing 
Edit Properties from the right mouse button pop-up menu, or double-clicking on it. 
Using the Display Properties dialog box, you can change the text itself, or change 
the text's color, font, or rotation. Once you have finished editing the text's properties, 
choose the OK button. 
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Placing and editing off-page connectors 

Off-page connectors are used to 
connect signals to like-named off­
page connectors and hierarchical ports 
on other schematic pages within the 
same schematic folder. [l(OFFPAGELEFT.L OFF PAGELEFT· R(¢ 

WI See also For more information about connecting designs using off-page 
connectors, see Connecting schematic folders and schematic pages in Chapter 6: 
Design structure. 

Placing off-page connectors 

To place an off-page connector, you use the Off~Page Connector command on the 
Place menu or the off-page connector tool on the tool palette. 

To place an off-page connector 

1 From the schematic page editor's Place menu, choose Off-Page Connector 
(ALT, P, F). 
or 
Choose the off-page connector tool on the schematic page editor's tool palette. 

The Place Off-Page Connector dialog box displays. 

2 In the Symbol text box, type the name of the symbol to place. If you aren't sure 
of the exact name of the symbol, you can enter wildcard characters to constrain 
the list of symbols, then choose the OK button. Valid wildcard characters are an 
asterisk (*) to match mUltiple characters and a question mark (?) to match a 
single character. 

104 OrCAD Capture for Windows User's Guide 



Chapter 7 Placing, editing, and connecting parts and electrical symbols 

After you type the name ofthe symbol to place, choose the OK button. All 
symbols in the libraries listed in the Libraries list box that match the symbol 
name are listed in the box below the Symbol text box. When you select a 
symbol from this box, its graphic image displays. 

! Tips You can add more libraries to the Libraries list box by choosing the Add 
Library button. Capture displays a standard Open dialog box that you can use to 
locate a library to add to the list. 

You can remove a library from the Libraries list box by selecting it and choosing 
the Remove Library button. 

You can assign a name by typing it in the Name text box. The name is used to 
connect to other off-page connectors in the same schematic folder. You can also 
assign a name after the symbol is placed. 

All of the options on the Place Off-Page Connector dialog box are described later 
in this section. 

3 When you have located the symbol you want to place, choose the OK button. 

An image of the symbol is attached to your pointer. You can press the right 
mouse button to display a pop-up menu with commands that you can use to 
change the appearance of the symbol before you place it. You can mirror the 
symbol horizontally or vertically, rotate the symbol, or edit its properties. 

Fb Note All objects that you can place on a schematic page have right mouse 
button pop-up menus. These menus are context sensitive, meaning they display 
commands that are appropriate for the selected object. For information about the 
commands on a pop-up menu, see Capture's online help. 

4 Move the pointer to the location on your schematic page where you want the 
symbol and click the left mouse button. This places the symbol on your 
schematic page. 

You can place multiple instances of the symbol by clicking the left mouse 
button each place you want an instance of the symbol. 

5 When you are done placing symbols, choose End Mode from the right mouse 
button pop-up menu, or press ESC. 
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Place Off·Page Connector dialog box 

Symbol Specifies the off-page connector symbol to use. If you aren't sure of the 
exact name of the symbol, you can enter wildcard characters to constrain the list of 
symbols, then choose the OK button. Valid wildcard characters are an asterisk (*) to 
match multiple characters and a question mark (?) to match a single character. The 
names of all symbols in the selected libraries that match the wildcard appear in the 
Symbol list box. 

Symbol list Lists the names of all symbols in the selected libraries that match the 
text entered in the Symbol text box. Ifmore than one library is selected, the symbol 
name is followed bya slash (I) and a library name. When you select a part in this list, 
its name displays in the Symbol text box, and its graphic displays in the preview 
box. 

Libraries Lists the library names currently available. Select the libraries from 
which to select symbols. All symbols in the selected libraries that match the Symbol 
text box display in the Symbol list. To select more than one library, press CTRL while 
you click the mouse .. 

Preview box Displays the graphic of the selected symbol. 

Name The name of the symbol. Other off-page connectors in the same schematic 
folder that have this name are connected to this off-page connector. 

Add Library Displays a standard Open dialog box that you can use to locate a 
library and add it to the Libraries list. 

Remove Library Removes the selected libraries from the Libraries list. 
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Editing off-page connectors 

You can edit an off-page connector after it is placed by selecting it and either 
choosing Properties from the Edit menu, or choosing Edit Properties from the right 
mouse button pop-up menu. You can also double-click on the off-page connector. 
This displays the Edit Off-Page Connector dialog box, which lets you change the 
Name. Once you have finished editing the information in the Edit Off-Page 
Connector dialog box, choose the OK button. 

You can also edit the display properties of the text associated with the off-page 
connector. Select only the text of the off-page connector, then either choose 
Properties from the Edit menu, or choose Edit Properties from the right mouse 
button pop-up menu. You can also double-click on the off-page connector. This 
displays a Display Properties dialog box. Once you have finished editing the 
properties, choose the OK button. 

You can click on an off-page connector and move it to another location. You can 
also use both the Mirror and Rotate commands from the Edit menu to change the 
appearance of the off-page connector. 

i=b Note You can create custom power, ground, and other symbols for hierarchical 
ports, off-page connectors, title blocks, and power objects by using the New 
Symbol command from the Design menu in the project manager window. For 
information on how to use this command, see Capture's online help. 
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Placing and connecting wires and buses 

You can determine whether wires or buses that cross each other are connected by the 
presence or absence of a junction. Unless a junction is present, wires or buses that 
cross each other are not connected. Likewise, if you drag a net up to another net so 
that they touch, the two nets are not connected unless you add a junction at the 
location where the nets meet. 

You can add a junction using the Place junction button on the schematic page 
editor's toolbar, or by choosing Junction from the Place menu in the schematic page 
editor. You can place junctions anywhere on a wire, but they only take effect when, 
another object is connected at the junction's location. You can remove a junction by 
selecting it and using the DELETE key, or by placing another junction on top of the 
existing one. 

Fb Note Junctions can only be placed on wires and buses. A junction cannot be 
placed in an open area, or on an object such as a pin or a port. 

Two wires or two buses can be connected physically by the following methods: 

• If you cross a wire segment of another wire and add a junction where the wires 
meet, a junction displays, and the wires are connected. 

• If you begin or end a wire segment on a segment of another wire, ajunction is 
added automatically, and the wires are connected. 

• If you begin or end a bus segment on a segment of another bus, a junction is 
added automatically, and the buses are connected. 

A wire and a bus can be connected in name only by the following methods: 

• If you begin or end a wire segment on a segment ofa bus, ajunction is added, 
and they will be connected. 

• If you begin or end a bus segment on a segment ofa wire, ajunction is added, 
and they will be connected. 
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Wires and buses, along with other parts and symbols in the project that are logically 
connected via net names, form a net. When you place a wire, it is assigned a system­
generated netname, which you can replace with an alias or a different netname. Once 
a bus acquires a valid name or alias, then that name or alias defines the signals 
carried by the bus and connects those signals to the corresponding nets. For 
example, the alias A[O:3] defines a four-signal bus and connects the four signals it 
carries with nets AO, AI, A2, and A3. 

Like wires, buses can acquire names and aliases by two means: 

g Direct application of a valid bus name 

• Electrical connection to a hierarchical port, off-page connector, or global bus 
pin with a valid bus name 

W See also For more information about placing and connecting wires and buses, 
see Capture's online help. 
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Placing wires 

When you connect a wire to a pin, Capture provides visual confirmation of the 
connection by removing the unconnected pin box on the pin. If two continuous wires 
cross at 90°, they are not electrically connected unless you create ajunction by 
double-clicking the left mouse button on one wire as you draw the other across it. 

Fb Note If you place parts so that two pins meet end to end, the pins are connected. 

! Tip To find out the name of the net a pin is on, double-click on the pin, then 
choose the User Properties button in the Pin Properties dialog box. The Net Name 
property is the name ofthe net. 

To place a wire 

1 From the schematic page editor's Place menu, choose Wire (ALT, P, w). 
or 
Choose the wire tool on the schematic page editor's tool palette. 

2 Click the left mouse button to start the wire. 

3 Move the mouse to draw the wire. Click the left mouse button if you want to 
place a vertex and change directions, or connect to another wire as you pass 
over it. 

Fb Note The wire is constrained to multiples of 90° unless you hold down the 
SHIFT key while you draw the wire. 

4 Double-click to end the wire. The wire displays in the selection color. 

S When you are done placing wires, choose End Mode from the right mouse 
button pop-up menu, or press ESC. 
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Select the wire and choose Properties from the Edit menu, choose Edit Properties 
from the pop-up menu, or double-click on the wire. This displays the Net Properties 
dialog box, in which you can select a net alias to be the netname in the netlist. Once 
you have finished selecting a net alias, choose the OK button. 

Fb Note When you click on a wire, all its graphical handles are highlighted. To add 
another wire to the selection, hold down the CTRL key and click on the additional 
wire. To select the entire net, click on the wire, then choose Select Entire Net from 
the right mouse button pop-up menu. 

You can also edit the display properties of the text associated with the wire. Select 
only the text of the wire, then either choose Properties from the Edit menu, or choose 
Edit Properties from the right mouse button pop-up menu. You can also double-click 
on the text. This displays a Display Properties dialog box. Once you have finished 
editing the properties, choose the OK button. 

~ Tip To edit a net alias, double-click on the alias. This displays the Edit Net Alias 
dialog box, in which you can change the Alias, Color, Rotation, or Font. Once you 
have finished editing the properties, choose the OK button. 

To move a wire, select it and drag it to a new location; the wire stretches to maintain 
its connectivity. To break the wire's connectivity, press ALT while you move it. To 
move a vertex, select a wire segment next to the vertex and drag the vertex to the 
new location. 

W See also For more information about editing wires and nets, see Capture's 
online help. 
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Placing buses 

A bus is a group of scalar signals (wires), and is never connected to a net. Once the 
bus acquires a valid name or alias, then that name or alias defines the signals carried 
by the bus and connects those signals to the corresponding nets. For example, the 
alias A[0:3] defines a four-signal bus that connects the four bus signals to the 
individual wires named AO, AI, A2, and A3. Net aliases on wires do not use 
brackets. 

To place a bus 

1 From the schematic page editor's Place menu, choose Bus (ALT, P, 8). 
or 
Choose the bus tool on the schematic page editor's tool palette. 

2 Click the left mouse button to start the bus. 

3 Move the mouse to draw the bus. Click the left mouse button if you want to 
place a vertex and change directions, or to connect to another bus as you pass 
over it. The bus is constrained to multiples of 90° unless you hold down the 
SHIFT key while you draw the bus. 

4 Double-click to end the bus. 

S Highlight the bus, then choose Net Alias from the Place menu. Enter an alias for 
the bus in the Place Net Alias dialog box that displays, then choose the OK 
button. 

Fb Note Bus names and aliases have the formX[m .. n]. Xrepresents the "base 
name." The portion m .. n represents the range of signals carried by the bus. Note 
that m may be less than or greater than n. In other words, both A[O . .3] and A[3 .. 0] 
are valid bus aliases. You can use two periods ( .. ), a colon (:), or a dash (-) to 
separate m and n. Do not use two digits for single-digit signals (for example, use 
A[O . .3], but don't use A[00 . .33]). 

6 When you are done placing buses, choose the selection tool or press ESC to 
dismiss the bus tool. 
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Select the bus and either choose Properties from the Edit menu, or choose Edit 
Properties from the right mouse button pop-up menu. You can also double-click on 
the bus. This displays the Net Properties dialog box, in which you can add or change 
the bus's properties. Once you have finished editing the information in the Net 
Properties dialog box, choose the OK button. 

You can also edit the display properties of the text associated with the bus. Select 
only the text of the bus, then either choose Properties from the Edit menu, or choose 
Edit Properties from the right mouse button pop-up menu. You can also double-click 
on the text. This displays the Edit Net Alias dialog box, which allows you to change 
the Alias, Color, Rotation, or Font. Once you have finished editing the properties, 
choose the OK button. 
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Placing bus entries 

Bus entries are used to bring a net into a bus. They are optional. The only distinction 
between a bus entry and a wire segment is that two wires that touch are connected, 
whereas two bus entries that touch are not connected. 

To place a bus entry 

1 From the schematic page editor's Place menu, choose Bus Entry (ALT, P, E). The 
bus entry is attached to the pointer. 

2 From the Edit menu, choose Rotate (ALT, E, 0) to rotate the bus entry 90° 
counterclockwise if the bus entry is not at the angle you need. 

3 Use the mouse to position one end of the bus entry on the bus, then click the left 
mouse button to place the bus entry. 

4 Repeat step 3 until all of the bus entries are placed. 

5 Choose the selection tool or press ESC to dismiss the bus entry tool. 

To connect multiple bus entries 

1 Place a wire to connect the first bus entry to a net. 

2 Place an alias on the wire using the lowest value in the bus range. For example, 
if you're using a bus alias of A[0:3], the lowest value in the bus range is AO. 

~ Tip To place an alias, choose Net Alias from the Place menu. Enter the net alias 
text (following the naming conventions for buses and nets), then choose the OK 
button. A rectangle representing the alias text attaches to the pointer. Click the left 
mouse button on the bus or net to place the alias. The alias text displays in the 
selection color. When you are done placing aliases, press ESC. 

3 Select the wire, then press CTRL while you drag a copy a specific distance so 
that it connects the next net to the bus. The alias value is increased by one. 

4 From the Edit menu, choose Repeat (ALT, E, R). The wire and the incremented 
alias text are placed at the specified distance from the previous set. 

5 Repeat step 4 for every bus entry in the bus, or repeat steps 3 and 4 as needed. 

6 When you are done connecting bus entries, press ESC. 

Editing bus entries 

To move a bus entry's text, select it and drag it to a new location. To rotate a bus 
entry, select it and choose Rotate from the Edit menu. 
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Adding and editing graphics and text 

Drawing tools 

You can create a wide variety of graphic shapes to add to your schematic pages. You 
can work with the snap-to-grid option turned on or turned off. For close work, you 
may want to zoom in on your graphic using the Go To command on the View menu. 

Before you begin drawing, you may want to specify default line and fill styles, 
because all lines and shapes you draw will use the current line style, and closed 
shapes that you draw will use the current fill style. You can use a variety of line or 
fill styles for any part. You can specify these styles in the Miscellaneous tab in the 
Preferences dialog box. 

Capture has two tool palettes: one for the schematic page editor window, and one for 
the part editor window. Both tool palettes are movable and resizable, and display 
tooltips that identify each tool. The tool palettes are each divided into two groups of 
tools. The electrical tools are in the first group and the drawing tools are in the 
second group. 

Schematic page editor tool palette. 

Part editor tool palette. 
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Drawing lines 

General rules for all drawing tools: 

• If you choose a drawing tool and press ESC before you begin drawing an object, 
the drawing tool changes to the selection tool. 

• If you choose a drawing tool, and click in an empty area before you begin 
drawing an object, the drawing tool changes to the selection tool. Note that this 
doesn't work when drawing arcs or polylines/polygons, or placing text or 
bitmaps. 

• If you choose a drawing tool, start drawing an object, and then press ESC, the 
unfinished object is removed, and the drawing tool changes to the selection tool. 

You use the line tool to draw a single line. The line you draw adopts the current line 
style. If you want to draw a line with multiple contiguous segments, use the polyline 
tool. 

To draw a line segment 

1 From the Place menu, choose Line (ALT, P, L). 
or 
Choose the line tool on the tool palette. 

2 Move the pointer to the line's beginning. 

3 Press and hold the left mouse button while moving the mouse to draw the line. 

4 Release the left mouse button to end the line. The line displays in the selection 
color. 

S Choose the selection tool or press ESC to dismiss the line tool. 

To resize a line 

Use the selection tool to select a line. Edit handles appear at either end of the line. 
With the pointer on one of the two edit handles, press the left mouse button and drag 
the line. You can change the angle of the line in the process of resizing it. 
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Drawing rectangles and squares 

You use the rectangle tool to create orthogonal shapes. To create a square, hold 
down the SHIFT key before you begin drawing. Any rectangles or squares you create 
will have the current fill style and line style. 

To draw a rectangle or a square 

1 From the Place menu, choose Rectangle (ALT, P, R). 
or 
Choose the rectangle tool on the tool palette. 

2 Move the pointer to one comer of the intended rectangle. 

3 Press and hold the left mouse button while you drag the mouse. The rectangle 
changes shape as you move the mouse. Release the left mouse button when you 
have the correct shape. To draw a square, hold down the SHIFT key while you 
perform this step. The rectangle displays in the selection color. 

4 Choose the selection tool or press ESC to dismiss the rectangle tool. 

To resize a rectangle or square 

Use the selection tool to select a rectangle or square. Edit handles appear on the four 
comers. With the pointer on one of the handles, press the mouse and drag the handle. 
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Drawing circles and ellipses 

You use the ellipse tool to draw a closed ellipse; if you want to draw an arc, use the 
arc tool. To draw a circle, hold down the SHIFT key while you drag the mouse. 
Because they are closed shapes, circles and ellipses will have the current fill style. 
They will also have the current line style. 

To draw an ellipse or a circle 

1 From the Place menu, choose Ellipse (ALT, P, s). 
or 
Choose the ellipse tool on the tool palette. 

2 Move the pointer to an edge of the intended ellipse. 

3 Press and hold the left mouse button while you drag the mouse. The ellipse 
changes shape as you move the mouse. If you want to draw a circle, hold down 
the SHIFT key while you perform this step. Release the left mouse button when 
you have the correct shape. The ellipse appears in the selection color. 

4 Choose the selection tool or press ESC to dismiss the ellipse tool. 

To resize an ellipse or circle 

Use the selection tool to select an ellipse or a circle. Edit handles appear on all four 
comers of the rectangle that encloses it. With the pointer on one of the handles, press 
the mouse and drag the handle. 
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You create an arc of any angle using the arc tool. Because it is a line, an arc adopts 
the current line style. If you want to create a full circle, use the ellipse tool. 

Drawing an arc is done in three stages: 

a Specify the center of the arc with the first mouse click. 

II Specify the radius of the arc with the second mouse click. 

D Specify the arc segment endpoint with the third mouse click. 

The arc is drawn counterclockwise from the endpoint, and displays in the selection 
color. 

To draw an arc 

From the Place menu, choose Arc (ALT, P, A). 
or 
Choose the arc tool on the tool palette. 

2 Move the pointer to establish the center of the arc, and press and hold the left 
mouse button. 

3 Drag the mouse out from the center to establish the radius of the arc, then click 
the left mouse button to establish the location of one end ofthe arc. 

4 Use the mouse to establish the other end of the arc and click the left mouse 
button. The arc is drawn counterclockwise from the endpoint, and displays in 
the selection color. 

5 Choose the selection tool or press ESC to dismiss the arc tool. 

To resize an arc 

Use the selection tool to select an arc. Edit handles appear at the ends of the arc. 
With the pointer on one of the handles, press the mouse and drag. The center 
remains the same. The other arc endpoint uses the new radius. 
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Drawing polylines and polygons 

To draw a line with multiple contiguous segments, use the polyline tool. The line 
you draw adopts the current line style. Polygons can be created with the polyline 
tool, and they adopt the current fill style. To create an non-orthogonal polyline, hold 
down the SHIFT key while you draw. 

To draw a polyline 

1 From the Place menu, choose Polyline (ALT, P, v). 
or 
Choose the polyline tool on the tool palette. 

2 Click the left mouse button to begin drawing, click to change directions, and 
double-click to end the final segment. To draw non-orthogonal polylines, press 
SHIFT. After you double-click, the polyline displays in the selection color. 

3 Choose the selection tool or press ESC to dismiss the polyline tool. 

To draw a polygon 

~ Follow the instructions above, ending the line with a single mouse-button click 
at the beginning point. The polygon adopts the current line and fill style. 

To resize a polyline or polygon 

Use the selection tool to select a polyline or polygon. Edit handles appear at the ends 
of all the lines in the polyline/polygon. With the pointer on a handle, press the left 
mouse button and drag the handle. 
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Adding fill to an object 

To add fill to an object, select the object, then from the Edit menu, choose 
Properties. Select a fill style from the Fill Style drop-down box, then choose the OK 
button. 

You can have closed shapes automatically filled in after you finish drawing them by 
defining a default fill. From the Options menu, choose Preferences, then choose the 
Miscellaneous tab. Click on the Fill Style drop-down box to display the options. 
Note that you can specify separate options for the schematic page editor and the part 
editor. Select one of the options and choose the OK button. 

Mirroring an object 

You can mirror objects horizontally, vertically, or both horizontally and vertically. 
Some objects, such as text and bitmaps, cannot be mirrored. If the Mirror command 
appears dimmed on the Edit menu, the object cannot be mirrored. 

To mirror an object, select the object. From the Edit menu, choose Mirror, then 
choose Horizontally, Vertically or Both from the pop-up menu. The object flips in 
the chosen direction. 

Rotating an object 

You can rotate objects by 90° increments. Some objects, such as bitmaps, cannot be 
rotated. If the Rotate command appears dimmed on the Edit menu, the object cannot 
be rotated. To rotate an object, select the object. From the Edit menu, choose Rotate. 
The selection rotates 90° counterclockwise. 

Cutting an object 

Select the object. From the Edit menu, choose Cut. The object is removed from the 
schematic page and placed on the Clipboard. 

Copying an object 

There are two ways to copy an object: 

• Select the object. From the Edit menu, choose Copy. The object remains on the 
schematic page and a copy of it is placed on the Clipboard. It can be pasted in 
Capture or in other Windows programs. 

• Position the pointer on the object. Press the left mouse button, hold down the 
CTRL key, and drag a copy of the object to the new location. 

~ Tip After you copy an object using the second method above, you can use the 
Repeat command (from the Edit menu) to place multiple copies of the object using 
the same spacing. This is a quick way to create an array of aligned objects. 
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Pasting an object 

To use the Paste command, an object must already be on the Clipboard via the Cut 
or Copy command. Place the pointer where you want the object to be pasted. From 
the Edit menu, choose Paste. The object is removed from the Clipboard and placed 
on the schematic page. 

Fb Note Capture can only paste text from other Windows applications. 

Deleting an object 

There are several ways to delete a selected object: 

• From the Edit menu, choose Delete. 

• From the right mouse button's pop-up menu, choose Delete. 

• Press DELETE. 

• Press BACKSPACE. 
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Placing a bitmap 

You can create a bitmap in another application and place it on a schematic page, on a 
library part, or in a custom title block. 

FD Note Because some printers and plotters do not interpret bitmaps correctly, you 
should place one bitmap and print or plot it, to ensure that the output is what you 
want before you place multiple bitmaps. 

To place a bitmap 

1 From the Place menu, choose Picture. A standard Open dialog box displays. 

2 Select the bitmap file. If the file is not listed in the File name text box: 

.. In the Look in drop-down list, select a new drive. 

• Choose the Up One Level button. 

• In the Files of type box, select the type of file you want to open. 

3 Choose the OK button. A rectangle representing the bitmap image is attached to 
the pointer. 

4 Click the left mouse button to place the bitmap at the desired location. If you 
want to place mUltiple copies of the bitmap, repeat this step. 

5 Press ESC or choose the selection tool. 

To resize a bitmap 

To resize a bitmap, select it so that it displays in the selection color with resize 
handles at the four comers. Position the pointer over a resize handle and drag the 
handle. The bitmap's size and shape change to accommodate the new dimensions. 
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Placing text 

You can place text, in the font of your choice, on a schematic page or on a part to 
document your schematic page. 

To place text on a schematic page 

1 From the Place menu, choose Text (ALT, P, T). 
or 
Choose the text tool on the tool palette. 

2 Enter the text. To type numbers using the numeric keypad on your keyboard, 
you must first enable the NUM LOCK key. 

3 Complete the dialog box selections by specifYing font, color, and rotation. 

4 Choose the OK button to close the dialog box. A rectangle representing the text 
is attached to the pointer. 

S Click the left mouse button to place the text at the desired location. You can 
place multiple copies of the text by clicking the left mouse button at each 
location where you would like text. 

6 When you are done placing text, choose End Mode from the right mouse button 
pop-up menu or press ESC. 

~ Tip If you have text in another Windows application, you can copy it to the 
Clipboard and paste it into the text dialog box using the CTRL +v shortcut keys. 

To move text 

1 Select the text so that it displays in the selection color with resize handles at the 
four comers. 

2 Position the pointer over the text-not a resize handle-and drag the text to the 
new location. 

3 Click an area where there are no parts or objects to deselect the text. 
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To move or copy text using the Clipboard 

1 Select the text. 

2 From the Edit menu, choose Cut (ALT, E, T). The text is placed on the Clipboard. 
or 
From the Edit menu, choose Copy (ALT, E, c). A copy of the text is placed on 
the Clipboard. 

3 From the Edit menu, choose Paste (ALT, E, p). The text is attached to the pointer. 

4 Move the pointer to the location where you want to place the text and click the 
left mouse button. The text is placed and displays in the selection color. 

5 Click an area where there are no parts or objects to deselect the text. 

To rotate text 

1 Select the text so that it displays in the selection color with resize handles at the 
four comers. 

2 From the Edit menu, choose Rotate (ALT, E, 0). The text rotates 90° 
counterclockwise. 

3 Repeat step 2 as necessary. 

4 Click an area where there are no parts or objects to deselect the text. 
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The text bounding box 

Deleting text 

Modifying text 

Text that you place wraps according to the dimensions of its bounding box. To 
change how the text wraps, select it so that it displays in the selection color with edit 
handles at the four comers. Position the pointer over an edit handle and drag the edit 
handle. The text inside the bounding box rewraps within the new dimensions. 

To delete the text and its bounding box, select the text so that it displays in the 
selection color with edit handles at the four comers. Press either the DELETE key or 
the BACKSPACE key. 

To delete text when it is highlighted in the Edit Text dialog box, press the DELETE 

key, the BACKSPACE key, or begin typing new text. 

To delete individual words within the text, double-click on the text, or select the text 
and choose Properties from the Edit menu. The Edit Text dialog box displays, with 
the text highlighted. Press one of the four arrow keys to remove the text 
highlighting. Double-click on the word you want to remove. Press the DELETE key or 
the BACKSPACE key. 

To add more text to text you have already placed, double-click on the text, or select 
the text and choose Properties from the Edit menu. The Edit Text dialog box 
displays, with the text highlighted. Press one of the four arrow keys to remove the 
text highlighting. Type the additional text. When you are done, choose the OK 
button. 

126 DrCAD Capture for Windows User's Guide 



Finding text 

Rep/acing text 

Chapter 8 Adding and editing graphics and text 

You can use the Find command to search for text in an entire project, in selected 
schematic pages, on one schematic page, or in the part editor. . 

To find text 

1 In the project manager, select the root schematic folder (to search the entire 
project) or select specific schematic pages. 
or 
Make the schematic page editor or the part editor the active window. 

2 From the Edit menu, choose Find. The Find dialog box displays. 

3 Leave the asterisk in the Find What text box to locate all occurrences of all text. 
or 
Narrow the text search by entering specific text in the Find What text box. 

4 Verify that the Match Case option is as you want it. 

5 Select Text from the object types in the Scope area. 

6 Choose the OK button. 

If you search the entire project or selected schematic pages from the project 
manager, the search results are listed in the browse window. If you search with 
either the schematic page editor window or the part editor window as the active 
window, the results ofthe search display in the selection color in either the 
schematic page editor window or the part editor window. 

Schematic page editor or part editor text can be replaced by entering the replacement 
text from the keyboard, or copying the replacement text from another application. 

To replace text 

1 Select the text so that it displays in the selection color with resize handles at the 
four comers .. 

2 From the Edit menu, choose Properties. The Edit Text dialog box displays, with 
the text highlighted. 

3 Enter the replacement text, then choose the OK button. 
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Importing text 

Exporting text 

You can import text from any Windows program that copies text to the Clipboard. 

To import text from other Windows applications 

1 In the other Windows application, copy the text to the Clipboard using that 
program's Copy command. 

2 Make the schematic page editor or part editor the active window. 

3 From the Place menu, choose Text. The Place Text dialog box displays. 

4 Press CTRL +v to paste the text into the text box, then verify that the color, font, 
and rotation are as you want them and choose the OK button. A rectangle 
representing the text is attached to the pointer. 

S Click the left mouse button to place the text at the desired location. 

6 When you are done placing text, press ESC or choose the selection tool. 

You can export Capture text to any Windows program that uses the Clipboard. 

To export text to other Windows applications 

1 In Capture, select the text you want to export. 

2 From the Edit menu, choose Cut or Copy. The text is placed on the Clipboard. 

3 Activate the other Windows application and use that application's Paste 
command to place the text. 
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Character formatting 

You may want the text to have a distinctive appearance, or to fit a specific space. 
Capture supports TrueType® fonts. You can preview a sample of the selected font 
before you choose it. You can also select the default font that you set up in the Fonts 
tab in either the Design Template dialog box or the Design Properties dialog box 
(available from the Options menu). 

To change fonts and point sizes 

1 If you are placing the text, choose Text from the Place menu. The Place Text 
dialog box displays. 
or 
If the text has already been placed, double-click on the text. The Edit Text 
dialog box displays. 

2 In the Font group box, choose the Change button. The Font dialog box displays. 

3 Select a font, style, and size. Sample text displays in the Sample group box. 

4 Choose the OK button twice. 

About screen fonts 

m See For information about setting up your screen fonts, see Chapter 4: Setting 
up your project. 
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Using macros 

In the schematic page editor, you can create a macro by recording a series of editing 
actions. For example, you can begin a macro recording, place a wire, place text that 
names the wire, then stop the macro recording. Macros are recorded at the command 
level (not at the keystroke level) and each macro is stored as a separate file. You can 
also create a macro in ASCII text, using valid Visual Basic syntax. 

W See For samples of valid Visual Basic syntax, see Capture's online help. 

When you record a macro, Capture assigns it a temporary name, and it is treated as a 
temporary macro. Temporary macros can be run during the current Capture session, 
but they are not saved for use in subsequent Capture sessions. You can make a 
temporary macro permanent by saving it using the Configure Macro dialog box 
(choose Configure from the Macro menu). 

Fb Note Since you cannot edit schematic pages in physical mode, the macro 
recorder and the macros are only available in logical mode. 

In general, you can record a macro command for each menu command available in 
the schematic page editor. However, because the macro commands are limited to the 
schematic page editor window, the following commands that result in moving to a 
new window are unavailable: 

• Ascend 

• Descend 

• Edit Part in Place 

When recording a macro, the Undo command is not recorded as a part of the macro. 
For this reason, you cannot create an undo macro using the Undo command. 
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Recording a macro 

A location recorded within a macro is relative to the previous action, not relative to 
where you began recording the macro. For example, you can record a macro to place 
a wire, move the cursor down one grid space, then place another wire. When you run 
the macro at a different location on your schematic page, the macro places a wire, 
moves down one grid space, then places another wire. 

To record a macro 

1 Click the left mouse button on the schematic page to set a location to begin 
recording the macro. 

2 From the schematic page editor's Macro menu, choose Record. The macro 
recorder tool palette containing three buttons displays, as shown below. 

3 Perform the series of edits that you want to record as a macro, using the three 
macro record buttons as necessary. 

• Use the left button to stop recording the macro. 

• Use the center button to pause recording. The pause mode is in effect until 
you choose the center button again. 

• Use the right button to cause a command to record in a ''with dialog" mode. 
If a command is recorded in this mode, the value you enter while recording 
the macro is not saved. Instead, when the macro is run, the command 
displays a dialog box so that you can fill in a value. When recording, the 
"with dialog" mode is in effect until you choose the right button again. 

4 Choose the left macro record button to stop recording the macro. 

Playing a macro 

Choose Play from the Macro menu to play back the most recently recorded macro or 
any macro you choose in the Configure Macro dialog box. 

To playa macro 

1 Click the left mouse button on the schematic page to set a location to begin 
playing the macro. 

2 From the schematic page editor's Macro menu, choose Play. 
or 
From the Configure Macro dialog box, choose Play. 
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Configuring a macro 

After you record a macro, you give it a name, and you can also assign it a menu 
entry, a shortcut key definition, and a description. Once you give a macro a name 
and save it, it automatically displays in the Macro name list box in the Configure 
Macro dialog box the next time you run Capture. The text you enter as the menu 
entry displays on the Macro menu, along with the macro's shortcut key definition, if 
you specified one. The text you enter as the description displays in the Description 
text box in the Configure Macro dialog box when you highlight the macro name. 

To configure a macro 

1 From the schematic page editor's Macro menu, choose Configure. The 
Configure Macro dialog box displays. 

2 If the macro you want is not selected, select it. 

3 In the Macro Name text box, enter a name for the macro and choose the Save 
button. The Macro Name dialog box displays. 

4 To assign a shortcut key, enter text corresponding to a shortcut key or key 
combination (for example, CTRL+7) in the Keyboard Assignment text box. 

5 . To have the macro appear as an entry on the Macro menu, enter the appropriate 
text (for example, Wirenames) in the Menu Assignment text box. 

6 To describe the macro, enter the appropriate text in the Description text box. 

7 Choose the OK button. The Save As dialog box displays. 

8 Select a file location and filename, choose the Save button, then choose the 
Close button. 
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Configure Macro dialog box 

Macro Name Displays the macro name. You can either select a macro from the 
macro name list box or type in a macro's name. The macro shown in the Macro 
Name field is the macro that is run if you choose Play from the Macro menu or 
choose the Run button in the Configure Macro dialog box. 

Configured Macros Displays the currently configured macros and any currently 
available temporary recordings. Selecting a name from the list fills in the dialog box 
fields with the appropriate values. 

Close Closes the dialog box. Since the editing changes you make in the dialog 
box are immediately saved to memory, the edits are not permanently saved to the file 
unless you use the Save command before you use the Close command. 

Record Closes the dialog box, displays the macro record dialog box, and records 
your editing actions until you choose the Stop button in the macro record dialog box. 
A recording is temporary (only available for the current Capture session) unless you 
assign it a macro name and save it using either Save or Save As. 

Play Runs the active macro. 

Add Displays a dialog box that you use to add a macro you have created. The 
macro must be in ASCII text, and use valid Visual Basic syntax. A newly added· 
macro is highlighted in the list of macros and becomes the active macro. 

Remove Removes a macro from the list of permanent macros, but does not 
remove the macro from your hard disk. 
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Save Updates an existing macro on your hard drive or saves a temporary macro to 
your hard drive. Saving a macro adds it to the list of configured macros and makes it 
the active macro. 

Save As Displays a Macro Name dialog box that you use to assign the macro a 
name, keyboard assignment, menu assignment, and description. Saving a macro adds 
it to the list of configured macros and makes it the active macro. 

Keyboard Assignment Specifies the shortcut key associated with the macro. 
You can specify a shortcut key for a temporary macro recording or change the 
shortcut key used for an existing macro by entering the text equivalent of a keyboard 
sequence in the Keyboard Assignment text box. 

Menu Assignment Specifies the menu assignment associated with the macro. 
You can specify a menu assignment for a temporary macro recording or change the 
menu assignment used for an existing macro by entering a menu entry in the Menu 
Assignment text box .. 

Description Specifies the descriptibn associated with the macro. You can specify 
a description for a temporary macro recording or change the description used for an 
existing macro by ·entering text in the Description text box. 

Naming a macro 

You can assign a macro a name of any length, but be aware that Windows systems 
such as Windows 3.11 will truncate your filename to eight characters. Since periods 
aren't allowed in macro filenames, don't specify a file extension for your macro 
filename: Capture will assign an extension of .BAS to your macro filename. If you 
want, you can rename the file with a different file extension using the Rename 
command in Windows Explorer. 

There are some restrictions regarding the names you give your macros. These 
restrictions are given below. 

• You cannot use spaces in a filename. 

• You cannot use the following filename extensions for your macro names, since 
they are reserved for Capture's use: .DBK, .DLL, .DSN, .EXE, .INI, .LLG, 
.OBK, and .OLB. 
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• You cannot use any of the names in the list below for your macro names, since 
they are reserved for use by Capture's macro subroutines. 

Copy PlaceBus PlaceTitieBlock 

Cut PlaceBusEntry PlaceTitieBlockWithDialog 

Delete PlaceEllipse PlaceWire 

DisplayProperty PlaceGround RemoveDisplayProperty 

DisplayPropertyEx PlaceGroundWithDialog RemoveProperty 

Drag PlaceJunction ReplacePart 

Duplicate PlaceLine Rotate 

FindBookMarks PlaceNetAlias SelectAll 

FindDRCMarks PlaceNetAliasWithDialog SelectBlock 

FindHierarchicalPorts PlaceNextPolygonPoint SelectObject 

FindNets PlaceNextPolylinePoint SetColor 

FindOffPageConnectors PlaceNoConnect SetFillStyle 

FindParts PlaceOffPage SetFont 

FindText PlaceOffPage WithDialog SetFontEx 

GoToAbsolute Place Picture SetHatchStyle 

GoToBookMark PlacePin SetLineStyle 

GoToGridReference PlacePin WithDialog SetLineWidth 

GoToRelative PlacePart SetProperty 

Group PlacePartWithDialog Ungroup 

MirrorHorizontal PlacePolygon ViewGrid 

MirrorVertical PlacePolyline ViewGridReference 

Move PlacePort ViewZoomScale 

Paste PlacePortWithDialog ZoomAll 

PlaceArc PlacePower ZoomArea 

PlaceBlock PlacePowerWithDialog Zoomln 

PlaceBlockWithDialog PlaceRectangle ZoomOut 

PlaceBookMark PlaceText ZoomSelection 

PlaceBookMarkWithDialog PlaceTextWithDialog 
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Assigning a shortcut key to a macro 

To assign a shortcut key to a macro, enter an alphanumeriC character (such as K) in 
the Keyboard Assignment text box in the Configure Macro dialog box, then save the 
macro. To enter a combination of keyboard keys and alphanumeric characters, add a 
plus sign (+), either with or without spaces, between the items (for example: ALT+2 
or ALT+ 2). Shortcut keys are not case-sensitive: you can specify ALT+2 or Alt+2. 

RJ Note Any shortcut keys you assign to your macros take precedence over the 
shortcut keys assigned to other Capture functions. For example, you can use 
CTRL +DEL as a key combination for a macro, even though it is the key combination 
assigned to clear the Capture session log. To restore an original shortcut key 
assignment (in this example, restoring CTRL +DEL to its original function of clearing 
the session log), assign a different shortcut key to your macro using the Keyboard 
Assignment text box in the Configure Macro dialog box, choose Save, then choose 
Close. 

To assist you in assigning shortcut keys to your macros, Capture has reserved the 
following shortcut-key starting sequences: 

CTRL 
ALT 

SHIFT 
CTRL+ALT 
CTRL+SHIFT 
CTRL +AL T+SHIFT 
ALT+SHIFT 

To use one of the starting sequences, enter it in the Keyboard Assignment text box, 
add a plus sign (+), then add an alphanumeric character (for example: CTRL+P). You 
have to use the starting sequences in the same order, and in the same format, as 
shown in the list above. For example, you cannot reverse the order of the keys, nor 
can you use CONTROL instead of CTRL. You cannot use a shortcut-key starting 
sequence by itself: SHIFT by itself will not function as a shortcut key. The following 
table shows all of the alphanumeric characters, function keys, punctuation keys, 
special keys, and arrow keys that you can use with the shortcut key starting 
sequences listed above. 

Type of key Available keys 

Alphabetic character A through z, inclusive 

Numeric character o through 9, inclusive 

Function key FI through F24, inclusive 

Punctuation key !, @, #, $, %, 1\, &, *, (,) 

Special key ESC, INS, DEL, PGUP, PGDN, HOME, END 

Arrow key LT, RT, UP, DN 
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About the Capture to Layout macros 

Included with Capture are three macros designed to reduce any problems you may 
have when preparing your Capture design for use in Layout. These macros are 
available on the Macro menu, and are: 

• Set Layout Part Properties 

• Set Layout Pin Properties 

• Set Layout Net Properties 

In addition, these three commands are available in the Configure Macro dialog box, 
as PCBPartProps, PCBPinProps, and PCBNetProps, respectively. When you play 
any of these macros, they bring up an appropriate dialog box in which you enter the 
values you want transmitted to Layout. 

m See For illustrations of the three dialog boxes that these three macros display, 
and descriptions and example values for their respective properties, see 
Transferring user-defined properties to Layout in Chapter 18: Using Capture with 
DrCAD Layoutfor Windows. 
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Changing your view of a schematic 
page 

Zooming 

There are several ways to change your view of a schematic page. They include 
zooming to a smaller or larger view of the schematic page; centering a view on a 
particular position; and moving to a different location. You can also choose whether 
or not to display a grid or grid references. 

In the schematic page editor and in the part editor, you can look closely at a 
particular area by using the Zoom In command on the View menu. Conversely, you 
can change your viewing perspective to increase the portion of the drawing board 
that is visible by using the Zoom Out command. When you zoom in or out, Capture 
centers your view on the current pointer position, if possible. If the pointer is outside 
the window, or if you choose the Zoom In or Zoom Out toolbar button, Capture 
centers your view on any selected objects. Otherwise, Capture zooms in or out on 
the center of the active window. 

I=b Note If you choose an editing function, then choose a command to change the 
view, your next mouse click implements the editing function. For example, if you 
have the circle tool selected and then zoom in or out, your next mouse click will 
start a circle. 

To zoom in 

~ From the View menu, choose Zoom, then choose In (ALT, v, Z, I). 
or 
Choose the zoom in tool on the toolbar. 

The current zoom scale is multiplied by the zoom factor. With a zoom factor of two, 
zooming in makes the image twice as large and displays half the area of the previous 
view. 
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To zoom out 

~ From the View menu, choose Zoom, then choose Out (ALT, V, Z, 0). 

or 
Choose the zoom out tool on the toolbar. 

The current zoom scale is divided by the zoom factor. With a zoom factor oftwo, 
zooming out halves the image size and shows twice the area of the previous view. 

To change the zoom factor 

1 From the Options menu, choose Preferences (ALT, 0, p), then choose the Pan 
and Zoom tab. 

2 In the Zoom Factor text box, enter the new zoom factor. Note that you can 
specify separate values for the schematic page editor and the part editor. 

3 Choose the OK button. 

Zooming to a specified scale 

The Zoom Scale dialog box provides predefined scales (25%, 50%, 100%, 200%, 
300%, and 400%). You can also type in a custom scale value (as a percentage). The 
scaling limits the size of the schematic page that can be displayed (for example, if 1 
unit = .01 ", then you can display: 320" at 100%, 160" at 200%,80" at 400%, and so 
on). 

~ Tip You can view the current scale in the status bar at the bottom of the 
schematic page editor window. It displays to the left of the X and Y coordinates. 

To zoom to a specific scale 

1 From the View menu, choose Zoom, then choose Scale (ALT, V, Z, s). 

2 Select one of the preset scales, or enter a custom scale. 

3 Choose the OK button. 
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Other viewing options 

You can view a selected area or the entire page, or you can center your view. 

To view a selected area 

1 From the View menu, choose Zoom, then choose Area (ALT, Y, Z, A). 

or 
Choose the zoom area tool on the toolbar. 

2 Move the pointer to one comer of the area to view. 

3 Press and hold the left mouse button as you move the pointer to the opposite 
comer of the area to view. 

4 Release the mouse button. The area is enlarged to fill the window. 

To view the entire page or part 

~ From the View menu, choose Zoom, then choose All (ALT, Y, Z, L). 

or 
Choose the zoom all tool on the toolbar. 

The entire schematic page or part is reduced or enlarged to fit the window. 

To center the view on an object or area 

1 Select objects or an area. 

2 From the View menu, choose Zoom, then choose Selection (ALT, Y, Z, E). 

The display scrolls so that the selected objects or selected area is in the center of the 
window. The zoom scale does not change. 

To center the view on your pointer 

~ Press SHIFT+C. 

The display scrolls so that the pointer's selection is in the center of the window. The 
zoom scale does not change. 
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Moving to a new location 

There are several different ways you can move to a new location on a schematic 
page. To move using the methods listed below, use the Go To command and dialog 
box. You can: 

• Move to a particular set of X, Y coordinates or to an X, Y location offset from 
the pointer's current position. 

• Move to a grid reference area, as indicated by the horizontal and vertical grid 
reference headings. 

• Move to a location previously marked by a bookmark. 

From the View menu, choose Go To to display the Go To dialog box, which has 
three tabs labeled Location, Grid Reference, and Bookmark, shown below and on 
the next page. 

Moving to an X, Y location 

The X and Y coordinates of your pointer's current location are displayed on the right 
side of the status bar. 

To move to a specific location 

1 From the View menu, choose Go To (ALT, v, G). 

2 Choose the Location tab. 

3 Enter the X and Y values, select the Absolute option, then choose the OK 
button. The coordinates are measured in inches or millimeters, depending on 
what you have configured in the Page Size tab on the Schematic Page Properties 
dialog box. Your pointer moves to the new coordinates. 

To move a specific distance 

1 From the View menu, choose Go To (ALT, v, G). 

2 Choose the Location tab. 

3 Enter the X and Y values that you want the pointer to move, select the Relative 
option, then choose the OK button. The jump distance is measured in inches or 
millimeters, depending on what you have configured in the Page Size tab on the 
Schematic Page Properties dialog box. Your pointer moves the specified 
distance. 
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Go To dialog box, Location tab 

GoTo ~ 
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X Specifies the X-axis coordinate for the jump. 

Y Specifies the Y-axis coordinate for the jump. 

Absolute and Relative Specifies the jump as absolute (to the indicated 
coordinates) or relative (the coordinates are offset to the pointer's current position). 

Jumping to a specific grid reference 

Grid references are marked on the left and upper edges of the schematic page. 

To jump to a reference area 

1 From the View menu, choose Go To (ALT, v, G). 

2 Choose the Grid Reference tab. 

3 Select a horizontal grid reference from the Horizontal drop-down list. 

4 Select a vertical grid reference from the Vertical drop-down list. 

S Choose the OK button. 

Go To dialog box, Grid Reference tab 

Go To ~ 
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Horizontal Specifies a horizontal grid reference for the jump. 

Vertical Specifies a vertical grid reference for the jump. 
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Jumping to a marked location 

To return repeatedly to a specific area of a schematic page, or to direct attention to a 
particular location, you can use a bookmark. To use a bookmark, you assign it a 
name and place it on a schematic page. When you want to return to it, use the Go To 
command. You can also reuse existing bookmarks by selecting them and moving 
them to new locations. Bookmarks are saved with your project. 

To place a bookmark 

1 From the Place menu, choose Bookmark (ALT, P, M). 

2 Enter the name of the bookmark, then choose the OK button. 

3 Position the pointer where you want the bookmark and click the left mouse 
button. The bookmark is placed, and displays in the selection color. 

4 Click an area where there are no parts or objects to deselect the bookmark. 

To rename a bookmark 

1 Select the bookmark. 

2 From the Edit menu, choose Properties (ALT, E, I). The Rename Bookmark 
dialog box displays. 

3 Enter a new name in the text box. 

4 Choose the OK button. 

To move to a specific bookmark 

1 From the View menu, choose Go To (ALT, v, G). 

2 Choose the Bookmark tab. 

3 Enter the name of the bookmark and choose the OK button. 

Go To dialog box, Bookmark tab 

Name Specifies a name of a bookmark for the jump. 
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Displaying the grid and grid references 

You can hide the grid display and grid references, then display them again later. 

To display or hide the grid 

~ From the View menu, choose Grid (ALT, Y, I). 

To display or hide the grid references 

~ From the View menu, choose Grid References (AL T, Y, R). 

Fb Note The settings in the Grid Display tab in the Preferences dialog box (from 
the Options menu) control whether the grid appears as grid dots or lines. The Grid 
Display tab setting also controls whether the pointer snaps to grid. 

Finding parts in a project 

Using the Find command and a part property value, you can locate a part in a 
project, schematic folder, or on a schematic page. In the Find dialog box, you enter a 
property value string and specify that you want to find a part. Capture searches all 
the parts to find those with a property value that matches the string. If you aren't 
sure of the exact property value string, you can enter wildcard characters to constrain 
the search list, then choose the OK button. Valid wildcard characters are an asterisk 
(*) to match multiple characters and a question mark (?) to match individual 
characters. 

To find a part on a schematic page 

1 Open the schematic page. 

2 From the Edit menu, choose Find (ALT, E, F). 

3 Enter the property value string that defines the part you want to search for. 

4 Select Parts from the object types in the Scope area. 

S Choose the OK button to start the search. Parts that have a property value 
matching the property value string of step 3 are selected on the schematic page. 

! Tip You can edit the properties of multiple parts when they are selected using 
the spreadsheet editor. From the Edit menu, choose the Properties command, or 
choose Edit Properties from the right mouse button's pop-up menu. For 
information on using the spreadsheet editor, see the section Using the spreadsheet 
editor to edit properties in Chapter 2: The Capture work environment. 
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To find a part in a project 

1 In the project manager, select the schematic folder or schematic pages you want 
to search. 

2 From the Edit menu, choose Find (ALT, E, F). 

3 Enter the property value string that defmes the part you want to search for. 

4 Select Parts from the object types in the Scope area. 

S Choose the OK button to start the search. Parts that have a property value 
matching the property value string of step 3 are listed in the browse window. 

6 Double-click on the part in the browse window to open the schematic page 
editor with the found part displayed and selected. 
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Libraries and parts 

Part Three provides information about libraries and parts. A library is a file that 
stores parts, symbols, title blocks, and schematics. Capture provides over 20,000 
parts contained in more than 80 libraries. You can create additional custom libraries 
to store any combination of items. Part Three includes these chapters: 

Chapter 11: About libraries and parts describes libraries and parts, how the parts in 
a design are stored in the design cache, and how you can replace or update parts in 
the design cache. 

Chapter 12: Creating and editing parts describes how to create new parts and store 
them in a library, how to edit parts in a library, and how to edit parts after they are 
placed on a schematic page. 

Part Three 





Chapter 11 

About libraries and parts 

Libraries 

Capture's libraries contain more than 20,000 parts. This chapter describes Capture's 
libraries, and explains how parts, packages, and electrical symbols are stored in 
libraries. 

Libraries are files that contain reusable part data. They contain parts that you can 
place as instances on schematic pages. Libraries may also contain a variety of 
symbols (such as power symbols, ground symbols, and so on) and title blocks that 
you can reuse in your projects. 

The relationship between the library and the parts and symbols it contains is similar 
to the relationship between a schematic folder and its contents. The contents of the 
library move with the library and are deleted with the library. 

You can create. custom libraries to store any combination of items. You can, for 
example, create a library to hold schematic pages that you use often. There is no 
need to create a library for a project, because the design cache holds all the parts and 
symbols used in the project. 

~:- Caution If you edit a library provided by Capture, you should give it a new and 
unique name so that you will not copy over your changes when you receive 
updated libraries. 

When you work with a library in Capture, you use 
the project manager. The project manager lists the 
parts and symbols contained in the library. 

Iil!ll TTL OLB I!!I~ES 

:t> 1488 
:t> 1489 
:e- 7400 
:e- 7401 
:e- 7402 
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To edit a part, double-click on it. The part opens in a part editor window. 

To move a part to a different library, open the source library and the destination 
library in separate project manager windows. Select the part and drag it from one 
library to the other. 

To copy a part to a different library, follow the same procedure but hold the CTRL 

key down while you drag the part. 

m See For information about printing a part, see Chapter 5: Printing and plotting. 

! Tip You can also use the Cut, Copy, and Paste commands on the Edit menu to 
move or copy parts between libraries. 

m See For general information about using the project manager, see Chapter 2: 
The Capture work environment. 

Because a library is a file, you can work with it in the Windows Explorer as well as 
in Capture. When you need to back up a library, use Windows Explorer to create a 
copy. 
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Chapter 11 About libraries and parts 

Parts are the basic building blocks of a project. A part may represent one or more 
physical elements, or it may represent a function, a simulation model, or a text 
description for use by an external application. A part's behavior is described by a 
PCB footprint, an HDL statement, or an attached schematic folder. 

Parts usually correspond to physical objects-gates, chips, connectors, and so on­
that come in packages of one or more parts. Packages that have more than one part 
are sometimes referred to as multiple-part packages. For simplicity, Capture usually 
refers to both parts and multiple-part packages as parts. 

You can specify packaging information when you create a part, or you can change it 
in the part editor (from the Options menu, choose Package Properties). 

Each part has graphics, pins, and properties that describe it. As you place the parts in 
a package to suit your design requirements, Capture maintains the identity of the 
single physical part-the package-for back annotation, netiisting, bills of materials, 
and processes that require it. 

The parts in a package may have different pin assignments, graphics, and user 
properties. If all the parts in a package are identical except for the pin names and 
numbers, the package is homogeneous. Ifthe parts in a package have different 
graphics, numbers of pins, or properties, the package is heterogeneous. 

Part instances 

A part instance is a part you have placed on a schematic page. You place part 
instances in logical mode. If you change to physical mode, you see occurrences of 
the part instances. 

W See For more information on how logical mode and physical mode affect parts 
and part instances, see Modes-logical and physical in Chapter 2: The Capture 
work environment. 

DrCAD Capture for Windows User's Guide 151 



Part 3 Libraries and parts 

The design cache 

When you place the first instance of a part in a design, a copy of the part is created 
in the design cache. The design cache stores one copy of every part used in the 
design. Nonnally, all instances of the part refer to this copy in the design cache. 

Fb Note Updating or replacing a part in the design cache affects every instance of 
the part in the design, as long as the part instances have retained their links to their 
original libraries. 

An original cache part also retains a link to the library part on which it is based, so 
you can update all of the parts in the design cache to synchronize them with the parts 
in the libraries. If you update all instances of a part, the new part replaces the old in 
the design cache, and the link with the original library is broken. If you update only 
the current part instance, you create a new part in the design cache, and the new part 
has no link to the original library. 

Fb Note Once you edit a part instance, the link to the original library no longer 
exists. This means: 

• Because it doesn't exist in a library, the only way to place a copy of the part is 
to use the Copy and Paste commands on the schematic page editor's Edit menu. 

• The part instance is not affected by the Update Cache command. 

• To restore its link with the original library, choose the Replace Cache command 
from the project manager's Design menu. 
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To replace a design cache part instance with a different library part 

1 Open the project containing the part instance you want to replace. 

2 Open the design cache and select the part instance you want to replace. 

3 From the Design menu, choose Replace Cache (ALT, D, c). The Replace Cache 
dialog box displays. 

Replace Cache Ei 

Part Name: 

I 74lS32 

Part ltbrarl': 

IC:\CAPTURE\UBRARY\ TTL.OlB 

OK 

Cancel 

Rrowse. .. 

Help 

~ Tip The text boxes in the Replace Cache dialog box contain the name of the part 
instance you are replacing and its original source library. You can leave these 
fields unchanged to update the part instance with its original version. This is 
useful if you have changed the part instance in the design cache and would like to 
use its original version, or if you have received an update to a library and want to 
use the new version of the library part. 

4 In the Part Name text box, type the name of the library part you want to use to 
replace the selected part instance, using appropriate upper case and lower case 
letters. (The part names are case-sensitive.) 

5 In the Part Library text box, type the path and filename of the part's library. 

6 Choose the OK button. Capture replaces the part instance you selected in step 2 
with the library part you specified in steps 4 and 5. 

To update selected parts in the design cache so they match their 
corresponding library parts 

When you update parts in the cache, any user-defined properties are preserved. 

R:J Note When you update parts in the cache, user-defined properties on pins are 
deleted. 

1 Ifit's not already open, open the project containing the parts you want to 
update. 

2 Open the design cache and select the parts you want to update. 

3 From the Design menu, choose Update Cache (ALT, D, u). Capture warns you 
that you will update the selected parts with parts from their original libraries. 

4 Choose Yes. Capture updates the parts you selected in step 2 with their 
corresponding library parts. Other projects that use these parts are not affected. 
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Primitive and nonprimitive parts 

A primitive part contains no hierarchy. A non primitive part has an underlying 
hierarchical description, such as an attached schematic folder. In Capture, this 
characteristic is defined in a property, called Primitive, on every part instance. When 
a part is specified as primitive, all of Capture's tools treat it as such. You cannot 
descend into a primitive part, even ifit has an attached schematic folder. 

Fb Note If you attach a schematic folder to a part in a homogeneous package in a 
library, the schematic folder is attached to each part in the package. Once the part 
is placed on a schematic page, you can attach different schematic folders to each 
part in the package. You cannot attach a schematic folder to a part in a 
heterogeneous package. 

You can change the Primitive property as often as you like during the design 
process. For example, you might create a part and attach a schematic folder whose 
schematic pages describe the part's gates and wiring, then attach schematic folders 
to some of those parts to describe their transistors. 

The following are some guidelines for using the Primitive property: 

• Before you create a netlist for simulation, specify the parts as nonprimitive, so 
that Create Netlist can descend far enough to find the transistor-level 
descriptions. 

• Before you create a netlist for board layout, specify the parts as primitive, so 
that Create Netlist stops at the gate-level descriptions. 

For part instances that have their Primitive property set to Default, you can set them 
as primitive or nonprimitive on a project-wide basis using the Design Properties 
command on the Options menu. Choose the Hierarchy tab, select either Primitive or 
Nonprimitive in the Parts group box, then choose the OK button. This is useful when 
you are describing and simulating your design at varying levels of abstraction (as 
when using top-down design). 
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Creating and editing parts 

In Capture you can create parts and add them to a new or existing library. You can 
also edit existing parts in a library or on a schematic page. All of these processes are 
described in this chapter. 

To create or edit a part, you use the part editor. There are many different ways to 
access the part editor: 

• To create a new part, open a new or existing library in the project manager. 
From the Design menu, choose the New Part command. 

• To edit an existing part, open a library in the project manager, then double-click 
on the part. 

• To edit a part instance on a schematic page, select it. From the Edit menu, 
choose Part. 

~ Tip-Parts and packages: homogeneous or heterogeneous 

A part may be divided into several logical parts all contained in a single physical 
package. You can distribute the individual logical parts throughout your project, 
while maintaining the part's identity as a single physical part. 

Each logical part has graphics, pins, and properties that describe it. If you define a 
package in which all the logical parts are identical except the pins, the package is 
homogeneous. For example, a hex inverter is a homogeneous package. If the 
logical parts vary in graphics, number of pins, or properties, the package is 
heterogeneous. An example of a heterogeneous package is a relay with a normally 
open switch, a normally closed switch, and a coil. 

Both homogeneous and heterogeneous packages may have shared pins, such as 
supply pins that are used by every logical part in the package. Often, these pins are 
invisible, but are connected by name to a power or ground net. 
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Creating a new part 

Defining a part 

You can create your own custom parts and save them in a library. A custom part can 
be a single part, or it can be a package that contains multiple parts. It can contain 
pins, graphics, text, and IEEE symbols. Graphics must be within the part's body, 
while text and IEEE symbols can be either inside or outside the part's body. Pins are 
attached to the part at the part body border, which defines the size and shape of the 
region in which you create the part body. 

To create a part, you complete three processes: you defme the part, you add graphics 
to the part, and you place pins on the part. This section describes these processes. 

Before you begin drawing a part, you must provide Capture with specific 
information about the part, such as the part's name. If the part is a multiple-part 
package, you can specifY how many parts are in the package and whether the part is 
homogeneous or heterogeneous. Once you provide this information, you can draw 
the part, place graphics, and place pins. 

To define a new part 

1 In the project manager, select the library you want to add the new part to. 

2 From the right mouse button's pop-up menu, choose New Part. The New Part 
Properties dialog box displays. 

3 In the Name text box, type a name for the part yO\! are creating. You can use the 
default settings for the other options on this dialog box, or you can change them 
to fit your requirements. For example, if this part is a multiple-part package, 
enter the number of parts in the package. All fields on the New Part Properties 
dialog box are described later in this section. 

Fb Note Once you designate the package type as either Homogeneous or 
Heterogeneous and choose the OK button to close the New Part Properties dialog 
box, the package type is set, and cannot be changed. 

4 When the part is specified to your requirements, choose the OK button. 

The part editor window displays, 
showing a dashed outline, which is the 
part body border. Pins will be placed on 
the part outside of this region, touching 
the part body border. The part's value 
displays below the part, and the part's 
reference displays above the part. The 
part editor window's title bar shows the 
name of the library, followed by the name of the part you are creating. 
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Fb Notes If you're creating a multiple-part package, the part editor window 
contains the first part in the package. If you are creating a homogeneous part, all 
edits you make to this part (with the exception of changes to pin numbers) apply to 
all parts in the package. If you are creating a heterogeneous part, edits you make to 
this part apply to this part only. To edit a different part in the package, choose 
Next Part or Previous Part from the View menu. 

To view all the parts in the package, choose Package from the View menu. You 
can edit a part by double-clicking on it in the package view. 

To view all of the package information, choose Package from the View menu, 
then choose Properties from the Edit menu. The Package Properties spreadsheet 
displays, showing the order of the pins, the groups of pins that are swappable, the 
pin numbers, the pin names, the pin types (normal or convert), and whether the 
pins are marked as Ignore. 

5 To change the size and shape of the part body border, select the border and drag 
the selection handles until the part body border is the size you want. 

6 Once you have established the part's border, you can use the drawing tools on 
the part editor's tool palette to draw the part and place text on the part. All 
graphics that make up the part must fit within the boundaries of the part body 
border-with the exception ofIEEE symbols and text. If you draw or place 
something other than IEEE symbols or text outside of the part body border, the 
part's border expands to encompass the graphics. 

!Wi See also For general information about adding graphics and text, and detailed 
information about placing IEEE symbols, see Adding graphics, text, and IEEE 
symbols to a part in this chapter. For details about each of the graphic and text 
tools, see Chapter 8: Adding and editing graphics and text. 

7 You can add pins to the part using the pin tool or the pin array tool. This is 
described in Placing pins on a part later in this chapter. 

8 When you are done creating the part, you must save it. From the File menu, 
choose Save (ALT, F, s). 

If you are creating this part in a new library that hasn't yet been saved, the Save 
As dialog box displays, giving you the opportunity to name the library file. If 
you are creating this part in a library that already exists, the part is saved in that 
library. 
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New Part Properties dialog box 

~ Tip After you have defined the part in the New Part Properties dialog box, you· 
can edit the part (except for changing the Package Type) using the Edit Part 
Properties dialog box. From the View menu, choose Package, then from the 
Options menu, choose Package Properties. 

Name The name of the part. This is used as the default part value when the part is 
placed on a schematic page. 

Part Reference Prefix Specifies the part reference prefix, such as C for 
capacitor or R for resistor. 

PCB Footprint The PCB physical package name to be included for this part in 
the netlist. 

Create Convert View Some library parts have a second form, such as a 
DeMorgan equivalent, as well as the standard representation. Select this option to 
give the part a convert view. If a part has a convert view, you can switch between 
the part's normal and convert views once the part is placed on a schematic page. 

~ Tip If a part has a convert view, you can change to it by choosing Convert from 
the part editor's View menu. You can also place a convert view of a part by 
selecting a part in the Place Part dialog box, selecting the Convert option, then 
choosing the OK button. 

Parts per Pkg Specifies the number of parts in the package. 

Homogeneous or Heterogeneous If the part is a multiple-part package, this 
specifies whether all the parts in the package have the same graphical representation 
(homogeneous) or different graphical representations (heterogeneous). 

158 OrCAD Capture for Windows User's Guide 



Chapter 12 Creating and editing parts 

Alphabetic or Numeric If the part is a multiple-part package, this specifies 
whether parts in the package are identified by letter or number. For example: 

• U?A (alphabetic) 

• U?-l (numeric-usually used for connectors) 

fji!:. Caution If you use Alphabetic identifiers, you are limited to 26 parts per 
package that will use letters. After the 26th part, Capture begins to use numbers as 
identifiers, instead of doubling up the letters, as in AA, AB, and so on. 

RJ Note The path and filename of the library that contains the part are displayed at 
the bottom left comer ofthe dialog box. 

Part Aliases Displays a dialog box that you use to add or remove part aliases, 
which are duplicate copies of parts that use different names in a library. Part aliases 
use the same graphics, attached schematic folders, and properties as the originals, 
with the exception of the part values. 

! Tip When you view a list of parts in a library, any parts that are placed via part 
alias display with lines through their centers. 

Attach Implementation Displays a dialog box that you can use to attach a 
schematic folder, VHDL entity, netiist, or project, thus creating a hierarchy. 

fji!:. Caution An attached schematic folder or other file external to the project or 
library is not stored with the project or library. If you copy or move the project or 
library to a new location, you must also move or copy the attached object to keep 
them together. In addition, you may need to edit the path to the attached schematic 
folder or file if you move the project to a new location with a different directory 
structure. 
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Attaching a schematic folder to a part 

!=b Note Library parts, part instances, part occurrences, and hierarchical blocks can 
have attached schematic folders. This section provides information about attaching 
a schematic folder to a library part. This information also applies, however, to part 
instances, part occurrences, and hierarchical blocks. 

Attaching a schematic folder to a part creates hierarchy in Capture. When you attach 
a schematic folder to a part, you specify the schematic folder's name or, optionally, 
specify a project containing the schematic folder. If you don't, Capture assumes the 
schematic folder is contained in the current project. If you attach a schematic folder 
to a part, you can move or copy the child schematic folder into the same library as 
the part after the schematic folder is created. This permits the part and attached 
schematic folder to be reused in other projects. If you specify an attached schematic 
folder, but the schematic folder has not yet been created, Capture creates the 
schematic folder when you descend the hierarchy on the part. To descend the 
hierarchy, you must define the part instance as nonprimitive. 

m See also For more information about the primitive and nonprimitive settings, 
see Primitive and non primitive parts in Chapter 11: About libraries and parts. 

~ Tip To define a part instance as nonprimitive, double-click on it, then set the 
Primitive option to No in the Edit Part dialog box. In physical mode, you can also 
define part occurrences as nonprimitive. This lets you control whether or not to 
descend the hierarchy on an occurrence-by-occurrence basis. 

Part instances with their Primitive property set to Default can be changed to primi­
tive or nonprimitive on a project-wide basis using the Design Template or Design 
Properties commands on the Options menu. Choose the Hierarchy tab, select either 
Primitive or Nonprimitive in the Parts group box, then choose the OK button. 

To attach a schematic folder to a part 

1 From the project manager's Design menu, choose New Part (ALT, D, T). 
or 
From the part editor's Options menu, choose Package Properties (ALT, 0, R). 
or 
Select a part instance on a schematic page. From the schematic page editor's 
Edit menu, choose Properties (ALT, E, p). 

2 Choose the Attach Implementation button. The Attach Implementation dialog 
box displays. 

3 Enter the name of the child schematic folder. 

4 If the child schematic folder is not in the current project, specify the project 
where the schematic folder is located. 

5 Choose the OK button twice. 
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Adding graphics, text, and IEEE symbols to a part 

Once you have defined a part, you can draw an outline to reflect the part's shape, 
and you can add graphics to add detail to the part. To add graphics to a part, you use 
the Line, Rectangle, Ellipse, Arc, Polyline, and Picture commands on the Place menu 
or the corresponding tools on the tool palette. You can also add text to the part using 
the Text command on the Place menu or the text tool on the tool palette. 

m See also For details about each of the graphic and text tools, see Chapter 8: 
Adding and editing graphics and text. 

Fb Note When you place graphics in a part, they must be within the part's body. If 
they don't fit within the part's body, the part body border expands to enclose the 
graphics. 

~ Tip Like the schematic page editor, the part editor can display the part you are 
working on at several levels of detail. Just use the Zoom command on the View 
menu or the right mouse button pop-up menu. 

A part can include IEEE symbols (shown at 
right). Unlike graphics, IEEE symbols do 
not have to be within the part's body. 

To place an IEEE symbol 

1 From the part editor's Place menu, choose IEEE Symbol (ALT, P, E). 

or 
Choose the IEEE symbol tool from the part editor's tool palette. 

2 In the Place IEEE Symbol dialog box, select a symbol from the Symbol list box. 
The symbol displays in the preview box. When you have selected the symbol 
you want to place, choose the OK button. The IEEE Symbol dialog box closes. 

An image of the IEEE symbol is attached to your pointer. You can press the 
right mouse button to display a pop-up menu with commands that you can use 
to change the appearance of the symbol before you place it. You can mirror the 
symbol horizontally or vertically, rotate the symbol, or choose another IEEE 
symbol to place. 

3 Move the pointer on your part to where you want the symbol arid click the left 
mouse button to place the symbol. You can place multiple instances of the 
symbol by clicking the left mouse button each place you want the symbol. 

4 When you are done placing symbols, choose the selection tool or press ESC to 
dismiss the IEEE symbol tool. 

~ Tip Once you've placed an IEEE symbol, you can change its size and shape by 
selecting it and dragging its selection handles. 
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Placing pins on a pari 

There are several ways you can place pins on a part. You can use the Pin command 
on the part editor's Place menu or the pin tool on the tool palette to place individual 
pins; or you can use the Pin Array command on the Place menu or the pin array tool 
on the tool palette to place several pins at once. 

Pins must connect to the part body border (the dotted line around the part). If the 
edge of a part body coincides with this border, pins can connect directly to the part 
body. However, if the part body is inside this border, you can draw a line between 
the part body and the pin on the part body border to make the pin look as though it 
connects to the part body. 

To place a pin 

1 From the part editor's Place menu, choose Pin (ALT, P, p). 
or 
From the part editor's tool palette, choose the pin tool. 

The Place Pin dialog box displays. You must provide information about the pin 
you are placing. 

2 In the Name text box, type a name and pin number for the pin you are placing. 
If a pin name is not specified, Capture generates one, because pins must be 
named. 

3 You can use the default settings for the other options on this dialog box or 
change them to fit your requirements. When the pin is specified to your 
requirements, choose the OK button. 

4 Using the pointer, drag the pin to the desired location along the part body 
border. 

S Click the left mouse button to place the pin. You can place multiple instances of 
the pin by clicking the left mouse button each time you want to place an 
instance of the pin. The pin number and name increment automatically. 

~ Tip To place multiple pins that are slightly different, you can click the right 
mouse button and choose the Edit Properties command. 

6 When you are done placing pins, choose End Mode from the right mouse button 
pop-up menu, or press ESC. 
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Place Pin dialog box 

Place Pin E3 

Harne: 
ID1 
Nllmber: 

··l-;:.S~.i"':'n:...;..e.:,----·~ .... ·• ': ·._'.· •. ·•· __ .... O_K ..... _., _· .... 1 
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'.!Passive 
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... ;a ·j!~~P!OPetI~~:;. I 
. ',. l:leip ,·Width··, 

ro S,Galar 

......... j ,:"'. 

i , 
" ('",;.e.~s'i 

Name The name of the pin. 

If a pin connects to a bus, the pin should be named in the format busname [range], 
for example A[O . .3]. You can use two periods ( .. ), a colon (:), or a dash (-) to 
separate the numbers in the range. Bus pins are expanded into separate pins in a 
netlist, just as a bus is separated into separate signals. 

Fb Note Bus pins can only be used for simulation purposes. They will not netlist 
properly for board layout. 

To enter a pin name with a bar over it (indicating negation), type a backslash 
character after each letter you want a bar over. For example, type R\E\S\E\T\ to 
define the name: 

RESET 

~ Tip You can make each part's pin names visible or invisible. From the part 
editor's Options menu, choose Part Properties (ALT, 0, R). When the User 
Properties dialog box displays, set Pin Names Visible to either True or False. 

Number The pin's number. 

Width If a pin connects to a wire, select Scalar. If a pin connects to a bus, select 
Bus. 

Pin Visible If this option is selected, the pin is visible when the part is placed on 
the schematic page. Otherwise, the pin is not visible on the schematic page. This 
option is only available for power pins. 
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Shape The shape ofthe 
pin, as shown at right. 
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Shape 

Dot 

Clock 

Dot-Clock 

Zero 

Short 

Line 

Pin shapes. 
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<P--

$ 
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Description 

An inversion bubble. 

A clock symbol. 

A clock symbol with an 
inversion bubble. 

A normal pin with a lead 
zero grid units in length. 

A normal pin with a lead 
one grid unit in length. 

A normal pin with a lead 
three grid units in 
length. 
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Type The type of the pin, as described in the table below. 

Pin type 

3-state 

Bidirectional 

Input 

Open 
collector 

Open emitter 

Output 

Passive 

Power 

Pin types. 

Description 

A 3-state pin has three possible states: low, high, and high 
impedance. In its high impedance state, a 3-state pin looks like an 
open circuit. For example, the 74LS373 latch has 3-state pins. 

A bidirectional pin acts as both input and output. For example, pin 
2 on the 74LS245 bus transceiver is a bidirectional pin. The value 
at pin 1 (an input) determines the activity of pin 2, as well as 
others. 

An input pin is one to which you apply a signal. For example, pins 
1 and 2 on the 74LSOO NAND gate are input pins. 

An open collector gate omits the collector pull-up. Use an open 
collector to make "wired-OR" connections between the collectors 
of several gates and to connect with a single pull-up resistor. For 
example, pin 1 on the 74LSOI NAND gate is an open collector 
gate. 

An open emitter gate omits the emitter pull-down. The proper 
resistance is added externally. EeL logic uses an open emitter gate 
and is analogous to an open collector gate. For example, the 
MC10100 has an open emitter gate. 

An output pin is one to which the part applies a signal. For 
example, pin 3 on the 74LSOO NAND gate is an output pin. 

A passive pin is typically connected to a passive device. A passive 
device does not have a source of energy. For example, a resistor 
lead is a passive pin. 

A power pin expects either supply voltage or ground. For 
example, on the 74LSOO NAND gate, pin 14 is VCC and pin 7 is 
GND. 

Fb Note Power pins that are invisible are not connected using wires and buses, but 
instead are connected globally via name. 

User Properties Displays the User Properties dialog box. You can use this 
dialog box to define additional properties for the pin. 
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To place several pins at once 

1 From the part editor's Place menu, choose Pin Array (ALT, P, 0. 
or 
From the part editor's tool palette, choose the pin array tool. 

The Place Pin Array dialog box displays. This dialog box is similar to the Place 
Pin dialog box, with these exceptions: 

• The Starting Name and Starting Number text boxes are used to specifY a 
name and pin number that is incremented for each pin that is placed. 

Fb Note The pin name only increments if the starting name ends with a number. 
Otherwise, all of the pins in the array have identical names. 

• The Number of Pins, Increment, and Pin Spacing text boxes are used to 
specity how the pins are placed. 

2 In the Starting Name text box, enter the name of the first pin. If the pin name 
ends in a digit (0-9), subsequent pin names in the array will be incremented by 
the value in the Increment text box (if there is no value in the Increment text 
box, the pin names are incremented by 1). 

3 In the Starting Number text box, enter the number of the first pin. Subsequent 
pin numbers will be incremented by the value in the Increment text box (if there 
is no value in the Increment text box, the pin names are incremented by 1). If 
you leave the Starting Number text box blank, the pins are not numbered. 

4 In the Number of Pins text box, specifY how many pins you want to place. 

S In the Increment text box, specifY the number by which you want to increment 
the pin name (if it ends in a digit) and pin number for each pin in the array. 

6 In the Pin Spacing text box, specifY the number of grid units you would like 
between each pin. 

7 Ifnecessary, change the default settings for Shape and Type to fit your 
requirements, then choose the OK button. 

8 Using the pointer, drag the pin array to the desired location along the part body 
border, then click the left mouse button to place the array. The array is 
positioned so that the first pin in the array is at the pointer. 

~ Tip You can place multiple copies of the array by clicking the left mouse button 
each time you want to place an array. Each time you place the array, the pin names 
and pin numbers are incremented based on the number of the last pin placed. 

Fb Note If the pin array is longer than the edge of the part body, the part body 
border expands to accommodate the extra pins. 
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9 When you are done placing arrays, choose End Mode from the right mouse 
button pop-up menu, or press ESC. 

~ Tip Once you place an array of pins, you can edit their properties as a group by 
selecting the pins, then choosing Properties from the Edit menu. This opens the 
spreadsheet editor, which you can use to edit the information for the pins. 

Place Pin Array dialog box 

Starting N§lle: 
101 
Starting Number: 
pO 
Humber of Pins: 
11 
Increment: 
11 
Pin S.Qacing: 

I' 

, Iune 
.. lwe: 
I Passive 

Starting Name The name of the first pin in the array. If the name ends with a 
digit (0-9), each pin in the array is incremented by the value specified in the 
Increment text box. 

For a name with a bar over it (indicating negation), type a backs lash character after 
each letter you want a bar over. For example, type R\E\S\E\T\ to define the name: 

RESET 

Starting Number The number of the first pin in the array. Each pin in the array 
is incremented by the value specified in the Increment text box. 

Number of Pins The number of pins in the array. 

Increment The number by which to increment the pin name (if it ends in a digit) 
and pin number for each pin in the array. This can be a negative number. 

Pin Spacing The number of grid units between each pin in the array. 

Shape The shape of the pins in the array, as described in Place Pin dialog box, 
earlier in this chapter. 

Type The type of the pins in the array, as described in Place Pin dialog box, 
earlier in this chapter. 
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About power and ground pins 

Both homogeneous and heterogeneous parts may have shared pins. A common use 
of shared pins is for supply pins (power or ground), which are referred to in Capture 
as power pins. Normally, power pins are invisible and global (meaning that they are 
connected to like-named power objects, power nets, and invisible power pins 
throughout the design). 

Merely displaying an invisible power pin does not change its global nature; however, 
connecting a wire or other electrical object to a power pin isolates it from the design­
wide (global) net. For information on displaying invisible power pins, see the section 
Displaying invisible power pins later in this chapter. 

On heterogeneous parts, power pins cannot appear on every part in the package. If 
you make the power pins visible, you must place them on at least one part in the 
package, then place that part in the design in order for the power connections to 
appear in a netlist. 

On homogeneous parts, power pins appear on every part in the package. The pin 
names are filled in automatically, but you must specify the pin numbers. To share the 
pins, make sure that the pin names and the numbers are the same for every part in the 
package. 

~~ Caution If you connect the same pin on multiple parts in a package, you can 
inadvertently short two nets. Use care to avoid this, and always run Design Rules 
Check before creating a netlist. 

168 DrCAD Capture for Windows User's Guide 



Chapter 12 Creating and editing parts 

Displaying invisible power pins 

You can display power pins on individual part instances or throughout a design. 
Merely displaying invisible power pins does not change their global nature. The 
method you choose to display power pins determines whether you can connect to 
them. Invisible power pins are always displayed in the part editor. 

To display invisible power pins on a part instance 

1 In the part editor, select a power pin. 

2 From the Edit menu, choose Properties. The Pin Properties dialog box displays. 

3 Select the Pin Visible option. 

4 Choose the OK button. 

FD Note If you connect to an invisible power pin that is displayed by this method, 
the pin is isolated from the design-wide power net. 

To display invisible power pins throughout a design 

1 From the project manager's Options menu, choose Design Properties, then 
choose the Miscellaneous tab. 

2 Select the Display Invisible Power Pins (for documentation purposes only) 
option, then choose the OK button. 

FD Note You cannot connect to an invisible power pin that is displayed by this 
method. 
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Editing an existing part 

You can edit an existing part in the library in which it resides, or you can edit a part 
after it is placed on a schematic page. 

Editing a part in a library 

Once you edit a part in a library, you can update existing projects with the new part 
using the Update Cache or Replace Cache commands on the project manager's 
Design menu. 

To edit a part in a library 

1 From the File menu, choose Open (ALT, F, 0). A standard Open dialog box 
displays. 

2 Choose the library containing the part you want to edit. The library opens, 
showing all its parts. 

3 Double-click on the part you want to edit. The selected part appears in the part' 
editor. 

4 Edit the part. 

You can resize it, add or delete graphics or symbols, and add or delete pins. 
These processes are all described in Creating a new part earlier in this chapter. 
You can also edit the part's properties. Editing properties is described in 
Chapter 2: The Capture work environment. 

5 When you are done editing the part, you must save it. From the File menu, 
choose Save (ALT, F, s). The part is saved in the library. 

~ Tips In the project manager, you can create a new part from an existing part by 
dragging a copy of the part (press the CTRL key while you drag the part) to a new 
library and then editing the part. 

You can also create an alias of the part by changing to package view in the part 
editor, choosing Package Properties from the Options menu, then choosing the 
Part Alias button. Once you create a part alias, you must save the part to have the 
alias show up in the library. In the library, part aliases display with lines through 
their part icons. 
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Editing a part on a schematic page 

Once you edit a part on a schematic page, you can apply the edits to all instances of 
the same part in the project, or you can apply the edits only to the particular part 
instance you edit. 

~~ Caution Once you edit a part instance on a schematic page, it is no longer 
linked to its corresponding library part. In addition, a new part (with _n appended 
to the original part name) appears in the design cache. This means that you can't 
perform a cache update on an edited part, since there is no link to the original 
library. 

To edit a part instance on a schematic page 

1 Select a part instance on a schematic page. 

2 From the Edit menu, choose Part (ALT, E, A). 

The library part that was used to define the part instance appears in the part 
editor. 

3 Edit the part. 

You can resize it, add graphics or symbols, and add or delete pins. These 
processes are all described in Creating a new part earlier in this chapter. You 
can also edit the part's properties. Editing properties is described in Chapter 2: 
The Capture work environment. 

4 When you are done editing the part, you must close it and save the changes on 
the schematic page. From the File menu, choose Close (ALT, F, c). 

A dialog box displays asking if you would like to: 

• Update only the part instance being edited (Update Current). 

• Update all instances of the part in the project (Update All). 

II Discard the edits to the part and return to the schematic page editor 
(Discard). 

• Cancel the close operation and return to the part editor to continue making 
changes to the part (Cancel). 

After you choose a response, the part editor window closes. Depending on your 
response, the change is reflected in the selected part or in all instances of the 
selected part. 

A new part (with _n appended to the part name) displays in the design cache, 
indicating that the link to the library part no longer exists. 
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Viewing parts in a package 

For a package containing multiple parts, you can use the Package command on the 
View menu to view all the parts in the package at once. You can then choose which 
part in the package to edit. If the package is homogeneous, you can only edit pin 
names and pin numbers, since each part in a package must have the same graphic 
representation. If the package is heterogeneous, you can make each part in the 
package graphically distinct. 

To view a package 

1 From the part editor's View menu, choose Package (ALT, V, K). The package 
view window (shown below) replaces the part editor window. 

14D _____ t... ... ~ __ .... _. 
.. ·--.. J.7 .. · 

{Wlue} 

........ -~~D· .. 6 
·----~f-L-/ ... -.... -.. --

{Wille} 

2 You can move from part to part using the ARROW and TAB keys. 

If the package is heterogeneous, you can select which part to edit by double­
clicking on it. The package view window closes and the selected part opens in 
the part editor window. 

If the part is homogeneous, double-clicking on any of the parts in the package 
closes the package view window and opens the part in the part editor window. 

~ Tip When editing a heterogeneous package, a quick way to move from one part 
in a package to another is to use the Next Part (ALT, v, x) and Previous Part 
(ALT, v, v) commands on the View menu. 
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Editing parts in a package 

For a package containing multiple parts, you can use the Package Properties 
spreadsheet to edit all the parts in the package at once. If the package is 
homogeneous, you can only edit pin names and pin numbers, since each part in a 
package must have the same graphic representation. If the package is heterogeneous, 
you can make each part in the package graphically distinct. When a normal and 
convert part are both available, the normal and convert names and types will appear 
on the spreadsheet. 

To edit parts in a package 

From the part editor's View menu, choose Package (ALT, V, K). The package 
view window replaces the part editor window. 

2 From the Edit menu, choose Properties. The Package Properties spreadsheet 
displays. 

3 Edit the pin location, pin order, pin group (for pin swapping), pin number, pin 
name, pin type, and whether the pin is to be ignored (for shared pins) as needed. 

4 Choose the OK button. 

Viewing a part's convert 

A convert view is an alternate view of a part. It can be used for things such as a 
DeMorgan equivalent of a part. If a part has a convert view, you can easily switch 
between the normal view and convert view in the part editor. 

To view a part's convert 

1 From the part editor's View menu, choose Convert (ALT, V, c). 

2 To go back to the normal view of the part, choose Normal from the View menu 
(ALT, v, N). 

Fb Note If you're editing a part that doesn't have a convert view, the Convert 
command is not available. 
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Processing your design 

Part Four provides details about processing your design once you have created it. It 
provides an overview of the design process, as well as detailed information about the 
project manager's Tools menu. Part Four contains these chapters: 

Chapter 13: About the processing tools provides general guidelines for processing 
your design and describes when to use Capture's different processing tools. 

Chapter 14: Preparing to create a netlist describes the tools you use to prepare a 
design for creating a netlist. It describes the Update Part References, Update 
Properties, Design Rules Check, and Gate and Pin Swap tools. 

Chapter 15: Creating a netlist explains how to create a netlist using the Create 
Netlist tool. 

Chapter 16: Creating reports explains how to create reports using the Bill of 
Materials and Cross Reference tools. 

Chapter 17: Exporting and 
importing schematic data describes 
the Export Properties and Import 
Properties tools used to move data 
into and out of Capture. 

Chapter 18: Using Capture with 
OrCAD Layout for Windows explains 
how to perform forward annotation, 
back annotation, and cross probing 
using Capture and Layout. 

Chapter 19: Using Capture with 
OrCAD Simulate for Windows 
describes intertool communication 
between Capture and Simulate, and 
explains how to use this feature to 
debug your Capture schematic 
interactively. 

Part Four 





Chapter 13 

About the processing tools 

A design process typically involves placing and connecting parts in the schematic 
page editor, then using Capture's tools to specify how parts are to be packaged and 
uniquely identified. You add information for simulation, synthesis, board layout, 
purchasing, or other external functions, then create a netlist and incorporate back 
annotation information from external applications. 

As shown in the figure at right, you use Update 
Part References, Design Rules Check, and Cross 
Reference to package the parts in your project and 
to check that there are no invalid conditions. In 
practice, you might run these tools several times 
before moving on to the next phase. 

You can add properties or change their values (see 
Using the spreadsheet editor to edit properties in 
Chapter 2: The Capture work environment). If you 
prefer editing in a full-featured spreadsheet or 
database program, use Export Properties to write 
data out and Import Properties to read it back in. 

Use Create Netlist to convey project information to 
Layout or Simulate. Layout can create a back 
annotation file detailing packaging changes that are 
needed because of routing or manufacturing 
constraints. Use Gate and Pin Swap to incorporate 
this information into your Capture project. Use Bill 
of Materials to create a list of the parts. 

After you do this, you may need to make additional 
changes to your project, then repeat some or all phases of the design process. In 
addition, you may want to analyze your project using intertool communication to 
communicate interactively with Layout for cross probing, or with Simulate to view 
signals in Capture as their states change during simulation. 
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Tools overview 

Fb 

Once you finish placing and connecting parts in the schematic page editor, usethe 
project manager's Tools menu commands to help you complete the design process. 

Note . You won't be able to use any of these tools to modify a schematic design 
attached to a hierarchical block if the design is external to the current project. 

Command OveNiew Described in 

Update Part Packages parts by resolving part references and Chapter 14: 
References pin numbers, or removes packaging information Preparing to 

by resetting part references to their unassigned create a netlist 
values. 

Gate and Pin Swaps pins or gates, or changes packaging, Chapter 14: 
Swap based on a swap file created by you or your Preparing to 

board layout program. create a netlist 

Update Adds properties, or changes the values of Chapter 14: 
Properties properties, based on an update file you create. Preparing to 

create a netlist 

Design Rules Reports and flags violations of electrical rules Chapter 14: 
Check and other design constraints. Starts by removing Preparing to 

existing DRC markers. create a netlist 

Create Netlist Creates a file that lists the logical intercon- Chapter 15: 
nections between signals and pins in one of Creating a 
more than thirty standard formats. netlist 

Cross Reports the schematic page and location of parts Chapter 16: 
Reference (used in developing or documenting a project). Creating 

reports 

Bill of Creates a formatted list of electrical and other Chapter 16: 
Materials parts in the project. Optionally adds Creating 

information, based on an include file you create. reports 

Export Creates a tab-delimited list-for manipulation in Chapter 17: 
Properties a spreadsheet or database program-of Exporting and 

properties and values for each part in the importing 
project. schematic data 

Import Adds properties, or changes the values of Chapter 17: 
Properties properties, based on a tab-delimited list in the Exporting and 

format created by the Export Properties importing 
command. schematic data 
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Preparing to create a netlist 

Updating part references 

After you place parts on a schematic page, all parts need to be uniquely identified 
using the Update Part References command on the project manager's Tools menu. 
This tool assigns unique part references to each part in a project. You use Update 
Part References after you've placed all parts and before you use other Capture tools. 
You can update part references incrementally (so that previously assigned part 
references are not changed), or you can update part references unconditionally, 
changing all the parts across all the schematic pages processed. 

~J:. Caution After you have created a netlist and read it into Layout, if you make 
further changes to your Capture design, only use the Incremental reference update 
option in the Update Part References dialog box when you update part references. 
Do not use the Unconditional reference update option. 

~ Tip Update Part References also assigns individual parts to a multiple-part 
package, thereby assigning unique pin numbers to each part in a multiple-part 
package. This process is sometimes called packaging. For more information on 
controlling packaging in multiple-part packages, see Capture's online help. 

Parts are updated in the order in which they appear on a schematic page, going from 
left to right and top to bottom, as shown in the figure below. 

U?A U?A UIA UIB 

~~ ~~ 
74LSD4 74LSD4 74LSD4 74LSD4 

U?A U?A UIC UID 

~~ ~~ 
74LSD4 74LSD4 74LSD4 74LSD4 

Before updating part references After updating part references 

Parts are updated from left to right, and from top to bottom. 
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To update part references 

In the project manager, choose the Logical option to update part references on 
part instances. 
or 
In the project manager, choose the Physical option to update part references on 
part occurrences. 

2 In the project manager, select the schematic pages on which to update part 
references. 

3 From the project manager's Tools menu, choose Update Part References 
(ALT, T, u). 
or 
Choose the update part references tool from the toolbar. 

The Update Part References dialog box displays. 

4 Set the options in this dialog box as necessary. You can specify whether to 
update the entire project or just the schematic pages selected in the project 
manager, whether to update the part references that haven't yet been updated, 
update all part references, or reset part references so that they have question 
marks in their names. These options are described in the section Update Part 
References dialog box. 

5 When the Update Part References dialog box has the settings you want, choose 
the OK button to begin the update. 
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Update Part References dialog box 

Update Part References £) 
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Scope Specifies whether to update all the part references in the design or just 
those on the selected schematic pages. 

Incremental reference update or Unconditional reference update or 
Reset part references to "?" Specifies whether to incrementally update parts 
with question marks in their part references, unconditionally update the parts in the 
selected schematic pages, or reset all the part references using a question mark (?). 

~!:. Caution After you have created a netlist and read it into Layout, if you make 
further changes to your Capture design, only use the Incremental reference update 
option in the Update Part References dialog box when you update part references. 
Do not use the Unconditional reference update option. 

Physical Packaging Specifies the properties that must match for Capture to 
group parts in a single package. See Capture's online help for information on how 
the Update Part References tool packages individual parts into mUltiple-part 
packages, as well as information about combined property strings. 

Reset reference numbers to begin at 1 in each schematic If this option 
is selected, Capture numbers part references beginning with 1 in each schematic 
folder. 

~!:. Caution If you don't instruct Capture to begin the reference numbers at 1, it 
looks at the selected schematic pages, finds the highest part reference number, and 
begins numbering from that number. This can result in duplicate reference numbers 
if the highest numbered part for each reference prefix is not represented in the 
schematic pages you have selected. If you suspect you have duplicate reference 
numbers, run Design Rules Check before you attempt to create a netlist. 
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Do not change the page number If you are in logical mode, the schematic 
pages are renumbered based on their order in the project manager. If you select this 
option, the pages are not renumbered. 

~ Tip The properties that contain the page number (Page Number and Page Count) 
are part of the title block. If you create a custom title block, you can give it these 
two properties, so that they are updated when you run Update Part References. 

182 OrCAD Capture for Windows User's Guide 



Chapter 14 Preparing to create a netlist 

Updating properties 

If you need to edit the properties for a few parts or nets, you can do so in the 
schematic page editor. If, however, you want to make changes to a number of parts 
or nets, the Update Properties tool is much quicker and easier than hand-editing each 
property you'd like to change. You can use Update Properties to edit any properties 
except part reference, net name, and net ID. You can also use Update Properties to 
add properties. In essence, it is a search-and-add-or-replace tool. 

To update properties, you create a file, called an update file, with one line for each 
part or net to change. The leftmost column identifies the part or net (by specifYing 
the property value to match), and the remaining columns provide the new property 
value. The format of the update file is described in Update file format later in this 
section. 

You can run Update Properties on projects in both logical and physical mode. 

To update part or net properties 

1 Using a text editor, create an update file, as described in Update file format later 
in this section. 

2 In the project manager, choose the Logical option to update part or net 
properties on part instances. 
or 
In the project manager, choose the Physical option to update part or net 
properties on part occurrences. 

3 To process only part of your project, select the pages to process in the project 
manager. 

4 From the project manager's Tools menu, choose Update Properties (ALT, T, p). 

The Update Properties dialog box displays. 

5 Set the options in this dialog box as necessary. You can specifY whether to 
process the entire project or just the schematic pages selected in the project 
manager, and whether to update parts or nets. You can customize your update 
further by specifYing that your comparison and update strings be converted to 
uppercase. You can also have Capture create a report file listing the properties 
that it changes. You must specifY the name ofthe update file containing the 
properties to match and the text to place in the specified properties. These 
options and others are described in the section Update Properties dialog box. 

6 When the dialog box has the settings you want, choose the OK button. Capture 
updates the properties you specified. If you set up the dialog box to create a 
report file, you can use a text editor to view the file when the Update Properties 
tool is done. 
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Update Properties dialog box 
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Scope Specifies whether to process the project or what is selected. 

Update parts or Update nets Specifies whether to update the properties of 
parts or nets. 

Convert the resulting combined property to uppercase Converts the 
combined property values to uppercase before a comparison is done. 

Convert the update property to uppercase Converts the update property to 
uppercase before it is placed in an object's property. 

Unconditionally update the property By default, a property is updated only 
if it is empty: properties with values are not updated. If this option is selected, the 
specified property is changed, regardless of whether it's empty. 

Do not change updated properties visibility Specifies that the visibility of 
the updated properties is not changed. 

Make the updated property visible/invisible Specifies that the updated 
property is to be made visible or invisible. 

Create a report file Specifies whether or not Capture creates a report file. If you 
select this option, enter the name of the report file in the Report File text box. 

Property Update File The name of the update file containing the properties to 
match, the properties to update, and the values to use to update the properties. This 
file has an extension of .UPD. 

184 DrCAD Capture for Windows User's Guide 



Chapter 14 Preparing to create a netlist 

Update file format 

The update file is an ASCII text file that you create to specify the properties to 
match, the properties to update, and the values to use to update the properties. The 
file can include comments-any text to the right of a semicolon is ignored by the 
Update Properties tool. 

The first line of the update file has this format: 

CombinedPropString PropToUpdatel PropToUpdate2 ... 

The first field is a combined property string specifying which properties to combine 
into a match string (note that property names in a property string must be enclosed in 
braces). The remaining fields in the line are the properties to update on each part or 
net to be updated. The combined property string and the property names entered in 
these fields must be enclosed in quotation marks. 

rn See For information about combined property strings, see Capture's online 
help. 

Subsequent lines of the update file have this format: 

MatchStringl Updatel Update2 .. . 
MatchString2 Updatel Update2 .. . 

The match string is the text used to compare with the values of the properties 
specified by the combined property string in the first line. The update fields are the 
values placed in the properties specified in the first line, if the match string matches 
the expanded combined property string. These values must also be enclosed in 
quotation marks. For example: 

"{Value}" 
"74LSOO" 
"74LS138" 
"74LS163" 
"8259A" 

"PCB Footprint" 
"14DIP300" 
"16DIP300" 
"16DIP300" 
"28DIP600" 

This indicates that the property to use as a match string is Value. Each time an 
object's Value matches the value listed in the left column of the update file, the 
corresponding text in the right column is placed in the object's PCB Footprint 
property. In this example, each time a part has a value of 74LSOO, the text 14DIP300 
is placed in the part's PCB Footprint property; each time a part has a Value of 
74LS138, 16DIP300 is placed in the part's PCB Footprint property, and so on. 
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Checking for design rules violations 

The Design Rules Check tool scans schematic designs and checks for conformance 
to basic design and electrical rules. The results of this check are marked on the 
schematic pages with DRC markers, and are also listed in a report. This makes it 
easy to locate and fix design or electrical errors. You can search for DRC markers 
using the Browse com~and on the project manager's Edit menu, and then double­
click on any item in the resulting list to go immediately to the location of the marker 
on your schematic page. Once you are viewing the marker on the schematic page, 
you can display the marker's text by double-clicking on it. 

You can specify the conditions that cause errors to be generated. Optional checks 
performed by the Design Rules Check tool include off-grid parts; unconnected nets, 
pins, ports, and off-page connectors; identical part references; type mismatch parts; 
and design elements that are not compatible with OrCAD's Schematic Design Tools 
product. 

R:J Note When Design Rules Check checks for unconnected nets, it looks for nets 
with less than two connection points. Thus, a net can still have unconnected 
endpoints that aren't reported by Design Rules Check. 

The Design Rules Check is helpful in preparing your project for use with other tools. 
For example, you can use the Design Rules Check tool to catch problems such as 
bus contention or shorted power pins before you generate a netlist to be used by 
simulation or synthesis tools. 

The Design Rules Check reports two categories of electrical rules violations: 

• Errors that should be fixed. 

• Warnings of situations that mayor may not be acceptable in your project. 

You can control whether electrical rules violations are reported as errors or warnings 
in the ERC Matrix tab of the Design Rules Check dialog box. Errors are always 
marked with DRC markers on the schematic page. Warnings are also marked with 
DRC markers if you select the Create DRC markers for warnings option in the 
Design Rules Check dialog box. In the report generated by Design Rules Check, 
however, the problems are categorized as WARNING or ERROR so that you can 
immediately identify the more critical problems. 

Once the Design Rules Check begins, it first removes existing DRC markers from 
the schematic pages being processed. This means that each time you run this 
process, the error markers on your schematic pages reflect the current state of your 
project. You can also use the Design Rules Check tool to remove DRC markers from 
schematic pages, but not do any further checking. Just select the Delete existing 
DRC markers option on the Design Rules Check dialog box. 

fIi'~ Caution You should AL WAYS run Design Rules Check before you create a 
netlist. 
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To check for design rules violations 

In the project manager, select the schematic pages that you want to check for 
design rules violations. 

2 From the project manager's Tools menu, choose Design Rules Check (ALT, T, D). 

or 
Choose the design rules check tool from the toolbar. 

The Design Rules Check dialog box displays. 

3 Select the settings you want in the Design Rules Check tab and in the ERC 
Matrix tab. For information about the settings in these tabs, see Design Rules 
Check dialog box, Design Rules Check tab and Design Rules Check dialog box, 
ERC Matrix tab later in this section. 

4 When both tabs of the Design Rules Check dialog box have the settings you 
want, choose the OK button. 

As Capture checks your project, it displays status information about the check. 
If you stop the design rules check midstream (by choosing the Cancel button in 
the status information dialog box), the schematic pages that have already been 
processed will have DRC markers marking any error situations that were 
encountered. 

5 Once the design rules check is complete, there are two ways to view the results: 

• You can open the DRC report file using a text editor or word processor. 
This file has a default extension of .DRC. The session log also contains the 
same information. 

~ Tip To view the information contained in a .DRC report, set up a file association 
using the Open With dialog box in Windows Explorer. By doing this, you can 
open the .DRC report by double-clicking on it in Windows Explorer. 

• You can use the Browse command on the project manager's Edit menuto 
display a list of all DRC markers in the project. 

This list gives information about each error and warning. Each DRC marker 
on a schematic page displays this same information. Once this list displays 
in the browse window, you can double-click on an item to go directly to it 
on its schematic page. Once you are viewing the marker on the schematic 
page, you can display the marker's text by double-clicking on it. You can 
also use the schematic page editor's Find command to find specific DRC 
markers. To do this, you must enter the text associated with the marker. 
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Design Rules Check dialog box, Design Rules Check tab 

The Design Rules Check tab contains options for things to include in the report 
generated by Design Rules Check. You can specify if you want to create DRC 
markers on the selected schematic pages for both errors and warnings, create DRC 
markers just for errors, or delete existing DRC markers instead of adding new ones. 
Note that if you select the option to delete existing DRC markers, the options that 
customize the DRC report become dimmed and aren't available for selection. 

o cSIt)n Rules Check £! 

r . Check hierarchicai,QOlt cOnnections • 
r Check gff.pageeonnectorcoi1nec:tiorii 

. ",-, 

rReport jdenticalpart referenc!n r Reportolf;grid objects 

. r Report t)lp8miimatch partt r Reportaa net narries 

. rRepcir! hierarchiCal ports and off-page connectors 

ReportEde:r ~iew Output 

!C:\CAPTURE\sAMPlES\FULLADD.DRC Rrowie ... ·1 

Scope Specifies whether to process the entire project or just the selected 
schematic page or pages. 

Check design rules or Delete existing DRC markers Specifies whether to 
check for design rules violations or just delete existing DRC markers. Note that if 
you select the Check design rules option, Capture deletes existing DRC markers 
before it begins the design rules check. 

Report All the remaining options on the dialog box are report options, and leave 
messages and reports in the session log. Selected report options are also included in 
the specified report file. 
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Create ORC markers for warnings Design Rules Check always places DRC 
markers on the schematic page for errors defined in the ERC Matrix tab. If you 
select this option, it also places DRC symbols on the schematic page for warnings 
defined in the ERC Matrix tab. 

Check hierarchical port connections Verifies that hierarchical pins on 
schematic pages in the parent schematic folder match hierarchical ports on schematic 
pages in the child schematic folder. Errors are generated if a hierarchical pin 
specified on a schematic page in a parent schematic folder doesn't have a 
corresponding hierarchical port with an identical name on a schematic page in the 
child schematic folder; if the number of hierarchical pins "nd hierarchical ports are 
different between [he parent and child schematic folders; and if the type of the 
hierarchical pins and hierarchical ports doesn't match. 

Check off-page connector connections Verifies that off-page connector 
nets on a schematic page match those on other schematic pages. 

Check unconnected nets Checks for these conditions: nets that aren't 
connected to at least two pins or hierarchical ports; nets that don't have a driving 
signal; and two nets with the same name in a schematic folder, but no off-page 
connector or hierarchical port to connect them. 

Check SOT compatibility Checks for compatibility with OrCAD's SDT 
product in case you plan on saving the project in SDT format. See Capture's online 
help for information about the rules you should follow if you are planning to use a 
Capture project in SDT. 

Report identical part references Checks for unique part references, and 
reports parts that use the same part reference. For example, Capture considers two 
VI's to be identical, two VIA's to be identical, and VI and VIA to be identical. 

Report type mismatch parts Reports parts that are packaged into the same 
physical package, but whose package properties conflict (primarily source package 
and PCB footprint). 

Report hierarchical ports and off-page connectors In the report file, lists 
all hierarchical ports and off-page connectors. 

Report off-grid objects In the report file, lists the names and locations of 
objects that are off grid. 

Report all net names In the report file, lists the names of all nets. 

Report File The name of the report file containing the information prepared by 
Design Rules Check. This file usually has an extension of .DRC. For an example of 
the report generated by the Design Rules Check tool, see the section Sample Design 
Rules Check report. 
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Design Rules Check dialog box, ERC Matrix tab 

You use the ERC matrix to set the electrical rules that Design Rules Check uses 
when testing connections between pins, hierarchical ports, and off-page connectors. 
All types of pins, hierarchical ports, and off-page connectors are listed in the 
columns and rows in the table. A test is represented by the intersection of a row and 
column. Either the intersection is empty, or it contains a W, or it contains an E. 

• An empty intersection represents a valid connection, in which case nothing is 
reported if you specify a report file. 

• A W represents a warning. 

• An E represents an error. 

You can cycle through these settings by pointing to an intersection and clicking the 
mouse button until the desired setting appears. For all rows except the Unconnected 
row, the DRC reports an error or warning for any net that has two connections as 
specified in the ERC matrix. For example, consider the dialog box above. If a net 
has an output pin and a bidirectional pin, a warning is issued based on the W in the 
intersection of the Output row and the Bidirectional column. For the Unconnected 
row, the DRC checks to see if the specified pin or port type is unconnected. 

~ Tip You can also type W for warning, E for error and N for an empty 
intersection. In addition, you can use the arrow keys to select other intersections. 
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Sample Design Rules Check report 

Design Rules Check 

Checking Schematic: 4BIT 

Checking Electrical Rules 

Checking for Unconnected Wires 

Checking Off-Page Connections 

Checking Pin to Port Connections 
WARNING: [DRC0014] Type of pin above does not match the pin type of 

corresponding port below fulladd 1,SUM 
WARNING: [DRC0014] Type of pin above does not match the pin type of 

corresponding port below fulladd 2,5UM 
WARNING: [DRC0014] Type of pin above does not match the pin type of 

corresponding port below fulladd 3,5UM 
WARNING: [DRC0014] Type of pin above does not match the pin type of 

corresponding port below fulladd_4,5UM 

Checking for Invalid References 

Checking for Duplicate References 

Checking for Compatibility with 5DT 

Reporting Off-Grid Objects 

Reporting Ports 
51 
S2 
53 
CIN 
5 [0 •• 3] 
X [0 .. 3] 
Y[O •• 3] 
YO 
Yl 
XO 
COUT 
Y2 
Xl 
Y3 
X2 
X3 
50 

Reporting Off-Page Connections 

Reporting Globals 

Reporting Net Names 
50 
N00074 
N00072 
N00070 
COUT 
eIN 
5 [0 .. 3] 
X[0 •• 3] 

Y [0 .• 3] 

Sample Design Rules Check report for 4BIT.DSN (page 1 of 3). 
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Y3 
Y2 
Yl 
YO 
X3 
X2 
Xl 
XO 
S3 
S2 
Sl 

Checking Schematic: FULLADD 

Checking Electrical Rules 
ERROR: [DRC0004] Possible pin type conflict halfadd_A,SUM Output 

Connected to Bidirectional Port 

Checking for Unconnected Wires 

Checking Off-Page Connections 

Checking Pin to Port Connections 

Checking for Invalid References 

Checking for Duplicate References 

Checking for Compatibility with 

Reporting Off-Grid Objects 

Reporting Ports 
X 
Y 
CARRY IN 
CARRY OUT 
SUM -

Reporting Off-Page Connections 

Reporting Globals 
VCC 
GND 

Reporting Net Names 
VCC 
CARRY OUT 
N00040 
N00038 
N00036 
Y 
X 
SUM 
CARRY IN 
GNU -

Checking Schematic: HALFADD 

Checking Electrical Rules 

SDT 

Sample Design Rules Check report for 4BIT.DSN (page 2 of 3). 
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Checking for Unconnected Wires 

Checking Off-Page Connections 

Checking Pin to Port Connections 

Checking for Invalid References 

Checking for Duplicate References 

Checking for Compatibility with 

Reporting Off-Grid Objects 

Reporting Ports 
X 
Y 
CARRY 
SUM 

Reporting Off-Page Connections 

Reporting Globals 
VCC 
GND 

Reporting Net Names 
SUM 
N00039 
GND 
VCC 
N00033 
N00031 
X BAR 
Y-
X 
CARRY 

SOT 

Sample Design Rules Check report for 4BIT.DSN (page 3 of 3). 
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Swapping gates and swapping pins 

Using Gate and Pin Swap, you can import changes created by external tools, such as 
a PCB layout application. Capture uses a simple file format (see Swap file format 
later in this section) to allow gate swapping, pin swapping, changing pins, and 
changing part references. If the external tool creates a back annotation file, edit the 
file to match the format described in Swap file format in this section. 

Fb Note To back annotate properties, use the Update Properties tool. 

When should you use Gate and Pin Swap? After you've completed your schematic 
design, or while you are routing a printed circuit board, you might discover that you 
can reduce via count, track length, or routing complexity by exchanging two gates of 
one part. You would use the PCB layout tool to rewire the board to exchange (or 
swap) the connections ofUIA and UIB. To ensure that your project reflects the 
rewired board, you create a swap file using the PCB layout tool and then run 
Capture's Gate and Pin Swap. When you look at the schematic page, you will see 
that UIA is where UlB was before, and vice versa. 

To swap gates and swap pins 

1 Generally, a swap file is created by another application such as OrCAD Layout 
for Windows. Alternatively, you can create a swap file using a text editor, 
following the format described in Swap file format later in this section. 

2 In the project manager, choose the Logical option to swap gates or pins on part 
instances. 
or 
In the project manager, choose the Physical option to swap gates or pins on part 
occurrences. 

3 To process only part of your project, select the pages to process in the project 
manager. 

4 From the project manager's Tools menu, choose Gate and Pin Swap. 
or 
Choose the gate and pin swap tool from the toolbar. 

The Gate and Pin Swap dialog box displays. 

5 Set the options in this dialog box as necessary. You can specify whether to 
process the entire project or just the selected schematic pages. You can also 
specify the name of the swap file containing the gates and pins to swap. These 
options are described in the section Gate and Pin Swap dialog box. 

6 When the dialog box has the settings you want, choose the OK button. Capture 
swaps the gates and pins you specified. 
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Gate and Pin Swap dialog box 

Gate and P,n Swap E! 

~ Process !!ntire design 

(' Process ~election 

5 wapEile: 

IC:\CAPTURE\SAMPLES\FULLADD.SWP 

[ OK 

Cancel 

Help 

ftrowse ... 

Scope Specifies whether to process the entire project or just the selected 
schematic page or pages. 

File Specifies the swap file. For more information, see Swap file format. 

Swap file format 

A swap file is an ASCII text file containing old and new part references. A swap file 
is typically created by another application, such as OrCAD Layout for Windows. 
You can also create a swap (.SWP) file using a text editor that can save the file in 
ASCII format. The file can include comments; any text to the right of a semicolon is 
ignored by the Gate and Pin Swap tool. Each line in a swap file, unless preceded by 
a semicolon, causes one action. The elements of each line may be separated with any 
number of space or tab characters. In general, the first element of the line specifies 
the type of swap. Ifno swap type is specified, CHANGEREF is assumed. The other 
swap types are GATESWAP, PINSWAP, and CHANGEPIN. 

The following example illustrates a swap file. The comments to the right of the 
semicolons describe what the swap file will do. 

CHANGEREF Ul U2 ;Change part reference Ul to U2 
U1C U2C ;Change part reference U1C to U2C 

GATE SWAP Ul U2 ;Swap parts Ul and U2 
GATE SWAP UIA UIB ;Swap gates UIA and UIB 
CHANGEPIN U7 1 2 ;Change pin 1 to pin 2 
CHANGEPIN U7 2 1 ;Change pin 2 to pin 1 
CHANGE PIN USB "DO" nOl" ;Change pin named DO to 01 
CHANGEPIN USB "01" "DO" ;Change pin named 01 to DO 

Note that there are two CHANGEPIN commands for each pin swap. If you entered 
just one line to change pins, for example: 

CHANGEPIN U7 1 2 

The original pin I is changed to pin 2; however, if you already have a pin 2, you will 
end up with two of them, unless you change the original pin 2 to something else. For 
this reason, a second line is needed to go with the first line. The complete command 
lines needed to perform a pin swap between pins I and 2 are: 

CHANGEPIN 
CHANGEPIN 

U7 
U7 

1 
2 

2 
1 
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Fb Note Swap files created by OrCAD's PCB 386+ are was/is files. These files 
contain no keyword identifiers; therefore, each line is asswned to be a 

.CHANGEREF instruction. In the swap file example above, the line without a 
keyword identifier (the second line) is an example of how changes are specified in 
a was/is file generated by PCB 386+. 

With the exception of the PINSWAP command, the commands in a swap file are 
was/is based. That is, the commands specify what the original values were and what 
the new values will be. For this reason, unlike some board layout programs, you 
cannot specify intermediate steps for the commands, except for PINSW AP. 

The PINSW AP command works off the present state of the pin. For this reason, you 
can perform intermediate steps, such as: 

PINSWAP U1 1 2 ; First swap 
PINSWAP U1 2 3 ; Second swap 

After both lines of the example above are processed, what was pin 1 is now pin 2, 
what was pin 2 is now pin 3, and what was pin 3 is now pin 1. The series of changes 
is shown in the following figure. 

original configuration after first swap after second swap 

For PINSW AP and CHANGEPIN, the part reference must be specified in the swap 
file, as well as the old and new values. Pin swaps are limited to pins of the same type 
and shape oil the same part. For example, you can swap pins on USB, but you cannot 
swap a pin on USB with a pin on USC. 

~:- Cautions Unlike CHANGEPIN commands, PINSW AP commands are order­
dependent within the swap file. For this reason, if you change the order of the 
PINSW AP commands, or use both PINSWAP and CHANGEPIN commands on 
the same part, you may get unexpected results. 

Gate and Pin Swap does.not check to make sure that parts are the same type before 
a swap is performed. Therefore, if you swap gates between dissimilar part types 
(as shown in the example below), odd results may occur in your project. 

GATESWAP U1C U2B ;Swap gates U1C and U2B 

196 DrCAD Capture for Windows User's Guide 



Chapter 15 

Creating a netlist 

After you create a project, you can create a netlist to exchange schematic 
information with other EDA tools. You can choose from more than 30 industry­
recognized netlist formats. Your choice of net list depends on the destination 
application. 

Using the Create Netlist tool 

Before you create a netlist, be sure your project is complete, has been annotated 
(using Capture's Update Part References command), and is free from electrical rule 
violations. Chapter 14: Preparing to create a netlist describes how to use Capture's 
tools to prepare your design before you create a netlist. 

m See For information on creating a Capture netlist for use with Layout, see 
Chapter 18: Using Capture with OrCAD Layoutfor Windows. 

The table below summarizes the type of net list you will get (flat or hierarchical), 
depending on the nature of your design and the netlist formatter you choose. 

Flat design 

Simple 
hierarchical design 

Complex 
hierarchical design 

Flat netlist 

Hierarchical netlist 

Hierarchical netlist 

Flat netlist 

Flat netlist 

Flat netlist, but it must be 
netlisted in physical mode 
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To create a netlist 

1 In the project manager, select your design. 

2 From the Tools menu, choose Create Netlist. The Create Netlist dialog box 
displays. 

3 Choose a netlist format tab. 

4 In the Netlist File text box, enter a name for the output file. If the selected 
format creates an additional file (such as a map file or pinlist file), enter its 
filename in the second text box. 

5 Ifnecessary, set the Part Value and PCB Footprint combined property strings to 
reflect the information you want in the netlist. 

W See For information about using combined property strings, see Capture's 
online help. 

6 Ifnecessary, set the format-specific options in the Options group box, and 
choose the OK button to close the Netlist Options dialog box. 

W See For information about the options for individual netlist formats, see 
Capture's online help. 

7 Choose the OK button to create the netlist. 

W See For information about the options in the Create Netlist dialog box, see 
Capture's online help. 
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Netlist format files 

Capture includes over 30 netlist format file types. They include: 

Algorex EEDESIGNER PCB 

Allegro FutureNet RacalRedac 

AlteraADF HiLo Scicards 

AppliconBRA VO IntelADF SPICE 

AppliconLEAP Intergraph Tango 

Cadnetix Layout Telesis 

Calay Mentor Vectron 

Calay 90 MultiWire Verilog 

Case OHDL VHDL 

CBDS PADS 2000 VST 

ComputerVision PADS-PCB VSTModel 

DUMP PC AD WireList 

EDIF200 PCADnlt XNF 

m See For information about the characteristics, formatting options, and an 
example of each netlist format, see Capture's online help. 
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Netname resolution 

In your schematic designs, you can assign a variety of netnames and aliases to 
signals that are connected. A netlist, however, needs exactly one name for each net. 

If the Create Netlist tool encounters multiple names for a single net, higher priority 
netnames override lower priority netnames. Priority is determined by the source of 
the name, ranked from highest to lowest, as follows: 

• Named nets 

• Hierarchical port names 

• Off-page connectors 

• Power object names 

• Aliases 

• System-generated names 

If there are any conflicts at any level of the comparison (if, for example, there are 
two power objects on a bus), they are resolved according to these rules: 

• Between netnames of equal precedence, priority follows alphabetical ord~r. 

• If the net is a bus, the net alias assigned to the greatest number of bus members 
has highest priority. 

A net may change names several times as Create Netlist works. For example, a net 
may start with an alias of Battery on one page, become ToBattery from an off-page 
connector, change again to become DC as a hierarchical port is encountered, and 
finally change to BatteryBackup when Create Netlist finds a named net with higher 
priority. 
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Creating a netlist for use with OrCAD Simulate for Windows 

You can easily create a netlist in Capture that you can use in Simulate. Or, you can 
use any other schematic or synthesis tool that creates an EDIF 2 0 0 or VHDL netlist 
targeted to devices for which you have acceptable VHDL simulation models. 

Creating net/ists within Capture 

Before you create a netlist, be sure your Capture project is complete, has been 
annotated, and is free from electrical rule violations. It is very important to observe 
all port connectivity rules pertaining to EDIF 2 0 0 and VHDL netlists for use in 
Simulate. A good way to check your project is by using the DRC (Design Rules 
Check) command in Capture. This command reports and flags violations of electrical 
rules and other design constraints, including identical part references, unconnected 
electrical objects, part type mismatches, off-grid parts, and so on. Once you are 
confident that your project is ready, you can generate a netlist representation for use 
with Simulate. 

~ Tip Capture's electrical rule check matrix can be customized to reflect VHDL 
port connection rules. 

To create a netlist 

1 In Capture's project manager, open your project. 

2 From the project manager, choose either the Logical option or the Physical 
option, depending on the type of netlist you are creating. 

~ Tip The project manager in Capture is typically set to logical mode when you 
generate a hierarchical netlist like EDIF 2 0 0 or VHDL. With the Logical option 
selected, it is possible to construct a complex hierarchy in which multiple 
hierarchical blocks or parts (like vendor-supplied soft macros) are associated with 
the same schematic page. 

3 From the project manager's Tools menu, choose Create Netlist. The Create 
Netlist dialog box displays. 
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4 Choose either the VHDL or EDIF 2 0 0 tab. 

~ Tip When you create your netlist, be sure to specify the hierarchy option for 
parts as nonprimitive. This allows Capture to descend the hierarchy of any soft 
macros that exist in your project to identify their primitive elements. 

5 Set the dialog box options, including directory and filename, as desired. If 
you're using the VHDL tab, select the 1076-93 option. 

6 Choose the OK button. Capture creates a netlist for your project. 

m See For information on using Capture netlists in Simulate, see, Chapter 19: 
Using Capture with OrCAD Simulate/or Windows. 
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Creating reports 

Capture provides two report tools that you can use to produce lists of the things 
contained in your project: Bill of Materials and Cross Reference. 

Creating a bill of materials 

You can use the Bill of Materials command from the project manager's Tools menu 
to create a bill of materials in a file which you can then print using a word processor 
or text editor. The bill of materials includes the properties item, quantity, reference, 
and part value. You can customize the report to include other properties. 

~ Tip A bill of materials includes parts that don't have pins. This makes it possible 
to include non-electrical parts such as screws, washers, and other hardware that 
you may have in your project. These parts won't, however, appear in'a netlist 
because they don't have pins. 

To create a bill of materials 

1 If desired, use a text editor to create an include file, as described in Include file 
format later in this section. 

2 In the project manager, choose the Physical option if you have a complex 
hierarchical design; otherwise, choose the Logical option. 

3 From the project manager's Tools menu, choose Bill of Materials. The Bill of 
Materials dialog box displays. 

4 Fill in this dialog box as desired. If you want to customize the infonnation 
contained in the bill of materials report, fill in the infonnation in the Line Item 
Definition area. If you are using an include file, be sure to check the Merge an 
include file with report check box, enter the combined property string, and 
specifY the name of the include file. 

S Choose the OK button when you are ready to create the report. 
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Bill of Materials dialog box 

B III of M alellals 13, 

,Srope--~----------~--~' 

:. r. ProceSs .!Intire d~gn 
(" Process .§electioll 

'I' Iltem\tQuantity\tReference\tPart 

. C,gmbined property string: 

IIOtem}\tIQuantity}\tlReference}\tNaluel , . 

I r Place each part entry on a separate Jne 
I 

('Include File-~----------------c----; 
I. I r Merge an include file with report 

Report----·----c----....."..--------.,..-~.·l· . 

Report fife: r ~ew OlAput 

Scope Processes the entire design or selected schematic pages. 

Header Text placed at the top of the first page. If this text box is left blank, there 
is no header on the first page. You can use this to specify column headers to match 
the data reported as defined by the combined property string. If you want the header 
items separated by tabs, use the \ t character sequence in the header text box, then 
insert corresponding tabs in the Combined property string text box. 

Combined property string Specifies which properties are included in or 
excluded from the bill of materials, and formats the output according to the tabs you 
insert and the order in which you specify the properties. When you specify the 
combined property string, you enclose property names in curly braces. When the Bill 
Of Materials is run, the properties in the curly braces are substituted with property 
values for the part (or left empty if the property is empty or doesn't exist on the 
part). The properties are left justified and separated by the characters you type 
outside the curly brackets. To insert a tab, use \ t. {Reference} \ t {Value} 
prints a part's reference, a tab character, and the part's value. 

Place each part entry on a separate line Select this item if you want each 
part to be listed on a separate line. 
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Merge an include file with report Select this item if you want to use an 
include file. 

Combined property string Specify the property to use to match the property 
value specified in quotes on each line of the include file. This is the search string, 
and is compared with match strings specified in the include file. 

Report File The name of the file to contain the bill of materials report. 

Include file format 

You can use an include file to have Bill of Materials add additional information to 
each line of the bill of materials. You create an include (.INC) file using any text 
editor that saves files in ASCII format. 

The first line of an include file is a header. The bill of materials is always keyed to 
the part value, so the first line begins with a pair of single quotes with no spaces or 
other characters between them. The rest of the first line contains any information you 
want to include to make the file and the bill of materials more readable-this usually 
consists of headers for the values in the rest of the file. If the include file has 
combined property strings separated by spaces, then the properties you specify in 
curly braces have to be separated with spaces also. 

The rest ofthe file contains a separate line for each part. Each line must begin with 
the property value (as specified in the Include File Combined property string in the 
Bill of Materials dialog box) enclosed in single quotes. This is the match string, and 
is compared with the search string specified in the Include File combined property 
string in the Bill of Materials dialog box. Following the property value (and on the 
same line) is the information that you want to add to the bill of materials. You can 
separate the part value from the additional information by any number of spaces or 
tab characters-Capture will align the first nonblank character in each line when it 
creates the bill of materials. 

The following example illustrates an include file. 
, , DESCRIPTION PART ORDER CODE 
'lK' Resistor 1/4 Watt 5% 10000111003 
'4.7K' Resistor 1/4 Watt 5% 10000114703 
'22K' Resistor 1/4 Watt 5% .10000112204 
'luF' Capacitor Ceramic Disk 10000211006 , .1uF' Capacitor Ceramic Disk 10000211007 

In the example above, the first column contains the match strings. If a match string 
matches the Include File Combined property string for the current part, the rest of 
the line (in the example above, the second and third columns) is tacked on to the end 
of the line item in the bill of materials. 

! Tip You can use an include file from OrCAD's Schematic Design Tools without 
modifying it. 
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Creating a cross reference report 

The Cross Reference tool creates a report of all parts with their part references and 
part names. You may specify that the report also give the coordinates of each part. 

To create a cross reference report 

1 In the project manager, choose the desired mode (Logical or Physical). 

2 From the project manager's Tools menu, choose Cross Reference. The Cross 
Reference Parts dialog box displays. 

3 Fill in this dialog box as desired. If you want to customize the information 
contained in the cross reference report, fill in the information in the Report area. 

4 Choose the OK button when you are ready to create the report. 

Cross Reference Parts dialog box 

Cross Reference Parts f3 

-'1 •. ' 100' "",-O_K--.I 
C·· SC?pe ................................. :: ... : ..... ,.. . ................... - ....... . 

i r.- Cross reference §1IiIe de$ign 

..................................... 1 ........ _CanceI ... ·· --,..' ..... 
Help .' • 

! (" Cross reference .lielection 
L.... ..... . .................................... ~~. 

. Sorting 

r.- Sort OlItputbyllsrt valUe, thenbyrefeience designator 
(". Stirt outJ:M by reference gesillnator. then by part value 

rReport---.....:.....------,--~----, 

! r Report the X and X coordinates oIaO part$ 

i r Report yoused parts in multiple par! packages' 
Report file: r ~iew Output 

IC:\D\.PTURE\SAMPLES\FULLADDX .!lrowse ... 

Scope Specifies whether to process the entire design or just the selected 
schematic page or pages. 

Sorting Specifies whether to sort output by part value or part reference. 
, 

Report the X and Y coordinates of all parts If you check this option, the 
report includes the X and Y coordinates of all parts. 

Report unused parts in multiple part packages If you check this option, 
the report identifies unused parts in multiple part packages. 

Report File The name of the file to contain the cross reference report. 
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Exporting and importing schematic 
data 

Exporting and importing designs 

Chapter 17 

You use the Export Design command to export a design or library in an EDIF or a 
DXF format. You use the Import Design command to import a design or library in 
an EDIF or a PDIF format. 

Exporting designs 

You can export either designs or libraries. 

To export a design or library 

1 Open the project containing the design or library to export. 

2 If you are exporting a design, select the design's folder. 
or 
If you are exporting a library, select the library's folder. 

3 From the project manager's File menu, choose Export Design. The Export 
Design dialog box displays. 

Export DeSIgn IE3 

EDIF 'I D)(f J 
Saveas .... .. . . 
IC:\ORCADWIN\CI>.PTURE\SA . .' 

~~~..,..r 
I;onIiguratkln fie 

:. · .. ··::·:·:·····.:.'.··:·1·· HelP· ... 
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4 Choose either the EDIF or the DXF tab. 

S Specify a path and filename in the Save As text box. 

6 If you're using the EDIF tab, locate and select an EDIF configuration (.CFG) 
file, if you have one (it is not required). 

7 Choose the OK button. The design or library is exported to a file. 
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Importing designs 

You can import either designs or libraries. 

To import a design or library 

1 Open a project that will contain the design or library you're importing. 

2 If you are importing a design, select the project's Design Resources folder. 
or 
If you are importing a library, select the project's Library folder. 

3 From the project manager's File menu, choose Import Design. The Import 
Design dialog box displays. 

Import DeSign EJ 

ED IF I PDIF I 
Qpen 

I 
,Save~ 

J,;;onflQUration file 

Browse 1 

... Browser 

4 Choose either the EDIF or the PDIF tab. 

5 Locate and select the file to import in the Open text box. 

6 Specify a path and filename in the Save As text box. 

7 If you're using the EDIF tab, locate and select an EDIF configuration (.CFG) 
file, if you have one (it is not required). 

8 Choose the OK button. The design or library is imported into your project. 
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Exporting and importing properties 

You use the Export Properties and Import Properties commands to change properties 
of parts and pins in a spreadsheet application, a database application, or in a text 
editor that preserves tab characters. First export the properties to a property file, edit 
the property file in the application of your chqice, then import the edited properties. 

~ Tip Capture can import properties with or without quotation marks around each 
field in the property file. The fields must be tab-delimited, though-all other 
characters, including commas and spaces, are treated as part of a field's text. Be 
sure your spreadsheet or database application can save in a tab-delimited format. 

Exporting properties 

You can export properties from a design or a library. 

~ Tip It is a good idea to update part references in the active mode (logical or 
physical) before you export properties. . 

Fb Note When you use the Export Properties command, only non-aliased parts are 
included in the property file, regardless of what you've selected; however, once 
you run Import Properties, the aliased parts change to match the non-a1iased parts. 

To export properties 

1 In the project manager, open the project containing the part properties to export. 

2 If you are exporting properties from a design, select the schematic folders or 
schematic pages containing the properties to export. 
or 
If you are exporting properties from a library, select the parts to expbrt. 

3 From the project manager's Tools menu, choose Export Properties. The Export 
Properties dialog box displays. 
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4 SpecifY whether the property file is to include all documents in the file, or just 
the documents you selected. 

5 SpecifY whether you want to export properties for parts only, or for parts and 
pins. 

6 SpecifY a filename for the output file using an .EXP extension. 

7 Choose the OK button. The property file is created. 
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Property file format 

When you export properties, Capture creates a tab-delimited list of keywords, 
identifiers, and properties, each of which is enclosed in double quotation marks. The 
first line of a property file begins with either the keyword DESIGN or the keyword 
LIBRARY, to identify the data as being from either a project or a library. 
Subsequent lines of the property file begin with one of the following keywords: 
PAGE, HEADER, PART, PIN, or SYMBOL. 

If you export multiple pages in logical mode, a PAGE and a HEADER line are listed 
for each page; if you export in physical mode, only one HEADER line, but no 
PAGE lines, are listed. If you export both parts and pins, each PART line is followed 
by a PIN line. If you export symbols, there are no PIN lines following the SYMBOL 
lines, since symbols have no pins. 

The HEADER lines are compiled from a superset of the property names found on 
parts (and pins, if applicable) from the whole page (for logical mode), from the 
whole project (for physical mode), or from the whole library. This means that (for 
logical mode) if part I has properties named A, B, and C, part 2 has properties 
named D, E and F, and a pin has properties named G, H, and I, then the HEADER 
line will have (after the first two columns) nine columns titled A, B, C, D, E, F, G, 
H, and I. 
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Editing a property file 

You can edit a property file in a spreadsheet or database application, or in a text 
editor as long as it doesn't convert the tabs to spaces. Depending on which 
application you use, the property file displays as rows and columns of cells or fields, 
or as lines of text. There are a few restrictions on the changes you can make in a 
property file: 

• You must not change or delete the first line. 

" You must not change or delete the first two fields in any line. 

• In logical mode, you must not change the sequence or number of lines. Also, do 
not change the sequence or number of lines in physical mode. 

m Do not delete a field from a HEADER line without also deleting the 
corresponding fields from subsequent lines. 

f17~ Caution If you add, delete, or reorder lines in a design property file created in 
logical mode, the file cannot be imported. If you move a PART line in a design 
property file (created in physical mode) or in a library property file, be sure to 
move all the PIN lines associated with it, and keep them in the same order; 
otherwise, importing the file may fail, or the file may cause unwanted changes to 
your project or library. In every case, it is much safer to make changes without 
adding, deleting, or reordering the lines in a property file. 

Keeping these restrictions in mind, you can generally make the following changes: 

• Add a field to a HEADER line and subsequent lines (add a column). This adds a 
property to parts and pins with a value in this field. The name of the property is 
the string in the HEADER line, and the value assigned to the part or pin is the 
string in the corresponding field. 

• Delete a field from a HEADER line and subsequent lines (delete a column). 
This has no effect on any part or pin. Deleting columns for properties you don't 
want to change may make the property file easier to edit. If you delete a field 
from a HEADER line without also deleting the corresponding fields from 
subsequent lines, Capture reports an error when you import the property file. 

f17~ Caution Column deletion must be done with care. Columns may be deleted 
only from HEADER, PART, PIN, and SYMBOL lines. For example, if you want 
to delete column 3 from a property file, but accidentally include column 3 of the 
DESIGN line, Capture reports an error when you import the property file. 

• Change the value ofa field. This resets the value of the property on all parts or 
pins with that property. 

Fb Note You can change part references by editing the References column of the 
property file, but in a multiple-part package the final element of the reference does 
not change. That is, changing U I A to U2B will result in the part reference U2A. 
You can also use Gate and Pin Swap to change part references. 
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Importing properties 

You can use the Import Properties command to import a file that you created with 
the Export Properties command and edited using a spreadsheet, database, or text 
editor application. 

~;:. Cautions Do not edit the project or library from which the properties were 
exported until after you import the changed properties. If you do, and the Import 
Properties procedure fails, you will have to export and edit the properties again. 

Be sure the same mode (logical or physical) is active in the project manager when 
you import properties as when you exported them. 

To import properties 

1 In the project manager, open the library or project containing the parts to 
import. 

2 From the project manager's Tools menu, choose Import Properties. The Import 
Properties dialog box displays. 

Library 
, 2J Macros 
. ,I> Netforms 

2JSamples 
~, Tutorial 

3 Select the file containing the properties. 

4 Choose the Open button. The properties are imported. 
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Chapter 18 

Using Capture with 
OrCAD Layout for Windows 

Layout has the ability to communicate interactively with Capture and other 
schematic design tools. This chapter explains how to use Capture with Layout to 
perform back annotation, forward annotation, and cross probing. 

When you make changes to your board in Layout, you can back annotate the 
information to Capture using the DrCAD Backannotation File (.SWP) option in 
Layout's Generate Reports dialog box. 

Select the Run ECD to Layout option in Capture's Create Netlist dialog box to 
automatically communicate changes you made in your Capture design to Layout. If 
the Layout file is open when you update the netlist file, Layout displays a dialog box 
asking if you want to load the new netlist file. If the Layout file is not open when the 
netlist changes, Layout prompts you to load the modified netlist when you reopen 
the Layout file. 

! Tip You can also use Layout's AutoECD command to forward annotate design 
properties, part information, and netlist changes to Layout from Capture. For 
information on using this command, see AutoECO in Capture's online help. 

You can also perform cross probing with Capture and Layout. With cross probing, 
you can select a part or net on a Capture schematic page or Layout board, and the 
corresponding object in the other application is highlighted. 

Moving a design from Capture into Layout is a three-part process: 

• Create a valid Capture design with footprints that Layout supports. 

• Generate a netlist in the Layout format. 

• Create a Layout board file. You can also transmit information concerning parts, 
nets, and pins by creating user-defined properties on the parts, nets, or pins. 
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Maintaining the integration between your Layout board and your Capture design 
requires that you periodically perform these tasks: 

• Create an OrCAD Backannotation File (.SWP) in Layout. 

• Perform a gate and pin swap in Capture using the back annotation file. 

• Use Layout's AutoECO command to forward annotate any edits you make in 
your Capture design into Layout. 

Fb Note Layout uses reference designators as identification for forward and back 
annotation. For this reason, all changes to reference designators must be made in 
Layout and back annotated to Capture. 

~~ Caution If you change existing reference designators in your Capture design and 
forward annotate them into your Layout board, your board will no longer be usable. 

Fb Note When you add new parts to your Capture design, use the Incremental 
reference update option in the Update Part References dialog box (as opposed to 
the Unconditional reference update option) when you update part references. 

Fb Note Any connections added to or deleted from your Layout board are not back 
annotated into Capture. For this reason, when you want to modifY connections, 
make the changes in Capture and forward annotate them to Layout. 
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Preparing your Capture design for use with Layout 

To prepare a Capture design for Layout you must first modify the design, assigning 
special properties and Layout-supported footprints to your parts. The tables in this 
section list the part, net, or pin properties supported by Layout. 

To prepare your Capture design for use with Layout 

1 Create a schematic design using Capture. 

D If you are creating a flat design or a simple hierarchical design, perform 
annotation, design rules checking, and netlist creation in logical mode. 

• If you are creating a complex hierarchical design, perform annotation, 
design rules checking, and netlist creation in physical mode. 

m See For information about simple and complex hierarchical designs, see 
Chapter 6: Design structure. 

For information about logical mode and physical mode, see Project manager 
options-Logical and Physical in Chapter 2. 

jji~ Caution In order to use intertool communication (ITC) between Capture and 
Layout, you must create netlists in physical mode. 

2 To transfer part, net, or pin information to Layout, assign values to the 
appropriate properties in the Set Layout Part Properties dialog box, the Set 
Layout Net Properties dialog box, or the Set Layout Pin Properties dialog box. 

m See For illustrations of these three dialog boxes, and descriptions and example 
values for their respective properties, see Transferring user-defined properties to 
Layout in this chapter. 
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3 Assign PCB footprints to each of your parts. Use only Layout-compatible 
footprints, choosing from those in the OreAD Layout/or Windows Footprint 
Libraries document, or those in your custom footprint libraries. 

4 If you are using parts from non-Layout libraries, such as discrete parts and 
custom footprints, check that the pin numbers of your part match the pad 
numbers of your Layout footprint. You may need to work with Capture's part 
editor or Layout's footprint libraries. In addition, you need to make sure that 
each pin has a pin number, as well as a pin name. 

RJ Note Layout doesn't accept PCB footprint names or part values that include 
spaces or tabs. Use the Capture spreadsheet editor to eliminate the spaces or tabs. 

5 With the project manager set to the correct mode (Logical or Physical, 
depending on the structure of your design), run Design Rules Check (from the 
Tools menu) to check for design rule violations. 
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Transferring user-defined properties to Layout 

To transfer part, net, or pin information to Layout, assign values to the appropriate 
properties in the Set Layout Part Properties dialog box, the Set Layout Net 
Properties dialog box, or the Set Layout Pin Properties dialog box. These three 
dialog boxes display when you choose their corresponding commands on the 
schematic page editor's Macro menu. 

In order to have the properties in the dialog boxes added to the parts, nets, or pins, 
you need to have the appropriate objects selected on the schematic page before you 
play any ofthe three macros. 

The value you enter for each property must be in uppercase, as shown in the tables. 

To add Layout part properties to a part 

1 Select a part on the schematic page. 

2 From the Macro menu, choose Set Layout Part Properties. The Set Layout Part 
Properties dialog box displays. 

:;: Set la90ut Part Properties f3 

CompFbsed·· I .QK I 
Comp§roup ·1 ,Cancel I 
Cornp)!;.ey··. .1 
ComaLII!: L 
Comp)..ocked .. 

1 
CompBol. I 
CompSide 

. J 

footprint I 
FPLlst I 
GateGro!l.p . I 
MirrorFootPrint I 
PArtNum ·1 
PartSl!.ape I 
PO!.YerPin· I 
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3 Enter values for those properties you want to add to the part, then choose the 
OK button. The properties are added to the part. See the table below for a 
description and example value for each of the properties in the dialog box. 

Property name Example value 

COMPFIXED YES 

COMPGROUP 2 

COMPKEY YES 

COMPLOC [1000, 1000] 

COMPLOCKED YES 

COMPROT 270.00 

COMPSIDE BOT 

FOOTPRINT DIP24 

FPLIST DIP24\400 

GATEGROUP 

MIRRORFOOTPRINT DIP24-M 

PARTNUM 489746 
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Description 

If the value is YES, the part (such as an edge 
connector) is permanently fixed to the board. 

An integer value that assigns the part to a group for 
placement. 

Used to designate a component as the key component 
in a given group. The key component is placed first, 
with -all the other components in the group placed in 
proximity to it. 

Part location on the board as X and Y coordinates. Use 
the following format [X, y], where X and Y represent 
the coordinates. Both must be integers in mils or 
microns. 

If the value is YES, the part is temporarily locked in 
position. 

Part rotation in degrees and minutes counterclockwise 
from the orientation defined in the Layout library. Use 
a period (.) to separate degrees and minutes. 

Determines which side of a board a part will reside on, 
TOP or BOT. 

An explicit definition of the footprint name to attach to 
the component. 

Comma-delimited list of alternate footprints to attach 
to components, to ease switching between footprints. 

Identifies gate swapping restrictions within a 
component. In order to be swapped, two gates must 
belong to the same gate group. 

An explicit mirror shape for the component, in the 
event you don't want Layout to perform mirroring. 

A customer part number that is generally unique for 
each customer and identifies the exact part, including 
manufacturer and case type. 



PARTSHAPE 74LS04 

POWERPIN YES 

Chapter 18 Using Capture with DrCAD Layout for Windows 

A generic part number (such as 74LS04 or CK05) that 
represents a certain part throughout the industry, but 
may not identifY the manufacturer or case type. Ifno 
footprint is defined, or the correct footprint isn't 
found, PARTSHAPE's value is compared to the data 
in SYSTEM.PRT (in ORCADWIN/LAYOUT/DATA) 
and the footprint listed in SYSTEM.PRT is used. 

Defines non-wired pins (such as unusual voltages) as 
belonging to a particular net. POWERPIN is typically 
used to override the standard GND or VCC 
attachments to particular pins of an Ie. 
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To add Layout net properties to a net 

1 Select a net on the schematic page. 

2 From the Macro menu, choose Set Layout Net Properties. The Set Layout Net 
Properties dialog box displays. 

3 Enter values for those properties you want to add to the net, then choose the OK 
button. The properties are added to the net. See the table below for a description 
and example value for each of the properties in the dialog box. 
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Property name Example value 

CONNWIDTH 10 

HIGHLIGHT YES 

MAXWIDTH 12 

MINWIDTH 8 

NETGROUP 2 

NETWEIGHT 60 

RECONNTYPE ECL 

SPACINGBYLAYER TOP=13, BOT=8 

TESTPOINT YES 

THERMALLAYERS GND 

VIAPERNET VIA 1 

WIDTH 12 

WIDTHBYLAYER TOP=6, BOT=12 
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Description 

Sets the track width, leaving MINWIDTH and 
MAXWIDTH at their defaults. 

If the value is YES, the net is highlighted. 

Sets the maximum track width. 

Sets the minimum track width. 

Identifies grouped nets. Use this to select or color nets 
as a group in Layout (for editing or routing). 

Integer between 1 and 100 assigning relative priority 
to the net. The default value is 50. 

Specifies the reconnect rules for each type of 
reconnect. Values are STD, HORZ, VERT, MIN, 
MAX,orECL. 

Net spacing for one or more layers. 

If the value is YES, a test point is automatically 
assigned to the net. 

Comma-delimited list assigning the net to specific 
plane layers. 

Via types allowed for net. 

Track width value assigned to the MINWIDTH, 
MAXWIDTH, and CONNWIDTH properties unless 
overridden. 

Net width for one or more layers. 
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Property name 

ECLTVPE 

PINGROUP 

To add Layout pin properties to a pin 

1 Select a pin on the schematic page. 

2 From the Macro menu, choose Set Layout Pin Properties. The Set Layout Pin 
Properties dialog box displays. 

3 Enter values for those properties you want to add to the pin, then choose the OK 
button. The properties are added to the pin. See the table below for a description 
and example value for each of the properties in the dialog box. 

Example value 

SOURCE 

Description 

Defines a pin as a Source, Load, or Target in terms of 
daisy-chain reconnection. 

Identifies pin swapping restrictions within a gate. In 
order to be swapped, two pins must belong to the same 
gate, and to the same pin group. 
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Creating a netlist- for use in Layout 

After you have prepared your design in Capture and it is free from design rules 
violations, you can create a netlist (.MNL) file for use with Layout. A copy of the 
LA YOUT.INI file must exist in the same directory as CAPTURE.EXE to generate a 
netIist. 

~ ~ Tip You must save your Capture design before creating a netlist. 

To create a netlist for use in Layout 

1 Open the Capture design. 

2 In the project manager, choose the Logical option. (If you have a complex 
hierarchical design, or if you-intend to perform cross probing, choose the 
Physical option.) . 

3 From the Tools menu, choose Create Netlist. The Create Netlist dialog box 
displays. 

4 Choose the Layout tab. The Layout tab displays. 

5 In the PCB Footprint group box, ensure that {PCB Footprint} is displayed in the 
Combined property string text box. 

m See For information about combined property strings, see Capture's online 
help. 

6 In the Netlist File text box, ensure that the path to the netlist file is correct. The 
netlist takes the name of the Capture design and adds a .MNL extension. 

7 Choose the OK button. Capture processes the netlist, then creates a .MNL file 
and saves it in the directory you specified in the previous step. 

Fb Note You may choose to exit Capture at this time. It is not necessary to run 
Capture and Layout simultaneously to take advantage of forward annotation. It 
takes a minimum of 16 MB of RAM to run both Capture and Layout. 

Fb Note If Capture is unable to create a .MNL file, the errors are written to the 
Capture session log and to the .ERR file in the target directory for the .MNL file. 
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Loading a new netlist into Layout 

WI See For information on loading a new netlist into Layout, see Capture's online 
help topic Creating a new Layout project from a Capture design. . 

Back annotating board information from Layout 

Fb Note Layout uses reference designators as identification for forward and back 
annotation. For this reason, all changes to reference designators must be made in 
Layout and back annotated to Capture. 

~~ Caution If you change existing reference designators in your Capture design and 
forward annotate them into your Layout board, your board will no longer be usable. 

Fb Note When you add new parts to your Capture design, use the Incremental 
reference update option in the Update Part References dialog box (as opposed to 
the Unconditional reference update option) when you update part references. 

In Layout, you can back annotate board changes for Capture using the OrCAD 
Backannotation File (.SWP). 

~~ Caution Don't create a second .SWP file without back annotating the first .SWP 
file to Capture; otherwise, the swap information in the first .SWP is overwritten by 
the second .SWP file. 

To back annotate 

1 From Layout's File menu, choose Reports. The Generate Reports dialog box 
displays. 

2 Select OrCAD Backannotation File (.SWP), then choose the OK button. 

Fb Note Once the .SWP file is created, the current Layout file no longer contains 
swap information. A copy of the board file is saved as BACKANNO.MAX. 

~~ Caution If you have renamed your components in your Layout board and created 
a .SWP file, those changes in reference designators are removed from the current 
board file (.MAX). Only the BACKANNO.MAX file retains the information on the 
original and current reference designators, but it is overwritten once you generate 
another .SWP file. So, if you want to retain the information on original and current 
reference designators, rename the BACKANNO.MAX file. 
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3 In Capture, open the design in physical mode if you're using a complex 
hierarchical design or if you created a netlist in physical mode. 

4 From Capture's Tools menu, choose Gate and Pin Swap. The Gate and Pin 
Swap dialog box displays. 

5 Ensure that the Process entire design option is enabled. 

6 Choose the Browse button, locate and select the report you created in Layout 
(design_name.SWP), then choose the OK button. The Layout information is 
back annotated to the design in Capture. 

7 If you're using a flat design or a simple hierarchical design, and you created a 
netlist in physical mode, open the .SWP file in a text editor (such as Notepad). 

8 Edit the line: 

View=Physical 

to: 

View=Logical 

then save and close the .SWPfile. 

9 In Capture, open your design in the project manager and choose the Logical 
option. 

10 From Capture's Tools menu, choose Gate and Pin Swap. The Gate and Pin 
Swap dialog box displays. 

11 Ensure that the Process entire design option is enabled. 

12 Choose the Browse button, locate and select the .SWP file you edited, then 
choose the OK button. The Layout information is back annotated to the logical 
mode of your Capture design. 
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Forward annotating schematic data to Layout 

Fb Note A copy of the LA YOUT.INI file must exist in the same directory as 
CAPTURE.EXE to perform forward annotation to Layout. 

To forward annotate 

1 In Capture, choose the Create Netlist toolbar button. The Create Netlist dialog 
box displays. 

2 Choose the Layout tab, then choose the OK button. 

3 In Layout's session frame, choose Tools, then ECO's, then one of the AutoECO 
options. The File A dialog box displays. 

W See For information on Layout's AutoECO options, see AutoECD in Capture's 
online help. 

4 Select a .MAX file to which you want to add the new schematic information, 
then choose the Open button. The File B dialog box displays. 

5 Locate and select the netlist (.MNL) that you created in step 2, then choose the 
Open button. The Output report dialog box displays. 

6 Specify a name for the output report ( usually design_name.LIS) and a location, 
then choose the Save button. The output report displays in a text editor and the 
Merged Output Binary dialog box displays. 

7 Specify a name and a location for the merged board, then choose the Save 
button. Layout merges the files based on the type of AutoECO you chose. 

W See You can also bring Capture netlist information into Layout by using the 
Run ECO to Layout option in the Layout tab in the Create Netlist dialog box. For 
information on this option, see the DrCAD Layout for Windows User's Guide. 
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Cross probing between Capture and Layout 

Using cross probing, you can select an object in Layout or Capture and have the 
corresponding object highlight in the other application. For example, you can select 
a net on a schematic page in Capture and see the corresponding net highlighted in 
Layout. 

Fb Note It is necessary to run Capture and Layout simultaneously to use cross 
probing. It takes a minimum of 16 MB of RAM to run both Capture and Layout. 

Enabling intertool communication between Capture and Layout 

To use cross probing, you must have created a netlist in physical mode and have the 
same design open in Layout as in Capture. In Capture you must be in physical mode, 
and you must enable intertool communication (ITC). It is not necessary to enable 
ITC in Layout, because cross probing is always active in Layout. 

~ Tip You use Layout's Half Screen command (from the Window menu) to tile the 
Capture and Layout windows so that you can view both on your screen. 

To enable ITC in Capture 

1 From Capture's Options menu, choose Preferences. The Preferences dialog box 
displays. 

2 Choose the Miscellaneous tab, select Enable intertool communication, then 
choose the OK button. 
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Cross probing from Capture to Layout 

When ITC is enabled in Capture and you select certain items on your schematic 
page, cross probing highlights the corresponding items in Layout. If you select a part 
or gate in a mUltiple-part package in Capture, cross probing highlights the 
corresponding module in Layout. If you select a wire segment or net in Capture, 
cross probing highlights the corresponding net (in its entirety) in Layout. 

Fb Note Capture must be in physical mode when cross probing. 

Fb Note When you use block selection in Capture, cross probing only highlights the 
last item selected in the block. There is no way to predict the order in which items 
are selected in a block selection. 

Any action you perform to select an object on your Capture schematic page 
(selecting using the mouse, using the Find command, or performing a browse of 
parts) causes the corresponding object in Layout to be highlighted. For more 
information, see the following table. 

Selecting this in Capture Highlights this in Layout 

Part Corresponding module 

Gate (multiple parts per package) Corresponding module 

Wire segment Entire net 

Net All routes for the net 

Pin on part Corresponding module 

To select an object in Capture for cross probing with Layout 

1 Open a Capture schematic page and a matching Layout design. 

2 Choose Half Screen from Layout's Window menu, then position the Capture 
and Layout session frames so that you can see both. 

3 In Capture, choose the Physical option in the project manager. 

4 From Capture's Options menu, choose Preferences. The Preferences dialog box 
displays. 

5 Choose the Miscellaneous tab, select Enable intertool communication, then 
choose the OK button. 

6 Select an object in Capture. The corresponding object is highlighted on the 
board in Layout. 
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Cross probing from Layout to Capture 

When LTC is enabled in Capture, selecting objects in Layout causes Capture to 
highlight the corresponding items in the schematic page editor. Selecting a module 
(or a module pad) causes Capture to highlight all the parts included in that module. 
Selecting a track or net causes Capture to highlight the corresponding net on the 
schematic page. 

Any action you perform to select an object on your Layout board (selecting using the 
mouse, using query, or using the Find command) causes the corresponding object on 
the Capture schematic page to be highlighted. For more information, refer to the 
following table. ' 

Selecting this in Layout 

Module 

Track 

Net 

Pad on module 

Highlights this in Capture 

All parts in the package 

Corresponding wire connection 

Corresponding nets 

Corresponding part (if the Manual 
Route tool is selected in Layout, the net 
is highlighted) 

To select an object in Layout for cross probing with Capture 

1 Open a Capture design and a matching Layout design. 

2 Choose Half Screen from Layout's Window menu, then position the Capture 
and Layout session frames so that you can see both. 

3 In Capture, choose the Physical option in the project manager. 

4 From Capture's Options menu, choose Preferences. The Preferences dialog box 
displays. 

5 Choose the Miscellaneous tab, select Enable intertool communication, then 
choose the OK button. 

6 Select an object in Layout. The corresponding object is highlighted on the 
schematic page in Capture. 

Fb Note In Capture, the schematic folder automatically opens and displays the 
schematic page on which the corresponding symbol is located. Scroll the window 
until the highlighted symbol is visible. 
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Using Capture with OrCAD Simulate 
for Windows 

Analyzing your Capture project with Simulate 

Chapter 19 

Simulate has the capability to communicate interactively with Capture using 
intertool communication (lTC). When ITC is enabled in both applications, signal 
values in Simulate are displayed in Capture, and signals selected in Simulate are 
highlighted in Capture. In addition, you can perform actions in Simulate on signals 
selected in Capture. 

If you determine that there is a problem with your project, you can modifY your 
Capture project, create a new netlist, reload your Simulate project (incorporating the 
new netlist), and rerun simulation without exiting either tool. 

You can view simulation values on the schematic page even if the simulation netlist 
has been optimized or flattened by another EDA tool. Capture will attempt to match 
context/signal pairs with a hierarchy/net of the project. It is possible for illegitimate 
signal annotation to occur when the simulation netlist and Capture project differ. 
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Debug your Capture project using intertool communication. 
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Part 4 Processing your design 

To enable ITC in Capture and Simulate 

1 In Capture, choose Preferences from the Options menu. The Preferences dialog 
box displays. 

2 Choose the Miscellaneous tab, select Enable intertool communication, then 
choose the OK button. 

3 In Simulate, choose Preferences from the Options menu; The Preferences dialog 
box displays. 

4 Choose the Run tab, select Enable intertool communication, then choose the OK 
button. 

Fb Note In order for ITC to function properly, a project must exist in Simulate that 
corresponds to the root schematic folder in Capture. 

234 OrCAD Capture for Windows User's Guide 



Chapter 19 Using Capture with DrCAD Simulate for Windows 

Viewing signal values in Capture using intertool communication 

Using lTC, you can view selected signals in Capture as their states change during 
simulation. The values for all signals display on the Capture schematic page at the 
current simulation run time. When examining signal history (signal values at 
simulation times earlier than the current simulation time) on the Capture schematic 
page, you will only see the values of the signals that you have selected to trace in ' 
Simulate. 

To display simulation states on your Capture schematic page 

In Simulate, select signals to view during simulation, as explained in Chapter 9: 
Selecting signals to view in the DrCAD Simulate for Windows User's Guide. 

2 In Capture, open the project and schematic page you want to view during 
simulation. 

3 In Capture, choose Physical in the project manager. 

4 Position the Capture and Simulate session frames so that you can see both. 

5 In Simulate, choose Start from the Run menu. The states for the selected signals 
are reflected at the current simulation time on the schematic page in Capture and 
in the wave, list, and/or watch windows in Simulate. 

6 If viewing the signal values in a wave window, position the time cursor 
anywhere in the waveform pane and release the left mouse button. Capture 
updates the schematic page to reflect the state values for the selected signals. 
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Selecting signal sets in Capture for use in Simulate 

You can select a set of signals on your Capture schematic page, then choose this 
signal set in Simulate when performing any Simulate function that involves selecting 
signals. These functions include selecting signals to trace in wave, list, and watch 
windows, viewing the signals' current values, applying stimuli to signals. and setting 
break on expression commands. Via lTC, when you select a signal set in Capture, 
Simulate assigns a signal context to that set-the "ITC" context. The ITC context is 
then available for selection in the Context window of the Select Signals and Browse 
Signals dialog boxes. The Browse Signals dialog box is accessible from the Stimulus 
and Break on Expression dialog boxes. 

For example (assuming that ITC is enabled in both applications), when you select a 
set of signals in Capture, they are available in the ITC context in the Select Signals 
dialog box in Simulate. 

To view signals selected in Capture in wave, list, and watch windows 

Ensure that ITC is enabled in Capture and Simulate, then open the Capture 
project and schematic page you want to view during simulation. 

2 In Capture, choose Physical in the project manager. 

3 On the schematic page, select the pin or net that you want to add to the signal 
display. 

4 In Simulate, select the wave, list, or watch window inwhich you want to view 
the signal. 
or 
From the Trace menu, choose New Wave Window, New List Window, or 
Watch Window. The Select Signals dialog box displays. 

5 In the Context window, choose ITC. The context and signal name display in the 
Signals in Context window. 

6 Select the context and signal name entry, move it to the Selected Signals 
window using the> button, then choose the OK button. The signal you selected 
on the Capture schematic page appears in the wave, list. or watch window in 
Simulate. 
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To specify interactive stimuli for signals selected in Capture 

Ensure that ITC is enabled in Capture and Simulate, then open the Capture 
project and schematic page you want to view during simulation. 

2 In Capture, choose Physical in the project manager. 

3 On the schematic page, select the pin or net to which you want to apply 
interactive stimuli. 

4 In Simulate, choose New Interactive from the Stimulus menu. The Stimulus 
dialog box displays. 

5 Choose the Absolute, Relative, or Clock tab from the upper left comer of the 
dialog box, then choose the Browse button. The Browse Signals dialog box 
displays. 

6 In the Context window, choose ITC. The context and signal name display in the 
Signals in Context window. 

7 Select the context and signal name entry, move it to the Selected Signals 
window using the> button, then choose the OK button. The signal you have 
selected appears in the Stimulate Signal Named text field. 

8 Create stimuli to apply to the selected signals during simulation. 

9 Repeat the process with the other tabs (Absolute, Relative, and/or Clock) as 
desired. 

10 When you choose the OK button to exit the Stimulus dialog box, Simulate asks 
if you want to load the new stimulus file. 

11 Choose the Yes button to load the stimulus file immediately. Simulate displays 
the new interactive stimulus file in a stimulus window. If the file has been 
loaded, the word "Loaded" displays with the title. 

m See For more detailed instructions on specifying stimuli in the Absolute, 
Relative, and Clock tabs in the Stimulus dialog box, see Chapter 5: Creating 
stimuli in the OrCAD Simulate for Windows User's Guide. 
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To set breakpoints on signals selected in Capture 

1 Ensure that ITC is enabled in Capture and Simulate, then open the Capture 
project and schematic page you want to view during simulation. 

2 In Capture, choose Physical in the project manager. 

3 On the schematic page, select the pin or net to which you want to add a 
breakpoint. 

4 In Simulate, choose the Break on Expression command from the Run menu 
(AL T, R, X). The Break on Signal Expression dialog box displays. 

5 Choose the Browse button. The Browse Signals dialog box displays. 

6 In the Context window, choose ITC. The context and signal name display in the 
Signals in Context window. 

7 Select the context and signal name entry, move it to the Selected Signals 
window using the> button, then choose the OK button. 

8 In the Operator drop-down list, choose the expression you want. 

9 In the Compare drop-down list, choose the comparison value, if necessary. 

10 Choose the Add button. The breakpoint appears in the Breakpoints window. 

11 Choose the OK button. Simulate executes the Breakpoint if the conditions are 
met. 

Incorporating Capture netlist changes into a Simulate project 

After you have used ITC to view selected signal values during simulation, you can 
edit your Capture schematic page as needed, add it to your Simulate project, and 
rerun simulation without exiting either tool. 

To incorporate netlist changes into a Simulate project 

1 In Capture, choose Logical in the project manager. 

2 Edit the schematic page as desired, using Capture's schematic page editor. 

3 In Capture, create a new netlist for the modified project. Use the same netlist 
name, in order to overwrite the old netlist. 

4 In Simulate, choose Load from the Run menu. Simulate loads the new version 
of the netlist and resets the simulation time to O. 

5 In Simulate, choose Start from the Run menu to run a simulation. 
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alias See net alias, part alias. 

ANSI Acronym for American National 
Standards Institute. 

arrow keys The directional keyboard keys 
used to navigate around your screen. Each key is 
marked with an arrow and is named for the 
direction in which the arrow points. There is an 
UP ARROW, DOWN ARROW, LEFT ARROW, and 
RIGHT ARROW key. 

ascend In a hierarchical design, to move 
from the child schematic folder to the parent 
schematic page. This is done in the schematic 
page editor using the Ascend Hierarchy 
command on the View menu. See also child, 
descend, parent. 

ASCII Acronym for American Standard Code 
for Information Interchange. The ASCII 
character-coding set enables different 
applications to exchange information. 

AutoECO Acronym for automatic 
engineering change order. Layout's AutoECO 
command translates schematic netlist 
information from Capture to Layout. See also 
forward annotate. 

Glossary 

back annotate To apply modifications to 
part properties in a design, such as updating part 
references and pin numbers, swapping gates, or 
swapping pins. Parts are back annotated in the 
project manager, using the Gate and Pin Swap 
command or the Update Properties command on 
the Tools menu. In Layout: to transmit data, such 
as gate and pin swaps, back to the schematic 
pages. See also forward annotate. 

bitmap Bitmaps are graphic images made up 
of pixels, which are tiny dots on a computer 
screen. Each pixel in a bitmap is represented by 
a number between 0 and 255, inclusive, with 0 
being the darkest (no luminance) and 255 being 
the lightest (full luminance}. Bitmaps have a 
.BMP extension, and can be placed on a 
schematic page using the Picture command on 
the schematic page editor's Place menu. 

bookmark Just as you can place a bookmark 
in a book to mark a specific page, you can place 
a bookmark on a schematic page to mark a 
location you would like to return to. To place a 
bookmark, use the Bookmark command on the 
Place menu in the schematic page editor. To go 
to a bookmark when in the schematic page 
editor, use the Go To command on the View 
menu. To go to a bookmark when in the project 
manager, use the Browse command on the Edit 
menu to display bookmarks in the browse 
window, then choose a bookmark. To edit a 
bookmark, double-click on it. 
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browse window This window displays the 
results of queries done using the Browse 
command on the Edit menu. You can double­
click on an object in the browse window to go to 
that item on its schematic page. 

bus A group of scalar signals (wires) that is 
never connected to a net. A bus name defines the 
bus signals and connects those .signals to the 
corresponding nets. For example, the bus name 
A[O:3] defines a four-signal bus and connects the 
four signals A[O], A[1], A[2], and A[3] with nets 
AO, AI, A2, and A3. See also bus entry, bus pin. 

bus entry A bus entry is used to tie a signal 
to a bus. The advantage of using bus entries 
instead of wires is that two bus entries can be 
connected at the same point on a bus without 
connecting the signals. If two wires are run 
directly to a bus at the same location, the signals 
are connected. See also bus, bus pin. 

bus pin A pin width that can carry multiple 
signals, as opposed to a scalar pin that only 
carries one signal. A bus pin represents all the 
pins for a bus, and they use the same naming 
conventions as buses. See also bus, bus entry. 

CAGE code An acronym for Commercial 
and Government Entity Code. A number­
provided by the federal government to its 
suppliers-that can be present in the title block 
of a schematic page. 

. child In a hierarchical design, a schematic 
folder whose circuitry is represented by a 
hierarchical block on the parent schematic page. 
To move from parent to child is to descend the 
hierarchy. A child contains circuitry referenced 
by its parent. See also ascend, descend, parent. 
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Clipboard A temporary storage location used 
to transfer data between files and between 
applications. You transfer data to the Clipboard 
by using the Copy or Cut command on the Edit 
menu, and you insert data from the Clipboard by 
using the Paste command on the Edit menu. 

complex hierarchy A design in which two 
or more hierarchical blocks (or parts with 
attached schematic folders) reference the same 
schematic folder. In the project manager, you 
can view a complex hierarchy two ways: in 
logical mode, you see one schematic folder that 
represents all references to that schematic folder; 
in physical mode, you see a separate schematic 
folder for each reference to that schematic 
folder. See also hierarchical design, logical 
mode, physical mode, simple hierarchy. 

convert An alternate form-such as a 
DeMorgan equivalent-that can be stored with 
each part. See also DeMorgan equivalent. 

cross probing When intertool 
communication is enabled in Capture, selecting 
objects in Capture causes the corresponding 
objects to be highlighted in Layout. Also, 
selecting objects in Layout causes the 
corresponding objects to be highlighted in 
Capture. Both applications must be open. See 
also intertool communication. 

DeMorgan equivalent An electrically­
equivalent part based on the DeMorgan rules of 
equivalence. These rules represent the duality of 
AND and OR in Boolean expressions: if all . 
AND operations are changed to OR operations, 
all OR operations are changed to AND 
operations, and all variables and constants are 
negated, then the value of the expression remains 
unchanged. A DeMorgan equivalent can be 
stored in the convert of a part. See also convert. 



descend In a hierarchical design, to open and 
view the child s&hematic folder represented by a 
hierarchical block on the parent schematic page. 
To descend a hierarchical design, you select a 
hierarchical block in the schematic page editor, 
then choose the Descend Hierarchy command on 
the View menu. See also ascend, child, parent. 

design cache A local library contained in 
each project that contains all the parts and 
symbols used in the project. 

design rules check (DRe) This tool, on the 
project manager's Tools menu, checks a design 
or part of a design for conformance to a set of 
configurable design criteria and electrical rules. 

document A schematic folder, schematic 
page, library, part, or symbol. Each of these is 
part of a project. 

EDA Acronym for Electronic Design 
Automation. Software and hardware tools used 
to ascertain the viability of an electronic design. 
These tools perform simulation, synthesis, 
verification, analysis, and testing of a project. 

EDIF Acronym for Electronic Design 
Interchange Format. A standard published by 
the EIA (Electronic Industries Association) that 
defines semantics and syntax for an interchange 
format that communicates electronic design 
information. 

equivalent See convert, DeMorgan 
equivalent. 

ERe Acronym for Electrical Rules Check, a 
subset of the Design Rules Check tool. The ERC 
matrix is used by Design Rules Check to evalu­
ate connections between pins, off-page connec­
tors, hierarchical ports, and hierarchical pins. 

Glossary 

flat design A schematic structure with no 
hierarchy (no hierarchical blocks; no parts with 
attached schematic folders). A flat design can 
include schematic pages in which output signals 
of one schematic page connect laterally to input 
signals of another schematic page through 
objects called off-page connectors. You place 
these objects using the Off-Page Connector 
command on the Place menu in the schematic 
page editor. Flat designs are practical for small 
designs with few schematic pages. See also 
hierarchical design, complex hierarchy, simple 
hierarchy, off-page connector. 

forward annotate The process of sending 
netlist data in the form of an .MNL file from 
Capture to Layout. 

graphic object An object drawn or pla~ed on 
a schematic page or part-such as an arc, hne, 
rectangle, ellipse, polygon, bitmap, text, or title 
block-that has no electrical connectivity. 

grid reference The border around a 
schematic page that acts as a visual reference for 
the grid. Grid references can be used as a . 
destination for the Go To command on the VIew 
menu, and can be set to visible or hidden in both 
the Design Template and Schematic Page 
Properties dialog boxes. 

heterogeneous package A package with 
multiple parts that are graphically different or 
contain different numbers of pins (for example, a 
relay). See also homogeneous package. 

DrCAD Capture for Windows User's Guide 241 



Glossary 

hierarchical block A symbol on a parent 
schematic page that refers to a child schematic 
folder. Hierarchical pins are placed within a 
hierarchical block, and hierarchical ports that 
refer to the hierarchical pins are placed on a 
schematic page within the child schematic 
folder. See also hierarchical pin, hierarchical 
port. 

hierarchical design A design in which 
schematic pages are interconnected vertically 
with hierarchical blocks (or parts with attached 
schematic folders). The root schematic folder's 
schematic pages contain symbols representing 
other schematic folders. See also complex 
hierarchy, flat design, root schematic folder, 
simple hierarchy. 

hierarchical pin A symbol, placed within a 
hierarchical block, that represents a signal 
connected to a like-named hierarchical port on 
another schematic page. See also hierarchical 
block, hierarchical port. 

hierarchical port A symbol, placed outside a 
hierarchical block, that represents a signal 
connected to a like-named hierarchical pin. 
Hierarchical ports can also connect to like­
named hierarchical ports. See also hierarchical 
block, hierarchical pin. 

homogeneous package A package with 
multiple parts that are graphically identical. See 
also heterogeneous package .. 

HPGL AcronymJor Hewlett-Packard 
Graphics Language, which is a plotter protocol. 

IEEE Acronym for Institute of Electrical and 
Electronics Engineers. 

inherent property One of the set of 
properties required for a given object. Unlike 
user-defined properties, inherent properties 
cannot be removed. 
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instance A part or symbol placed on a 
schematic page. You place part instances in 
logical mode. If you change to physical mode, 
you see occurrences of the part instances. See 
also instance property, logical mode, occurrence, 
physical mode. 

instance property A property that is 
attached to an instance, as opposed to a property 
that is attached to an occurrence or added to a 
part in a library. You edit instance properties in 
logical mode. Instance properties can be 
overridden by occurrence properties, which are 
not reflected on the instance. See also instance, 
logical mode, occurrence, physical mode. 

intertool communication (ITe) A 
capability that allows OrCAD products to share 
information for display and transfer. See also 
cross probing. 

-
junction A junction, shown as a small dot, is 
placed at the connection point where two 
perpendicular wires or buses cross, to give visual 
confirmation that the items are electrically 
connected. If you draw a wire across another 
wire at a 90-degree angle, the wires are not 
electrically connected unless you create a 
junction by clicking the left mouse button on the 
existing wire as you draw the new wire across it. 

_lIlllliiii ~ 

library A collection of often-used parts, 
graphics, schematic pages, and symbols. 

location An X, Y coordinate on a schematic 
page or part. You can move to a location using 
the Go To command on the View menu in the 
schematic page editor. 



logical mode A mode that displays the 
"folded" view of a design, and thus part 
references and pin numbers (that can be edited) 
on part instances. These can be seen in physical 
mode, but not edited. Logical mode doesn't 
reflect any changes made to occurrences in 
physical mode. To display the logical mode of a 
design, use the Logical option in the project 
manager. See also instance, occurrence, part 
instance, physical mode. 

macro A series of commands you can record, 
then execute by pressing one key or a 
combination of keys. Macros greatly reduce the 
number of keystrokes required to perform 
complex or repetitive actions. 

mirror To flip along the X (horizontal) or Y 
(vertical) axis, or both. 

net The wires, buses, parts, and symbols that 
are logically connected via net names, aliases, 
off-page connectors, and hierarchical ports. 

net alias A name used to specifY signal 
connections between unconnected wires or 
buses. For example, if you have wires in two 
remote locations in a schematic folder, you can 
assign each wire an alias (such as ABC) to 
connect the signals without physically drawing a 
wire between them. 

netlist A file that lists the interconnections of 
the project elements by the names of the 
connected signals, parts, and pins. 

nonpfimitive A part with an underlying 
hierarchy, such as an attached schematic folder. 

Glossary 

occurrence An instance placed on a 
schematic page, as displayed in physical mode. 
You can edit properties on occurrences, but you 
cannot edit an occurrence's physical appearance 
(such as the shape of a hierarchical block). See 
also instance. 

occurrence property A property attached to 
an occurrence, as opposed to a property attached 
to an instance or added to a part in a library. You 
can edit occurrence properties in physical mode. 
Occurrence properties override instance 
properties, but are not reflected on the instance. 

off-page connector An object that conducts 
signals between schematic pages within the same 
schematic folder. See also flat design. 

package A physical part that contains more 
than one logical part. For example, a 2N3905 
transistor, a fuse, and a 74LSOO are packages. 
Each part in a package has a unique part 
reference comprised of an alphanumeric prefix 
common to all the parts in the package, and a 
letter unique to each part. For example, a 
74LSOO with a part reference prefix ofVl5 
would have four parts with part references of 
Ul5A, Ul5B, VI5C, and Ul5D. See also 
heterogeneous part, homogeneous part. 

pan To change the portion of the schematic 
page or part being viewed by dragging objects 
from one location to another. As you drag an 
object while holding the left mouse button down, 
the schematic page or part pans across the active 
window. 

parent A schematic page containing a 
hierarchical block that references another 
schematic folder (called a child). See also child, 
hierarchical block. 
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part A part is a basic building block of a 
project that may represent one or more physical 
elements, or a function, a simulation model, or a 
text description for use by another application. A 
part's behavior is described by a SPICE model, 
an attached schematic folder, HDL statements, 
or other means. Parts usually correspond to 
physical objects (gates, connectors, and so on) 
that come in packages of one or more parts. You 
can think ofthese packages as physical parts and 
the parts you place on a schematic page as logi­
cal parts. Physical parts with more than one logi­
cal part are sometimes referred to as "multiple­
part packages." For simplicity, Capture usually 
refers to both as parts. See also package. 

part alias A duplicate copy of a part that uses 
a different name. A part alias uses the same 
graphics, attached schematic folders, and 
properties as the original, with the exception of 
the part value. 

part editor The editor used to create and edit 
parts and symbols. 

part instance An instance of a part. See also 
instance. 

part primitive See primitive. 

PCB Acronym for printed circuit board. 

physical mode A mode that displays the 
"unfolded" view of a design, and thus part refer­
ences, pin numbers, or properties on occurrences 
of part instances. Even though they are visible, 
part references and pin numbers are not editable 
in physical mode. Since changes made to part 
references and pin numbers on occurrences of 
part instances override the values on the original 
part instance, this mode gives you an opportunity 
to customize specific part instance occurrences 
without affecting the original part instance. See 
also instance, logical mode, occurrence. 
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pin A pin acts as a point of connectivity for 
the part it is attached to. In addition to input and 
output pins, there are also 3-state, bidirectional, 
open collector, open emitter, passive, and power 
pins. If a pin connects to a wire, it is a scalar pin; 
if it connects to a bus, it is a bus pin. See also 
hierarchical pin. 

pin swap The exchange of identical pins in 
order to decrease route lengths. 

pin-to-pin spacing The physical spacing 
between pins on a device. 

polygon A graphic object made up of 
polylines (multiple contiguous segments) whose 
beginning and end are attached to form a closed 
shape that can be filled. See also polyline. 

polyline A line with multiple contiguous 
segments. You place a polyline using the 
Polyline command on the Place menu. 

port See hierarchical port. 

primitive A part or hierarchical block with no 
underlying hierarchy. 

project A single file that includes all of the 
schematic folders, schematic pages, parts, and 
symbols that make up a project. You can view 
these project elements in the project manager. A 
basic project contains one schematic folder and 
one schematic page, while a complex project 
may contain a number of schematic folders, each 
containing several schematic pages. 

project manager The window used to 
perform project-wide tasks, such as locating 
objects, creating a netiist, or generating reports. 
This window displays the structure of the 
schematic folders and schematic pages contained 
in a design. You can view the project structure in 
logical mode or in physical mode. See also 
hierarchical design, logical mode, physical 
mode, simple hierarchy. 



property A characteristic of an object that can 
be edited. A property consists of a name and a 
value. Examples of property names are part 
value and color. Their respective property values 
can be something such as capacitor and red. 

root schematic folder The schematic folder 
at the top of a hierarchical design. The root 
schematic folder displays a backslash in its 
folder icon in the project manager. A project has 
only one root schematic folder. 

scalar A pin width that carries only one 
signal, as opposed to a bus pin that can carry 
multiple signals. 

schematic design A graphical 
representation of a circuit using a set of 
electronic symbols, hierarchical blocks, and 
connections. Typically used by system and 
programmable logic designers to express a 
structural design description. 

schematic folder A collection of all 
schematic pages at the same level of hierarchy in 
a design. In the project manager, a schematic 
folder behaves like a container. See also flat 
design, hierarchical design, root schematic 
folder, schematic page. 

schematic page The pages on which a 
design is drawn. Schematic pages display in a 
window, called the schematic page editor, in 
which you can place parts and draw wires. 

schematic page editor The editor used to 
create and edit schematic pages. 

session frame The window in which the 
various elements of Capture-such as the 
session log, project manager, schematic page 
editor, and part editor-run. 

Glossary 

session log A window that displays text 
messages generated by Capture, such as errors 
and informational messages. The session log 
starts empty with each new Capture session, but 
you can save its contents to a text file. 

signal An electrical impulse of a 
predetermined voltage, current, polarity, and 
pulse width. 

simple hierarchy A design in which there is 
a one-to-one correspondence between 
hierarchical blocks (or parts with attached 
schematic folders) and the schematic folders 
they reference. Each hierarchical block (or part 
with an attached schematic folder) represents a 
unique schematic folder. See also complex 
hierarchy, hierarchical design. 

source library The path and filename where 
a part's definition resides. A filename with an 
.OLB extension indicates that the part was 
placed "as is" from the library. A filename with 
a .DSN extension indicates that the part no 
longer matches the original library part, and the 
changed part's definition only resides in the 
design where the part was edited. 

spreadsheet editor A window used to edit 
the properties of multiple objects at once. 

tabbed dialog box A dialog box that has 
different views that can be displayed by clicking 
on tabs along the top of the dialog box. 

TrueType A font (typeface) that displays in a 
printout exactly the way it displays on the 
screen. True Type fonts are scaleable to any font 
size, and several of these fonts are installed 
automatically when you install Windows. 
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Glossary 

user-defined property A property you add 
to an object. Unlike inherent properties, user­
defined properties can be removed. See also 
inherent property. 

vertex The point at which the sides of an 
angle meet. You create this by drawing a wire or 
line in one direction, then changing direction to 
create an L-shaped or V -shaped wire or line. 

wildcard A symbol, usually used in searches, 
that represents a missing or unknown character 
or sequence of characters. Valid wildcard 
characters are an asterisk (*) to match multiple 
characters and a question mark (?) to match 
individual characters. 

X axis The horizontal or left-to-right direction 
in a two-dimensional system of coordinates. The 
X axis is perpendicular to the Y axis. 

Y axis The vertical or bottom-to-top direction 
in a two-dimensional system of coordinates. The 
Y axis is perpendicular to the X axis. 
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zoom To change the view of a window, 
making the objects appear larger or smaller. 
When you zoom out, the objects are smaller and 
you see more of the schematic page or part. 
When you zoom in, the objects are larger, but 
you see less of the schematic page or part. 

zoom factor The amount by which the zoom 
scale is multiplied or divided when you choose 
Zoom In or Zoom Out on the schematic page 
editor's View menu. The Zoom factor is 
normally 2, but you can change it using the 
Preferences command on the Options menu. For 
example, a zoom scale of two makes the image 
of the screen twice as large when you zoom in 
and half as large when you zoom out. 

zoom scale The relative size of the image on 
the screen, as a percentage of the normal size. 
For example, a zoom scale of250% means the 
image on the screen is two and one-halftimes as 
large as normal. 



A 
adding macros, 134 
annotation 

back,226 
forward,228 

Arc command 
tool palette button, 21 

arcs 
drawing, 119 
resizing, 119 

area selection, 25 
arrow keys, be 
attached implementation, 88, 96, 159 
attached schematic folders, 77, 88, 96, 154, 159, 

160 
descending, 154, 160 
homogeneous package, 154,160 
in complex hierarchical designs, 75 
in simple hierarchical designs, 73 

attaching implementations to hierarchical blocks, 
94 

AutoECO, 215 
autosaving files, 45 
autoscrolling, defining, 43 

B 
back annotation, 226 
BACKANNO.MAX file, 226 
backslash, in root schematic folder icon, 6, 73 
bidirectional, pin type, 165 
Bill of Materials 

command, 177, 178, 203 
dialog box, 204 
include file format, 205 
toolbar button, 19 

bitmaps 
placing, 123 
plotting, 67 
resizing, 123 

Bookmark command, 144 
bookmarks 

jumping to, 144 
placing, 144 
properties, editing, 28 
renaming, 144 

Index 

border visibility, defining for new designs, 55 
Browse command, 13 
browse window, 13 

sort buttons, 13 
browsing a project or library, 13 
Bus command, 112. 

tool palette button, 21 
bus entries, placing, 114 
Bus Entry command, 114 

tool palette button, 21 
buses 

editing, 108 
names,108,112 
placing, 108 
properties, editing, 28 
user-defined properties, 27, 29 

C 
CAPSYM.OLB, 77 
Capture 

configuration, 39 
properties for use with Layout, 138 
SDT compatibility, 57, 59 

CAPTURE.INI, 86 
character formatting, 129 
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Index 

circles 
drawing, 118 
resizing, 118 

Clear Session Log command, 17 
Close Project command, 38 
colors 

defining for graphics, 45 
defining for VHDL syntax, 48 
defining preferences, 41 

commands 
Arc, 21 
Bill of Materials, 19 
Browse, 13 
Bus, 21 
Bus Entry, 21 
Clear Session Log, 17 
Close Project, 38 
Copy, 18 
Create Netiist, 19 
Cross Reference, 19 
Cut, 18 
Design Properties, 39 
Design Rules Check, 19 
Design Template, 39 
Ellipse, 21 
Exit, 38 
Export Design, 207 
Export Properties, 210 
Find, 13, 17 
Gate and Pin Swap, 19 
Ground,21 
Group, 26 
Help Topics, 19 
Hierarchical Block, 21 
Hierarchical Pin, 21 
Hierarchical Port, 21 
IEEE Symbol, 22 
Import Design, 209 
Import Properties, 214 
Junction, 21 
Line, 21 
Net Alias, 20 
New, 18 
No Connect, 21 
Off-Page Connector, 21 
Open, 18,35 
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Part, 20 
Paste, 18 
Pin, 22 
Pin Array, 22 
Polyline, 21 
Power, 21 
Preferences, 39 
Print, 18 
Properties, 27, is, 29 
Rectangle, 21 
Redo, 18,30 
Repeat, 31 
Save, 18,37 
Schematic Page Properties, 39 
Select All, 26 
Status Bar, 23 
Text, 21 
Tool Palette, 22 
Toolbar,19 
Undo, 18,30 
Ungroup, 26 
Update Part References, 19 
Wire, 20 
Zoom All, 19 
Zoom Area, 19 
Zoom In, 18 
Zoom Out, 18 

complex hierarchy, 75 
Configure Macro dialog box, 134 
configuring macros, 133 
Control key, ix 
Convert command, 158, 173 
convert view of a part, 158, 173 
Copy command, 121, 122, 125, 128 

toolbar button, 18 
Create Netlist 

command, 154, 160, 177, 178 
dialog box, 198 
format files, 199 
toolbar button, 19 

creating macros, 131 
cross probing, 229 

Capture to Layout, 230 
Layout to Capture, 231 



Cross Reference 
command,178 
dialog box, 206 
toolbar button, 19 

custom 
libraries, 149 
parts, 156 

Cut command, 121, 128 
toolbar button, 18 

D 
defining 

autosaving interval, 45 
autoscrolling, 43 
Capture settings, 39 
colors, 41 

for graphics, 45 
for VHDL syntax, 48 

fill style for graphics, 45 
fonts for VHDL syntax, 48 
grid display, 42 
grid references, 61 
highlighting for VHDL syntax, 48 
line style for graphics, 45 
line width for graphics, 45 
macros 

for display on Macro menu, 133, 135 
names, 134, 135 
shortcut keys, 133, 135, 137 

panning, 43 
project manager fonts, 45 
schematic page size, 61 
schematic page units, 61 
session log fonts, 45 
text editor preferences, 48 
TrueType fonts as strokes, 45 
zoom factor, 43 

deleting an object, 122 
DeMorgan equivalent, 158 
descending into attached schematic folders, 154, 

160 
deselecting, 26 
design cache, 153 
Design Cache folder, 6 
design folder, 6 
design process, 177 

Design Properties 
command,39 
dialog box 

Fonts tab, 58 
Hierarchy tab, 58, 154 
Miscellaneous tab, 60 
SDT Compatibility tab, 59 

Design Resources folder, 6, 34, 36, 209 
Design Rules Check 

command,178 
dialog box, 188 

ERC Matrix tab, 190 
sample report, 191 
toolbar button, 19 

design rules violations, checking for, 178 
design structure 

complex hierarchical, 75 
flat, 72 
hierarchical, 73 
simple hierarchical, 73 

Design Template 
command,39 
dialog box 

Fonts tab, 50 
Grid Reference tab, 55 
Hierarchy tab, 56,154 
Page Size tab, 53 
SDT Compatibility tab, 57 
Title Block tab, 51 

designs 
exporting to a file, 207 
importing to a project, 209 
opening, 35 

displaying invisible power pins, 169 

Index 

drag, maximum number of objects displayed, 44 
drawing 

adding fill, 121 
arcs, 119 
circles, 118 
ellipses, 118 
lines, 116 
polygons, 120 
poly lines, 120 
rectangles, 117 
squares, 117 
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Index 

DRC markers, 178, 186 
properties, editing, 28 

drivers 
plotter, 63 
printer, 63 

DXF files, 207 

E 
ECO, 215 

Run ECO to Layout, 215 
EDIF files, 207 

configuration files, 208, 209 
Edit Part dialog box, 87 
editing, 27 

ground symbols, 92 
hierarchical blocks, 98 
off-page connectors, 107 
power symbols, 92 
properties, 27 
property files, 213 
spreadsheet editor, 28 
user-defined properties, 27, 29 

Ellipse command 
tool palette button, 21 

ellipses 
drawing, 118 
resizing, 118 

Escape key, ix 
Exit command, 38 
Export Design 

command, 207 
dialog box 

DXF tab, 207 
EDIF tab, 207 

Export Properties 
command, 178,210 
dialog box, 210 

exporting 
designs, 207 
libraries, 207 
properties, 210 

to a file, 178 
text, 128 

extensions for filenames 
.INI,39 
.OLB,51 
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F 
file extensions 

.INI,39 

.MNL, 225 

.OLB,51 

.SWP,226 
file formats 

DXF,207 
EDIF,207 
include file, 205 
netlist format files, 199 
PDIF,207 
property file, 212 
swap file, 195 
update file, 185 

file types 
netlist files, 225 
swap files, 226 

files 
auto saving, 45 
BACKANNO.MAX, 226 
DXF,207 
EDIF,207 

configuration files, 208, 209 
LA YOUT.lNI, 225 
opening, 35 
PDIF,207 
property files, 212 

fill sty Ie, 115 
defining for graphics, 45 

fill, adding to a graphic object, 121 
Find command, 13, 17 
finding 

parts in a design, 145 
parts on a schematic page, 145 

flat designs, 72 ( 
off-page connectors, 72 

folders 
Design Cache folder, 6 
design folder, 6 
Design Resources folder, 6, 34, 36, 209 
Library folder, 6, 209 
Outputs folder, 6 
schematic folders, 6, 33 



fonts 
changing placed text, 129 
defining 

for existing designs, 58 
for new designs, 50 
for VHDL syntax, 48 

project manager, 45 
screen, 129 
session log, 45 
TrueType, 45 

format files, netlist, 199 
forward annotation, 228 

G 
Gate and Pin Swap 

command, 177, 178 
dialog box, 195 
swap file format, 195 
toolbar button, 19 

global power pins, 60, 88, 165, 168 
Go To 

command, 142 
dialog box 

Bookmark tab, 144 
Grid Reference tab, 143 
Location tab, 143 

Grid command, 145 
grid display 

dots or lines, 42 
setting visibility, 42 
snap-to-grid, 42 

grid references 
defining for new designs, 55 
displaying or hiding, 145 

Grid References command, 145 
grid spacing, defining, 53 
Ground command, 90 

tool palette button, 21 
ground pins, 168 
ground symbols, placing, 92 
Group command, 26 
grouping, 26 

H 
Help Topics command, toolbar button, 19 
help, online, 24 
heterogeneous package, 151, 154, 155 
Hierarchical Block command 

dialog box, 96 
tool palette button, 21 

hierarchical blocks 
attached implementation, 94, 96 
complex hierarchical designs, 75 
hierarchical designs, 73 

Index 

nets between schematic folders and schematic 
pages, 76 

placing, 98 
simple hierarchical designs, 73 
user-defined properties, 27, 29 

hierarchical designs, 73 
complex, 75 
hierarchical blocks, 73 
simple, 73 

Hierarchical Pin command, 102 
tool palette button, 21 

hierarchical pins, 77 
nets between schematic folders and schematic 

pages, 76 
off-grid, 102 
properties, editing, 28 

Hierarchical Port command, 100 
tool palette button, 21 

hierarchical ports, 77 
nets between schematic folders and schematic 

pages, 76 
placing, 100 
properties, editing, 28 

hierarchy, 73, 154, 160 
attached implementation, 88, 94, 159 
complex, 75 
defining 

for existing designs, 58 
for new designs, 56 

placing hierarchical blocks, 94 
simple, 73 

highlighting, defining for VHDL syntax, 48 
homogeneous package, 151, 155 

attaching schematic folders, 154 
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Index 

I 
IEEE Symbol command, 161 

tool palette button, 22 
IEEE symbols 

adding to a part, 161 
Import Design 

command,209 
dialog box 

EDIF tab, 209 
PDIF tab, 209 

Import Properties 
command, 178,214 
dialog box, 214 

importing 
designs, 209 
libraries, 209 
properties, 214 

from a file, 178 
text, 128 

include file format, 205 
input, pin type, 165 
instances, 11 
intertool communication (ITC) 

enabling in Capture, 229, 234 
enabling in Layout, 229 
enabling in Simulate, 234 

J 
jumping 

to a bookmark, 144 
to a grid reference, 143 
to a marked location, 144 
to a new location, 142 

Junction command, tool palette button, 21 
junctions, 110 

K 
keyboard keys, ix 
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L 
LA YOUT.INI file, 225 
libraries, 150 

copying parts to a different library, 150 
custom, 149 
exporting to a file, 207 
importing to a project, 209 
moving parts to a different library, 150 
opening; 35 

Library folder, 6, 209 
Line command, tool palette button, 21 
line style, 115 

defining for graphics, 45 
line width, defining for graphics, 45 
lines 

drawing, 116 
resizing, 116 

Logical command, 75 
logical mode, 9 

M 
Macro Name dialog box, 133 
macros 

adding, 134 
Capture to Layout, 138 
configuring, 133 
creating, 131 
defining 

for display on Macro menu, 133, 135 
shortcutkeys,133,135,137 

naming, 134, 135 
playing, 132 
recording, 132 
removing, 134 
saving, 135 
shortcut key assignments, 137 
temporary, 131 

Mirror command, 121 
modes 

logical,9 
physical, 10 

. when to use, 12 
multiple objects, selecting, 25 
mUltiple-part packages, 151 

creating, 156 



N 
naming macros, 134, 135 
Net Alias command, tool palette button, 20 
net aliases, 108, 112 

editing, III 
net names, 108 
net properties, transferring to Layout, 222 
netlist 

creating, 178 
for Layout, 225 
for simulation, 201 

format files, 199 
netname resolution, 200 
nets 

hierarchical blocks, between schematic 
folders and schematic pages, 76 

hierarchical pins, between schematic folders 
and schematic pages, 76 

hierarchical ports, between schematic folders 
and schematic pages, 76 

off-page connectors, between schematic pages 
in a single schematic, 76 

properties, editing, 28 
user-defined properties, 27, 29 

New command, toolbar button, 18 
New Part command, 156 
New Part Properties dialog box, 158 
Next Part command, 172 
No Connect command, 93 

tool palette button, 21 
nonprimitive parts, 83, 154, 160 

o 
occurrences, II 
Off-Page Connector command, 104 

tool palette button, 21 
off-page connectors, 77 

in flat designs, 72 
example, 78 

nets between schematic pages in a single 
schematic, 76 

placing, 107 
properties, editing, 28 

online 
help, 24 
tutorial, 24 

open collector, pin type, 165 
Open command, 35 

toolbar button, 18 
open emitter, pin type, 165 
output pin type, 165 
Outputs folder, 6 

P-Q 
Package command, 172, 173 
package view, part editor, 15 
packages, 82,151 

heterogeneous, 151, 155 
homogeneous, 151, 155 

attaching schematic folders, 154 
plotting, 64 
printing, 64 
user-defined properties, 27, 29 
viewing, 172, 173 

page size, defining for new designs, 53 
panning, defining, 43 
Part command, 84 

tool palette button, 20 
part editor, 15 

tool palette, 22, 115 
part instances, 11, 153 

editing, 171 
properties, editing, 28 
user-defined properties, 27, 29 

part occurrences, 11, 29 
part properties, transferring to Layout, 219 
part view, part editor, 15 
parts 

attached schematic folders, 73, 75, 77 
convert view, 158, 173 
copying to a different library, 150 
editing 

in a library, 170 
on a schematic page, 171 

finding, 145 
heterogeneous package, 151, 155 
homogeneous package, 151, 155 

attaching schematic folders, 154 
IEEE symbols, placing, 161 

Index 
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Index 

instances, 11, 28, 153 
moving to a different library, 150 
multiple-part packages, 151 
occurrences, 11 
packages, 151 
part body, 156 
part body border, 156 
part reference, 159 
PCB footprint, 158 
pins, placing, 162 
plotting, 64 
printing, 64 
user-defined properties, 27, 29 

passive, pin type, 165 
Paste command, 122 

toolbar button, 18 
PCB footprint property, 88, 185, 198,225 
PDIF files, 207 
Physical command, 75 
physical mode, 10 

when to use, 12 
Picture command, 123 
Pin Array command, 166 

tool palette button, 22 
Pin command, 162 

tool palette button, 22 
pin properties, transferring to Layout, 224 
pins 

connecting to wires, 110 
ground,168 
invisible, displaying, 169 
name, 163 
number, 163 
placing mUltiple, 166 
placing on a part, 162 
power, 168 
shape, 164 
shared, 155, 168 
types, 165 
user-defined properties, 27, 29 
visibility, 163, 168 . 
width,163 

pin-to-pin spacing, defining for new designs, 53 
Place Ground Symbol dialog box, 91 
Place Hierarchical Block dialog box, 96 
Place Hierarchical Pin dialog box, 103 
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Place Hierarchical Port dialog box, 101 
Place Off-Page Connector dialog box, 106 
Place Part dialog box, 85 
Place Pin Array dialog box, 167 
Place Pin dialog box, J 63 
Place Power Symbol dialog box, 91 
placing 

bitmaps, 123 
bus entries, 114 
ground symbols, 92 
hierarchical blocks, 98 
hierarchical pins, 102 
off-page connectors, 107 
power symbols, 92 
text, 124 

playing macros, 132 
plotting, 63 

bitmaps, 67 
drivers, 63, 67 
HPGL emulation, 67 
parts or packages, 64 
pen colors, 67 
previewing, 65 
rendering TrueType fonts as strokes, 45 
scaling output, 66 
schematic pages, 64 
text editor, 65 

polygons 
drawing, 120 
resizing, 120 

Polyline command, tool palette button, 21 
polylines 

drawing, 120 
resizing, 120 

Power command, 89 
tool palette button, 21 

power pin visibility, defining, 60 
power pins, 168 

visibility, 88 
power symbols, placing, 92 
power, pin type, 165 



Preferences 
command,39 
dialog box 

Colors tab, 25 
Colors/Print tab, 41 
Grid Display tab, 42 
Miscellaneous tab, 45 
Pan and Zoom tab, 43, 140 
Select tab, 25, 44 
Text Editor tab, 48 

previewing print output, 65 
Previous Part command, 172 
primitive parts, 83, 154 
Primitive property, 88, 154, 160 

Default option, 154, 160 
on hierarchical blocks, 96 

Print command, 64 
toolbar button, 18 

Print Preview command, 65 
Print Setup command, 63 
printing, 63 

drivers, 63 
parts or packages, 64 
previewing, 65 
rendering TrueType fonts as strokes, 45 
scaling output, 66 
schematic pages, 64 
setting up, 63 
text editor, 65 

project manager, 5 
browse window, 13 
File tab, 8 
folders 

Design Cache folder, 6 
design folder, 6 
Design Resources folder, 6 
Library folder, 6 
Outputs folder, 6 
schematic folders, 6 

font, 45 
Hierarchy tab, 8 
Logical option, 9 
Physical option, 9 
pop-up menus, 12 
schematic pages, 6 
toolbar button, 19 

projects 
adding 

files, 36 
VHDL files, 34 

closing, 38 
deleting files, 36 
folders 

Design Resources, 34, 36, 209 
Library, 209 
schematic, 33 

opening, 35 
saving, 37 

properties 
editing, 27, 177 

a property file, 213 
exporting, 210 

to a file, 178 
importing, 214 

from a file, 178 
Layout net properties, 222 
Layout part properties, 219 
Layout pin properties, 224 
spreadsheet editor, 177 
user-defined, 27, 29 

Properties command, 27, 28, 29 
property file format, 212 

R 
recording macros, 132 
Rectangle command, tool palette button, 21 
rectangles, drawing, 117 
Redo command, 30 

toolbar button, 18 
redoing actions, 30 
removing macros, 134 
Repeat command, 31 
repeating actions, 30 
Replace Cache command, 153 

Index 

replacing a part instance in the design cache, 153 
reports 

bill of materials, 178,203 
cross reference, 178 

root schematic folder, 6, 73 
Rotate command, 121 
Run ECO to Layout, 215 
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s 
Save command, 37 

toolbar button, 18 
saving macros, 135 
scaling 

plotter output, 66 
printer output, 66 

schematic folders, 6, 33 . 
attaching to a part, 160 

schematic page editor, 14 
tool palette, 115 

Schematic Page Properties 
command, 39 
dialog box 

Grid References tab, 61 
Page Size tab, 61 
Miscellaneous tab, 62 

schematic page size, defining for new designs, 
53 

schematic pages, 6 
creation date, 62 
defining 

grid references, 61 
page size, 61 
units, 61 

modification date, 62 
plotting, 64 
printing, 64 

screen fonts, 129 
SDT compatibility with Capture, 57, 59 
Select All command, 26 
selecting 

all objects, 26 
area, 25 
deselecting, 26 
multiple objects, 25 
one object, 25 

seleCtion border, intersect or enclosed, 44 
session frame, 3 
session log, 17 

font, 45 
shared pins, 155, 168 
shortcut key assignments for macros, 137 
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signals 
selecting for simulation, 236 
setting breakpoints, 238 
viewing during simulation, 235 

simple hierarchy, 73 
example, 78 

simulation 
creating a netlist for, 201 
incorporating netlist changes, 238 
selecting signal values, 236 
setting breakpoints on signals, 238 
specifying interactive stimuli, 237 
viewing signal values, 235 

snap-to-grid, defining, 42 
spreadsheet editor, 28, 177 
squares 

drawing, 117 
resizing, 117 

status bar visibility, 23 
Status Bar command, 23 
swap file format, 195 
swapping gates or pins, 178 

T 
tab spacing, defining for text editor, 48 
temporary macros, 131 
text 

bounding box, 126 
character formatting, 129 
deleting, 126 
editing, 126 
exporting, 128 
finding, 127 
importing, 128 
moving, 124 
placing, 124 
rendering TrueType fonts as strokes, 45 
replacing, 127 
rotating, 125 
typing,x 

Text command, 124, 129 
tool palette button, 21 

text editor, 16 
defining preferences, 48 
plotting, 65 
printing, 65 



three-state, pin type, 165 
title blocks, 149 

defining for new designs, 51 
visibility, defining for new designs, 55 

tool palette 
part editor, 20, 115 

IEEE Symbol command, 22 
Pin Array commmand, 22 
Pin commmand, 22 

schematic page editor, 20, 115 
Arc command, 21 
Bus command, 21 
Bus Entry command, 2 i 
Ellipse command, 21 
Ground command, 21 
Hierarchical Block command, 21 
Hierarchical Pin command, 21 
Hierarchical Port command, 21 
Junction command, 21 
Line command, 21 
Net Alias command, 20 
No Connect command, 21 
Off-Page Connector command, 21 
Part command, 20 
Polyline command, 21 
Power command, 21 
Rectangle command, 21 
selection tool, 20 
Text command, 21 
Wire command, 20 

visibility, 22, 44 
Tool Palette command, 22 
toolbar,18 

Bill of Materials command, 19 
Copy command, 18 
Create Netlist command, 19 
Cross Reference command, 19 
Cut command. 18 
Design Rules Check command, 19 
Gate and Pin Swap command, 19 
Help Topics command, 19 
New command, 18 
Open command, 18 
Paste command, 18 
Print command, 18 
project manager tool, 19 

Redo command, 18 
Save command, 18 
Undo command, 18 
Update Part References command, 19 
visibility, 19 
Zoom All command, 19 
Zoom Area command, 19 
Zoom In command, 18 
Zoom Out command, 18 

Toolbar command, 19 
tutorial, online, 24 

u 
Undo command, 30 

toolbar button, 18 
undoing actions, 30 
Ungroup command, 26 

Index 

unit of measure, defining for new designs, 53 
Update Cache command, 153 
Update Part References 

command, 178, 182 
dialog box, 181 
toolbar button, 19 

Update Properties 
command, 178, 185 
dialog box, 184 
update file format, 185 

updating 
part references, 178, 182 
properties, 178, 185 
selected parts in the design cache, 153 

user-defined properties, 27, 29 

v 
VHDL files 

creating, 16 
opening, 35 
viewing, 16 

VHDLsyntax 
defining 

colors, 48 
fonts, 48 
highlighting, 48 
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viewing 
centering, 141 
entire page or part, 141 
selected area, 141 

visibility 
power pins, 60, 88 
status bar, 23 
tool palette, 22, 44 
toolbar,19 

W-y 
window 

active, 3 
browse, 13 
part editor, 15 
project manager, 5 
schematic page editor, 14 
session frame, 3 
session log, 17 
text editor, 16 

Wire command, 110 
tool palette button, 20 

wires 
editing, J08 
placing, 108 
properties, editing, 28 

z 
Zoom All command, 141 

toolbar button, 19 
Zoom Area command, 141 

toolbar button, 19 
zoom factor, 140 

defining, 43 
Zoom In command, 139 

toolbar button, 18 
Zoom Out command, 140 

toolbar button, 18 
zoom scale, 140 
zooming, 139 
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TM Email 
International email 

Technical support email 
Website 

FTPsite 
Technical support 

Corporate offices 
Fax 

FOR WINDOWS ® 

Sales, North America 
Sales, outside North America 
Maintenance sales 

Project manager Tool tips 

Root schematic 
folder 

Schematic 
page 

Design cache 

Outputs folder 

Design Rules 
Check report 

Session log 

Double-click on error number to display 
context-sensitive help for errors 

Dockable toolbar 

Toolbar 

info@orcad,com 

intl@orcad.com 

techsupport@orcad.com 
http://www.orcad.com 

ftp·orcad.com 
(503) 671-9400 
(503) 671-9500 

(503) 671-9501 

800-671-9505 
Contact local OrCAD representative 
800-671-9505 (North America) 

Schematic 
page editor 

Browse 
window 

Library 
manager 

Part editor 

Session 
frame 

Path to 
current file 



Project manager menu set 
:'~~ OrCAD Capture lor Wondows ~[i'l f3 

-'¥!.Ii 

illlJC 
s ... /Io ... 
AlcfliveProjecl ... 

Print PrOJ&ow ... 
frint, .. 
ptIotSetup ... 

IlDPortD.,;gn. .. 
E'POl!D";gn .. 

1 Cmo •.• 1b 
2C:\ORCADWlN\ .. \FI_~.1b 
.:IC:\ORCADWIN\ .. \cm_~diri 
! C\OICADwin\ ... \~cpj 
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Nowlichemolic.,. 
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NewI!HDL~ .. 
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NewSymboj. .. 

Bename. .. 
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1 The Accessories menu displays commands for third-party vendor tools. 

Keystroke I Action 

Operating the mouse 
SPACEBAR Click left mouse button 

Press/hold SPACEBAR Presslhold left mouse button 
Release the SPACEBAR Release the left mouse button 

ENTER Double-click on selected item 

Getting help 
FI Help command 

Printing and saving 
CTRL+P Print active schematic or part 
CTRL+S Save active schematic or part 

Editing 
CTRL+Z Undo 

F4 Repeat 
CTRL+X Cut 
CTRL+C Copy 

CTRL+SHIFT+C Copy image to Clipboard 
CTRL+V Paste 
DELETE Delete 
CTRL+E Edit properties of selection 

CTRL+RorR Rotate selection 
CTRL+U Ungroup selection 
CTRL+F Find 

H Mirror horizontally 
V Mirror vertically 

CTRL+T Toggle grid snap on and off 
CTRL+N View next part 
CTRL+B View previous part 

CnoatellletlioL 
!;lo>oR ___ .. 

em of Materiob. .• 

EiPoit Proper .... .. 
!fII>OIIPlopat .... .. 

lIot. 
1I"."""""Potb 
tlff·P_Com ...... 
/lool<mOrk. 
llRCMatkoto 

Keystroke 

Changing the view 
C 
I 

0 
F5 

CTRL+G 
CTRL+A 
CTRL+D 
PAGE UP 

PAGE DOWN 
CTRL+PAGE UP 

CTRL+PAGE DOWN 

Placing 
B 
E 
N 
P 
T 
W 
y 

J 

Macros 
F7 
F8 
F9 

CTRL+FI 
CTRL+F2 
CTRL+F3 

110 .. _ 

l;=Ode 
TileliorizontaiIY 
TiIe.l!ertiCally 
8t'rongel""". 

1 CMOS 

I Action 

Center view around cursor 
Zoom in 
Zoom out 
Redraw active window 
Go to 
Ascend hierarchy 
Descend hierarchy 
Pan up 
Pan down 
Pan left 
Pan right 

Bus 
Bus entry 
Net alias 
Part 
Text 
Wire 
Polyline 
Junction 

Macro record 
Macro play 
Macro configure 
Set Layout part properties 
Set Layout pin properties 
Set Layout net properties 



Project manager 

Logical or 
physical mode 

Hierarchy tab 

Hierarchical 
design structure 

Session log 
(minimized) 

Status bar 

hl~~~~~~~~~~Iilli~~~~m==============l--Dockable toolbar 

~~~~~!i~~~~~~~~~~~ __ Schematic 

Schematic page editor menu set 

page editor 

Dockable tool 
palette 

Selected items 

Zoom scale 

Cursor position 

1 The Accessories menu displays commands for third-party vendor tools. 



Dockable tool bar 

Library 
manager 

Part listing 

Package 
properties 
spreadsheet 

Project manager 
(minimized) 

Session log 
(minimized) 

PrintPte~w. .. 

OM 

frinl.. 0,1"' 

Part editor menu set 
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--..&If,o!!::I+- Part editor 

Dockable tool 
palette 

Package view 

Selected items 

Zoom scale 

Cursor position 
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